xdebug - устанавливаем/обновляем

Как установить новую версию xdebug - об этом лучше всего читать на странице в форму которой нужно засунуть результат phpinfo()

Но, на всякий случай, я опишу последовательность проведенных мной действий

wget http://xdebug.org/files/xdebug-2.2.5.tgz

tar -xvzf xdebug-2.2.5.tgz

cd xdebug-2.2.5

# phpize
-bash: phpize: command not found

# aptitude install phpize
Couldn't find any package whose name or description matched "phpize"

Чтобы установить на debian wheezy утилиту phpize, нужно установить php5-dev, в результате чего в том числе будет установлена утилита phpize

# aptitude install php5-dev
The following NEW packages will be installed:
autoconf{a} automake{a} autotools-dev{a} libltdl-dev{a} libltdl7{a} libssl-dev{a} libssl-doc{a} libtool{a} php5-dev
shtool{a} zlib1g-dev{a}
0 packages upgraded, 11 newly installed, 0 to remove and 0 not upgraded.
Need to get 6,113 kB of archives. After unpacking 17.4 MB will be used.
Do you want to continue? [Y/n/?] Y

# phpize
Configuring for:
PHP Api Version: 20100412
Zend Module Api No: 20100525
Zend Extension Api No: 220100525

# ./configure

# make

# cp modules/xdebug.so /usr/lib/php5/20100525+lfs

Готово.

p.s. если Вы получаете ошибку "E: Unable to locate package phpize", то чтобы установить phpize на Ubuntu, выполните:

apt-get install php5-dev

Оцени публикацию:
  • 0,0
Оценили человек: 0

Похожие статьи:


Предложения и пожелания:
Ваше имя:
Ваш E-mail:
Сколько будет Οдин + Τри
Главная
X

youtube.com/watch?v=7hFivbgIEqk

При полном или частичном использовании материалов данного сайта, ссылка на сайт "yapro.ru" обязательна как на источник информации.
Автоматический импорт материалов и информации с сайта запрещен.
Copyrights © 2007 - 2017 YaPro.Ru

Главная » Веб-мастеру » Unix »