CAUTION: provisional headers are shown

Столкнулся с проблемой загрузки изображения, один клиент не мог загрузить png-файл с планшета и пожаловался. Пришлось подключить по USB-шнуру свой планшет к убунте, набрать в хроме на убунте chrome://inspect/#devices, подтвердить в планшете, что доверяю убунте и в хроме убунты я увидел свой девайс и открытые в нем вкладки, теперь можно выбирать любую из вкладок нажимая на нее и дебажить в девелопер-тулабре.

Попробовал загрузить указанное клиентом изображение, действительно, оказалось загрузка не происходит, а в developer-tolbar (вкладка Network) видно, что запрос есть, но не отправлен и выглядет это так:

enter image description here

Первым делом я конечно подумал на криво написанную Ajax-загрузку, начал дебажить, но ничего не выходило. Поэтому, я просто написал простой php-скриптик: 

<?php
print_r($_FILES);
?>
<!DOCTYPE html>
<html lang="en" class="">
<head>
<meta charset='utf-8'>
</head>
<body>
<form method=post enctype="multipart/form-data" action="/run.php">
<input type="file" name="image">
<input type="submit">
</form>
</body>
</html>

Но даже так отправить файл не получилось, пришлось гуглить.

Согласно некоторым рекомендациям, начал разбираться. Предположительно виновник какой-то Extention, проверил, в браузере планшета нет ни одного дополнения. Далее сложнее:

1. набрал в браузерной строке (на планшете): chrome://net-internals

2. слева сверху повыбирал разные вкладки (events, export и т.п.), попробовал посмотреть на эти вкладки до загрузки файла и после, информация появляется, но собранные с помощью этих вкладок логи лично мне никак не помогли. Например сохраненных export это огромный JSON-файл в котором нет информации о попытке загрузить изображение. Event выдает "disk cache entry", что тоже привело только к баге, которую закрыли, т.к. всем пофиг.   

Все тесты проводил на Android 4.2.2 (версия ядра 3.0.31-1709803), номер сборки JDQ39.P5110XXDMI1

Проблема в браузере Chrome 32.0.1700.99 для Android и стандартном браузере Android.

Отсюда делаю вывод - возможно проблема даже не в браузерах, а на уровне ниже.

Кому интересно потестить, приатачиваю изображение виновник.

Удачки и если будут идеи как побороть, обязательно пишите.

Оцени публикацию:
  • 2,6
Оценили человек: 2

Похожие статьи:


Комментарии посетителей:
  • У меня похожая проблема, вижу те же заголовки, только при отправке данных формы, подскажите удалось продвинуться в решении?
    Когда в аjax() меняю на синхронный режим ошибка не возникает. Но нужен асинхронный
    03 июня 2016, 13:30 коммент полезен : 0 # Иван7
Предложения и пожелания:
Ваше имя:
Ваш E-mail:
Введите изображенные цифры:
Captcha
Главная
X

youtube.com/watch?v=7hFivbgIEqk

При полном или частичном использовании материалов данного сайта, ссылка на сайт "yapro.ru" обязательна как на источник информации.
Автоматический импорт материалов и информации с сайта запрещен.
Copyrights © 2007 - 2017 YaPro.Ru

Главная » Веб-мастеру » Программы »