Собственные примеры.

Чтобы проставить количество кадров, задний фон и размер рисунка нужно нажать Ctrl+М

Установить временно сетку

Чтобы поменять размер сетки нужно нажать Ctrl+Alt+G и выстовить размер своей сетки

Чтобы красиво залить слово нужно выделить его

теперь нажать Ctrl+B , слово разобьется по буквам

и еще раз нажать Ctrl+B, в результате получим:

после выбрать выбрать красивую заливку и получим:

А если в меню Color Mixer выбрать Bitmap то в качестве заливки можно выбрать рисунок.

и получим

Чтобы указать какой слой будет выше нужно всего лишь перетащит его повыше на киноленте

Очень удобно применять для слоев папки, в которые можно складывать слои

Которую можно по набности сворачивать и разворачивать( выбрать правой кнопкой)

Чтобы получить полную власть над слоем выберите Layer Propeties, клацнув правой кнопкой мыши

Normal - обычный слой

Guide - направляющий слой( должен содержать траекторию движеня)

Guided - направляемый слой (должен содержать те самые объекты которые необходимо переместить вдоль траектории, заданной в направляющем слое);

Mask - маска для объектов, расположенных на маскируемых слоях;

Masked - маскируемый слой;

Folder - папка слоев.

Outline Color - задает цвет контура оъектов слоя( для идентификации объектов на разных слоях)

View Layers as outlines - все имеющие изображения представить в виде контуров( аналогично квадрата на киноленте).

Layer Height - выбрать высоту слоя на киноленте( возможны значения: 100%, 200%, 300%).

стр.42

Автоматическая прорисовка. Для этого выделяем наш кадр

и выставляем в поле Frame Tweening-->Motion

Easing- замделение- ускорение(в %)

Rotate ( вращение): CW- по часовой стрелке, CWW- против часовой стрелки

Option --> Orient to path - заставляет двигаться объект по траектории учитывая повороты по кривой

Для преобразования фигуры из одной в другую(называется морфинг) служит в поле Frame Tweening-->Shape

Тут же знакомое Easing и Blend(способ преобразования), может быть Distкшигешму(постепенная трансформация) и Angular(быстрая трансформация)

Для пробы создайет в 1-ом кадре квадрат в 20-ом треугольник и в 40-ом опять квадрат, а теперь в 1,20, и 40 проставте значение в поле Frame Tweening-->Shape и посмотрите результат

Для того преобразования отдельных частей( например носа людоеда в хвост мыши ) нужно использовать маркеры( маленькие кружочки с буквами по алфавиту ). Для этого нужно нажать на начальном кадре Ctrl+Shift+H. Теперь перемещаем на нужную узловую точку( в первом кадре ) и то же повторяем в следующем кадре.

и

Смотрим и удивляемся :)

К сожалению морфинг не позволяем трансформировать растровые рисунки и символы из библиотеки.

Чтобы вызвать библиотеку Ctrl+L

Теперь о Масках.

1. Напишите ваше имя

2.Создайте заключительный кадр ну скажем 25-ый (F5)

3.Создайте новый слой

Теперь выше слова test создайте прямоугольник и выстовите Create Motion Tween

теперь поставте заключительный кадр 25-ый (F6)

перетащите прямоугольник вниз ( ниже надписи test )

теперь щелкните правой кнопкой мыши на имени слоя с прямоугольником и выберите Mask

Теперь нажмите Ctrl+Enter и просмотрите что у Вас получилось :)

Если Вы импортируете файлы формата PNG или GIF , то будет сохранен режим прозрачности, а в случае с анимированным форматом GIF изображение автоматически будет разбито на кадры с сохранением временных промежутков.

Очень важный момент играет качество(Qualiti) сохранение проекта( Export )

Для настроек сохранения других форматов используйте комбинацию Ctrl+Shift+F12

Чтобы придать буквам оболочку нужно нажать S, и залить букву, буква обзаведется своим контуром.

Цветовое оформление текста.

После того как вы обзавели ваши буквы контуром, клацните Y и по середине слова проведите волнистую линию, далее выделите внутреннюю верхнюю часть букв и залейте их градиентной заливкой( плавно меняющей цвета ). Теперь клацни V и сделай 2-ой щелчек по кривой которую ты нарисовал

и нажми Delete. Любуйся :)

Работа с Action Script

Готовые кнопки можно выбрать из готовой библиотеке:

Теперь создайте жука который движется по определенной траектории, далее создайте еще один слой на который поместите(перетащите из библиотеки) 2-е кнопки старт и стоп. Далее нажмите на кнопку play, нажмите Ctrl+Alt+A. Теперь в разделе Action выберите play, нажмите на первой строчке и выстовите следующие параметры:

Тоже самое проделайте с кнопкой stop, только в Action выберите stop, и в Key Press выстовите h

Теперь нажмите Ctrl+Enter и когда вы будете нажимать H, жук будет останавливаться а нажимая Y будет обрато ползти :)

Теперь поговорим о HTML-страницах

Выделяем кнопку и в поле [image] выбираем Get URL

URL - адрес страницы

Windows - окно в котором нужно вывести страницу

_self - текущее окно

_blank - новое окно

_parent - родительское окно, ну то с которого пришли на эту страницу

_top - самое старшее окно в иерархии

Variable - в раскрывающемся списке выбираетс яспособ предачи данных на сайт, если тковые в фильме получены( например, с помощью форм):

Don't sent - не посылать , используется для простого открытия HTML - страницы или сайта,

Send using GET - передача по методу GET, при котором данные присоединяются к адресу,

Set using POST - передача по методу POST, пременяется передачи данных для CGI - скриптов

Чтобы создать меню нужно в 1-ом кадре создать кнопку, присвоить ей значения play, и в первом кадре установить значение stop.

Теперь во втором кадре делаем еще ниже или выше 3 кнопки и присваеваим 2-ому кадру значение stop. Все проверь, теперь когда ты будешь клацать на кнопке 1-ого кадра будут вылазить кнопки 2-ого кадра, а еще один клик будет закрывать наше меню :)

Подсказка: Чтобы избавится от задерки в клипе при переходе от конца в начало, нужно просто поставить последнему кадру клипа действие play

Кадры:

F5 - продолжить текущий кадр.

F6 - ключевой кадр

F7 - пустой ключевой кадр

Ставлю кнопкам атрибут появления фигур.(тоесть когда я буду нажимать на кнопки будут появлятся фигуры )

Выбираю кнопку и выствляю следующее:

Подсказка: Допустим, что у нас на рабочей сцене имеется кнопка и клип с пресвоенным ему именем, состоящий из 40 кадров, а первому кадру назначено действие stop ( то есть клип останваливается на первом кадре ). Пре щелчке на кнопке клип должен начинать воспроизводиться. Для этого требуется назначить кнопке сценарий, выполняющий запуск клипа.