What's new in Flash 5

Начало > Что нового во Flash 5

Что нового во Flash 5

Новые свойства пакета Flash 5 обеспечивают расширенные возможности для создания графики, увеличения интерактивности и облегчения процесса работы. Он также имеет значительно расширенные возможности ActionScript - языка написания скриптов. См. " Что нового в ActionScript" в справке по ActionScript.

Создание графики

Расширенные средства управления цветом, включены панели Mixer (Смеситель), Fill (Заливка), Stroke (Линии) и Swatches - панель управления текущей палитрой, и средства управления инструментами Fill и Stroke, обеспечивающие дополнительные возможности для создания графики. См. Работа с цветом.

Новые подсветки выбора облегчают идентификацию выделенных линий. См. Выделение объектов.

Перемещаемые направляющие помогают выравнивать объекты в Сцене. См. Использование сетки, направляющих и линеек.

Инструмент Pen (Перо) позволяет создавать точный путь, он работает также, как перо в Macromedia FreeHand или Macromedia Fireworks. См. Использование инструмента Pen (Перо).

Рабочий процесс

Новые панели для работы с цветом, текстом, командами, кадрами, элементами и целыми клипами значительно облегчают работу во Flash. См. Основы Flash.

Общие библиотеки позволяют связываться с библиотечными элементами как с внешними активами. Можно создавать шрифтовые символы, кнопки, графику, клипы и звуки и включить их в общие библиотеки. См. Использование общих библиотек.

Macromedia Dashboard позволяет быть в курсе последних новостей об использовании Flash. См. Macromedia Dashboard для Flash.

Собственные "горячие" клавиши, которые можно назначить командам и функциям Flash для настройки удобного рабочего пространства. См. Настройка "горячих" клавиш.

Поддержка импорта файлов в формате MP3 позволяет импортировать уже компрессированный звук во Flash. Это уменьшает время, необходимое для экспорта озвученного клипа, так как не требует сжатия звука в течение экспорта. Использование компрессированного звука уменьшает размер Flash-файлов и снижает требования к памяти при работе в редакторе. См. Добавление звука.

Интерактивность

Расширенный язык ActionScript обеспечивает значительное расширение интерактивности во Flash. См. ActionScript Help.

Movie Explorer позволяет легко просматривать полное содержание текущего клипа и панель Properties (Свойства) выбранного элемента для его модификации. См. Использование Movie Explorer.

Команда Print позволяет назначать команды для печати кадров Flash-клипа из Flash Player, распечатывать кадры как векторную или растровую графику. См. ActionScript Help.


What's new in Flash 5

Начало > Что нового во Flash 5 > Расширенная интеграция с другими приложениями

Расширенная интеграция с другими приложениями

Поддержка импорта FreeHand и Fireworks PNG файлов позволяет импортировать эти файлы во Flash, как доступную для редактирования графику, с сохранением слоев, текста и других элементов. См. Размещение графики во Flash.

Расширенная интеграция с Macromedia Generator позволяет создавать быстро обновляемый динамический контент. См. О Generator и Flash.

Расширенная интеграция с Macromedia Fireworks позволяет легко запускать Fireworks для редактирования растровой графики, импортированной во Flash. См. Редактирование растровых рисунков.


Guide to instructional media

Начало > Путеводитель по учебным приложениям

Путеводитель по учебным приложениям

Пакет Flash 5 содержит ряд приложений, которые помогут Вам быстро освоить программу и получить опыт в создании собственных Flash-клипов — интерактивную справку, которую Вы в данный момент читаете, интерактивные уроки, учебник, две печатных книги и регулярно обновляемый веб-сайт.

Уроки и учебник

Если Вы новичок или Ваши знания Flash ограничены, начинайте знакомство с пакетом с уроков. Они познакомят Вас с основным свойствам Flash, одновременно позволяя практиковаться на отдельных примерах.

Учебник знакомит с рабочей средой Flash, показывая основы создания клипа. Он требует понимания тем, освещенных в уроках.

Для запуска уроков, выберите Help > Lessons > Introduction.

Использование Flash и ActionScript Reference

Using Flash содержит инструкции и информацию обо всех инструментах и командах. Это обеспечивается как справкой, так и печатным руководством. Интерактивная справка содержит ряд клипов для демонстрации эффектов и свойств Flash.

The ActionScript Reference содержит инструкции и информацию об ActionScript, включая его написание, создание интерактивности и полный словарь. Это обеспечивается как справкой, так и печатным руководством.

Flash Help

Данная справка содержит три больших раздела: Using Flash, ActionScript Reference и ActionScript Dictionary.

Для получения лучших результатов при использовании Flash Help, Macromedia настоятельно рекомендует пользоваться Netscape Navigator 4.0, Microsoft Internet Explorer 4.0 или их более поздними версиями для Windows, и Netscape Navigator 4.0, Microsoft Internet Explorer 4.5 или их более поздними версиями для Macintosh. Если Вы используете броузеры третьего поколения, все содержание клипов и Flash Help будет доступно, но некоторые свойства типа Поиска, не будут работать. Одновременное использование Flash и Flash Help на Macintosh может потребовать до 32 МБ памяти, в зависимости от запросов Вашего броузера.

Использование Flash Help:

1 | Выберите один из трех разделов справки из меню Help.
2 | Для перемещения по разделам справки, воспользуйтесь любым из методов:
 | Contents (Содержание) - информация организована по предметам. Используйте левое меню для выбора тем.
 | Index (Индекс) - информация организована подобно традиционному печатанному индексу. Нажмите на термин, чтобы перейти к связанной с ним теме.
 | Search (Поиск) находит любую строку символов во всем тексте справки. Эта опция требует 4.0 или более поздней версии броузера и поддержки Java. Для поиска фразы, введите ее в текстовое поле.
 | Для поиска файлов содержащих два ключевых слова (например, layers и style), разделите слова знаком плюс (+).
 | Для поиска файлов содержащих полную фразу, в качестве разделителей слов используйте пробелы.
 | Кнопки Previous (Предыдущая) и Next (Следующая) позволяют перемещаться по страницам внутри раздела.
 | Изображение логотипа Flash связанно с Flash Support Center веб сайтом.

Macromedia Dashboard для Flash

Macromedia Dashboard (Приборная панель) для Flash обеспечивает доступ к ресурсам разработки Flash непосредственно изнутри приложения. Используйте Macromedia Dashboard для получения информации о ряде тем, связанных с Flash.

Macromedia регулярно посылает новое содержание для Macromedia Dashboard. Вы можете выбрать автоматический или ручной режим обновления.

Просмотр Macromedia Dashboard:

1 | Выбрать Help > Macromedia Dashboard.
2 | Нажать на вкладку Dashboard и выбрать тему.

Установка режима обновления:

В Macromedia Dashboard включите Auto Update для автоматического регулярного обновления панели. Отключите этот параметр, если хотите обновлять ее содержание вручную, нажимая кнопку Update.

Примечание: Для обновления содержания необходимо быть подключенным к Интернет.

Flash Support Center

Flash Support Center - регулярно обновляемый веб сайт, содержащий последнюю информацию о Flash, рекомендации опытных пользователей, расширенные темы, примеры, советы и другие обновления. Заходите на сайт почаще для получения последних новостей и информации о работе в программе.


Overview

Учебник > Краткий обзор

Краткий обзор

Представьте, что однажды был создан вебсайт магазина бумажных змеев. Покупатели приходили бы на этот сайт, чтобы посмотреть на статические изображения различных змеев и выбрать то, что им понравится. Честно говоря, большинство заказчиков ушло бы неудовлетворенным, такой сайт не привлек бы их внимание.

Теперь представьте, что Вы можете добавить Flash на этот сайт. В этом учебнике Вы будете автором веб-страницы для магазина бумажных змеев "Orbit Kites" - интерактивного сайта, который позволяет пользователям просматривать и конструировать своих собственных змеев. После выбора змея, заказчик нажимает на кнопку и видит его стоимость и анимацию этого змея в полете.

По окончанию учебной программы, Вы сможете пользоваться теми возможностями и преимуществами, которые предоставляет Flash и будете знать больше о создании Flash-клипов. Вы изучите следующие темы:

Изменение свойств Flash-клипа
Импорт, создание и модификация содержания, показываемого в Вашем клипе
Озвучивание кнопок
Использование Сцены (Stage) и Монтажной линейки (Timeline) для монтажа клипа
Создание анимации движений (motion-tweening) и форм (shape-tweening)
Использование команд для повышения интерактивности и облегчения работы
Тестирование клипа для проверки эффективности загрузки
Экспорт клипа для использования в сети

В зависимости от опыта, Вам потребуется примерно час для завершения учебной программы.


Animate instances

Учебник > Анимация элементов

Анимация элементов

Flash предлагает несколько различных путей анимации элементов, использующих методы покадровой (frame-by-frame) или автоматической (tweening) анимации. Во втором методе определяется, как элемент выглядит в первом ключевом кадре, затем определяется, как тот же самый элемент выглядит в следующем keyframe. Flash автоматически создает анимацию между этими двумя ключевыми кадрами. Для этого Учебника, Вы создадите два различных типа tweening-эффектов: движение бумажного змея (motion tweening эффект - анимация движения) и движение веревки (shape tweenin эффект - анимация формы).

Как узнать, какого именно из бумажных змеев анимировать, если клип имеет девять возможных комбинаций змеев (три модели змея, умноженные на три цвета змея)? Или потребуется сделать это со всеми девятью? К счастью, нет. Вместо этого, будем использовать специальный указатель места змея (placeholder), который поможет с установками анимации. Позже в этом Учебнике Вы создадите функцию, которая будет определять змея, выбранного заказчиком. На основании информации, полученной функцией, внешний клип с выбранным змеем появится в анимации, заменив собой placeholder.

В ходе подготовки анимации необходимо изменить точку отсчета у бумажного змея.

Изменение точки отсчета

По умолчанию, точка отсчета символа в SWF-файле находится в верхнем левом углу.

Предполагается, что змей будет вращаться во время полета. Необходимо переместить точку отсчета указателя места змея, таким образом, чтобы, когда указатель места будет заменен на изображение змея, он будет вращаться вокруг своего центра, а не вокруг верхнего левого угла.

Команда Edit Center позволяет переместить центр элемента в другое место, по сравнению с исходным символом.

1 | В слое labels линейки, найдите кадр с меткой "kite flight loop" (№ 168) и щелкните на нем, чтобы перейти на это место.
2 | Выделите змея, находящегося на сцене.
3 | Если панель Instance (Экземпляр) не открыта, нажмите на кнопку Instance Panel, в нижнем правом углу окна сцены.
 | Обратите внимание, при выделении змея на сцене, в панели Instance появляется имя символа - placeholderKite и имя экземпляра - demoKite. В последствии, после того, как добавите ActionScript к Вашему клипу, выбранный заказчиком змей заменит собой экземпляр demoKite во время воспроизведения клипа.
4 | Выберите Modify > Transform > Edit Center.
 | Появится изображение точки отсчета (маленькое перекрестие).
5 | Перетащите точку отсчета примерно в центр змея.

Создание анимации движения для змея.

После того, как заказчик выбрал змея, он нажимает кнопку Fly It! и ему выводится счет и демонстрируется полет змея. Чтобы получить эффект летящего в небе змея, добавьте анимацию движения в Ваш клип.

Для этого движения, Вы зададите свойства змея, такие как позиция, размер и поворот для экземпляра в одной точке линейки, затем измените эти свойства в ключевом кадре, который вставите в линейку. Flash автоматически создаст содержание всех кадров между ключевыми.

Добавление ключевого кадра в конец анимации

При добавлении ключевых кадров, имейте в виду, что для изменения анимации Вы можете вставлять их где хотите. Кроме первого и последнего ключевого кадра, нет необходимости вставить ключевые кадры именно в те места, которые определены в этом Учебнике.

1 | На линейке, удостоверьтесь, что находитесь в кадре № 168 слоя kite.
 | Обратите внимание на ключевой кадр, указывающий начало Вашей анимации. Также обратите внимание на направляющую линию на Сцене, задающую путь змея. На линейке этот путь находится в слое Guide:kite, который является направляющим (guide) слоем, облегчающем размещение объектов на Сцене.
 | Направляющая призвана только помогать перемещать объект по заданному пути и при воспроизведении клипа ее не видно. Направляющие слои на линейке обозначаются специальным значком.
2 | Используйте меню масштабирования в нижнем левом углу окна сцены для ее увеличения до 800%.
 | Теперь обратите внимание на то, что направляющая пути не сплошная замкнутая линия, она имеет небольшой разрыв для окончания анимации.
3 | В слое kite на линейке, перейдите на кадр № 229 и выберите Insert > Keyframe.
 | Проверьте показание номера кадра внизу линейки, чтобы убедиться в том, что Вы находитесь в нужном кадре.
 | Ключевой кадр окончания анимации появиться в кадре № 228.
4 | На увеличенной, как было указано ранее, сцене, в кадре № 229 слоя kite, перетащите изображение змея немного направо, таким образом, чтобы точка отсчета оказалась на другой стороне пути.
 | Вы определили положение элемента в конце анимации.
 | Примечание: Если точка отсчета уже была расположена на правой стороне пути, анимация не будет работать. Сделайте последовательную отмену до момента определения точки отсчета и переместите ее левее того места, где она была установлена Вами.
5 | Восстановите масштаб сцены до 100%.

Задание анимации движения

Теперь, когда Вы определили начало и конец анимации, используете панель Frame (кадр) для задания ее типа.

1 | В слое kite на линейке, нажмите на любой кадр между № 168 с началом анимации и № 228, ее окончанием, для выделения этого кадра.
2 | Выберите Window > Panels > Frame и на открывшейся панели выберите Motion (движение) из списка Tweening.
3 | Удостоверьтесь, что включена опция Snap .
 | Включение опции Snap гарантирует, что змей будет присоединен к направляющей своей точкой отсчета.
 | Если сплошная линия появилась между ключевыми кадрами на линейке и кадры имеют светло синий фон, значит анимация движения сделана корректно.
 | Если между ключевыми кадрами появляется штриховая линия, это указатель того, что анимация движения выполнена не правильно, обычная причина этого, случайное удаление начального или конечного ключевого кадра.

Добавление промежуточных ключевых кадров.

Теперь добавьте промежуточные ключевые кадры, которые укажут места, где анимация будет изменена.

1 | В слое kite линейки, перейдите на кадр № 175 и нажмите F6, чтобы вставить ключевой кадр.
 | Змей на сцене передвинут вдоль заданного пути в позицию, определенную кадром № 175.
2 | В слое kite, аналогично вышеописанному, вставьте ключевые кадры в кадры №№ 184, 198, 207 и 214.

Масштабирование и вращение змея.

Анимация будет более реалистична, если змей будет изменять свой размер и вращаться по ходу движения по заданному пути. Для достижения этого эффекта, сделайте увеличение и уменьшение размеров змея, в добавленных Вами ключевых кадрах и его поворот на некоторый угол.

1 | В слое kite перейдите на кадр № 175.

Примечание: Если Вы вставили ключевые кадры в другие места, а не в те, которые определены в Учебнике, Вы можете масштабировать и вращать змея точно так же, как описано здесь.

2 | На панели инструментов выберите инструмент Arrow (Стрелка) и модификатор Scale (Масштаб). На Сцене, нажмите и перетащите один из угловых маркеров установки размера, расположенных вокруг изображения змея, чтобы немного увеличить его размер.
3 | Включите модификатор Rotate (Вращение). На Сцене, поместите курсор поверх одного из угловых маркеров поворота.
 | Курсор изменит свой вид на четыре стрелки, замкнутые в круг.
4 | Нажмите и потащите маркер для поворота змея примерно на 30° по часовой стрелке.
5 | Перейдите на кадр № 184. На Сцене, используйте модификатор вращения для поворота змея приблизительно на 60° против часовой стрелки. Используйте модификатор масштаба для уменьшения размера изображения.
 | Во время воспроизведения анимации, змей будет удаляться.
6 | Перейдите на кадр № 198. На Сцене, используйте модификатор масштаба, чтобы сделать размер змея меньше.
7 | В ключевых кадрах №№ 207 и 214, используйте модификатор масштаба для увеличения изображения.
8 | Для просмотра анимации змея в полете, протащите playhead от кадра № 168 до кадра № 228.

Примечание: Не забывайте периодически записывать Вашу работу.

Зацикливание анимации

По достижению кадра № 229 анимация останавливается. Чтобы змей летал непрерывно, анимацию необходимо зациклить.

1 | В слое actions линейки, вставьте ключевой кадр в кадр № 228, и двойным щелчком откройте панель Frame Actions.
2 | Нажмите на значок Actions для открытия этой категории, затем в списке команд дважды щелкните на команде goto.
3 | В списке Type (тип), выберите Frame Label.
4 | В списке Frame, выберите kite flight loop.
 | Линейка содержит метку "kite flight loop", расположенную в кадре № 168. Вы задаете переход воспроизведения от кадра № 228, в который вставили ключевой кадр, обратно к кадру № 168 на начало анимации.
5 | Удостоверьтесь, что включена опция Go to and Play и закройте панель Frame Actions.

Создание анимации формы для веревки

Для оживления полета змея, Вы использовали анимацию движения (motion tweening). Чтобы оживить веревку, за которую привязан змей, используем анимации формы (shape tweening). Для этого Вы нарисуете форму, в данном случае веревку, в одной точке линейки и измените ее в других точках. Для создания анимации, Flash автоматически сделает изменения формы во всех кадрах между начальным и конечным ключевыми кадрами.

1 | В слое string на линейке, вставьте ключевой кадр (F6) в кадр № 168, место начала анимации полета.
2 | На панели инструментов выберите инструмент Pencil (карандаш). Нажмите на палитру цветов для ее открытия и выберите бледный оттенок желтого.
3 | В модификаторе Pencil Mode (режим), выберите Smooth (сглаженный).
4 | Для открытия панели Stroke, выберите Window > Panels > Stroke. В меню Stroke Size переместите ползунок на 2 или введите число 2 в текстовом поле.
5 | На Сцене, проведите плавную линию от бобины, приблизительно до "яблочка мишени" в центре змея.
6 | При необходимости, воспользуйтесь инструментом Arrow (Стрелка) для выделения и сглаживания линии при помощи модификатора Smooth (сглаживание).
7 | В слое string линейки, вставьте ключевой кадр в кадр № 230.
 | В дополнение к ключевому кадру в кадре 230, конечный ключевой кадр появится в кадре 229. .
8 | В кадре № 231, выберите Insert > Blank Keyframe, таким образом, начиная с этого кадра, веревка показана не будет.

Создание анимации формы для веревки

Перед началом создания анимации формы, блокируйте на линейке слои kite, sky и Guide:kite, чтобы случайно не сдвинуть какие-нибудь объекты на сцене.

1 | В слое string, нажмите для выделения на любой кадр между кадрами №№ 168 и 229.
2 | Если панель Frame (Кадр) не открыта, выберите Window > Panels > Frame и на панели в списке Tweening, выберите Shape (Форма).
 | Как и в предыдущем случае с анимацией движения, появившаяся сплошная линия между ключевыми кадрами, сообщает, что все сделано правильно. Кадры под ней приобретут светло зеленый цвет - признак анимации формы.
3 | Перейдите на кадр № 168. Медленно протащите playhead направо вдоль линейки до тех пор, пока веревка не отделится от змея. Добавьте другой ключевой кадр в этой точке линейки.

Примечание: Промежуток между изображением змея и веревкой может быть довольно большим, прежде чем потребуется добавить новый ключевой кадр. Нет необходимости вставлять его для маленького промежутка.

4 | Выберите инструмент Arrow (Стрелка) в инструментальной панели. Если веревка выделена, щелкните где-нибудь на Сцене для снятия выделения, затем перетащите верхний конец веревки в такую позицию, чтобы он снова касалась яблочка мишени.
5 | Используйте инструмент Arrow (Стрелка), с выбранным модификатором Smooth (Сглаживание), чтобы поддерживать требуемый изгиб веревки, подцепляя ее указателем мыши за середину и перемещая в нужном направлении.
 | Сделайте анимацию так, чтобы веревка, во время движения змея, не смотрелась оторванной от него.
6 | По мере медленного перемещения playhead направо, вставляйте ключевой кадр в слой string каждый раз, когда образуется промежуток между змеем и веревкой, затем повторяйте шаги 4 и 5, и так до тех пор, пока не достигнете конца анимации в кадре № 229.
7 | Для просмотра получившегося результата, перейдите на кадр № 168 и выберите Control > Play. По окончанию просмотра анимации, выберите Control > Stop.

Note: Не забывайте почаще сохранять Вашу работу.


Use actions to streamline authoring

Учебник > Использование команд для вывода результата

Использование команд для вывода результата

Теперь Вы готовы добавить в Ваш клип команды, определяющие выбранного заказчиком змея и показывающие его в клипе с выводом соответствующего счета. Воспользуйтесь панелью Frame Actions для создания функции - блока многократно используемого кода, выполняющего определенную задачу. В нашем случае задача состоит в том, чтобы, в зависимости от выбора сделанного заказчикам, загрузить определенный SWF-файл с изображение змея во Flash Player.

Примечание: Файлы с изображениями всех моделей и цветов змеев находятся в Вашей директории My_kite.

В дополнение к функции, которую предстоит создать, воспользуемся командой Include для связи с другой функцией во внешнем текстовом файле.

Примечание: В задачи этого Учебника не входит обучение синтаксису ActionScript. См. ActionScript Help для получения дополнительной информации о создании ActionScript.

Создание функции.

Назовем создаваемую функция refreshKite.

Параметр, названый currentKite, будет сообщать функции refreshKite какой тип и цвет змея был выбран заказчиком.

1 | В слое actions линейки, дважды щелкните на ключевом кадре в кадре № 1.
 | Откроется панель Frame Actions. В случае необходимости, измените размеры панели, чтобы видеть оба окна. В правом окне уже содержится команды ActionScript, к которым необходимо будет добавить новые команды.
2 | В левом списке команд нажмите на значок Actions для его раскрытия и дважды щелкните на команде function.
 | Можно просто перетащить команду function вниз имеющегося в правом окне текста с кодом.
3 | В строке Name (имя) введите refreshKite.
4 | В строке Parameters (параметры), введите currentKite.
 | Функция будет использовать параметр currentKite (текущий выбор змея) для идентификации змея, предназначенного к показу.
5 | В категории Actions, дважды щелкните на loadMovie.
 | Эта команда заменяет мувиклип на сцене, на SWF, определенный ее параметрами.
6 | В строке URL введите currentKite+".swf"
7 | Включите опцию Expression (выражение), расположенную справа от этого поля ввода.
 | Включая опцию Expression, вы сообщаете Flash'у, что currentKite + ".swf" на литеральная строка, а выражение. Функция использует это выражение для определения имени внешнего файла.
8 | В списке Location выберите Target, а в правом поле введите demoKite.
 | Как Вы должны помнить из предыдущих шагов, имя экземпляра placeholderKite есть demoKite.
9 | Удостоверьтесь, что в списке Variables указано Don't Send.
10 | В левом списке команд дважды щелкните на set variable, для определения новой переменной.
 | Переменная является неким контейнером, хранящим информацию. Например, такую, как тип выбранного змея. В Вашем клипе она будет использоваться для хранения именно этой информации
11 | В поле Variable введите chosenKite - имя новой переменной. Убедитесь, что опция Expression, справа от поля ввода, отключена.
12 | В поле Value введите currentKite. Включите опцию Expression, справа от поля ввода.

Включение внешней функции

Вы узнали, что функция состоит из команд, выполняющих задачи, на основании информации, получаемых от параметров. Теперь Вы включите в Ваш ActionScript внешнюю функцию, которая покажет счет, соответствующий выбранному змею. Внешняя функция, названная kiteFunction.txt, находится в текстовом файле в директории Tutorial/My_kite. Для связи с внешним файлом воспользуйтесь командой Include.

Преимущество такой связи с внешним файлом, по сравнению с созданием функции внутри, заключается в том, что его можно редактировать без внесения изменений в клип.

Внешняя функция демонстрирует, насколько кратким, но мощным может быть ActionScript:

function generateInvoice (Style, Color, Price, currentKite) {

_root.invoice.invoiceStyle = Style;
_root.invoice.invoiceColor = Color;
_root.invoice.invoicePrice = Price;
flyingKite = currentKite;

}

Однако, обратите внимание, что эта функция не прокомментирована. Хорошая идея снабдить Ваш ActionScript комментариями, примечаниями о цели скрипта и его действиях, облегчающими его понимание. Ниже приведен текст той же функции с такими пояснениями. Комментарии в ActionScript помещаются после двойного слэша (//), все находящееся после него до конца строки, игнорируется интерпретатором Flash.

function generateInvoice (Style, Color, Price, currentKite) {
//Sets the invoiceStyle variable of the invoice movie clip to the //value of the Style parameter

_root.invoice.invoiceStyle = Style;

//Sets the invoiceColor variable of the invoice movie clip to the //value of the Color parameter

_root.invoice.invoiceColor = Color;

//Sets the invoicePrice variable of the invoice movie clip to the //value of the Price parameter

_root.invoice.invoicePrice = Price;

//Sets the variable flyingKite equal to the variable currentKite

flyingKite = currentKite;

}

Теперь добавьте команду include, которая свяжет, созданную Вами внутреннюю функцию, с внешней функцией.

1 | В категории Actions панели Frame Actions, перетащите значок include в конец текста в правом окне.
2 | В поле Path введите KiteFunction.txt.
3 | Закройте панель Frame Actions.

Note: Не забывайте почаще сохранять Вашу работу.


Publish the movie

Учебник > Публикация клипа

Публикация клипа

Примите поздравления! Вы почти завершили работу. В заключение, воспользуетесь командой Publish (публикация), чтобы создать файл с расширением SWF, который будет возможно использовать в сети.

Если Вы используете команду Publish с параметрами настройки по умолчанию, Flash создаст сетевую версию SWF-файла и запишет его вместе с HTML-файлом, содержащим специфические теги для показа SWF.

Как только Вы ввели все необходимые параметры Publish Settings (настройки публикации), можете неоднократно экспортировать клип во все выбранные форматы сразу, просто выбирая File > Publish. Flash сохраняет параметры настройки публикации, определенные Вами для данного клипа, поэтому каждый клип может иметь собственные параметры настройки.

Проверка эффективности загрузки клипа

Для гладкого воспроизведения клипа в Интернет, кадр должен быть загружен прежде чем воспроизведение дойдет до него. Если клип доходит до кадра, который еще не успел загрузиться, воспроизведение приостанавливается, пока нужные данные не будут подкачены из сети.

Вы можете использовать Bandwidth Profiler для проверки клипа и идентификации кадров, в которых возможно возникновение пауз. Bandwidth Profiler графически показывает, количество данных содержащихся в каждом кадре клипа и успевают ли они подгружаться при выбранном быстродействии модема.

1 | Выберите Control > Test Movie.
 | Flash сделает экспорт клипа в SWF-файл и откроет его в новом окне.
2 | В меню Debug (Отладка), выберите скорость модема для моделирования скорости загрузки. .
 | Вы также можете использовать опцию Customize (Настройка), для задания своей скорости загрузки.
3 | Выберите View > Bandwidth Profiler для просмотра диаграммы эффективности загрузки SWF.
 | Каждая затененная область представляет собой кадр клипа. Ее высота пропорциональна размеру кадра в байтах и килобайтах. Если область выходит за пределы красной линии, то в этом месте воспроизведение клипа может приостановиться, пока не загрузится весь кадр.

Примечание: Хотя Bandwidth Profiler не показывает никаких серьезных проблем с загрузкой учебного клипа, Вы можете оптимизировать клип для более быстрой загрузки. Подробности см. Оптимизация клипа.

4 | Когда закончите рассматривать Bandwidth Profiler, выберите View > Bandwidth Profiler для его отключения. Закройте окно теста для возврата в среду редактирования.

Использование команды Publish (Публикация)

Сохраните клип и выберите File > Publish.

Flash запишет Ваш клип в виде SWF-файла и, при необходимости, создаст дополнительные файлы, в зависимости от тех параметров настройки, которые указаны в окне диалога Publish Settings (Установки публикации). Все эти файлы Вы найдете в Вашей директории My_kite.

Просмотр установок публикации

Использование окна диалога Publish Settings, позволяет просто изменять настройки публикации выходного SWF-файла.

1 | Для просмотра настроек публикации, выберите File > Publish Settings.
 | По умолчанию Flash сконфигурирован для создания поддерживающего HTML-файла, который отображает Flash-клип или альтернативное изображение.
 | Когда Вы выбираете формат, требующий дополнительных параметров настройки, появляется новая вкладка.

Изменение установок публикации.

По умолчанию, Flash дает SWF-файлу то же самое имя, как и у FLA-файла. Так как Вы создаете сайт для магазина Orbit kites, укажите для SWF новое имя - OrbitKites.swf.

1 | На вкладке Formats (Форматы) окна диалога Publish Settings, отключите опцию Use Default Names.
2 | В строке Flash (.swf) выделите имеющийся там текст и введите OrbitKites.swf, затем нажмите OK.
 | В следующий раз, когда Вы воспользуетесь командой Publish, Flash создаст файл с именем OrbitKites.swf.


The next steps

Учебник > Следующие шаги

Следующие шаги

Завершая Учебник, Вы теперь знаете, как делать следующее:

Изменять свойства Flash-клипа
Импортировать, создавать и изменять содержание
Озвучивать кнопку
Использовать Сцену и Линейку для монтажа клипа
Создавать анимацию движений и форм
Использовать команды для создания интерактивного клипа
Тестировать клип на эффективность загрузки
Экспортировать клип для использования в сети

Для продолжения изучения пакета, ознакомьтесь с темами раздела Using Flash и Flash Help.


What you should know

Учебник > Что Вы должны знать

Что Вы должны знать

Хотя учебник разработан для начинающих пользователей Flash, Вам необходимо знать основы Flash, описанные в семи уроках, которые можете найти во Flash Help. Эти интерактивные уроки, созданные во Flash, предлагают введение в следующие предметы:

Рисование
Символы
Слои
Текст
Кнопки
Звук
Анимация

Для просмотра Уроков, выберите Help > Lessons, затем выберите урок из списка. Для лучшего понимания материала Учебника, убедитесь, что разобрались с теми понятиями, которые рассмотрены в уроках.


View the completed movie

Учебник > Просмотр готового клипа

Просмотр готового клипа

Чтобы понять то, что Вам предстоит создать, до начала работы над клипом, посмотрите уже готовую версию Учебника. Эта версия позволит исследовать линейку (Timeline), Movie Explorer, библиотеку (Library) и сцену (Stage) для лучшего понимания процесса.

1 | В директории с установленным Flash 5, откройте Tutorial > Finished.
2 | Выберите файл Kite.swf и перетащите его в открытое окно броузера.
 | Flash файл, предназначенный для редактирования (исходный файл), имеет расширение FLA. Клип, готовый для просмотра во Flash Player, имеет расширение SWF.
3 | Нажмите на одну из кнопок "Select a Kite" для выбора типа воздушного змея.
 | Обратите внимание на то, что при нажатии кнопки слышен звук.
4 | Нажмите на одну из кнопок "Select a Color" для выбора окраски воздушного змея.
 | Змей изменит свой цвет в соответствии с выбранным.
5 | Нажмите на кнопку "Fly It!".
 | Слушайте звук и наблюдайте анимацию.
 | Мувиклип меньшего размера воспроизводится внутри основного Flash-клипа.
 | Обратите внимание, что в зависимости от Вашего выбора, изменяется цена, название и цвет змея.
6 | Для повтора нажмите кнопку "Back".
7 | Когда закончите просматривать SWF файл, можете закрыть окно или оставить его открытым, в качестве эталона.

Анализ файла Kite.fla

Для понимания того, как организован клип, полезно проанализировать готовый FLA-файл. Имеется ряд способов делать это. Выполните следующие шаги:

1 | Выберите File > Open в меню Flash. В директории с установленным Flash найдите и откройте Tutorial/Finished/Kite.fla.
 | Готовый учебный клип откроется во Flash-редакторе.
2 | Чтобы видеть всю поверхность сцены (Stage) и монтажной линейки (Timeline), выберите Window > Close All Panels. 1
3 | Для изменения размеров линейки и сцены, переместите вверх или вниз полоску, разделяющую их. Воспользуйтесь вертикальным скроллингом на линейке для просмотра всех, находящихся на ней, слоев.
4 | Когда Вы изучали урок об анимации, то узнали, что ключевой кадр, это такой кадр, в котором определяется изменение в анимации. Теперь обратите внимание на слои и кадры, содержащие ключевые кадры.
 | Начальные и промежуточные ключевые кадры обозначаются в виде закрашенных кружков, конечные - маленьких прямоугольников 2.
5 | Для просмотра меток (labels), которыми автор обозначил сегменты клипа, внимательно изучите на линейке верхний слой "labels" (метки).
 | В дополнение к использованию меток для создания и идентификации сегментов клипа, их можно использовать для перемещения по клипу, переводя воспроизведение на кадр, обозначенный меткой, когда пользователь нажимает на кнопку. В Учебнике эта тема будет освещена более подробно позже.
6 | Просмотрите следующий слой, который называется "actions" (команды).
 | На слое команд находятся кадры с ActionScript - специальным языком написания скриптов.
 | Каждая строчная буква a , которую Вы видите в некоторых кадрах, обозначает наличие в нем ActionScript.
7 | Нажмите на playhead и медленно потащите его вдоль линейки.
 | Наблюдайте, как изменения действий на сцене соответствуют изменениям на линейке. Однако обратите внимание на то, что при ручном перемещении playhead, клип воспроизводится последовательно по кадрам, а не так, как он будет показан пользователям. Команды ActionScript в клипе делают возможным переходы воспроизведения на специфические кадры, а не только последовательное перемещение вдоль линейки.

Использование Movie Explorer

Movie Explorer помогает с организацией, размещением и средствами редактирования и наиболее полезен для работы над клипом, имеющим сложное наполнение. С иерархической древовидной структурой, Movie Explorer обеспечивает понимание в организации и течении клипа, и особенно полезен при одновременной работе над клипом нескольких человек.

1 | Если Movie Explorer еще не открыт, выберите Window > Movie Explorer или нажмите на кнопку "Movie Explorer", находящейся в нижнем правом углу окна со сценой.
2 | Для просмотры структуры клипа, в случае необходимости, увеличьте размер Movie Explorer (потащите окно за нижний правый угол).
 | Кнопки фильтрации Movie Explorer отображают или скрывают информацию.
3 | Нажмите на треугольник в верхнем правом углу Movie Explorer и в открывшемся меню проверьте, включены ли опции Show Movie Elements (показ элементов клипа) и Show Symbol Definitions (показ описаний символа).
4 | В верхней левой части окна удостоверьтесь, что включены только следующие кнопки фильтрации - Show Text (показ текста), Show Buttons, Movie Clips, and Graphics (показ кнопок, мувиклипов и графики) и Show ActionScripts (показ ActionScripts).
5 | Просмотрите список всего содержимого клипа и их связи между собой.
 | Например, просматривая кнопку Rokkaku Kite, Вы увидите, что имеется связанный с ней ActionScript. Раскройте его ветку, чтобы просмотреть те команды, которое воспроизводятся, когда пользователь нажимает на кнопку Rokkaku Kite.
6 | Выключите кнопку фильтрации Show ActionScripts и включите Show Frames and Layers (показ кадров и слоев).
7 | Перейдите наверх списка. В слое labels (метки), дважды нажмите кадр №43 (rokkaku), чтобы переместить playhead на линейке на кадра с меткой rokkaku.
 | Также будут открыты панели, связанные с этим кадром.
 | Для просмотра элемента, указанного в иерархическом дереве, дважды щелкните по соответствующему значку. При двойном нажиматии на значок кадра, playhead перемещается на этот кадр в линейке. При выборе другого типа элемента, появляется связанная с ним панель, позволяющая просматривать или изменять свойства этого элемента.
8 | Выключите кнопку фильтрации Show Frames and Layers.
9 | С строке поиска (Find) напечатайте rokkaku kite BUTTON.
 | Movie Explorer покажет результаты поиска.
10 | Сделайте Right-click (Windows) или Control-click (Macintosh) на изображении кнопки Rokkaku Kite в списке и выберите Find in Library (найти в библиотеке) в появившемся контекстном меню.
 | Find in Library откроет библиотеку, если она еще не открыта и выделит искомый символ в окне библиотеки.
 | Библиотека содержит и организует элементы вашего клипа.
11 | Закройте Movie Explorer.
12 | Закройте клип File > Close.
 | Если Вы сделали какие-то изменения в клипе, не записывайте их.

Открытие начального файла

Теперь Вы готовы создать свой учебный клип.

1 | Выберите File > Open.
2 | В директории с установленным Flash, найдите и откройте Tutorial/My_kite/MyKite.fla.
 | Будет загружен частично завершенный клип Учебника.
3 | Выберите File > Save As и сохраните клип под новым именем в той же директории где и MyKite.fla.
 | Создание копии файла, позволит Вам и другим пользователям, повторить материал Учебника снова, используя исходный MyKite.fla.
4 | Если окно библиотеки на открыто, выберите Window > Library.

Note: При освоении Учебника, не забывайте почаще сохранять свою работу.

От редактора:

  1. Для этого на клавиатуре можно просто нажать клавишу TAB. Общая рекомендация, если хотите работать с пакетом профессионально, изучите "горячие" клавиши. Потратьте на это некоторое время, зато в последствии не придется шарашиться по опциям меню в поисках нужной, что очень облегчает и ускоряет работу.

  2. По умолчанию так, но возможно настроить их вид, как в четвертой версии, это уже кому как удобно.


Define properties to set up a Flash movie

Учебник > Установка свойств Flash-клипа

Установка свойств Flash-клипа

Конфигурация свойств клипа - первый шаг в его создании. Используйте окно диалога Movie Properties (свойства клипа) для задания общих установок, таких, как частота кадров в секунду (frames per second - fps), размер сцены и цвет заднего фона.

Изменение свойств клипа, заданных по умолчанию

1 | Выберите Modify > Movie.
2 | В окне диалога Movie Properties удостоверьтесь, что в строке Frame Rate стоит число 12.
 | Клип будет воспроизводится с частотой 12 кадров в секунду, как наиболее оптимальной для воспроизведения анимации в сети.
3 | Нажмите на Background Color (цвет заднего фона) и в открывшемся окне выберите темно серый цвет.
 | При выборе цвета, его шестнадцатеричное значение высвечивается в поле, расположенном в верхней части окна. Нам понадобится серый цвет, со значением #333333.
4 | После задания свойств, нажмите OK.

Для дополнительной информации о свойствах клипа, см. Создание нового клипа и установка его свойств.


Create media

Учебник > Создание содержания

Создание содержания

В дополнение к импортированию, Flash предлагает ряд инструментальных средств, для создания высококачественной графики и текста. В этом Учебнике текст содержит информацию о каждом выбранном воздушном змее. Вы создадите символ, который будет сообщать заказчикам эту информацию.

Примечание: В течение работы с Учебником, не исключено, что Вам потребуется отменить сделанные Вами изменения. Flash может отменить несколько из недавних изменений. Их количество зависит от числа уровней отмены, заданного в свойствах (Preferences) Flash. Чтобы сделать отмену, выберите Edit > Undo или нажмите Control+Z (Windows) или Command+Z (Macintosh). Наоборот, можно восстановить то, что Вы отменили, выбирая Edit > Redo или нажимая Control+Y (Windows) или Command+Y (Macintosh).

1 | Выберите Insert > New Symbol.
2 | В окне диалога Symbol Properties (свойства символа) укажите имя box TEXT.
3 | В опции Behavior (поведение), включите Graphic и нажмите OK.
 | Flash переключится в режим редактирования символа. Обратите внимание, что имя редактируемого символа, появляется в верхнем левом углу окна. Фон окна останется тем же самым оттенком серого, который был установлен Вами в окне Movie Properties.
4 | На инструментальной панели выберите инструмент Text.
5 | Если панель Character не открыта, выберите Window > Panels > Character.
6 | В списке Font (шрифт), панели Character, выберите _sans.
 | В клипе этот шрифт будет заменяться на шрифт группы sans serif (Arial, Helvetica или подобный), установленный по умолчанию на компьютере пользователя.
7 | В строке Font Height (высота шрифта) введите число 12 или используя ползунок, установите нужное значение.
8 | Нажмите кнопку Bold.
9 | Нажмите кнопку выбора цвета и в открывшейся панели выберите белый цвет, имеющий шестнадцатеричное значение # FFFFFF.
10 | Щелкните инструментом Text где-нибудь в левой части окна и введите следующий текст: The box kite was invented by an Australian, Lawrence Hargrave, in 1893. He used the kite to carry weather instruments aloft.
 | Хотя Вами был выбран белый цвет, во время ввода он будет выглядеть серым на белом фоне.
11 | Выбранным инструментом Text нажмите на маркер изменения размеров (маленький круг в верхнем правом углу текстового блока) и перетащите его налево до слова invented.
 | Текст будет разбит на несколько строк. Как только Вы начнете перемещать маркер, он изменит свой вид на квадрат, это является указателем того, что текстовый блок теперь имеет фиксированную ширину.

Изменение точки отсчета текстового блока

Каждый текстовый блок, как и другие элементы во Flash, имеет точку отсчета, которую можно использовать для его позиционирования. Проверьте точку отсчета Вашего текстового блока, чтобы удостовериться, что она соответствует точкам отсчета других текстовых блоков в клипе. Это гарантирует, что все текстовые блоки будут выравниваются корректно.

1 | На инструментальной панели выберите инструмент Стрелка (Arrow).
 | Выделите текстовый блок на сцене.
2 | Откройте панель Info, выбрав Window > Panels > Info или нажмите на кнопку Show Info, расположенную в нижней правой части окна сцены.
3 | Панель Info содержит маленькую сетку с черным квадратиком, отображающим точку отсчета. Если черный квадратик находится не в левом углу сетки, нажмите на верхний левый квадратик для перемещения точки отсчета в эту позицию.
4 | Введите 0 для X и Y координат и нажмите Enter (Windows) или Return (Macintosh), затем закройте Info панель.
5 | Нажмите надпись "Scene 1" в левом верхнем углу окна для возврата в режим редактирования клипа.
 | Во Flash можно создавать различные сцены, используя команду Insert > Scene. В этом Учебнике используется только одна сцена.

Тестирование Вашего клипа

В любой момент, во время редактирования, Вы можете проверять, как клип будет выглядеть и вести себя в виде SWF-файла.

1 | Сохраните Ваш клип и выберите Control > Test Movie.
 | Flash экспортирует SWF копию Вашего клипа.
2 | В SWF-файле нажмите кнопку Box Kite и обратите внимание на то, что, вместо того, чтобы выдать текст о Box Kite, как ожидается, Вы видите текст о Rokkaku Kite. Oops! Вы должны заменить rokkaku ТЕКСТ на правильный текст о Box Kite.
3 | Закройте SWF-file и вернитесь во Flash-редактор.

Замена экземпляра

Во время редактирования иногда возникает необходимость заменить один элемент на другой. Flash упрощает этот процесс, позволяя заменить один экземпляр на другой, с сохранением атрибутов первоначального экземпляра.

1 | На слое labels линейки, щелкните на кадр с меткой "Box Red" (№ 21) для перемещения playhead в раздел клипа, содержащий информацию о box kite.
 | Выбранный номер кадра будет показан в статус-строке внизу линейки.
2 | Инструментом Стрелка выделите на сцене экземпляр текста, содержащего: "The rokkaku is a Japanese fighting kite ..."
 | Это текст, который необходимо заменить на текст о box kite, который был создан Вами раньше.
3 | Если панель Instance невидима, выберите Window > Panels > Instance.
 | Откроется панель Instance.
4 | На панели Instance, нажмите кнопку Swap Symbol (замена символа).
5 | В окне диалога Swap Symbol, дважды щелкните на символ box TEXT в списке символов.
 | При необходимости пролистайте список, чтобы найти нужный символ.
 | На сцене новый символ заменит собой предыдущий. Новый символ наследует все атрибуты старого.


Import media

Учебник > Импорт содержания

Импорт содержания

В дополнение к созданию текста и графики во Flash, можно импортировать ряд типов медиа в ваш клип. Для Вашего клипа потребуется звук, который будет воспроизводиться при нажатии на кнопку "Fly It!". Чтобы соединить звук с кнопкой, сначала необходимо импортировать звуковой MP3-файл. Используя этот сжатый звуковой формат, вы гарантируете, что звук не увеличит размер вашего клипа значительно.

1 | Выберите File > Import.
2 | Если Вы используете Windows, то в окне диалога Import, в директории с установленным Flash, найдите и откройте Tutorial/My_kite, и дважды щелкните на wizz.mp3.
 | Если Вы используете Macintosh, в директории с установленным Flash, найдите и откройте Tutorial/My_kite, и дважды щелкните на wizz.mp3f, Затем нажмите Import.
 | Звуковой файл появиться в окне библиотеки. Для прослушивания, выберите его в списке и нажмите на кнопку Play (воспроизведение) в окне библиотеки.


Organize your library

Учебник > Организация библиотеки

Организация библиотеки

Вообще, является хорошей практикой, размещать все элементы библиотеки по соответствующим папкам. Этот Учебник требует многих элементов содержания, так что их рациональная организация в библиотеке достаточно важна. В этом разделе Вы переместите Ваш текстовый элемент в папку Text и создадите новую папку для звуковых файлов, а затем переместите все звуки в эту папку.

1 | В библиотечном меню Options, выберите Collapse All Folders (закрыть все папки), чтобы видеть какие элементы находятся вне папок.
2 | выберите символ "box TEXT" и перетащите его в папку "Text".
3 | Двойным щелчком закройте папку "Text".

Создание новой папки для звука.

1 | В библиотечном меню Options, выберите New Folder и введите ее название "Sound".
2 | Если необходимо, измените размер окна библиотеки чтобы видеть одновременно звуковые файлы и новую папку "Sound".
3 | Выделите все звуковые файлы, для чего Control-click (Windows) или Command-click (Macintosh) на chirp.mp3, squeak.mp3, switch2.mp3 и wizz.mp3. Перетащите выделенные файлы внутрь папки "Sound".


Add sound to a button

Учебник > Озвучивание кнопки

Озвучивание кнопки

Создавая кнопку, Flash автоматически включает в нее ключевые кадры (keyframes), соответствующие ее различным состояниям, связанным с указателем мыши. Кадр Over, например, представляет вид кнопки, когда указатель находится над ней. Другие ключевые кадры кнопки - Up, Down и Hit. Для большей информации о ключевых кадрах кнопки, см. урок Buttons (Help > Lessons > Buttons).

Теперь добавьте звук к кадру Down - звук будет воспроизводится при нажатии на кнопку. Так как добавление звука к символу кнопки происходит в библиотеке, он будет присутствовать в каждом экземпляре этой кнопки на сцене.

1 | В окне библиотеки дважды щелкните на папке Buttons для ее открытия.
2 | Выберите символ "fly it BUTTON", затем выберите опцию Edit из меню Options. Можно также дважды щелкнуть изображение символа в окне библиотеки.
 | Flash переключится в режим редактирования символа.
3 | Выберите Insert > Layer и введите имя Sound для нового слоя.
 | Для редактирования названия слоя, можно дважды щелкнуть на его имени.
4 | На слое Sound выделите кадр Down (№ 3) и вставьте в него пустой ключевой кадр - Insert > Keyframe.
5 | Для определения свойств звука, дважды щелкните на третьем кадре слоя Sound.
 | В дополнение к панели Sound, могут появиться другие панели.
6 | На панели Sound, выберите wizz.mp3 в списке звуков. Затем закройте панель.
7 | Выберите Edit > Edit Movie или нажмите Scene 1 в левом верхнем углу окна для возврата в режим редактирования клипа.

Примечание: Не забывайте почаще сохранять Вашу работу. Также помните, что Вы можете выбрать Control > Test Movie, чтобы услышать, как выбранный звук будет воспроизводиться в SWF.


Use the Stage and Timeline

Учебник > Использование Сцены и Линейки

Использование Сцены и Линейки

Теперь, когда вы создали, импортировали и изменили содержание, используйте Сцену и Линейку для монтажа клипа. Можно создавать элементы содержания прямо на Сцене, в этом случае они не появляются в библиотеке, если не будут преобразованы в символ. Можете использовать Сцену для размещения импортируемых элементов по отдельным кадрам. Порядок размещения таких кадров на Линейке и определяет, когда те или иные элементы появляются в клипе при прохождении playhead через эти кадры.

Изменение ширины и высоты кнопки

На Сцене отсутствует одна из кнопок выбора змея, необходимо ее добавить, изменить ее размер и выровнять с остальными.

Эта кнопка в библиотеке имеет больший размер чем кнопки выбора на Сцене. Используйте панель Info для изменения ее размера.

1 | Если панель Info не открыта, выберите Window > Panels > Info или нажмите кнопку Info Panel в правом нижнем углу окна Сцены.
2 | На линейке нажмите первый кадр слоя Pick a Kite Button.
3 | Перетащите на сцену кнопку "rokkaku kite BUTTON" из библиотеки и поместите ее между двумя другими кнопками выбора змеев. Когда сделаете это, кнопки должны выглядеть следующим образом:
4 | В панели Info измените ширину (W) на 54.2 и высоту (H) на 50.0, нажмите Enter (Windows) или Return (Macintosh).

Выравнивание объектов на Сцене

Используйте панель Align для выравнивания объектов между собой и, в частности, Ваших трех кнопок выбора змеев.

1 | На Сцене выделите эти кнопки выбора, поочередно нажимая на каждую и одновременно удерживая клавишу Shift.
 | Playhead должен все еще находиться в первом кадре линейки.
2 | Если панель Align не открыта, выберите Window > Panels > Align.
3 | В панели Align нажмите кнопку Vertical Align Top, третью кнопку справа в верхнем ряду, чтобы выровнять кнопки по их точкам отсчета.
4 | Нажмите кнопку Horizontal Distribute Left, третью кнопку справа в среднем ряду, это равномерно распределит кнопки по горизонтали.
 | В зависимости от того, куда Вы поместили кнопку Rokkaku Kite, может потребоваться дальнейшее выравнивание. Выравнивайте их, используя другие кнопки выравнивания на панели Align, пока не достигнете желаемого результата.

Создание управляющей команды для экземпляра кнопки

Flash позволяет создавать интерактивность, путем добавления команд к клипу. Панель Actions (команды) как раз и предназначена для написания управляющих скриптов на языке ActionScript. Она используется для просмотра, написания, редактирования или ввода команд.

Теперь, используя панель Actions, Вы создадите навигационную команду, которая будет переводить воспроизведение клипа на соответствующий кадр линейки, когда пользователь нажмет кнопку Rokkaku Kite.

1 | На сцене просто выделите кнопку Rokkaku Kite (удерживая Shift нажмите на другие кнопки выбора змеев для отключения их выделения).
 | У Вас осталась выделенной средняя кнопка. Панель Instance может помочь Вам идентифицировать выбранный объект по имени.
 | Playhead должен находиться в первом кадре линейки.
2 | Выберите Window > Actions или нажмите на кнопку Actions в нижнем правом углу окна сцены.
 | Появится панель Object Actions.

Примечание: Когда Вы используете панель Actions для работы с командами вложенными в объект, панель имеет название Object Actions (команды объекта). При работе с командами вложенными в кадр, Flash открывает панель Frame Actions (команды кадра).

3 | Нажмите на треугольник в правом верхнем углу панели для открытия контекстного меню. Удостоверьтесь, что включена опция Normal Mode (нормальный режим), а не Expert Mode (экспертный режим).
 | Экспертный режим предназначен для пользователей, хорошо владеющих языком ActionScript. В Нормальном режиме, поля для ввода параметров помогут Вам в создании команд.
 | В случае необходимости, нажмите треугольник в нижем правом углу панели Object Actions для открытия секции окна с полями ввода параметров. Перемещением вертикальной линейки можно регулировать размеры окна со списком команд и окна скриптов.
4 | Нажмите на значок Actions (команды), чтобы развернуть эту категорию, затем найдите в списке и дважды щелкните на команде goto.
5 | В нижней части окна откройте список Type (тип) и выберите Frame Label (метка кадра).
6 | В списке Frame (кадр) выберите rokkaku.
 | Этим Вы определили, что нажатие кнопки Rokkaku Kite, будет переводить воспроизведение клипа с первого кадра на кадр с меткой rokkaku.
7 | Выключите опцию Go to and Play внизу панели Object Actions.

Определение нужного воздушного змея

В дополнение к команде Go To, добавьте команды, которые покажут нужного воздушного змея, когда пользователь нажмет кнопку Rokkaku Kite.

1 | В списке команд дважды щелкните на setProperty.
2 | В списке Property (свойства), выберите _visible (Visibility)
3 | В поле Target (цель) введите demoKite и убедитесь, что отключена опция Expression (выражение), находящаяся рядом с этим полем ввода.
4 | В поле Value (значение) введите True и включите опцию Expression, находящуюся рядом с этим полем ввода.
5 | В списке команд дважды щелкните на loadMovie.
6 | В поле URL введите r.swf, это имя внешнего файла с изображением нужного бумажного змея.
7 | В списке Location (расположение), выберите Target.
8 | В поле Location введите demoKite.
9 | Удостоверьтесь, что в списке Variables установлено Don't Send и отключены обе опции Expression, после этого закройте панель Actions.

Примечание: Для получения дополнительной информации о командах setProperty и loadMovie, см. ActionScript Help.

Блокировка объектов

Теперь, когда Вы разместили и изменили кнопки, блокируете их, чтобы гарантировать от случайного смещения и редактирования.

1 | В слое Pick a Kite Button на линейке, нажмите черную точку в колонке Lock (блокировка).
 | Вместо точки появится значок замка. Для разблокирования слоя, нажмите на этот значок.


Flash basics overview

Основы Flash > Краткий обзор Flash'а

Краткий обзор Flash'а

Flash-клипы, это графика и анимация для вебсайтов. В первую очередь они состоят из векторной графики, но также могут содержать импортированные растровые рисунки и звуки. Flash-клипы могут быть интерактивными, что позволяет осуществлять ввод данных от пользователей, также можно создавать разветвленные по своей структуре клипы, способными взаимодействовать с другими веб-приложениями. Веб дизайнеры используют Flash для создания элементов навигации, анимированных логотипов, продолжительной по времени анимации с синхронизированным звуковым сопровождением и даже полностью функциональные Flash-сайты. Flash-клипы компактны, состоят из векторной графики, поэтому быстро загружаются и могут масштабироваться под разрешение экрана монитора пользователя.

Возможно вы уже сталкивались с Flash-клипами на многих вебсайтах, включая Disney®, The Simpsons® и Coca-Cola®. Миллионы пользователей сети имеют в своих компьютерах, броузерах или в своем системном программном обеспечении Flash-player, другие загрузили его с сайта компании Macromedia. Установленный на локальном компьютере Flash-player, воспроизводит клипы в броузере или как самостоятельная программа. Это подобно просмотру видео на VCR — Flash-player является устройством отображения Flash-клипов, создаваемых во Flash-редакторе.

Для просмотра интерактивного вступления во Flash, выберите Help > Lessons > Introduction.


The Flash work environment

Основы Flash > Рабочая среда Flash

Рабочая среда Flash

При создании и редактировании клипов приходится работать с такими ключевыми понятиями:

Сцена (The Stage) - прямоугольная область на экране, в которой воспроизводится клип
Монтажная линейка, Линейка (The Timeline) - Место, где создается анимация
Образцы, элементы, символы (Symbols) - составные части клипа многократного использования
Библиотека (The Library window) - место, где хранятся образцы
Муви эксплорер (The Movie Explorer) - инструмент для обзора составляющих клипа и его структуры
Инструментальные панели (Floating, dockable panels) - прилегающие панели, предназначенные для работы с объектами и элементами клипа, и конфигурирования рабочей среды Flash для максимального удобства ее использования.


The Flash work environment

Основы Flash > Рабочая среда Flash > Сцена и Монтажная линейка

Сцена и Монтажная линейка

Как и в кинофильме, Flash-клипы делятся по времени на кадры. Сцена, это та площадка, на которой вы создаете содержимое каждого кадра в клипе, рисуя напрямую в редакторе или импортируя готовую графику извне.

Сцена - место, на которой создается содержимое каждого кадра в клипе.

На Монтажной линейке просходит синхронизация анимации и размещение элементов клипа на отдельных слоях. Линейка показывает каждый кадр в клипе.

На Монтажной линейке просходит синхронизация анимации и размещение элементов клипа на отдельных слоях.

Слои похожи на стопку стеклянных листов, с расположенными на них объектами. Таким образом, различные элементы объединяются в единое изображение.

Логотип, стул и навигационные кнопки расположены в клипе на раздельных слоях.


The Flash work environment

Основы Flash > Рабочая среда Flash > Символы и экземпляры

Символы и экземпляры

Символы это элементы, которые многократно используются в клипе. Символ может быть графическим (graphic), кнопкой (button), мувиклипом (movie clips), звуковым файлом (sound files) или шрифтом (fonts). Когда создается символ, то он помещается в библиотеку. Когда вы размещаете символ на Сцене, то создается экземпляр (instance) символа - полная копия того символа, который находится в библиотеке.

Использование символов сокращает размер файла, т.к. независимо от количества его используемых экземпляров, Flash хранит символ только в одном месте файла. Поэтому удобно использовать символы (анимированные или какие-либо другие), для элемента, который появляется в клипе более одного раза. Вы можете изменить свойства экземпляра не изменяя основной символ или можете редактировать основной символ и тогда вносимые вами изменения коснутся всех экземпляров, используемых в клипе.

Можно редактировать символы прямо на сцене, при этом другие элементы, расположенные на сцене, оказываются приглушенными и недоступными. Также можно редактировать символы в отдельном окне. При редактировании символа в окне линейки показывается только линейка редактируемого символа. Смотрите Редактирование символов.

Можно искать и открывать символы в библиотеке через Movie Explorer, используя команду Find in Library. Смотрите Использование Movie Explorer.

Для получения большей информации о символах и экземплярах, смотрите урок "Символы", находящийся в Help > Lessons > Symbols и Использование символов и образцов.

Редактирование символа отдельно (слева) и непосредственно в клипе.


The Flash work environment

Основы Flash > Рабочая среда Flash > Символы и интерактивные клипы

Символы и интерактивные клипы

Символы также являются неотъемлемой частью создания интерактивных клипов, вы можете использовать образцы символов для создания интерактивности в клипе. Например, создайте символ кнопки, который меняется, реагируя на действия мышки и разместите образец символа на сцене. Для создания более сложных интерактивные клипы, можно использовать такой тип символа, как мувиклип (movie clip). Смотрите Создание интерактивных клипов.


The Flash work environment

Основы Flash > Рабочая среда Flash > Библиотека

Библиотека

Библиотека - то место, где хранятся созданные во Flash символы и импортированные извне файлы, включая звуковые файлы, растровую графику и клипы QuickTime. Окно библиотеки позволяет организовывать ее содержимое в папках, сортировать определенные объекты по их типу. Смотрите Использование библиотеки.


The Flash work environment

Основы Flash > Рабочая среда Flash > Панели

Панели

Для просмотра, организации и изменения элементов во Flash-клипе используются всплывающие панели, содержащие команды и опции, относящиеся к каждому типу элемента. Панели позволяют изменять символы, образцы, цвета, текст, кадры и другие элементы.

Используйте панели для изменения интерфейса Flash'а, выводя не экран нужные и убирая ненужные вам панели. Смотрите Использование панелей.


Creating a new movie and setting its properties

Основы Flash > Создание нового клипа и определение его свойств

Создание нового клипа и определение его свойств

При каждом своем открытии программа создает новый файл с расширением FLA. В процессе работы вы можете создавать дополнительные новые клипы. Для задания размера, частоты кадра, цвета заднего фона и т.п. свойств нового клипа, используется окно диалога Movie Properties.

Создание нового клипа и установка его свойств:

1 | Выберите File > New.
2 | Выберите Modify > Movie. Откроется окно диалога The Movie Properties.
3 | Для задания частоты кадров (Frame Rate), введите количество кадров, воспроизводимых каждую секунду. Для большинства компьютеров, воспроизводящих анимацию, особенно с веба, достаточно иметь 8 - 12 fps (frames per second - кадров в секунду). Первоначально по умолчанию установлено 12 fps.
4 | Для установления размера сцены, выберите одну из следующих опций:
 | Для задания размера в пикселах, введите соответствующее значение ширины (Width) и высоты (Height). Первоначально по умолчанию размер клипа 550 x 400 пикселов. Минимальный размер - 18 х 18 пикселов; максимальный - 2880 x 2880 пикселов.
 | Чтобы установить такой размер сцены, чтобы вокруг содержимого было равное количество свободного места, нажмите Match Contents. Чтобы минимизировать размер клипа, перед использованием Match Contents произведите выравнивание всех элементов по верхнему левому углу сцены.
 | Чтобы установить размер экрана до максимально доступной области для печати, нажмите Match Printer. Эта область зависит от размера бумаги и текущего отступления, выбранного в Margins диалогового окна Page Setup (Windows) или Print Margins (Macintosh).
5 | Чтобы установить цвет заднего фона вашего клипа, выберите цвет из меню Background color.
6 | Выберите единицу измерения из выпадающего меню Ruler Units для измерительных линеек вдоль верхней и боковой стороны рабочего окна. Смотрите Использование сетки, указателей и линейки. (Опция Ruler Units также зависит от единиц, используемых в информационной панели.)
7 | Нажмите OK.


Previewing and testing movies

Основы Flash > Предварительный просмотр и тестирование клипов

Предварительный просмотр и тестирование клипов

Создавая клип, вам может потребуется его воспроизвести для просмотра анимации и тестирования интерактивного управления. Это можно сделать прямо внутри Flash, в отдельном окне или в Веб броузере.


Previewing and testing movies

Основы Flash > Предварительный просмотр и тестирование клипов > Предварительный просмотр клипа в рабочем окружении

Предварительный просмотр клипа в рабочем окружении

Для просмотра клипов используйте команды на Controller'е или команды клавиатуры.

Чтобы просмотреть текущую сцену, сделайте следующее:

Выберите Control > Play.
Выберите Window > Toolbars > Controller (Windows) или Window > Controller (Macintosh) и нажмите Play.
Нажмите Enter (Windows) или Return (Macintosh). Анимация воспроизводится с той частотой кадров, которая была установлена для клипа.
Для покадрового просмотра анимации, используйте кнопки Step Forward и Step Backward, расположенные на Controller'е или выберите эти команды в меню Control. Также вы можете нажимать на клавиатуре кнопки < и >. Чтобы переместиться на первый или последний кадр клипа, используйте кнопки First Frame или Last Frame, расположенные на Controller'е.

Примечание: Для просмотра кадров в клипе можно перемещать проигрывающую головку. Смотрите Перемещение проигрывающей головки.

В меню Control можно изменить воспроизведение клипа. Обратите внимание, что используя следующие команды, вы также должны выбрать Control > Play.

Воспроизведение клипа в зацикленном режиме:

Выберите Control > Loop Playback.

Воспроизведение всех сцен клипа:

Выберите Control > Play All Scenes.

Воспроизведение клипа без звука:

Выберите Control > Mute Sounds.

Для включения команд кадра или кнопки:

Выберите Control > Enable Simple Frame Actions или Enable Simple Buttons.


Previewing and testing movies

Основы Flash > Предварительный просмотр и тестирование клипов > Тестирование клипов

Тестирование клипов

Flash может воспроизводить клип в собственной среде. Много анимационных и интерактивных функций не работают, пока клип не экспортирован в свой заключительный формат. Используя команды в меню Control, вы можете экспортировать текущий клип в формате Flash Player и сразу же воспроизвести в новом окне. Экспортируемый клип использует опции, устанавливаемые в диалоговом окне Publish Settings. Вы также можете использовать это окно для тестирования скорости загрузки. Смотрите Тестирование загрузки клипа. В дополнение можете протестировать клип в броузере.

Также можно протестировать клип, используя Отладчик (Debugger). Смотрите "Использование Отладчика" в главе устранения проблем справки по ActionScript.

Тестирование всех интерактивных функций и анимации:

Выберите Control > Test Movie или Control > Test Scene.

Flash создаст SWF-файл, откроет его в отдельном окне и поиграет с помощью Flash Player'а. Файл SWF размещается в той же директории, где и файл FLA.

Тестирование клипа в броузере:

Выберите File > Publish Preview > HTML. Смотрите Предварительный просмотр.


The Flash workflow

Основы Flash > Работа во Flash

Работа во Flash

Работая во Flash, вы создаете клип, что-либо рисуя или импортируя, размещая это на сцене (Stage) и анимируя с помощью монтажной линейки (TimeLine). Используя специальные команды (actions), указывающие клипу порядок его действия, можно придать ему интерактивность.

По окончании работы, вы экспортируете его в формате Flash Player'a (*.swf), предназначенном для воспроизведения во Flash Player или как отдельный исполняемый файл, содержащий в себе Flash Player.

Воспроизвести Flash-клип можно следующими способами:

В броузерах, таких как Netscape Navigator и Microsoft Internet Explorer, оборудованных Flash Player'ом
С помощью Flash ActiveX компоненты в Microsoft Office, Microsoft Internet Explorer для Windows и других средах, содержащих ActiveX.
Во Flash Player'е - самостоятельной программе.
Как самостоятельный прожектор - исполняемый видео файл, который может быть просмотрен без наличия специального программного обеспечения.

Для получения большей информации смотрите Обзор Публикации и экспорта.


Saving movie files

Основы Flash > Сохранение файлов клипа

Сохранение файлов клипа

Вы можете сохранить исходный FLA-файл, используя его текущее имя и местоположение или сохранить документ, используя другое имя или местоположение. Также можете возвратиться к последней сохраненной версии файла.

Чтобы сохранить документ:

1 | Выполните следующее:
 | Чтобы переписать текущую версию, выберите File > Save.
 | Чтобы сохранить файл в нужное вам место или под другим именем, выберите File > Save As.
2 | Если вы выбираете команду Save As или файл еще не сохранялся ранее, введите имя файла и его местоположение.
3 | Нажмите Save.

Чтобы возвратиться к последней сохраненной версии файла:

Выберите File > Revert.


Using the toolbox

Основы Flash > Использование панели инструментов

Использование панели инструментов

Инструменты, находящиеся в панели инструментов, позволяют рисовать, закрашивать, выделять и изменять графику, а также изменять вид Сцены. Панель инструментов поделена на 4 секции:

Секция Инструменты (Tools) содержит инструменты рисования, закрашивания и выделения.
Секция Вид (View) содержит инструменты масштабирования и панорамирования в окне программы.
Секция Цвета (Colors) содержит модификаторы для цветов штриховки и заливки.
Секция Опции (Options) отображает модификаторы выделенного инструмента, которые влияют на операции рисования и редактирования.

Для получения информации об использовании инструментов рисования и закрашивания, смотрите Инструменты рисования и закрашивания. Для получения информации об использовании инструментов выделения, смотрите Выделение объектов. Для получения информации об использовании инструментов изменения, смотрите Просмотр Сцены.

Чтобы показать или скрыть панель инструментов:

Выберите Window > Tools.

Чтобы выбрать инструмент, сделайте следующее:

Нажмите на инструмент, который хотите использовать. В зависимости от того, какой инструмент вы выбираете, внизу появляется набор свойств для данного инструмента.
Нажмите на клавиатуре комбинацию клавиш, соответствующую нужному вам инструменту.


Using toolbars (Windows)

Основы Flash > Использование линеек инструментов (Windows)

Использование линеек инструментов (Windows)

Для открытия и закрытия линеек инструментов, содержащих значки для меню команд, в Windows используются команды подменю. Также можно закрепить стандартную панель инструментов и панель инструментов для рисования или сделать их "плавающими" поверх окна.

Открытие или закрытие линейки инструментов:

Выберите Window > Toolbars и выберите из следующих опций:

Главная (Main) отображает стандартную линейку, которая содержит ярлыки для таких стандартных команд как Открыть (Open) и Печать (Print).
Статус (Status) показывает строку состояния, содержащую информацию о командах и кнопках, а также состояние клавиш Caps Lock и Num Lock.
Контролер (Controller) показывает панель управления предварительным просмотром клипа.

Перемещение панели инструментов:

Просто перетащите ее в нужное вам место.

Чтобы закрепить панель инструментов, перетащите ее к краю Flash окна. Панель автоматически переключается в горизонтальное положение, когда стыкуется к верхнему или нижнему краям экрана или принимает вертикальный вид, когда стыкуется с левым или правым краями экрана. Чтобы избежать стыковки, удерживайте клавишу Ctrl во время перетаскивания к краю окна.


Using panels

Основы Flash > Использование панелей

Использование панелей

Выплывающие панели помогают просматривать, располагать и изменять элементы в клипе. Опции, доступные на панелях, управляют характеристиками выделенных элементов.

Панели во Flash позволяют работать с объектами, цветами, текстом, образцами, кадрами, сценами и всеми клипами. Например, панель Character используется для работы с текстом, а панель Frame, для введения названия кадра и выбора режима анимации. Чтобы посмотреть полный список доступных в Flash панелей, выберите Window > Panels.

Вы можете отобразить, скрыть, сгруппировать и изменить размер панелей в процессе работы. Также можно показать и скрыть несколько панелей, включая панели Info, Mixer, Instance, Frame и Actions, используя быстрый запуск (Launcher bar) - кнопки, расположенные в правом нижнем углу рабочего окна.

Можно сгруппировывать панели вместе в произвольном порядке, а также сохранять произвольный расклад панелей. Также можно вернуть расклад панелей к принятому по умолчанию (отображая панели Info, Mixer, Character и Instance в правой части окна программы) или к тому раскладу, который вы предварительно сохранили.

Большинство панелей включают в себя выпадающее меню с дополнительными опциями. Выпадающее меню обозначено треугольником в правом верхнем углу панели. (Если треугольник отсутствует, то для данной панели выпадающего меню нет.)

Открыть панель:

Выберите Window > Panels и отметьте нужную панель в списке.

Чтобы закрыть панель, сделайте одно из следующего:

Нажмите на кнопку Закрыть в верхнем правом углу (Windows) или верхнем левом углу (Macintosh).
Выберите Window > Panels и отключите нужную в списке.
Нажмите правой кнопкой мыши (Windows) или Ctr+щелчок (Macintosh) по панели и выберите Close Panel из контекстного меню.

Открытие или закрытие панели, с использованием Launcher bar:

В Launcher bar нажмите кнопку панели Info, Color Mixer, Character, Instance или Actions.

Примечание: Используя Launcher bar, также можно открывать или закрывать окно библиотеки или Movie Explorer. Смотрите Использование библиотеки или Использование Movie Explorer.

Использование опции выпадающего меню панели:

1 | Для открытия меню нажмите на треугольник в правом верхнем углу панели.
2 | Щелкните на пункте меню.

Закрытие всех панелей:

Выберите Window > Close All Panels.

Группировка панелей:

Перетащите панель за ее ярлык к другой панели.

Переключение панели на передний план среди группы других панелей:

Щелкните по поверхности панели.

Выделение панели в отдельное окно:

Перетащите панель за ее ярлык в сторону.

Перемещение панели или группу панелей:

Перетащите панель или группу панелей за их заголовок.

Сохранение расклада панелей:

Выберите Window > Save Panel Layout. Введите название для расклада и нажмите OK.

Удаление расклада:

Откройте папку программы Flash 5 на вашем жестком диске и удалите файл Panel Sets.

Выбор расклада панелей:

1 | Выберите Window > Panel Sets.
2 | Из подменю, выберите Default Layout, чтобы установить расклад панелей по умолчанию или выберите расклад, который вы предварительно сохранили.

Изменение размера панели:

Перетащите нижний правый угол панели (Windows) или перетащите квадрат размера в правом нижнем углу панели (Macintosh).

Свертывание панели или группы панелей (Windows):

Дважды щелкните на ее заголовке, повторите для восстановления размера.

Свертывание панели или группы панелей (Macintosh):

Нажмите на кнопку Свернуть в правой части заголовка окна, повторите для восстановления размера.


Using context menus

Основы Flash > Использование контекстных меню

Использование контекстных меню

Контекстные меню содержат команды, относящиеся к текущему выделенному объекту. Например, когда вы выделяете кадр в окне линейки (Timeline), то контекстное меню содержит команды для создания, удаления и изменения кадров и ключевых кадров.

Контекстное меню для выделенного кадра

Открыть контекстное меню:

Нажмите правой кнопкой мыши (Windows) или Ctrl+щелчок мыши (Macintosh) на объекте на линейке, в Библиотеке или на Сцене.


Using the Timeline

Основы Flash > Использование Монтажной линейки

Использование Монтажной линейки (Timeline)

Монтажная линейка организует и управляет содержимым клипа в слоях и кадрах. Главные составляющие линейки - слои, кадры и воспроизводящая головка.

Слои клипа показаны в колонке в левой части линейки. Кадры каждого слоя отображены в ряд справа от названия слоя. Курсор линейки, находящийся в верхней части, показывает номер кадра. Воспроизводящая головка показывает текущий кадр, отображенный на Сцене.

Статусная строка в нижней части линейки, показывает текущий номер кадра, текущий параметр кадра и время, прошедшее с начала клипа до текущего кадра.

Примечание: Если компьютер не способен воспроизводить анимацию достаточно быстро, показываемое значение кадра может отличаться от показываемого кадра клипа.

Вы можете изменить способ отображения кадров, а также заголовки содержимого кадра. Линейка показывает, где в клипе анимация, включая покадровую анимацию и автоматическую анимацию. Для получения большей информации об анимации, смотрите Создание анимации.

Кнопки управления в разделе слоев позволяют скрыть/показать, заблокировать/разблокировать или отобразить содержимое слоя в виде линий обводки. Смотрите Редактирование слоев.

На линейке можно вставлять, удалять, выделять и перемещать кадры. Также можно перетаскивать кадры на другое место в том же слое или на другой слой. Смотрите Работа с кадрами на Монтажной линейке.


Using the Timeline

Основы Flash > Использование Монтажной Линейки > Настройка внешнего вида Монтажной Линейки

Настройка внешнего вида Монтажной Линейки

По умолчанию Монтажная Линейка появляется в верхней части главного окна, над Сценой. Чтобы изменить ее положение, Вы можете состыковать Монтажную Линейку с основанием или любой стороной главного окна или же показывать ее, как собственное окно. Можно также прятать Монтажную Линейку.

Вы можете изменять размер Монтажной Линейки, чтобы изменять число видимых слоев и кадров. Когда слоев больше, чем может быть показано в Монтажной Линейке, просматривать дополнительные слои можно с помощью линейки прокрутки на правой стороне линейки.

Перемещение Монтажной Линейки:

Перетаскивать мышкой Монтажной Линейку, щелкнув под заголовком.

Перетащите Монтажную Линейку к какой-нибудь стороне главного окна для ее закрепления и она "прилипнет" к ближайшей стороне. Если это нежелательно, удерживайте Ctrl во время перетаскивания.

Изменение размера поля имени слоя:

Потянуть за линию, разделяющую поля имени и область кадров Линейки.

Для изменения размера Монтажной Линейки нужно сделать следующее:

Если Монтажная Линейка закреплена, как часть главного окна, потяните за линию, отделяющую ее от главного окна.
Если Монтажная Линейка не закреплена, как часть главного окна, потяните за нижний правый угол (в Windows) или за область изменения размера в нижнем правом углу (Macintosh).


Using the Timeline

Основы Flash > Использование Монтажной Линейки > Перемещение ползунка

Перемещение ползунка

Ползунок, двигающийся по Монтажной Линейке, призван показывать текущий кадр, отображаемый на Сцене. Заголовок Монтажной Линейки показывает нумерацию кадров, так что для перемещения к нужному кадру Вы просто двигаете ползунок по линейке до номера кадра.

Когда Вы работаете с настолько большим количеством кадров, что все они не отображаются одновременно на Монтажной Линейке, можете поставить ползунок по центру Монтажной Линейки для более удобного отображения текущего кадра.

Для перехода к кадру:

Щелкните на положении кадра в заголовке Монтажной Линейки или просто перетащите ползунок в нужную позицию.

Для центровки ползунка на середине ролика:

Щелкните на кнопке Center Frame внизу Монтажной Линейки.


Using the Timeline

Основы Flash > Использование Монтажной Линейки > Изменение отображения кадров на Монтажной Линейке

Изменение отображения кадров на Монтажной Линейке

Вы можете изменять размер кадров на Монтажной Линейке и просматривать периоды кадров с крашеными ячейками. Вы можете также включать предварительный просмотр содержания кадров на Монтажной Линейке. Эти превьюшки полезны для быстрого обзора содержимого ролика, но они отнимают дополнительное место на экране.

Для изменения режима отображения кадров на Монтажной Линейке:

1 | нажмите кнопку Frame View в верхнем правом углу Монтажной Линейки для открытия меню с режимами отображения кадров.
2 | Выберите одну из следующих опций:
 | Для изменения ширины ячеек кадров, выберите Tiny, Small, Normal, Medium или Large. (Режим Large полезен для детального просмотра звукового содержания.)
 | Для уменьшения высоты ячеек кадров выберите Short.
 | Для включения/выключения подкраски кадровых периодов выберите Tinted Frames.
 | Для отображения предварительного просмотра содержимого каждого кадра, сжатого до размеров ячейки кадра на Монтажной Линейке, выберите Preview. Это может привести к изменению видимого размера ячейки.
 | Для отображения превьюшек каждого кадра, включая пустые, выберите Preview in Context. Это полезно для контроля движения анимированных элементов, но, как правило, такие превьюшки получаются меньше по размеру, чем при выборе опции Preview.
 | Меню режима отображения кадров
 | Опции просмотра Short и Normal
 | Опции Preview и Preview in Context


Using the Timeline

Основы Flash > Использование Монтажной Линейки > Создание меток кадров и комментирование клипов

Создание меток кадров и комментирование клипов

Метки кадров полезны для идентификации кадров на Монтажной Линейке и могут использоваться вместо их номеров в командах типа Go To. Если Вы добавляете или удаляете кадры, метка перемещается вместе с кадром, которому она назначена, какой бы номер не приобретал этот кадр. Метки кадров компилируются вместе с другими данными ролика, так что избегайте длинных меток, чтобы минимизировать размер файла.

Комментарии к кадру полезны как пояснения для себя и, возможно, других разработчиков ролика. Комментарии к кадру не включаются в конечный файл, так что их можно делать сколь угодно длинными.

Для создания метки кадра или комментария:

1 | Выделить кадр и выбрать Window > Panels > Frame.
2 | В панели Frame введите текст для метки кадра или введите комментарий в поле Label. Чтобы сделать текст комментарием, поставьте двойной слэш (//) в начале каждой строки текста.


The Flash workflow

Основы Flash > Работа во Flash > Графика во Flash

Графика во Flash

Flash предоставляет различные методы создания графики и ее импортирования из других программ. Также с помощью инструментов рисования и раскрашивания вы можете создавать новые объекты и изменять параметры имеющихся. См. Рисование и Работа с цветом.

Вы также можете импортировать векторную и растровую графику из других программ и редактировать ее в Flash. См. Использование импортированной графики.

Примечание: Также возможен импорт звуковых файлов, как описано в Добавление звука.


Using the Timeline

Основы Flash > Использование Монтажной линейки > Работа с кадрами на Монтажной линейке

Работа с кадрами на Монтажной линейке

На Монтажной линейке существуют обычные и ключевые кадры. Ключевые кадры - это кадры, в которых вы явно определяете элементы анимации и/или вставляете скрипт для управления анимацией. На монтажной линейке такие кадры выделяются черной точкой. Вы можете изменять продолжительность автоматической анимации, просто перемещая ключевой кадр на монтажной линейке.

Вы можете выполнять следующие действия над кадрами, в том числе и ключевыми:

Вставлять, выбирать, удалять и перемещать кадр
Перетаскивать кадр на новое место в том же слое либо на другой слой
Копировать и вставлять кадр
Преобразовывать ключевые кадры в обычные
Перетаскивать объекты из библиотеки на Сцену для их добавления в текущий кадр

Монтажная линейка способна отображать tweened кадры анимации. Для информации по редактированию tweened кадров, смотрите Создание анимации, краткий обзор.

Для вставки кадров в Монтажную линейку, выполните следующее:

Для вставки нового кадра выберите Insert > Frame.
Для создания нового ключевого кадра выберите Insert > Keyframe, или щелкните правой кнопкой мыши (Control-клик для Macintosh) на нужном кадре и выберите Insert Keyframe из контекстного меню.
Чтобы создать новый пустой ключевой кадр, выберите Insert > Blank Keyframe или щелкните правой кнопкой мыши (Control-клик для Macintosh) на нужном кадре и выберите Insert Blank Keyframe из контекстного меню.

Для удаления или изменения любого кадра выполните следующее:

Для удаления кадра, ключевого кадра или последовательности кадров выделите нужные кадры и выберите Insert > Remove Frame или щелкните правой кнопкой мыши (Control-клик для Macintosh) и выберите Remove из контекстного меню. Соседние кадры останутся без изменений.
Для перемещения кадра или последовательности кадров и их содержимого, перетащите нужные кадры в требуемое место.
Для увеличения протяженности ключевого кадра перетащите нужный кадр, удерживая Alt (Windows) или Option (Macintosh) в кадр, долженствующий ограничить протяженность.
Чтобы скопировать ключевой кадр или последовательность кадров, перетащите нужный кадр (кадры), удерживая Alt (Windows) или Option (Macintosh) на новое место.
Чтобы скопировать и вставить кадр или последовательность кадров, выделите нужное и выберите Edit > Copy Frames. Выделите кадр или последовательность кадров, предназначенные для замены, и выберите Edit > Paste Frames.
Для конвертации ключевого кадра в обычный выделите кадр и выберите Insert > Clear Keyframe или щелкните правой кнопкой мыши (Control-клик для Macintosh) и выберите Clear Keyframe из контекстного меню. Тогда этот ключевой кадр и все последующие кадры вплоть до следующего ключевого заполнятся содержимым предыдущего ключевого кадра.
Для изменения длительности tweened анимации, перетащите первый или последний кадры влево или вправо. Для изменения длительности покадровой анимации смотрите Создание покадровой анимации.
Чтобы добавить объект из библиотеки в текущий ключевой кадр, перетащите объект из окна библиотеки в нужный кадр на Сцене.


Using scenes

Основы Flash > Использование сцен

Использование сцен

Для тематической организации роликов вы можете использовать сцены. Например, можно использовать различные сцены для заставки, сообщения о загрузки и прочего.

Когда вы опубликовываете ролик, содержащий в себе более одной сцены, сцены в SWF-файле воспроизводятся в одной последовательности в том порядке, в котором они представлены в панели Scene в FLA-файле. Кадры в SWF файле имеют сквозную нумерацию через все сцены. Например, если ролик содержит две сцены по 10 кадров, то кадры во второй сцене будут иметь номера 11-20.

Вы можете добавлять, удалять, дублировать, переименовывать и изменять порядок сцен.

Для остановки или паузы ролика в конце каждой сцены или для обеспечения нелинейной навигации по ролику, используете скрипты. Смотрите Создание интерактивных роликов, краткий обзор.

Панель Scene

Для отображения панели Scene:

Выберите Window > Panels > Scene.

Для просмотра отдельной сцены:

Выберите View > Goto, затем выберите название сцены из подменю.

Чтобы добавить новую сцену, выполните следующее:

Нажмите Add Scene в панели Scene.
Выберите Insert > Scene.

Для удаления сцены, выполните следующее:

Выберите кнопку Delete Scene в панели Scene.
Откройте сцену, которую вы хотите удалить и выберите Insert > Remove Scene.

Для изменения названия сцены:

Дважды щелкните на названии сцены в панели Scene и введите новое название.

Для дублирования сцены:

Нажмите кнопку Duplicate Scene в панели Scene.

Для изменения порядка следования сцен в ролике:

Перетащите нужную сцену в нужное место в панели Scene.


Using the library

Основы Flash > Использование библиотек

Использование библиотек

Библиотека, входящая в Flash ролик, хранит символы, и те, которые созданы непосредственно в ролике, и те, которые были импортированы, и позволяет просматривать и организовывать элементы библиотеки для работы. Окно библиотеки содержит полный список элементов. Значок, следующий за названием элемента, показывает тип элемента.

Когда вы выбираете какой-либо объект в библиотеке, в верхней части окна библиотеки появляется возможность предварительного просмотра выбранного элемента. Если выбранный объект представляет собой анимацию или звуковой файл, можно использовать кнопку Play в окне предварительного просмотра.

Вы можете организовывать объекты библиотеки в папки. Столбцы окна библиотеки отображают название объекта, его тип, количество раз использования его в ролике, способ включения объекта в библиотеку (если объект ассоциирован с подключенной библиотекой), и дата последней модификации. Вы можете сортировать объекты в библиотеке по любому столбцу. Окно библиотеки также содержит выпадающее меню Options с опциями, позволяющими модифицировать объекты библиотеки.

Для редактирования объектов библиотеки, включая импортированные файлы, используйте меню Options. Вы можете обновлять импортированные файлы после редактирования их во внешнем редакторе, используя команду Update в меню Options.

Вы можете открывать библиотеку в любом файле FLA во время работы в Flash, чтобы сделать объекты библиотеки доступными для текущего ролика.

Вы можете создавать постоянные библиотеки во Flash, доступные в любой момент работы. Flash также включает несколько уже готовых библиотек, содержащих кнопки, картинки, клипы и звуки, которые вы можете добавлять в собственные ролики. Встроенные библиотеки Flash и постоянные библиотеки, созданные вами, отображаются в меню Window > Common Libraries. Смотрите Работа с общими библиотеками.

Вы можете экспортировать библиотеку по определенному адресу URL для создания подключаемой библиотеки, что позволит вам подсоединять множество объектов такой библиотеки к любому ролику. Смотрите Использование подключаемых библиотек.

Для отображения окна библиотеки, выполните следующее:

Выберите Window > Library.
Нажмите кнопку Library в нижней правой части рабочего окна.

Для использования объектов библиотеки в текущем ролике:

Перетащите объект из окна библиотеки на сцену. Объект будет добавлен в текущий слой.

Для открытия библиотеки из другого файла Flash:

1 | Выберите File > Open as Library.
2 | Выберите Flash file, в котором находится требуемая библиотека и кликните Open.

Библиотеки выбранных файлов откроются в текущем ролике с именами файлов вверху окна библиотеки. Для использования объектов выбранной библиотеки в текущем ролике перетаскивайте нужные объекты в окно библиотеки текущего ролика.

Для изменения размера окна библиотеки выполните следующее:

Перетаскивайте нижний правый угол.
Кликните кнопку Wide State для расширения окна Library так, чтобы были видны все колонки.
Кликните кнопку Narrow State для сужения окна библиотеки до столбца имен.

Для изменения ширины колонок:

Расположите указатель мыши между заголовками колонок и тяните разделитель в нужном направлении. Вы не можете менять порядок следования колонок.

Для использования меню Library Options:

1 | Кликните по треугольнику в верхнем правом углу окна библиотеки для открытия выпадающего меню.
2 | Кликните по нужному пункту меню.


Using the library

Основы Flash > Использование библиотек > Работа с папками в окне библиотеки

Работа с папками в окне библиотеки

Можно упорядочивать объекты в окне библиотеки, используя папки, подобно тому, как это делается в Windows Explorer или Macintosh Finder. Когда вы создаете новый клип, он помещается в выбранную папку. Если не выбрана никакая папка, клип помещается в корневой список библиотеки.

Для создания новой папки:

Нажмите кнопку New Folder в нижней части окна библиотеки.

Для перемещения объектов из папки в папку:

Перетащите объект из одной папки в другую.

Для того, чтобы открыть или закрыть папку, выполните следующее:

Дважды щелкните на папке.
Выберите нужную папку и выберите Expand Folder или Collapse Folder из меню окна библиотеки.

Для открытия или закрытия всех папок:

Выберите Expand All Folders или Collapse All Folders из меню окна библиотеки.


Using the library

Основы Flash > Использование библиотек > Сортировка объектов в окне библиотеки

Сортировка объектов в окне библиотеки

Вы можете сортировать объекты в окне библиотеки по алфавиту в любой колонке. Сортировка объектов позволит вам просматривать сходные объекты вместе. Объекты сортируются внутри папок.

Для сортировки объектов в окне библиотеки:

Щелкните на заголовке колонки для сортировки по данной колонке. Щелкните треугольную кнопку с правой стороны заголовка колонки для обращения порядка сортировки.


Using the library

Основы Flash > Использование библиотек > Редактирование объектов библиотеки

Редактирование объектов библиотеки

Вы можете редактировать объекты в библиотеке или, в случае импортированного файла, во внешнем редакторе.

Для редактирования объекта в библиотеке:

1 | Выберите объект в окне библиотеки.
2 | Выберите одно из следующего в меню Library Options:
 | Выберите Edit для редактирования объекта во Flash.
 | Выберите Edit With и приложение, которое будет использовано как внешний редактор.


Using the library

Основы Flash > Использование библиотек > Переименование объектов библиотеки

Переименование объектов библиотеки

Можно переименовывать объекты в библиотеке. Изменение названия объекта в библиотеке не меняет имени файла.

Чтобы переименовать объект библиотеки, выполните следующее:

Дважды щелкните на названии объекта и введите новое название в текстовом поле.
Выберите объект и щелкните на значке свойств в нижней части окна библиотеки. Введите новое название объекта в диалоговом окне Symbol Properties и нажмите OK.
Выберите объект и пункт Rename из меню Library Options, затем введите новое название объекта в текстовом поле.
Щелкните левой кнопкой мыши (Windows) или удерживайте Control (Macintosh) на объекте и выберите Rename из контекстного меню, затем введите новое название объекта в текстовом поле.


Using the library

Основы Flash > Использование библиотек > Удаление объектов библиотеки

Удаление объектов библиотеки

Когда вы удаляете объект из библиотеки, все экземпляры или места размещения объекта также удаляются. Колонка Use Count в окне библиотеки показывает, сколько раз использован объект.

Для удаление объекта библиотеки:

Выберите объект и щелкните на значке мусорной корзины в нижней части окна библиотеки.


Использование библиотек

Основы Flash > Использование библиотек > Поиск неиспользуемых объектов библиотеки

Поиск неиспользуемых объектов библиотеки

Для уменьшения размера FLA файла можно отобрать неиспользуемые объекты библиотеки и удалить их. Однако, обычно это не приводит к уменьшению размера SWF файла, поскольку неиспользуемые в ролике объекты не включаются в публикацию.

Примечание Георгия Сторма (переводчика). Иногда все же полезно очищать библиотеку от ненужных элементов перед публикацией, поскольку на сцене могут оставаться фантомные включения когда-то помещенных, а потом, по небрежности, не полностью удаленных объектов. Так бывает при невнимательном использовании команды Break Apart :)

Для поиска неиспользуемых элементов выполните следующее:

Выберите пункт Select Unused Items из меню Options.
Отсортируйте объекты библиотеки с помощью столбца Use Count. Смотрите Сортировка объектов в окне библиотеки.


Using the library

Основы Flash > Использование библиотек > Обновление импортированных файлов в окне библиотеки

Обновление импортированных файлов в окне библиотеки

Если вы используете внешний редактор для редактирования файлов, импортированных в Flash, таких как растровые изображения или звуковые файлы, можете обновлять такие файлы прямо из Flash без необходимости их реимпорта.

Для обновления импортированных файлов:

Выберите импортированный файл в окне библиотеки, затем выберите пункт Update from the Library в меню Options.


The Flash workflow

Основы Flash > Работа во Flash > Анимация во Flash

Анимация во Flash

Используя Flash, можно анимировать объекты, перемещать их по Сцене и/или менять форму, размер, цвет, прозрачность, вращение и другие их свойства. Можно создать покадровую анимацию, содержащую отдельные изображения для каждого кадра. Также можно создать автоматическую анимацию, в которой указываются первый и последний кадры анимации, а Flash Playr при воспроизведение сам просчитывает кадры между ними. См. Создание анимации.

Вы также можете создавать анимацию в клипах, используя команду Set Property. Подробнее смотрите справку по ActionScript.


Using the library

Основы Flash > Использование библиотек > Работа с общими библиотеками

Работа с общими библиотеками

Можете использовать встроенные библиотеки, поставляемые с Flash для добавления клипов, кнопок или звуков в ваши ролики. Вы можете также создавать постоянные библиотеки для Flash, которые могут быть использованы в любых, создаваемых вами роликах. (Библиотеки, которые создаются вместе с роликом, доступны только в данном ролике, если вы не делаете такую библиотеку общей (постоянной) или не используете команду File > Open As Library.)

Оба типа библиотек можно увидеть в подменю Window > Common Libraries.

Для создания постоянной библиотеки:

1 | Создайте Flash file с библиотекой, содержащей символы, которые вы хотите включить в постоянную библиотеку.
2 | Поместите Flash file в папку Libraries, размещенную в папке с установленным Flash на вашем жестком диске.

Для использования объекта из общей библиотеки в ролике:

1 | Выберите Window > Common Libraries, затем выберите нужную библиотеку из подменю.
2 | Перетащите нужный объект из общей библиотеки в библиотеку для текущего ролика.


Using shared libraries

Основы Flash > Использование подключаемых библиотек

Использование подключаемых библиотек

Можно создавать подключаемые библиотеки, чтобы использовать их компоненты во многих Flash роликах. Для использования подключаемой библиотеки вы объявляете компоненты подключаемой библиотеки в одном ролике, а потом подключаете эти компоненты к другим роликам. Когда вы подсоединяете компоненты подключаемой библиотеки, это выглядит как ссылка на внешний файл, и файл с компонентами не включается в ролик.

Использование подключаемых библиотек может оптимизировать ваш рабочий процесс и управление наборами ваших компонентов различными способами. Например, вы можете использовать подключаемые библиотеки для:

использования одного звукового файла по всему сайту
использования одного шрифтового символа в нескольких сайтах (о шрифтовых символах подробнее здесь: Создание шрифтовых символов)
использования одного источника для какого-либо элемента анимации, используемого во многих сценах или роликах
создания центральной библиотеки ресурсов с целью трассировки и контроля

О создании и подсоединении подключаемых компонентов

Чтобы создать подключаемую библиотеку, которую вы могли бы использовать с другими роликами, вы устанавливаете опции подсоединения для элементов в библиотеке ролика. Когда вы сохраняете ролик, подключаемая библиотека сохраняется вместе с FLA-файлом.

Чтобы использовать компоненты из подключаемой библиотеки, выберите File > Open As Shared Library в текущем ролике и выберите нужный файл с подключаемой библиотекой. Подключаемая библиотека откроется, как окно обычной библиотеки в текущем ролике. Затем вы добавляете компоненты из подключаемой библиотеки в библиотеку текущего ролика, чтобы создать линки на подключаемые компоненты.

Вы должны поместить распределенную библиотеку на вебсервер вместе с роликами, использующими ее, с тем, чтобы подключенные элементы могли быть использованы. Для публикации подключаемой библиотеки на вебсервере нужно опубликовать ролик, в котором вы создали подключаемую библиотеку. Эта процедура размещает распределенную библиотеку по тому же адресу, где располагаются SWF-файлы. (Вы можете задать другое размещение распределенной библиотеки, если желаете.)

Когда воспроизводится ролик, содержащий ссылки на подключаемые компоненты, он загружает распределенную библиотеку из указанного места на вебсервере и использует подключенные компоненты. Ролик подгружает подключаемую библиотеку полностью, как только достигает первого кадра, имеющего ссылку на подключенный элемент. (Если ролик содержит ссылки более чем на одну подключаемую библиотеку, каждая библиотека подгружается независимо, в момент, когда появляется первый элемент из данной библиотеки.)

Если при подгрузке подключаемой библиотеки происходит ошибка, ролик не будет воспроизводиться. Рекомендуется делать подключаемые библиотеки как можно меньшими для уменьшения времени загрузки, также полезно делать тестовые ролики с подключением нужных библиотек для проверки правильности их подгрузки.

Определение компонентов подключаемой библиотеки

Используете диалоговое окно Symbol Linkage для установки опций подключения к существующим элементам библиотеки, для определения элементов библиотеки как компонентов подключаемой библиотеки. После установления опций подключения необходимо сохранить файл ролика, в котором вы это сделали, для того, чтобы сделать подключаемые компоненты доступными для подключения из других роликов.

Также можете использовать Symbol Linkage для объявления имени-идентификатора для мувика или звукового файла, предназначенного для воспроизведения с использованием метода attachMovie или attachSound. Для дополнительной информации по методу attachMovie , смотрите "Присоединение мувиков" в разделе мувиков справки по ActionScript. Для информации о методе attachSound, смотрите "Создание элементов управления звуком" в разделе по интерактивности справки по ActionScript.

Для определения компонентов подключаемой библиотеки:

1 | В открытом файле ролика выберите Window > Library или нажмите на кнопке Library в линейке запуска (в нижнем правом углу окна приложения) для отображения окна библиотеки, если она еще не видна.
2 | Выполните одно из следующих действий:
 | Выберите нужный элемент в окне библиотеки, затем Linkage из меню опций библиотеки.
 | Выполните правый клик (Windows) или клик с Control (Macintosh) на элементе в окне библиотеки, затем выберите Linkage из контекстного меню.
3 | В диалоговом окне Symbol Linkage Properties выберите Export This Symbol.
4 | В текстовом поле Identifier введите имя-идентификатор для элемента. (Не используйте пробелы при вводе.)
5 | Нажмите OK.
6 | Сохраните файл с роликом.

О публикации подключаемой библиотеки на вебсервер

Подключаемая библиотека должна быть размещена на сервере как SWF-файл, для того, чтобы подключенные компоненты были доступны из ролика, содержащего ссылки на них. Когда вы публикуете ролик, содержащий подключаемую библиотеку (т.е. ролик, в котором вы объявили подключаемую библиотеку), подключаемая библиотека автоматически включается в SWF-файл ролика.

Вам не нужно указывать URL для подключаемой библиотеки для включения библиотеки в SWF-файл ролика. Однако, вы можете указывать другой URL для подключаемой библиотеки, если требуется разместить библиотеку в другом месте.

Для указания URL подключаемой библиотеки:

1 | В окне библиотеки выберите Shared Library Properties из меню Library Options.
2 | В диалоговом окне Shared Library Properties введите URL, по которому будет находиться подключаемая библиотека.
3 | Нажмите OK.

Подсоединение компонентов подключаемой библиотеки

Для подсоединения компонентов подключаемой библиотеки, вы открываете файл с библиотекой и добавляете элементы из подключаемой библиотеки в библиотеку текущего ролика.

Для создания ссылок на подключаемые компоненты, вы открываете FLA-файл подключаемой библиотеки. Нет необходимости осуществлять публикацию подключаемой библиотеки как SWF-файл, чтобы создать ссылки на подключаемые компоненты.

Примечание: Для предварительного просмотра подсоединенных компонентов во время тестирования ролика или для отображения подсоединенных компонентов во время воспроизведения, необходимо сначала создать SWF-файл для подключаемой библиотеки. Чтобы создать SWF-файл для подключаемой библиотеки, вы публикуете ролик, в котором объявлена нужная подключаемая библиотека.

Для подсоединения компонентов подключаемой библиотеки:

1 | В открытом окне ролика выберите File > Open As Shared Library.
2 | Выберите нужную подключаемую библиотеку и нажмите Open.
 | Подключаемая библиотека откроется, как окно библиотеки в текущем ролике. Команды меню Options в окне подключаемой библиотеки будут серыми, что означает, что они недоступны.
3 | Для подсоединения компонентов из подключаемой библиотеки в текущий ролик, выполните одно из следующий действий:
 | Перетащите нужный компонент из подключаемой библиотеки в библиотеку текущего ролика.
 | Перетащите нужный компонент из подключаемой библиотеки на Сцену.
 | Название подключаемого компонента появится в окне библиотеки текущего ролика. Компонент подключен к текущему ролику как внешний файл; он не становится частью текущего ролика.


Using the Movie Explorer

Основы Flash > Использование Movie Explorer

Использование Movie Explorer

Movie Explorer представляет из себя простое средство для просмотра и упорядочивания содержимого ролика и выбора отдельных элементов ролика для редактирования. Он предлагает множество возможностей для организации работы по созданию роликов. Например, вы можете использовать Movie Explorer, чтобы делать следующее:

Искать элемент в ролике по имени
Вызывать панель свойств для выбранного элемента для внесения изменений
Знакомиться со структурой Flash ролика, созданного другим разработчиком
Находить все экземпляры отдельного символа или скрипта
Заменять все тексты, набранные одним шрифтом на другой шрифт
Просматривать пары имена/значения для объектов Macromedia Generator
Копировать текст в буфер для вставки во внешний текстовый редактор для проверки орфографии
Распечатывать список объектов, отображаемый в настоящий момент в Movie Explorer

Movie Explorer содержит список содержимого ролика, составленного в виде иерархического дерева. Можно отфильтровывать различные категории элементов ролика, отображаемых в Movie Explorer, выбирая из текста, графики, кнопок, мувиков, скриптов, импортированных файлов и объектов Generator. Можно просматривать выбранные категории как элементы ролика (сцен), описания символов, или все вместе. Можно раскрывать и сворачивать дерево навигации.

Movie Explorer имеет всплывающее меню опций и контекстное меню для выполнения различных операций над выбранными элементами или изменения режима отображения в Movie Explorer. Всплывающее меню опций вызывается по нажатии треугольной кнопки в правом верхнем углу окна Movie Explorer.

Для вызова Movie Explorer:

Выберите Window > Movie Explorer.

Для включения фильтров категорий элементов, отображаемых в Movie Explorer:

Нажмите одну или более кнопок фильтров справа от надписи Show для отображения текста, символов, скриптов, импортированных файлов, кадров или слоев. Для дополнительной настройки элементов, нужных для просмотра, нажмите кнопку Customize. Выберите желаемые опции в диалоговом окне Movie Explorer Settings для отображения таких элементов.
Из всплывающего меню в верхнем правом углу Movie Explorer выберите Show Movie Elements для отображения элементов в сценах; выберите Show Symbol Definitions для отображения описаний символов. (Обе опции могут быть включены одновременно.)

Для поиска элементов с использованием поля Find:

В поле Find введите название элемента, шрифта, строки скрипта, номера кадра или пару имя/значение объекта Generator. Find будет искать все элементы, в настоящее время отображаемые в Movie Explorer.

Для выбора элемента в Movie Explorer:

Щелкните по элементу в дереве навигации. Для выбора более одного элемента при щелчке удерживайте Shift.

Полный путь к выбранному элементу будет отображен в нижней части Movie Explorer. Выбор сцены в Movie Explorer показывает первый кадр этой сцены. Выбор элемента в Movie Explorer выбирает элемент на сцене, если слой, содержащий элемент, не заблокирован.

Для использования всплывающего меню Movie Explorer или команд контекстного меню:

1 | Выполните одно из следующего:
 | Для вызова всплывающего меню щелкните по треугольнику в правом верхнем углу Movie Explorer.
 | Для вызова контекстного меню сделайте правый клик (Windows) или Control-клик (Macintosh) на элементе в навигационном дереве Movie Explorer.
2 | Выберите опцию из меню:
 | Goto Location перенесет вас на нужный слой, сцену или кадр в ролике.
 | Goto Symbol Definition переходит к описанию символа для символа, выбранного в списке элементов в Movie Explorer. Описание символа содержит список всех файлов, ассоциированных с символом. (Опция Show Symbol Definitions должна быть выбрана. Подробности ниже.)
 | Select Symbol Instances переносит к сцене, содержащей экземпляры символа, выбранного в поле описания символа. (Опция Show Movie Elements должна быть включена. Подробности ниже.)
 | Find in Library подсвечивает выбранный символ в библиотеке ролика (Flash сам откроет окно библиотеки, если оно не было открыто).
 | Properties открывает соответствующую панель или панели для выбранных элементов. (Некоторые элементы могут иметь более одной ассоциированной с ним панели.)
 | Rename позволяет вам ввести новое имя для выбранного элемента.
 | Edit in Place позволяет редактировать выбранный символ прямо на Сцене.
 | Edit in New Window позволяет редактировать выбранный символ в новом окне.
 | Show Movie Elements показывает элементы вашего ролика, сгруппированные по сценам.
 | Show Symbol Definitions показывает все элементы, ассоциированные с символом.
 | Copy Text to Clipboard копирует выбранный текст в буфер обмена. Вы можете вставлять текст во внешний текстовый редактор для проверки орфографии и других операций.
 | Cut, Copy, Paste, и Clear выполняют соответствующие операции над выбранным элементом. Модификация элемента в списке модифицирует соответствующий элемент в ролике.
 | Expand Branch разворачивает дерево навигации на выбранном элементе.
 | Collapse Branch сворачивает дерево навигации на выбранном элементе.
 | Collapse Others сворачивает все ветви на дереве навигации, не содержащие выбранный элемент.
 | Print печатает иерархический список элементов, в настоящий момент отображаемый в Movie Explorer.


Viewing the Stage

Основы Flash > Просмотр Сцены

Просмотр Сцены

Для изменения вида Сцены вы можете изменять масштаб или перемещать Сцену в рабочем окружении Flash. Также возможно менять вид Сцены с помощью команд View.


Viewing the Stage

Основы Flash > Просмотр Сцены > Масштабирование

Масштабирование

Вы можете просматривать всю Сцену на экране, или же часть ее при большом увеличении, с помощью изменения масштаба. Степень максимального увеличения зависит от разрешения вашего монитора и размера ролика.

Для увеличения или уменьшения масштаба Сцены используйте следующие приемы:

Для увеличения определенного элемента выберите инструмент Zoom и щелкните им на нужном элементе. Для переключения инструмента Zoom между уменьшением/увеличением используйте модификаторы Reduce или Enlarge соответственно или удерживайте клавишу Alt (Windows) или Option (Macintosh).
Для увеличения области, с которой вы сейчас работаете, очертите данную область прямоугольником, используя инструмент Zoom. Flash установит степень увеличения так, что выделенная область заполнит все окно.
Для изменения масштаба всей сцены выберите View > Zoom In или View > Zoom Out.
Для установления определенного масштаба в процентах выберите View > Magnification и выберите нужный процент в выпадающем подменю, или выберите нужный процент в левом нижнем углу окна приложения.
Для отображения содержимого текущего кадра выберите View > Magnification > Show All, или выберите Show All в нижнем левом углу окна приложения. Если Сцена пуста, будет отображена вся Сцена.
Для отображения всей Сцены выберите View > Magnification > Show Frame или выберите Show Frame в нижнем левом углу окна приложения.
Для отображения рабочей области, окружающей Сцену, выберите View > Work Area. Рабочая область будет показана светло-серым фоном. Используйте команду Work Area для просмотра элементов, частично или полностью лежащих вне сцены. Например, чтобы получить птичку, влетающую в кадр, первоначальная позиция птички должна быть вне сцены и располагаться в рабочем пространстве.


Viewing the Stage

Основы Flash > Просмотр Сцены > Прокрутка сцены

Прокрутка сцены

Когда Сцена укрупнена, вы можете не видеть ее полностью. Инструмент Hand позволит вам прокручивать Сцену до нужного места без изменения масштаба просмотра.

Для прокрутки:

1 | Выберите инструмент Hand. Для временного переключения между различными инструментами и инструментом Hand, удерживайте пробел, выбирая инструмент из набора.
2 | Перетаскивайте сцену.


Using the grid, guides, and rulers

Основы Flash > Использование сетки, направляющих и линеек

Использование сетки, направляющих и линеек

Когда сетка отображается в ролике, она выглядит как линии, проведенные поверх всей сцены. Вы можете выравнивать объекты по сетке, а также изменять размер сетки и цвет ее линий.

Когда линейки отображаются в окне ролика, они появляются сверху и слева от окна. Вы можете выбирать единицы измерения для линеек. Если линейки включены, то когда вы двигаете какой-либо элемент по сцене, специальные линии на линейках показывают краевые размеры движимого элемента.

Когда линейки отображаются в окне ролика, вы можете вытаскивать в окно ролика направляющие, нажав на линейке и протащив курсор до нужной позиции. Вы можете перемещать направляющие, блокировать их, скрывать и удалять. Также можно менять цвет направляющих и выравнивать по ним объекты. Перемещаемые направляющие существуют только на той монтажной линейке, на которой были созданы.

Примечание: Для создания направляющих специальной формы вы можете использовать опорные слои направляющих. Смотрите Использование опорных слоев.

Для включения/выключения отображения направляющих:

Выберите View > Rulers.

Для установки единиц измерения направляющих:

1 | Выберите Modify > Movie.
2 | Выберите нужную опцию из всплывающего меню Ruler Units.

Для включения/выключения отображения сетки или направляющих:

Выберите View > Grid > Show Grid or View > Guides > Show Guides.
Выберите View > Grid > Edit Grid or View > Guides > Edit Guides, и выберите Show Grid или Show Guides в диалоговом окне.

Примечание: Если сетка видна и опция Snap to Grid включена, то направляющие, которые вы создаете, будут "прилипать" к сетке.

Для включения/выключения "прилипания" к направляющим или сетке, выполните одно из следующего:

Выберите View > Grid > Snap to Grid или View > Guides > Snap to Guides.
Выберите View > Grid > Edit Grid или View > Guides > Edit Guides, и выберите Snap to Grid или Snap to Guides в диалоговом окне.

Примечание: "Прилипание" к направляющим имеет преимущество перед "прилипанием" к сетке, если направляющая помещена между ячейками сетки.

Для настройки степени "прилипания" к сетке или направляющим:

1 | Выберите View > Grid > Edit Grid или View > Guides > Edit Guides.
2 | Выберите нужную опцию из выпадающего меню Snap Accuracy в диалоговом окне.

Для изменения цвета сетки или направляющих:

1 | Выберите View > Grid > Edit Grid или View > Guides > Edit Guides.
2 | Щелкните по цветному квадратику и выберите нужный цвет из палитры.
 | По умолчанию сетка имеет серый цвет, а направляющие - зеленый.

Для изменения размеров ячейки сетки:

1 | Выберите View > Grid > Edit Grid.
2 | В диалоговом окне Grid введите нужные значения для вертикального и горизонтального размеров ячейки сетки и нажмите ОК.

Для перемещения направляющей:

Используйте инструмент Arrow (стрелка) для перетаскивания направляющей.

Для блокировки направляющих или для их удаления:

Выберите View > Guides > Edit Guides, затем Lock Guides или Clear All и нажмите OK.

Примечание: Команда Clear All Guides удаляет все направляющие с текущей сцены.

Для удаления направляющей:

Если направляющие разблокированы, используйте инструмент Arrow для перетаскивания направляющих обратно на линейку.


Customizing keyboard shortcuts

Основы Flash > Настройка горячих клавиш

Настройка горячих клавиш

Можно настраивать комбинации клавиш в Flash аналогично комбинациям, используемым вами в других программах. По умолчанию Flash использует встроенный набор комбинаций, разработанный для Flash. Вы также можете выбирать встроенные наборы комбинаций клавиш, соответствующие наборам популярных графических приложений, таких как Fireworks, Adobe Illustrator и Adobe Photoshop.

Для создания специального набора горячих комбинаций вы можете сделать дубликат существующего, а затем добавлять и удалять из него отдельные комбинации. Вы можете удалить любой созданный набор.

Для выбора набора комбинаций клавиш:

1 | Выберите Edit > Keyboard Shortcuts.
2 | В диалоговом окне Keyboard Shortcuts dialog box, выберите нужный набор комбинаций клавиш из выпадающего меню Current Set.

Для создания нового набора комбинаций:

1 | Выберите набор комбинаций клавиш как описано выше.
2 | Выберите кнопку Duplicate Set.
3 | Введите название для нового набора и кликните OK.

Для переименования созданного набора горячих клавиш:

1 | В диалоговом окне Customize Shortcuts dialog box выберите набор из выпадающего меню Current Set.
2 | Выберите кнопку Rename Set.
3 | В диалоговом окне Rename dialog box введите название для нового набора и кликните OK.

Примечание: Вы не можете переименовывать встроенные наборы горячих клавиш.

Для добавления или удаления горячих клавиш:

1 | Выберите Edit > Keyboard Shortcuts и выберите набор для редактирования.
2 | Выберите Drawing Menu Commands, Drawing Tools, или Test Movie Menu Commands из выпадающего меню Commands для просмотра горячих комбинаций в выбранной категории.
3 | В списке Commands выберите команду, нужную для добавления или удаления из набора.
 | Описание выбранной команды появится в окне Description.
4 | Выполните одно из следующего:
 | Для добавления комбинации, нажмите кнопку Add Shortcut (+).
 | Для удаления комбинации, нажмите кнопку Remove Shortcut (-) и переходите к шагу 6.
5 | Если вы добавляете комбинацию, введите ее саму в текстовом окне Press Key.

Примечание: Для ввода комбинации клавиш просто наберите ее на клавиатуре. Вам нет нужды прописывать названия отдельных клавиш, таких как Control, Option и так далее.

6 | Выберите Change.
7 | Повторите эту процедуру для добавления или удаления дополнительных комбинаций клавиш.
8 | Выберите OK.

Для удаления набора горячих клавиш:

1 | Выберите Edit > Keyboard Shortcuts. В диалоговом окне Customize Shortcuts нажмите кнопку Delete Set.
2 | В диалоговом окне Delete Set выберите нужный набор клавиш и нажмите Delete.

Примечание: Вы не можете удалять встроенные наборы горячих клавиш, поставляемые с Flash.


Printing Flash files as you edit movies

Основы Flash > Печать Flash изображений

Печать Flash изображений

Вы можете распечатать кадры из FLA файлов для предварительного просмотра.

Вы также можете указывать кадры, предназначенные для распечатки из Flash Player с помощью проигрывателя Flash роликов. Смотрите Создание клипов для печати..

Во время распечатки кадров из FLA файла вы используете диалоговое окно Print для указания нужной сцены или кадра для печати, а также количество копий. В Windows диалоговое окно Page Setup позволяет указать формат бумаги, ее ориентацию и множество других опций печати — включая отступы и будут ли все кадры распечатаны на каждой странице. На Macintosh подобные опции поделены между диалоговыми окнами Page Setup и Print Margins.

Диалоговые окна Print и Page Setup стандартны внутри обоих операционных систем, а их внешний вид зависит от выбранного драйвера принтера.

Для установления опций печати:

1 | Выберите File > Page Setup (Windows) или File > Print Margins (Macintosh).
2 | Установите отступы на странице. Выберите опцию Center для печати кадра по центру страницы.
3 | В выпадающем меню Frames выберите print all frames in the movie или only the first frame для каждой сцены.
4 | В выпадающем меню Layout выберите одну из следующих опций:
 | Actual Size печатает кадры в полный размер. Введите значение в опции Scale для увеличения/уменьшения печатаемого кадра.
 | Fit on One Page уменьшает или увеличивает каждый кадр так, что он заполняет все печатное поле на странице.
 | Опция Storyboard печатает несколько маленьких превьюшек на одном листе. Введите их количество на страницу в текстовом поле Frames. Установите отступы между ними в текстовом поле Story Margin. Выберите Label для печати метки кадра как превьюшки.

Для предварительного просмотра распечатки вашей сцены:

Выберите File > Print Preview.

Для печати кадров:

Выберите File > Print.


Printing Flash files as you edit movies

Основы Flash > Печать Flash файлов > Разрешение проблем печати

Разрешение проблем печати

Если у вас возникли проблемы при печати Flash файлов на PostScript принтере, возможно, одна из закрашенных областей на вашем рисунке имеет слишком много узлов. (Чаще всего проблема возникает на старых принтерах, поддерживающих только PostScript Level 1.) Есть два пути решения такой проблемы:

Выберите Disable PostScript в диалоговом окне Print Margins (Macintosh) или в Preferences (Windows), и попытайтесь печатать еще раз. Это может замедлить печать, но сделать ее успешной. ( Для информации по настройкам смотрите Настройки Flash.)
Упростите ваш рисунок. Проблемы с печатью обычно возникают с одной большой кривой со сложными краями. Вы можете решить проблему, разбив сложную область на несколько попроще. Используйте Modify > Curves > Optimize для уменьшения сложности таких областей.

Также стоит заметить, что Flash не может напечатать эффект прозрачности (альфа-канал) или слои-маски.


The Flash workflow

Основы Flash > Работа во Flash > Интерактивность во Flash

Интерактивность во Flash

Flash позволяет создавать интерактивные клипы, для управления которыми, организацией условных переходов в различные части клипа, перетаскивания объектов, ввода информации в формы, а также осуществлять множество других операций, клиенты могут использовать клавиатуру или мышь.

Интерактивные клипы создаются путем написания команд (actions) на ActionScript. Для получения информации об основных командах, смотрите Создание интерактивных клипов. Для получения полной информации об использовании ActionScript, смотрите ActionScript Reference Help.


Speeding up movie display

Основы Flash > Увеличение скорости отображения клипа

Увеличение скорости отображения клипа

Для увеличения скорости отображения клипа вы можете использовать команды из меню View для выключения опций рендеринга, которые требуют больших вычислений и замедляют воспроизведение.

Ни одна из этих команд не влияет на то, как Flash экспортирует ролик. Для установки качества отображения Flash ролика в окне браузера, вы можете использовать теги OBJECT и EMBED. Команда Publish может сделать это для вас автоматически. Для дополнительной информации смотрите Публикация Flash-клипов.

Для изменения скорости воспроизведения:

Выберите View и следующие опции:

Outlines показывают только обводку фигур на сцене и представляют все линии тонкими. Это позволяет с большим удобством менять форму графических элементов и ускоряет работу со сложными сценами.
Fast выключает антиалиасинг и сохраняет отображение всех цветов и линий неизменными.
Antialias включает антиалиасинг для линий, фигур и растра. Он делает отображение линий и фигур сглаженными. Эта опция делает прорисовку сцены более медленной, чем опция Fast. Антиалиасинг работает лучше на видеокартах, поддерживающих тысячи (16-битный цвет) или миллионы (24-битный) цветов. В 16- или 256-цветном режиме черные линии выглядят сглаженее, но цвета могут смотреться лучше в режиме Fast.
Antialias Text сглаживает неровности любого текста. Эта команда лучше всего работает на шрифтах большого размера и может вызывать замедление при большом количестве текста. Это наиболее распространенный режим работы.


Flash preferences

Основы Flash > Настройки Flash

Настройки Flash

Flash позволяет настраивать основные функции программы, равно как и операции редактирования, вкупе с операциями с буфером обмена.

Для изменения настроек Flash можете использовать подменю Edit > Preferences. Смотрите также Настройки рисования.

Для изменения настроек:

1 | Выберите Edit > Preferences.
2 | Щелкните на закладке General, Editing или Clipboard и выберите соответствующие опции.

Для изменения основных настроек выберите следующие опции:

В Undo Levels введите значение от 0 до 200 для установления количества откатов действий. Откаты требуют памяти; чем больше количество откатов, тем больше расходуется системной памяти.
В Printing Options (только для Windows), выберите Disable PostScript для отключения вывода PostScript во время печати на PostScript принтере. По умолчанию эта опция отключена. Включите эту опцию, если вы имеете проблемы с печатью на PostScript принтере. Включение этой опции вызовет замедление печати на PostScript принтере.
В Selection Options, выберите Shift Select для управления тем, как Flash будет делать выбор нескольких элементов. Когда опция Shift Select выключена, щелчок на следующих элементах добавляет их к выбранным элементам. Если же эта опция включена, щелчок на следующих элементах отменяет их выделение, если клавиша Shift не нажата.
Выберите Show Tooltips для появления подсказок в момент, когда курсор задерживается над иконкой окна. Выключите эту опцию, если появление подсказок нежелательно.
В Timeline Options, выберите Disable Timeline Docking для того, чтобы монтажная линейка не могла стать частью главного окна приложения. Смотрите также Использование монтажной линейки.
Выберите Use Flash 4 Selection Style для отображения выбранных кадров так, как это было в Flash 4.
Выберите Show Blank Keyframes для показа чистых кадров как кадров с пустыми кружками.
В Highlight Color, выберите Use This Color и нужный цвет из выпадающей палитры, или выберите Use Layer Color, чтобы использовать цвет обводки текущего слоя.
В Actions Panel выберите Normal Mode для создания скриптов, используя шаблоны команд из левой панели, либо выберите Expert Mode для прямого ввода команд ActionScript в текстовом поле.

Для установки опций редактирования используйте следующие опции:

Для Pen Tool Options смотрите Настройка инструмента Pen.
Для Drawing Settings смотрите Настройка рисования.

Для настройки работы с буфером обмена используйте следующие опции:

Для Bitmaps (только для Windows) выберите опции Color Depth и Resolution, чтобы указать глубину цвета и разрешение для растровых изображений, помещаемых в буфер обмена. Выберите Smooth для того, чтобы применить антиалиасинг. Введите значение для Size Limit, чтобы установить предельное количество оперативной памяти, которое будет использовано при помещении растрового изображения в буфер обмена. Увеличивайте это значение, если работаете с большими картинками. Если ваш компьютер небогат памятью, выберите None.
Для Gradients (только для Windows), выберите нужную опцию для установки уровня качества градиентных заливок, помещаемых в метафайл Windows. Выбор высокого качества увеличивает время, требуемое для копирования изображения. Используйте эту установку для определения качества градиента в случае помещения изображений вне Flash. Если вы вставляете изображение обратно в Flash, качество его градиентов сохраняется независимо от установленной опции Gradients.
Для опции PICT (только для Macintosh), для Type, выберите Objects для сохранения данных, копируемых в буфер обмена как векторная графика, или выберите один из растровых форматов для конвертации векторной графики в растровую. Введите значение для Resolution. Выберите Include Postscript для включения данных PostScript. Для Gradients выберите опцию для установки нужного уровня качества для PICT. Выбор высокого качества увеличивает время, требуемое для копирования изображения. Используйте эту установку для определения качества градиента в случае помещения изображений вне Flash. Если вы вставляете изображение обратно в Flash, качество его градиентов сохраняется независимо от установленной опции Gradients.
Для FreeHand Text, выберите Maintain Text as Blocks для сохранения возможности редактировать текст, вставляемый в файл FreeHand.


The Flash workflow

Основы Flash > Работа во Flash > Настройка веб-сервера для Flash-Player'а

Настройка веб-сервера для Flash-Player'а

Чтобы пользователь мог просматривать ваши Flash клипы в сети, сервер должен быть правильно настроен для распознавания Flash-клипов как файлов в формате Flash Player'а.

Ваш сервер уже может быть правильно настроен. Чтобы протестировать его конфигурацию, посмотрите Техническое примечание #12696 (TechNote #12696) на сайте Центр поддержки Macromedia Flash. Если ваш сервер настроен неправильно, следуйте описанным процедурам.

Настраивая сервер, нужно правильно установить MIME-типы (Multipart Internet Mail Extension), чтобы файлы с расширением .swf принадлежали к Shockwave Flash.

Броузер, получающий корректный тип MIME, запустит нужное ему расширение (plug-in), управляющую или вспомогательную программу, предназначенную для обработки и правильного отображения входящих данных. Если тип MIME отсутствует или неправильно обработан сервером, броузер может выдать сообщение об ошибке или пустое окно.

Примечание: При публикации Flash-клипа, вам необходимо сделать его корректные настройки . Смотрите Публикация и экспорт.

Для настройки сервера сделайте следующее:

Если ваш сайт обслуживается через Internet провайдера, свяжитесь с ним и попросите добавить на сервер MIME-тип application/x-shockwave-flash с расширением .swf.
Если вы управляете собственным сервером, посмотрите документацию вашего вебсервера, чтобы получить инструкции о добавлении или настройке MIME-типов.


About vector and bitmap graphics

Основы Flash > О векторной и растровой графике

О векторной и растровой графике

Компьютеры отображают графику в векторном или растровом формате. Понимание разницы между этими двумя форматами может помочь вам работать более эффективно. Flash позволяет создавать и анимировать компактную векторную графику и импортировать и управлять векторной и растровой графикой, созданной в других программах.


About vector and bitmap graphics

Основы Flash > О векторной и растровой графике > Векторная графика

Векторная графика

Термин "Векторная графика" применим к графическим изображениям, состоящим из линий и кривых, называемых векторами, и имеющих такие свойства, как цвет и координаты расположения. Например, рисунок листа состоит из точек, через которые проходят линии, создающие очертание листа. Цвет листа описывается цветом линий обводки и цветом заливки площади листа.

При редактировании векторной графики, вы меняете свойства линий и кривых, составляющих форму. Векторную графику можно перемещать, масштабировать, изменять форму и менять цвет без изменения качества изображения. Векторная графика не зависит от разрешения, т.е. может быть отображена на устройствах вывода с различной разрешающей способностью без потери какого-либо качества.


About vector and bitmap graphics

Основы Flash > О векторной и растровой графике > Растровая графика

Растровая графика

Термин "Растровая графика" применим к графическим изображениям, состоящим из цветных точек, называемых пикселами, размещенных в пределах сетки. Например, изображение листа описано координатами и цветом каждого пиксела в сетке, создавая изображение как мозаику.

При редактировании растрового изображения, изменяются пикселы, а не линии и кривые. Растровая графика зависит от разрешения, потому что изображение содержит фиксированное, в пределах сетки определенного размера, количество пикселов. Редактирование растровой графики может изменить качество изображения. В особенности, изменение размера растровой графики может привести к "потрепанности" края изображения. Отображение растровой графики на устройстве, которое имеет более низкое разрешение, чем исходное изображение, также ухудшает качество вывода.


Drawing overview

Рисование > Обзор рисования

Обзор рисования

Инструменты рисования Flash позволяют создавать и редактировать графические элементы клипа. Для запуска интерактивного введения в рисование во Flash, выберите Help > Lessons > Drawing.

До начала рисования важно понять, как действуют инструменты рисования, и как рисование, заливка и редактирование одних графических элементов могут повлиять на другие графические элементы, расположенные в том-же слое.


Using the Pen tool

Рисование > Использование инструмента Pen > Настройка узловых точек

Настройка узловых точек

Рисуя кривую инструментом Pen, вы создаете узловые точки, через которые проходит кривая. Когда вы рисуете прямые сегменты линии или прямую линию соединенную с криволинейными сегментами, создаются угловые точки, соединяющие криволинейные и прямые сегменты.

По умолчанию выделенные точки кривой отображаются как полые точки, а выделенные угловые точки отображаются как полые квадраты.

Для преобразования сегмента линии из прямолинейного в криволинейный или наоборот, преобразуйте угловые точки в точки кривых или наоборот.

Узловые точки можно перемещать, добавлять или удалять. Переместите узловую точку инструментом Subselection (Дополнительный выбор) и отрегулируйте длину или угол прямых сегментов или наклон изогнутых сегиментов. Можно слегка сместить выделенную узловую точку и внести некоторое изменение.

Удаление ненужных узловых точек на кривой оптимизирует ее и уменьшает размер файла.

Перемещение узловой точки:

Переместите ее используя инструмент Subselection.

Смещение узловую точку (точки):

Выберите точку (или точки) используя инструмент Subselection и используя клавиши со стрелками перемещайте эту точку (точки).

Для преобразования узловой точки сделайте следующее:

Для преобразования угловой точки в точку кривой используйте инструмент Subselection с нажатой клавишей Alt (для Windows) или Option (для Macintosh).
Для преобразования точки кривой в угловую точку используйте инструмент Pen, просто щелкните им на точке.

Добавление узловой точки:

Щелкните инструментом Pen на сегменте линии.

Для удаление узловой точки сделайте следующее

Для удаления угловой точки - щелкните один раз на точке инструментом Pen.
Чтобы удалить точки кривой - щелкните дважды инструментом Pen на точке. (Первый щелчок преобразует точку в угловую точку, второй - удалит ее.)
Выберите точки инструментом Subselection и нажмите клавишу Delete.


Using the Pen tool

Рисование > Использование инструмента Pen > Корректировка сегментов

Корректировка сегментов

Можно корректировать прямые сегменты, изменяя их наклон или длину, у криволинейных сегментов можно менять кривизну или направление.

При перемещении "ручки поворота" точки криволинейного сегмента, кривые с обоих сторон от точки изменяются. При перемещении "ручки поворота" угловой точки, изменяется только та кривая, которая находится на той-же стороне что и "ручка поворота".

Корректировка прямолинейных сегментов:

1 | Выберите инструмент Subselection и выделите прямолинейный сегмент.
2 | Используйте инструмент Subselection для перемещения узловых точек сегмента в новую позицию.

Корректировка криволинейных сегментов:

Выберите инструмент Subselection и перетащите сегмент.

Примечание: узловые точки будут невидимы когда вы щелкаете по линии инструментом Subselection. Чтобы увидеть их после изменения, щелкните по линии инструментом Subselection или Pen. Также изменение сегментов инструментом Subselection может привести к увеличению количества точек на линии.

Корректировка точек или "ручек поворота" на кривой:

1 | Выберите инструмент Subselection и выделите сегмент кривой линии. У этого сегмента появятся "Ручки поворота".
2 | Воспользуйтесь одним из следующих способов
 | Для изменения положения узловой точки на кривой, перетащите эту точку.
 | Для изменения формы кривой с одной стороны узловой точки, перетащите ее или откорректируйте "ручку поворота". Удерживайте клавишу Shift чтобы сделать перемещение кратным 45°.


Painting with the Brush tool

Рисование > Рисование инструментом Brush (Кисть)

Рисование инструментом Brush (Кисть)

Инструмент Кисть создает мазки, аналогичные мазкам настоящей кисти. Этот инструмент позволяет создавать специальные эффекты, в том числе каллиграфию. На наиболее чувствительных графических планшетах можно изменять ширину мазка, изменяя давление на стило.

Работая инструментом Brush, можете использовать импортированный битмап, как заполняющий цвет (заливку). См. Разрыв (Breaking apart) отдельного растрового рисунка.

Использование инструмента Brush:

1 | Возьмите инструмент Brush.
2 | Выберите заполняющий цвет. См Определение атрибутов цвета линий и заливки.
3 | Щелкните на модификаторе режима Brush и выберите режим рисования:
 | Paint Normal (Нормальное рисование) - рисует поверх линий и заливок.
 | Paint Behind (Рисование позади) - зaкрашивает незаполненные области Сцены на том же самом слое, не затрагивая линии и ранее закрашенные области.
 | Paint Selection (Рисование по выделению) - применяет новый цвет к выделенному объекту, когда вы указываете цвет закрашивания (или растровый файл, который будет использоваться для заполнения) в модификаторе Fill (заливка) или в панели Fill. Эта настройка аналогична простому выделению заполненной области и применению к ней нового заполнения.
 | Paint Fills (Рисование по заполнению) - при этой настройке заполняются пустые области, а линии не затрагиваются.
 | Paint Inside (Рисование внутри) - зaкрашивает область, в которой вы начинаете закрашивание, и никогда не закрашивает линии. Это действие напоминает книжку для раскрашивания, где надо аккуратно закрасить контурные фигуры. Если вы начинаете красить в пустой области, то закрашивание не затрагивает уже закрашенные области
 | Исходный рисунок, Нормальное рисование, Рисование позади, Рисование по Выделению, Рисование по Заполнению, Рисование Внутри
4 | Выберите размер кисти, форму кисти и цвет закрашивания в модификаторах инструмента Brush.
5 | Если к вашему компьютеру подключен графический планшет, то можно выбрать модификатор Pressure (давление), чтобы ширина мазков кисти изменялась в зависимости от давления на стило.
6 | Проведите Кистью по Сцене. Нажмите и удерживайте клавишу Shift, чтобы мазки получались строго горизонтальными или вертикальными.


Reshaping lines and shape outlines

Рисование > Изменение формы и стиля линий

Изменение формы и стиля линий

Изменять линии и контуры, созданные инструментами Карандаш, Кисть, Линия, Овал или Прямоугольник можно зацепив и перетаскивая их инструментом Стрелка или оптимизируя их кривизну.

Можно также использовать инструмент Subselection (Дополнительный выбор), чтобы отобразить точки на линиях и контурах фигур и изменить их. Информацию о настройке узловых точек, см. Использование инструмента Pen.

Отображение узловых точек на линии или контуре фигуры, созданной Карандашом, Кистью, Линией, Овалом или Прямоугольником:

1 | Выберите инструмент Subselection.
2 | Щелкните на линии или контуре фигуры.


Reshaping lines and shape outlines

Рисование > Изменение формы и стиля линий > Изменение формы с помощью инструмента Arrow (Стрелка)

Изменение формы с помощью инструмента Arrow (Стрелка)

Чтобы изменить отдельную линию или контур фигуры, зацепите и потяните любую точку линии, используя инструмент Arrow (Стрелка). Указатель изменится на другой, что укажет какое изменение допустимо для этой линии или заливки.

Flash настраивает кривизну сегмента линии соответственно новому положению перемещенной точки. Если перемещенная точка является конечной точкой, то зацепив и перемещая ее, вы можете удлинять или сокращать линию. Если перемещенная точка является вершиной угла, то сегменты линии, формирующие угол, остаются прямыми, но или вытягиваются или сокращаются.

Когда рядом с указателем появляется угол вы можете изменить вершину угла. Когда рядом с указателем появляется кривая, можно изменять кривую.

Некоторые мазки Кисти проще изменить, если они представлены в виде контуров.

Затрудняясь изменить сложную линию, можете скруглить ее чтобы удалить некоторые детали и таким образом упростить. Увеличив представление объекта на Сцене, вы также упростите эту задачу; см. Оптимизация кривых или Просмотр Сцены.

Изменение линии или контура фигуры, инструментом Arrow:

1 | Возьмите инструмент Arrow.
2 | Выполните следующие шаги:
 | Зацепите и потяните любую точку сегмента, чтобы изменить его.
 | Нажмите и удерживайте клавишу Control (Windows) или Option (Macintosh) чтобы создать новую угловую точку.


Reshaping lines and shape outlines

Рисование > Изменение формы и стиля линий > Выпрямление и скругление линий

Выпрямление и скругление линий

Можно изменять линии и контуры фигур, спрямляя или скругляя их.

Примечание: настройте градус автоматического скругления или выпрямления, указав настройки рисования в диалоговом окне Preferences (Параметры). См. Выбор настроек рисования.

Настройка Straightening (выпрямление) слегка выпрямляет уже нарисованные линии и кривые, но не влияет на прямые сегменты.

Можно также использовать выпрямление, чтобы Flash распознавал фигуры. Если вы рисуете овалы, прямоугольники или треугольники при выключенной настройке Recognize Shapes (изменение форм), вы можете использовать настройку Straightening (выпрямление), чтобы сделать фигуры геометрически точными. (Информацию о настройке Recognize Shapes (изменение форм) см. Выбор настроек рисования.) Фигуры, соприкасающиеся с другими элементами, не распознаются.

Распознавание преобразует верхние фигуры в фигуры второго ряда.

Настройка Smoothing (скругление) смягчает кривизну и другие изменения на всем протяжении кривой. При этом также уменьшается количество сегментов кривой. Эффект скругления относителен и не влияет на прямые сегменты. Это особенно полезно, когда вы затрудняетесь редактировать множество очень коротких изогнутых сегментов линии. Выбрав все сегменты и скруглив их, можно уменьшить количество сегментов и создать более плавную кривую, которая более удобна для редактирования.

Повторное применение скругления или выпрямления сделает каждый сегмент более гладким или более прямым - в зависимости от того, насколько изогнут или прям был каждый сегмент первоначально.

Скругление контура выбранного заполнения или кривой линии:

Выберите инструмент Arrow (стрелка) и щелкните на модификаторе в секции Options (настройки) в панели инструментов или выберите команду Modify > Smooth).

Применение выпрямления для выделенного контура фигуры или линии:

Выберите инструмент Arrow (стрелка) и щелкните на модификаторе Straighten (выпрямление) в разделе Options (настройки) в панели инструментов или выберите команду Modify > Straighten.

Использование распознавания фигуры:

Выберите инструмент Arrow (стрелка) и щелкните на модификаторе Straighten (выпрямление) или выберите команду Modify > Straighten.


Reshaping lines and shape outlines

Рисование > Изменение формы и стиля линий > Оптимизация кривых

Оптимизация кривых

Другой способ скруглять кривые состоит в том, чтобы оптимизировать их. При этом кривые линии и контуры областей заполнения очищаются за счет уменьшения количества криволинейных сегментов, описывающих эти элементы. Оптимизация кривых также положительно сказывается на уменьшении размера выходного файла.

Для оптимизация кривых:

1 | Выделите элементы подлежащие оптимизации и выберите команду Modify > Optimize.
2 | В диалоговом окне Optimize Curves (Оптимизация кривых) потяните ползунок Smoothing (скругление), чтобы определить степень скругления.
 | Точные результаты зависят от конкретных кривых. Вообще, оптимизация уменьшает количество кривых и несколько изменяет контуры по сравнению с первоначальным видом.
3 | Установите дополнительные настройки:
 | Use Multiple Passes (применить несколько проходов) - выполняет процесс скругления до тех пор, пока дальнейшая оптимизация не станет бесполезной; эта настройка аналогична повторным операциям над выделенным элементом.
 | Show Totals Message (показать сообщение) - сообщает о степени оптимизации после завершения операции.
4 | Нажмите ОК.


Erasing

Drawing > Стирание

Стирание

Стирание с помощью инструмента Eraser (Резинка) удаляет контуры и закрашенные области. Можно быстро стереть все находящиеся на Сцене элементы или отдельные их части, кроме того, можно стирать перемещением.

Можно настроить инструмент Eraser так, чтобы стирать только контуры или только заполненные области или только отдельную заполненную область. Инструмент может иметь форму круга или квадрата одного из пяти размеров.

Быстрое удаление всего на Сцене:

Дважды щелкните по инструменту Eraser.

Удаление части контура или закрашенной области:

1 | Выберите инструмент Eraser и затем щелкните на модификаторе Faucet (краник).
2 | Щелкните на той части контура или заполненной области, которую вы хотите удалить.

Стирание перемещением:

1 | Выберите инструмент Eraser.
2 | Щелкните на модификаторе Eraser Mode (режим резинки) и выберите режим стирания:
 | Erase Normal (стереть нормально) - стираются контуры и заполнения на активном слое.
 | Erase Fills (стереть заполнение) - стираются только закрашенные области, контуры остаются без изменений.
 | Erase Lines (стереть линии) - стираются только линии, закрашенные области не изменяются.
 | Erase Selected Fills (стереть выбранное заполнение) - стирается только выбранная в настоящее время закрашенная область, а контуры, выделенные и невыделенные, не затрагиваются. (Прежде чем использовать инструмент в этом режиме, выберите закрашенную область, которую хотите стереть.)
 | Erase Inside (стереть внутри) - вытирает область, в которой вы начинаете стирать. Если Вы начинаете стирать с пустого места, то ничто не будет стерто. Этот режим не затрагивает линии.
3 | Щелкните на модификаторе Eraser Shape (Форма резинки) и выберите нужную форму резинки и ее размер. Удостоверьтесь, что модификатор Faucet (Краник) при этом не выделен.
4 | Перейдите на Сцену.


Modifying shapes

Рисование > Изменение фигур

Изменение фигур

Формы фигур можно изменять преобразовывая линии в залитые области, расширяя форму или смягчая грани залитого объекта, изменяя кривые линии фигуры.

Опция Lines to Fills (линии в заливки) позволяет преобразовывать линии в закрашиваемые области, после чего можно заполнять линии градиентами или стирать часть линии. Опции Expand Shape (расширение фигур) и Soften Edges (размывка граней) позволяют расширять заполненные фигуры и смягчать грани форм.

Эти возможности лучше применять к маленьким формам, не содержащим мелких деталей. Применение опции Soften Edges к фигурам с большим количеством деталей может увеличить размер файла.

Преобразование линий в залитые области:

1 | Выберите одну или несколько линий.
2 | Выберите команду Modify > Shape > Convert Lines to Fills.
 | Выбранные линии преобразуются в заполненные области. Такое преобразование может увеличить размеры файла, но может также ускорить прорисовку некоторых анимаций.

Расширение формы залитого объекта:

1 | Выберите заполненную форму. Эта опция лучше всего работает для отдельной заполненной фигуры не имеющей контура.
2 | Выберите команду Modify gt; Shape > Expand Fill.
3 | В диалоговом окне Expand Path (путь расширения) укажите в пикселах значение Distance (расстояние) и выберите для него направление Expand (наружу) или Inset (внутрь). Expand - увеличивает фигуру, Inset - уменьшает ее.

Размывка граней объекта:

1 | Выберите заполненную форму. Эта опция лучше всего действует для отдельной заполненной области, не имеющей контура.
2 | Выберите команду Modify > Shape > Soften Fill Edges.
3 | Задайте следующие настройки:
 | Distance (расстояние) - ширина размывки в пикселах.
 | Number of Steps (количество шагов) - указывает, сколько кривых будет использоваться для размывки грани. Большее количество шагов дает больший эффект, но увеличивает размер файла и замедляет его прорисовку.
 | Expand (наружу) и Inset (внутрь) - определяет направление размывки.


Snapping

Рисование > Привязка

Привязка

Чтобы автоматически выровнять элементы между собой, можно использовать привязку. Привязку можно включить модификатором Snap (привязка) для инструмента Arrow (Стрелка) или командой Snap to Objects (привязать к объекту) из меню View (вид).

Примечание: можно также привязывать элементы к координатной сетке или к направляющим. Подробную информацию см. Использование сетки, направляющих и линеек.

Если для инструмента Arrow (Стрелка) включен модификатор Snap (привязка), то когда вы перетаскиваете элемент, под указателем появляется маленькое черное кольцо. Маленькое кольцо изменяется на большое кольцо, когда объект будет находиться в пределах расстояния привязки к сетке.

Чтобы включить или выключить привязку, выполните один из следующих шагов:

Выберите инструмент Arrow и щелкните на модификаторе Snap в панели инструментов.
Выберите команду View > Snap to Objects. При этом в меню около нее появляется пометка, означающая, что эта настройка выбрана.

Когда вы перемещаете или изменяете объект, позиция инструмента Arrow на объекте обеспечивает контрольную точку для привязки. Например, если вы перемещаете заполненную область, перетаскивая ее, зацепив за центр, то центр привязывается к другим объектам. Это особенно удобно для привязки фигур к траекториям движения при создании анимаций.

Настройка точности привязки:

Отрегулируйте настройку Connect Lines (соединять линии) в разделе Drawing Settings (настройки рисования) в диалоговом окне Preferences (параметры). См. Выбор настроек рисования.

Примечание: размещение объекта при привязке удобнее контролировать, перетаскивая его за край или угол, а не за центр.


Flash drawing and painting tools

Рисование > Инструменты Flash для рисования и заливки

Инструменты Flash для рисования и заливки

Flash предоставляет различные инструменты для рисования произвольных или прямых линий, фигур и траекторий, а также их заливки.

Для рисования произвольных линий и форм, используется инструмент Pencil (карандаш), рисование будет похоже на рисование настоящим карандашом. См. Рисование с использованием Pencil (карандаш).
Для рисования прямых или кривых линий, используется инструмент Pen (перо). См. Использование инструмента Pen (перо).
Инструменты Line (линия), Oval (овал) и Rectangle (прямоугольник) позволяют рисовать соответствующие основные геометрические примитивы. См. Рисование линий, овалов и прямоугольников.
Инструмент Brush (кисть) оставляет мазки, как бы от работы кистью. См. Рисование с использованием Brush (кисть).

При использовании инструментов рисования к создаваемому объекту применяются текущие параметры линии и заливки. Для их изменения у существующего объекта, необходимо использовать интструменты Paint Bucket и Ink Bottle. См. Определение атрибутов цвета линий и заливки.

Созданные линии и контуры фигур можно изменять различными способами. Заливка и контур рассматриваются как отдельные объекты. Можно выбирать их по отдельности для изменения или перемещения. См. Изменение формы и стиля линий.

Вы можете использовать автоматическое выравнивание относительно друг друга, сетки или направляющих. См. Использование сетки, направляющих и линеек.


Choosing drawing settings

Рисование > Выбор настроек рисования

Выбор настроек рисования

Такие действия, как привязка, сглаживание и выпрямление можно настроить так как вам надо. Вы можете изменить настройку Tolerance (Допуск) для каждого из этих действий. Настройка Tolerance относительна и зависит от разрешающей способности монитора вашего компьютера и масштаба представления сцены. По умолчанию каждое действие включено и использует настройку Tolerance (Допуск) со значением Normal (Обычный).

Настройка опций рисования:

1 | Выберите команду Edit > Preferences и щелкните на вкладке Editing (редактирование).
2 | В группе Drawing Settings (настройки рисования) задайте следующие настройки:
 | Connect Lines (соединение линий) - определяет, насколько близко надо нарисовать линию, чтобы ее конечная точка была автоматически привязана к конечной точке существующей линии. Возможные настройки: Must Be Close (должно быть близко), Normal (нормально) и Can Be Distant (может быть разнесено). Эта настройка также управляет горизонтальным и вертикальным распознаванием линии, то есть насколько точно рисуемая линия должна совпадать с вертикалью или горизонталью, чтобы Flash сделал ее точно горизонтальной или вертикальной. Когда настройка Snap to Objects (привязка к объектам) включена, то эта же настройка определяет максимальное расстояние для привязки объектов.
 | Smooth Curves (сглаживание кривых) - определяет степень изогнутых линии при рисовании их инструментом Pencil (карандаш) в режиме Straighten (спрямление) или Smooth (сглаживание). (Сглаженные кривые легче изменять, а более грубые точнее соответствуют первоначальным контурам.) Возможные настройки: Off (отключено), Rough (грубо), Normal (нормально) и Smooth (сглаженный).

Примечание: можно и далее скруглять изогнутые сегменты, используя команду Modify >Smooth и Modify >Optimize.

Recognize Lines (распознавание линий) - определяет, насколько точно надо рисовать сегмент линии инструментом Pencil (карандаш), чтобы Flash распознал ее как прямую. Возможные значения Off (нет), Strict (точно), Normal (нормально) и Tolerant (приблизительно). Если эта настройка выключена во время рисования, то вы можете спрямить линию позже, выделив один или несколько сегментов и выбрав команду Modify > Straighten.
Recognize Shapes (распознавание линий) - определяет, насколько точно должны быть нарисованы круги, овалы, квадраты, прямоугольники, 90- и 180-градусные дуги, чтобы Flash распознал их как геометрические фигуры и привел их к точному виду. Возможные значения Off (нет), Strict (точно), Normal (нормально) и Tolerant (приблизительно). Если Recognize Shapes (распознавание линий) выключена во время рисования, то как и в случае со спрямлением линий, вы можете спрямлять сегменты фигур позже, выделив, например, один или несколько связанных сегментов и выбрав команду Modify > Straighten.
Click Accuracy (точность щелчка) - определяет, насколько близко необходимо подвести указатель, чтобы выделить элемент. Возможные значения: Strict (точно), Normal (нормально) и Tolerant (приблизительно).


About overlapping shapes in Flash

Рисование > Перекрытие объектов во Flash

Перекрытие объектов во Flash

При проведении линии поперек другой линии или закрашенной фигуры инструментами Pencil (Карандаш), Line (Линия), Oval (Овал), Rectangle (Прямоугольник) или Brush (Кисть), их перекрывающиеся фрагменты разделяются в точках пересечения. С помощью инструмента Arrow (Стрелка) можно выделить и переместить или изменить каждый сегмент отдельно от других.

Примечание: Перекрытие линий создаваемых инструментом Pen (Перо) не приводит к их разделению на отдельные объекты. См. Использование инструмента Pen.

Заливка; заливка и линия проведенная поверх нее; две заливки и три линии получившиеся в результате сегментации

Когда вы рисуете поверх линии или формы, часть объекта которая была перекрыта будет заменена на то что находится сверху. Части закрашенные одним цветом сливаются. Части закрашенные различными цветами остаются разделенными. Используйте эти особенности для создания масок, вырезания (высечки) и других операций. Например высечка ниже была сделана так: перемещаем несгруппированный образ змея на зеленую фигуру, снимаем выделение змея, и затем убираем части змея прочь из зеленой фигуры.

Во избежание случайного изменения фигур и линий при наложении, можно их сгруппировать или использовать слои для их разделения. См Grouping objects and Обзор использования слоев.


Drawing with the Pencil tool

Drawing > Рисование инструментом Pencil (карандаш)

Рисование инструментом Pencil (карандаш)

Во Flash'е линии и фигуры рисуются инструментом Pencil (Карандаш) почти так же, как это делается реальным карандашом. Для сглаживания линий при рисовании, выберите соответствующий режим рисования инструмента Pencil.

Рисование инструментом Pencil:

1 | Выберите Pencil.
2 | Выберите цвет, ширину и стиль линии. См Определение атрибутов цвета линий и заливки.
3 | В нижней части панели инструментов выберите режим рисования:
 | В режиме Straighten (спрямление) можно рисовать прямые линии, а если они будут похожи на простые квадраты, треугольники, овалы или круги, то они будут преобразованы в эти фигуры.
 | Выберите режим Smooth (сглаживание) для рисования гладких изогнутых линий.
 | Режим Ink позволит рисовать безо всяких сглаживаний и выпрямлений.
 | Линии нарисованные в режимах Straighten, Smooth и Ink соответственно
4 | Перейдите в рабочее окно и рисуйте в нем. Удерживая клавишу Shift, можно рисовать вертикальные или горизонтальные линии.


Drawing straight lines, ovals, and rectangles

Рисование > Рисование прямых линий, овалов и прямоугольников

Рисование прямых линий, овалов и прямоугольников

Инструменты Line (линия), Oval (овал) и Прямоугольник (Rectangle) предназначены для создания этих примитивов. Инструменты Овал и Прямоугольник позволяют рисовать уже залитые фигуры. Инструмент Прямоугольник позволяет создавать прямоугольники с прямыми или скругленными углами.

Для рисования прямых линий, овалов или прямоугольников:

1 | Выберите Line (линия), Oval (овал) или Rectangle (прямоугольник).
2 | Выберите атрибуты линии и заливки, как описано в Определение атрибутов цвета линий и заливки.

Примечание: атрибуты заливки для инструмента Line (линия) недоступны.

3 | Для инструмента Прямоугольник определите скругление углов, для чего выберите опцию Round Rectangle Radius (радиус округления углов) и введите значение радиуса угла. Значение "0" (нуль) соответствует прямому углу.
4 | Перейдите на сцену. Если используете инструмент Прямоугольник, то после того как нарисовали прямоугольник, удерживая правую клавишу мыши, используйте клавиши стрелок "вверх" и "вниз", чтобы корректировать радиус скругления углов.
 | Работая инструментом Овал и Прямоугольник, удерживайте нажатой клавишу Shift чтобы рисовать правильный круг или квадрат соответственно.
 | Работая инструментом Line, удерживайте нажатой клавишу Shift при рисовании, чтобы провести линию под углом кратным 45° .


Using the Pen tool

Рисование > Использование инструмента Pen (Перо)

Использование инструмента Pen (Перо)

Для создания точных прямых или плавных линии можно использовать инструмент Pen (Перо). Можно создавать прямые или изогнутые сегменты линий и регулировать величину угла, длину прямых и наклон изогнутых сегментов.

При рисовании инструментом Pen, можно щелчком мыши создавать узловые точки в сегментах прямой линии, а щелчком и протаскиванием - узловые точки в сегментах изогнутой линии. С помощью таких точек регулируются прямые и изогнутые сегменты линии, причем можно преобразовывать кривые линии в прямые и наоборот. Таким же образом можно создавать точки на линиях, созданных другими инструментами рисования Flash: Карандашом (Pencil), Кистью (Brush), Линией (Line), Овалом (Oval) или Прямоугольником (Rectangle) и регулировать эти линии. См. Изменение формы и стиля линий.


Using the Pen tool

Рисование > Использование инструмента Pen > Настройка параметров инструмента Pen

Настройка параметров инструмента Pen

Можете настроить инструмент Pen так, что будете видеть сегменты линий или их узловые точки. Выбранные сегменты линий или узловые точки будут выделены обводкой, цвет которой соответствует цвету, установленному для выделения объектов слоя.

Настройка инструмента Pen:

1 | Выберите Edit > Preferences и нажмите на закладку Editing.
2 | В блоке Pen Tool, установите следующие опции:
 | Show Pen Preview (Предварительный просмотр) - позволяет предварительно видеть сегментирование линии до того, как она будет нарисована. Flash показывает сегменты линий по мере того, как вы перемещаете указатель по сцене, и до тех пор, пока вы не сделаете щелчок для создания узловой точки. Если эта опция не выбрана, Flash не будет показывать сегменты линии над которыми находится указатель до тех пор, пока узловую точка не будет создана.
 | Show Solid Points (Показ основных точек) - невыделенные узловые точки будут отображаться как закрашенные точки, а выбранные узловые точки будут отображаться как пустые точки. Эта настройка указана по умолчанию. Если эту опцию не выбрать, то выбранные точки будут выглядеть как закрашенные, а не выбранные как пустые.
 | Show Precise Cursors (Показ прецизионного курсора) - для более точного размещения линий указатель инструмента Pen будет выглядеть, как прецизионный курсор (перекрестие), а не в виде значка инструмента Pen. Выключение этой опции возвращает курсору вид, установленный по умолчанию.

Примечание: Нажмите клавишу Caps Lock чтобы переключить вариант отображения инструмента.

3 | Нажмите OK.


Using the Pen tool

Рисование > Использование инструмента Pen > Рисование прямых линий инструментом Pen (Перо)

Рисование прямых линий инструментом Pen (Перо)

Чтобы нарисовать инструментом Pen прямой сегмент, создайте узловые точки на линии, которые определят длину каждого сегмента линии.

Рисование прямых линий инструментом Pen:

1 | Выберите инструмент Pen.
2 | Определение атрибутов линий и заливки. См. Определение атрибутов цвета линий и заливки.
3 | Поместите указатель на сцене в том месте, где хотите начать рисовать линию и щелчком установите первую узловую точку.
4 | Сделайте щелчок там где вы хотите закончить первый сегмент прямой линии. Удерживайте кнопку Shift чтобы указатель перемещался под углом кратным 45°.
5 | Таким же образом создайте следующие сегменты.
6 | Чтобы закончить построение линии как замкнутую или незамкнутую фигуру, выполните один из следующих шагов:
 | Чтобы закончить линию, не замыкая ее, дважды щелкните на последней точке или щелкните на инструменте Pen в панели инструментов, или щелкните, нажав и удерживая клавишу Contol (Windows) или Command (Macintosh) где-нибудь вне линии.
 | Чтобы замкнуть линию, наведите инструмент Pen на первую узловую точку. Если все сделано правильно, то при этом рядом с указателем появится маленькая окружность. Щелкните или потяните ее, чтобы замкнуть линию.
 | Чтобы завершить линию в том виде как она есть, выберите команду Edit > Deselect All или выберите иной инструмент в панели инструментов.


Using the Pen tool

Рисование > Использование инструмента Pen > Рисование кривых инструментом Pen (Перо)

Рисование кривых инструментом Pen (Перо)

Кривую линию можно создать, перемещая инструмент Перо (Pen) в нужном направлении, чтобы создать первую узловую точку, а затем переместите инструмент Перо (Pen) в ином направлении, чтобы создать вторую узловую точку.

При рисовании инструментом Перо (Pen) изогнутого сегмента, узловые точки представляются в виде линейных тангенс-маркеров ("ручки поворота"). Наклон и длина каждого тангенс- маркера определяет наклон и высоту (или глубину) кривой. Перемещение этих "ручек" приведет к изменению формы кривой. См. Настройка сегментов.

Рисование кривой линии:

1 | Выберите инструмент Pen.
2 | Установите инструмент Pen на сцене в точку, с которой начнете рисовать кривую. Нажмите на кнопку мыши. Появится первая узловая точка и указатель инструмента превратится в стрелку.
3 | Протащите указатель в направлении куда хотите направить кривую. Когда начнете тащить указатель, появятся "ручки поворота". Нажмите и удерживайте клавишу Shift, чтобы создать угол кратный 45 градусам.
4 | Отпустите кнопку мыши.
 | Длина и наклон "ручек" определяют форму сегмента кривой. Можно подкорректировать форму кривой линии позже, используя эти "ручки поворота".
5 | Поместите указатель там, где хотите завершить сегмент кривой, нажмите кнопку мыши и протяните курсор в противоположном направлении, чтобы завершить сегмент. Нажмите и удерживайте клавишу Shift, чтобы создать угол, кратный 45 градусам.
6 | Чтобы нарисовать следующий сегмент кривой, поместите указатель там, где хотите его завершить.


Working with color overview

Работа с Цветом > Краткий обзор работы с Цветом

Краткий обзор работы с Цветом

Использование заданной по умолчанию палитры или палитры, которую Вы создаете, Вы можете выбирать цвета, чтобы окрашивать объекты, их контур или заполнять объект полностью. Применение штрихового цвета окрасит контур формы цветом. Применение заполняющего цвета к форме окрасит внутреннее место формы цветом.

При применении штрихового цвета к форме, Вы можете выбирать любой однотонный цвет, и также Вы можете выбирать стиль и толщину линий. Для заполнения формы, Вы можете применять твердый цвет, градиент или растровую картинку (bitmap). Для применения такой картинки, Вы должны импортировать ее в текущий файл. Вы можете также применяться прозрачный цвет линий или заполнять выделенную область, или заполнять объект без контура. И Вы можете применять однотонные цвета, чтобы напечатать файл. См. Установка атрибутов.

Панель Mixer позволяет Вам создавать и редактировать однотонные цвета. Создавать и редактировать градиенты, используя панель Fill. Вы можете импортировать, экспортировать, удалять, и изменять цветовую палитру для файла, используя панель Swatches.


Creating and editing solid colors with the Mixer panel

Работа с Цветом > Создание и редактирование однотонных цветов на панели Mixer

Создание и редактирование однотонных цветов на панели Mixer

Чтобы создавать и редактировать однотонные цвета, Вы можете использовать панель Mixer. Если на рабочем поле выбран объект, Вы можете делать любые изменения цвета в панели Mixer, применяемые к Вашему выбору.

Вы можете выбирать цвет из существующей цветовой палитры или создавать новый цвет. Вы можете выбирать цвета в RGB или HEX режиме, или задавать значение Alpha, чтобы определить степень прозрачности цвета.

Создание или редактирование однотонных цветов на панели Mixer:

1 | Выберите Window > Panels > Mixer.
2 | Для установки режима отображения цвета, выберите RGB (параметр по умолчанию), HSB, или HEX из всплывающего меню в верхнем правом углу панели Mixer.
3 | Нажмите палитру цветов для линии или заливки, чтобы определить, какой признак должен быть изменен.
 | Если Вы выбрали заливку объекта градиентом, палитра цветов отображает градиент. Чтобы заменять градиент в выборе однотонным цветом, щелкните палитру цветов, и выберите однотонный цвет, как описано в шаге 4.
 | Если в данный момент Вы редактируете градиент, панель Mixer отображает цветной блок и метку с цветом выбранным в данный момент в редакторе градиента. Чтобы заканчивать сеанс редактирования градиента, щелкните на этой метке в панели Mixer.
4 | Сделайте один из следующих вариантов:
 | Нажмите палитру цветов линий или заливки, и выберите цвет из всплывающего окна.
 | Нажмите в цветной полосе внизу панели Mixer, чтобы выбрать цвет.
 | Введите значения цвета в рамки значений: Красный, Зеленый, Синий для RGB режима; Оттенок, Насыщенность и Яркость для HSB режима или HEX-код для HEX режима. Введите значение Alpha, чтобы определить степень прозрачности, от 0 до 100.
 | Нажмите кнопку заданных по умолчанию цветов для Stroke и Fill, чтобы возвратиться к заданным по умолчанию параметрам настройки цвета (белый для заливки и черный для линий).
 | Щелкните кнопку ротации цветов Stroke и Fill.
 | Нажмите кнопку None (отсутствие цвета), чтобы применить прозрачную заливку или линию.

Обратите внимание: Вы можете применять прозрачный цвет линии или заливки к новому объекту, но не к существующему объекту. Вместо этого, выберите существующий цвет линии или заливки и удалите.

5 | Чтобы добавить цвет, определенный в шаге 4 к цветовому списку образцов для текущего файла, выберите Add Swatch из всплывающего меню в верхнем правом углу панели Mixer.


Modifying color palettes

Работа с Цветом > Изменение цветовых палитр

Изменение цветовых палитр

Каждый файл Flash содержит его собственную цветовую палитру, сохраненную в файле Flash. Flash отображает палитру файла в образцах модификаторов цветов линий, заливок и в панели Swatches. Заданная по умолчанию цветовая палитра - Безопасная сетевая палитра в 216 цветов. Вы можете добавлять цвета к текущей палитре, используя панель Mixer. См. Создание и редактирование однотонных цветов с панелью Mixer.

Чтобы импортировать, экспортировать и изменять цветовую палитру файла, Вы используете панель Swatches. Вы можете дублировать цвета, удалять цвета из палитры, заменять заданную по умолчанию палитру, перезагружать безопасную сетевую палитру, если Вы ее изменили, или сортировать палитру по оттенку.

Вы можете импортировать и экспортировать, однотонные цвета и палитры градиентов между файлами Flash, также как между Flash и другими приложениями, типа Macromedia Fireworks и Adobe Photoshop.


Modifying color palettes

Работа с Цветом > Изменение цветовых палитр > Дублирование или удаление цвета из палитры

Дублирование или удаление цвета из палитры

Вы можете дублировать или удалять индивидуальные цвета, или очищать все цвета палитры.

Дублировать цвет или удалять цвет из цветовой палитры:

1 | Выберите Window > Panels > Swatches.
2 | Щелкните цвет, который Вы хотите дублировать или удалить.
3 | Выберите Дублирование Образца (Duplicate Swatch) или Удаление Образца (Delete Swatch) из всплывающего меню в верхнем правом углу.

Очищать все цвета цветовой палитры:

В панели Swatches, выберите Очистка Цветов (Clear Colors) из всплывающего меню в верхнем правом углу. Все цвета будут удалены из палитры кроме черного и белого.


Modifying color palettes

Работа с Цветом > Изменение цветовых палитр > Использование заданной по умолчанию палитры и Безопасной сетевой палитры

Использование заданной по умолчанию палитры и Безопасной сетевой палитры

Вы можете сохранять текущую палитру как заданную по умолчанию палитру, заменять текущую палитру заданной по умолчанию палитрой, определенной для файла, или загружать Безопасную сетевую палитру, чтобы заменить текущую палитру.

Загружать или сохранять заданную по умолчанию палитру:

В панели Swatches, выберите одну из следующих команд из всплывающего меню верхнем правом углу.

Загрузить Заданные по умолчанию Цвета (Load Default Colors) - заменяет текущую палитру заданной по умолчанию палитрой.
Сохранить как Заданную по умолчанию (Save as Default) - сохраняет текущую цветовую палитру как заданную по умолчанию палитру. Новая заданная по умолчанию палитра используется, когда Вы создаете новые файлы.

Загрузить Безопасную сетевую 216-цветную палитру:

В панели Swatches, выберите Web 216 из всплывающего меню в верхнем правом углу.


Modifying color palettes

Работа с Цветом > Изменение цветовых палитр > Сортировка палитры

Сортировка палитры

Чтобы делать более удобным расположение цветов, Вы можете сортировать цвета в палитре по оттенкам.

Сортировка цвета в палитре:

В панели Swatches, выберите Сортировку Цветов (Sort by Color) из всплывающего меню в верхнем правом углу.


Modifying color palettes

Работа с Цветом > Изменение цветовых палитр > Импорт и экспорт цветовых палитр

Импорт и экспорт цветовых палитр

Для импорта и экспорта RGB цвета и градиентов между файлами Flash, используются файлы Набора Цвета Flash (CLR файлы). Вы можете импортировать и экспортировать палитры цвета RGB, использующие Цветные Табличные файлы (ACT файлы), который могут использоваться Macromedia Fireworks и Adobe Photoshop. Можно импортировать цветовые палитры, но не градиенты, из GIF файлов. Нельзя импортировать или экспортировать градиенты из ACT-файлов.

Импорт цветовой палитры:

1 | В панели Swatches, выберите одну из следующих команд из всплывающего меню в верхнем правом углу:
 | Чтобы добавить импортированные цвета в конец текущей палитры, выберите Add Colors.
 | Чтобы заменить текущую палитру импортированными цветами, выберите Replace Colors.
2 | Найдите нужный файл и выделите его.
3 | Щелкните ОК.

Экспорт цветовой палитры:

1 | В панели Swatches, выберите Save Colors из всплывающего меню в верхнем правом углу.
2 | В диалоговом окне, которое появляется, введите название для цветной палитры.
3 | Для Сохранить Как (Windows) или Формат (Macintosh), выберите Flash Color Set или Color Table. Нажмите Save.


Specifying stroke and fill attributes

Работа с Цветом > Определение атрибутов цвета линий и заливки

Определение атрибутов цвета линий и заливки

Для определения цвета линий или заливки, используется Stroke и Fill из набора средств управления в комплекте инструментов, инструменты "Бутылка Чернил" ("Ink Bottle") и "Ковш Краски" ("Paint Bucket") или панель Stroke и панель Fill. Чтобы изменять стиль или толщину линии, используется панель Stroke. Для создания или редактирования градиентов, а так же применения растровых рисунков для заливки - панель Fill.

Когда создаются новые объекты с рисунком используя инструментальные средства рисования, объекты могут быть окрашены с признаками, указанными в инструментальных средствах Stroke и Fill. Можно также изменять признаки существующих объектов используя эти панели.

Для копирования признаков Stroke и Fill из одного объекта в другой применяется инструмент "Пипетка" ("Eyedropper").


Specifying stroke and fill attributes

Работа с Цветом > Определение атрибутов цвета линий и заливки > Использование средств управления Stroke и Fill в комплекте инструментов

Использование средств управления Stroke и Fill в комплекте инструментов

Выбрать цвет линии или однотонный или градиентный цвет заливки, можно переключая цвета заливки или окраски линий или выбирая значения по умолчанию (черные линии и белая заливка), используя средства управления Stroke и Fill в комплекте инструментов.

Комплект инструментов, средства управления Stroke и Fill устанавливают признаки рисование для новых объектов, которые Вы создаете инструментальными средствами рисования. Чтобы использовать средства управления Stroke и Fill или изменить признаки рисования существующих объектов, необходимо сначала выбрать объект.

Для применения средств управления Stroke и Fill из комплекта инструментов нужно сделать одно из следующего:

Щелкните треугольник рядом с палитрой цветов линии или заливки и выберите цветной образчик из всплывающего окна. Градиенты могут быть выбраны только для цвета заливки.
Введите значение HEX-кода цвета в текстовое поле во всплывшем цветовом окне.
Щелкните кнопку None в окне, чтобы выбрать прозрачный цвет линии или заливки.

Обратите внимание: Вы можете применять прозрачный цвет линии или заливки к новому объекту, но нельзя применять их к уже существующему объекту. Вместо этого выберите существующий цвет линии или заливки и удалите его.

Щелкните кнопку Color Picker во всплывающем цветовом окне и выберите цвет из Цвета Picker.
Щелкните кнопку ротации цветов Fill и Stroke в комплекте инструментов, чтобы поменять цвета между заливкой и цветом линии.
Нажмите кнопку задания цвета по умолчанию Fill и Stroke в комплекте инструментов, чтобы вернуться к заданным по умолчанию цветовым параметрам настройки (белый цвет заливки и черный цвет линий).


Specifying stroke and fill attributes

Работа с Цветом > Определение атрибутов цвета линий и заливки > Определение цвета линии, стиля и толщины в панели Stroke

Определение цвета линии, стиля и толщины в панели Stroke

Для изменения цвета линии, ее стиля и толщины у выбранного объекта, используется панель Stroke. Стиль линии можно выбирать из стилей, которые поставляются в комплекте Flash, или создать собственный.

Выбор цвета, стиля и толщины линии в панели Stroke:

1 | Выберите Window > Panels > Stroke.
2 | Для выбора цвета, щелкните треугольник рядом с палитрой цветов линии, и сделайте одно из следующего:
 | Выберите цветной образчик из палитры.
 | Введите значение HEX-кода цвета в текстовое поле.
 | Щелкните кнопку None, чтобы задать прозрачный цвет линии.

Обратите внимание: можно применять прозрачный цвет линии или заливки к новому объекту, но нельзя применять их к уже существующему. Вместо этого выберите существующий цвет линии или заливки и удалите его.

Щелкните кнопку Color Picker, и выберите цвет из Цвета Picker.

3 | Чтобы выбрать стиль линии, щелкните треугольник для открытия выпадающего меню стилей и выберите опцию из меню. Для создания собственного стиля, выберите Custom из меню в верхнем правом углу панели Stroke, затем выберите опции в диалоговом окне line style, и щелкните OK.

Обратите внимание: Выбор стиля линии отличающегося от Solid может увеличивать размер файла.

4 | Чтобы выбрать толщину линии, щелкните треугольник рядом со всплывающим меню Weight и установите движок на желаемую толщину.


Specifying stroke and fill attributes

Работа с Цветом > Определение атрибутов цвета линий и заливки > Работа с однотонными и градиентными цветами, заливка растровым рисунком в панели Fill

Работа с однотонными и градиентными цветами, заливка растровым рисунком в панели Fill

Для выбора прозрачного или однотонного цвета, градиента или растрового рисунка для заливки, используется панель Fill. Она также позволяет создавать и редактировать градиентные цвета заливки. Можно применять растровый рисунок для заливки, используя те рисунки, которые уже импортированы в текущий файл. Для информации о создании растрового рисунка для заливки, см. Разрыв отдельного растрового рисунка.

Использование панели Fill для прозрачной заливки:

1 | Выберите Window > Panels > Fill.
2 | Выберите кнопку None из меню Fill.

Обратите внимание: можно применять прозрачный цвет линии или заливки к новому объекту, но нельзя применять их к уже существующему. Вместо этого выберите существующий цвет линии или заливки и удалите его.

Использование панели Fill для однотонной заливки:

1 | Выберите Window > Panels > Fill.
2 | Выберите Solid (Однотонный цвет) из меню Fill.
3 | Щелкните треугольник рядом с палитрой цветов заливки и сделайте одно из следующего:
 | Укажите на нужный цвет в палитры.
 | Введите значение HEX-кода цвета в текстовое поле.
 | Щелкните кнопку Color Picker для открытия всплывающего меню и выберите цвет из Цветов Picker.

Использование панели Fill для применения, создания и редактирования градиентной заливки:

1 | Выберите Window > Panels > Fill.
2 | Выберите один из следующих пунктов меню Fill:
 | Линейный градиент (Linear Gradient) создает градиент, который меняет оттенок от начальной до конечной точки по прямой линии.
 | Радиальный градиент (Radial Gradien) создает градиент, который меняет оттенок от начальной до конечной точки по окружности.
3 | Щелкните палитру цветов Fill в комплекте инструментов и выберите градиент из палитры.
4 | Чтобы изменить цвет в выбранном градиенте, щелкните один из указателей ниже полосы определения градиента, нажмите палитру цветов, которая находится рядом с полосой определения градиента и выберите цвет.
5 | Чтобы добавить указатель на градиент, нажмите ниже полосы определения градиента. Выберите цвет для нового указателя как описано в шаге 4.
6 | Чтобы удалить указатель из градиента, перетащите указатель в сторону от полосы определения градиента.
7 | Чтобы сохранить градиент, щелкните треугольник в верхнем правом углу панели Fill, и выберите Add Gradient из всплывающего меню. Градиент будет добавлен в палитру Образцов для текущего файла.

Использование панели Fill для заливки растром (bitmap):

1 | Выберите Window > Panels > Fill.
2 | Выберите растровый рисунок (Bitmap) из меню Fill.
3 | Щелкните по нему в окне, которое появляется в панели Fill.
 | Используя инструмента Ковша Краски можно изменять растровый рисунок при заливке. См. Использование инструмента "Ковш Краски".


Specifying stroke and fill attributes

Работа с Цветом > Определение атрибутов цвета линий и заливки > Использование инструмента "Ковш Краски" (Paint Bucket)

Использование инструмента "Ковш Краски" (Paint Bucket)

Инструмент "Ковш Краски" заполняет обведенные области цветом. Он может или заполнять пустые области или изменять цвет уже окрашенных областей. Можно заливать однотонными цветами, градиентами и растровыми рисунками. Можно использовать инструмент "Ковш Краски" для заполнения областей, которые не полностью обведены или обозначены, в этом случае можно определить, как Flash будет заполнять промежутки в закрашиваемых формах при использовании "Ковша".

Можно также использовать инструмент "Ковш Краски" для корректировки размера, определять направление и центр градиента или заливаемого растрового рисунка. Для информации о создании растрового рисунка для заливки, см. Разрыв отдельного растрового рисунка.

Обратите внимание: когда, при заливке инструментом "Ковш Краски", Вы изменяете растровый рисунок, изменяются все случаи его использования для заливки, а не только тот, который установлен в данном выборе.

Левая форма полностью не обведена, но может быть залитой. Звездная форма состоит из индивидуальных линий, которые определяют область, которая может быть заполнена.

Использование инструмента "Ковш Краски" для заполнения области:

1 | Выберите инструмент "Ковш Краски".
2 | Выберите цвет заливки и стиль, как описано в работе с однотонным, градиентным цветом или растровым рисунком заливки.
3 | Щелкните модификатор Размера Промежутков и выберите размер промежутка:
 | Выберите Не Закрывать Промежутки (Don't Close Gaps), если хотите закрыть промежутки вручную перед заполнением формы. Заполнение промежутков вручную может оказаться быстрее для сложных рисунков.
 | Выберите опцию Закрывать (Close), чтобы Flash сам заполнил форму, имеющую промежутки.
4 | Щелкните ковшом по форме или выделенной области, которую хотите заполнить.

Обратите внимание: Если промежутки слишком большие, то вероятно, придется закрывать их вручную.

Корректировка градиента или растрового рисунка для заливки инструментом "Ковш Краски":

1 | Выберите инструмент "Ковш Краски".
2 | Щелкните модификатор Transform Fill.
3 | Щелкните область заполненную градиентом или растровым рисунком.
 | Когда выбираете градиент или растровый рисунок для редактирования, появляется точка его центра, и отображается блок с маркерами редактирования, ограничивающий его. Когда мышь наводится на любом из этих маркеров, вид курсора изменяется для указания функции маркера.
 | Нажмите Shift, чтобы ограничить направление линейного градиента, углом в 45° .
4 | Измените градиент или заливку любым из следующих способов:
 | Повторно установите точку центра градиента или растрового рисунка, перетащите точку центра.
 | Измените ширину градиента или растрового рисунка, перетаскивая квадратный маркер на стороне блока ограничений. (Эта опция изменяет только размеры заливки, а не объекта, содержащего заливку.)
 | Измените высоту градиента или растрового рисунка, перетаскивая квадратный маркер внизу блока ограничения.
 | Вращайте градиент или растровый рисунок, перетаскивая круговой маркер вращения в углу. Вы можете также перетащить самый нижний маркер на круге ограничения кругового градиента или заливки.
 | Чтобы масштабировать линейный градиент или заливку, перетащите квадратный маркер в центре блока ограничения.
 | Чтобы изменять радиус кругового градиента, перетащите средний круговой маркер на круге ограничения.
 | Чтобы искажать или наклонять заливку в пределах формы, перетащите один из круговых маркеров на верхней или правой стороне блока ограничения.
 | Для неперекрывающегося расположения растрового рисунка внутри формы, масштабируйте заливку.

Обратите внимание: Чтобы видеть все маркеры при работе с большими заливками или заливками находящимися близко к краю рабочей области, выберите View > Work Area.


Specifying stroke and fill attributes

Работа с Цветом > Определение атрибутов цвета линий и заливки > Использование инструмента "Бутылка Чернил" (Ink Bottle)

Использование инструмента "Бутылка Чернил" (Ink Bottle)

Для изменения цвета, ширины и стиля линий или основ формы используется инструмент "Бутылка Чернил". Можно применять только твердые цвета, градиенты или растр к линиям не применимы.

Использование инструмента "Бутылка Чернил", скорее чем выбор индивидуальных линий, делает более легким изменение признаков линий многократных объектов одновременно.

Использование инструмента "Бутылка Чернил":

1 | Выберите инструмент "Бутылка Чернил".
2 | Выберите цвет линии, как описано в Использовании панелей Stroke и Fill.
3 | Выберите тип линии и ширину линии в панели Stroke. См. Определение цвета линии, стиля и толщины в панели Stroke.
4 | Щелкните объект в рабочем поле, чтобы применить модификации к линии.


Specifying stroke and fill attributes

Работа с Цветом > Определение атрибутов цвета линий и заливки > Использование инструмента "Пипетка" (Eyedropper)

Использование инструмента "Пипетка" (Eyedropper)

Инструмент "Пипетка" предназначен для копирования заливки и признаков линий у одного объекта и немедленного применения их для другого объекта. Инструмент "Пипетка" также позволяет брать образец растрового рисунка для его использования в заливке. См. Разрыв отдельного растрового рисунка.

Использование инструмента "Пипетка" для копирования и примения признаков линий или заливок:

1 | Выберите инструмент "Пипетка" и щелкните линию или заполненную область, чей признак требуется применить на другой линии или заполненной области.
 | Когда Вы щелкаете по линии, инструмент автоматически изменяется на инструмент "Бутылка Чернил". Когда Вы щелкаете заполненную область, он автоматически изменяется на инструмент "Ковш Краски" и включается модификатор "Блокировка Заполнения" (Lock Fill). См. Блокировка градиента или растрового рисунка при заливке рабочей области.
2 | Щелкните другую линию или заполненную область, чтобы применить новые признаки.


Specifying stroke and fill attributes

Работа с Цветом > Определение атрибутов цвета линий и заливки > Блокировка градиента или растрового рисунка при заливке рабочей области

Блокировка градиента или растрового рисунка при заливке рабочей области

Можно блокировать градиент или растровый рисунок для получения эффекта заливки по всем объектам рабочей области, при этом будет казаться, что объекты являются масками, под которыми находится Ваш градиент или точечный рисунок.

Когда выбрана Блокировка, заливка Кистью или Ковшом выполняется одновременно для всех объектов находящихся в рабочей области.

Использование Блокировки.

Чтобы использовать блокированный градиент или растровый рисунок:

1 | Выберите Кисть или Ковш и выберите градиент или растровый рисунок для заливки.
2 | Нажмите модификатор Блокировка Заливки.
3 | Сначала окрасьте области, где Вы хотите видеть центр заливки, затем двигайтесь к другим областям.


Using imported artwork overview

Использование импортированной графики > Краткий обзор импортированной графики

Краткий обзор использования импортированной графики

Ваш Flash-клип может использовать графику, созданную в других приложениях. Можно импортировать векторную графику и растровые рисунки в файлах разнообразных форматов. Если на вашем компьютере установлен QuickTime 4 или более поздней версии, то можете импортировать файлы дополнительных форматов. Для большей информации, см. Форматы импортируемых файлов.

Возможен импорт файлов FreeHand (версии 7 и выше) и файлов PNG Fireworks непосредственно в Flash, с сохранением признаков этих форматов.

Чтобы импортировать звуковые файлы в формате WAV (Windows), AIFF (Macintosh), и MP3 (обе платформы) форматы, см. Импорт звуков.


Converting bitmaps to vector graphics

Использование импортированной графики > Преобразование растровых рисунков в векторную графику

Преобразование растровых рисунков в векторную графику

Команда Trace Bitmap конвертирует растровый рисунок в векторное изображение с доступными для редактирования дискретными областями цвета. Используйте эту команду, чтобы управлять изображением, как векторным графическим символом, или чтобы уменьшать размер файла.

После конвертирования растрового рисунка в векторное изображение, полученный векторный рисунок не будет больше связан с растровым символом в окне Библиотеки.

Обратите внимание: Если импортированный растровый рисунок содержит сложные формы и много цветов, преобразованный векторный рисунок может иметь больший вес, чем первоначальный растровый. Пробуйте разнообразные параметры настройки в диалоговом окне Trace Bitmap, чтобы найти равновесие между качеством изображения и размером файла.

Вы можете также разорвать (break apart) растровый рисунок, чтобы изменить изображение, используя инструментальные средства Flash для рисования и окрашивания изображения. См. Разрыв (Breaking apart) отдельного растрового рисунка.

Конвертация растрового рисунка в векторное изображение:

1 | Выберите растровый рисунок в текущей сцене.
2 | Выберите Modify > Trace Bitmap.
3 | Введите значение Color Threshold между 1 и 500.
 | Сравниваются два рядом находящихся пиксела, если различие в значениях цвета RGB - меньше чем цветовой порог, эти два пиксела рассматриваются, как окрашенные одним цветом. При увеличении порогового значения, Вы уменьшаете число цветов.
4 | Для Минимальной Области (Minimum Area), введите значение между 1 и 1000, этим задается число окружающих пикселей, рассматриваемых при назначении цвета пикселу.
5 | Для Огибающей Кривой (Curve Fit), выберите опцию из всплывающего меню, чтобы определить степень сглаженности (округлости).
6 | Для Порога Угла (Corner Threshold), выберите опцию из всплывающего меню, чтобы определить сохранять-ли острые углы или необходимо их сглаживать.

Чтобы создавать векторное изображение, которое выглядит более похожим на первоначальный растровый рисунок, вводят следующие значения:

Результаты использования команды Trace Bitmap

Color Threshold: 10
Minimum Area: 1 pixel
Curve Fit: Pixels
Corner Threshold: Many Corners


Breaking apart a bitmap

Использование импортированной графики > Разрыв (Breaking apart) отдельного растрового рисунка

Разрыв (Breaking apart) отдельного растрового рисунка

Разрыв (Breaking apart) растрового рисунка отделяет пикселы в изображении в дискретные области, которые могут быть выбраны и изменены отдельно. Когда разрывается растровый рисунок, то его можно изменять используя встроенные инструментальные средства для рисования и окрашивания.

Используя инструмент Лассо (Lasso) с модификатором Волшебной Палочки (Magic Wand), можно изменять окраску выбранных областей растрового рисунка, который был.

После того, как закрасите области с растрового рисунка, можете использовать инструмент "Ковш Краски", чтобы вращать, искажать или масштабировать растровое изображение. См. Использование инструмента "Ковш Краски".

Разрыв (break apart) отдельного растрового рисунка:

1 | Выберите растровый рисунок в текущей сцене.
2 | Выберите Modify > Break Apart.

Окраска изображением растрового рисунка:

1 | Разорвите растровый рисунок, как описано выше.
2 | Выберите инструмент "Пипетка" (Eyedropper) и щелкните по растровому рисунку.
 | Пипетка как-бы заполняется растровым рисунком и изменяется на активный инструмент "Ковш Краски".
3 | Окрасьте нужную Вам область с помощью "Кисти" или "Ковша Краски".

Изменение заполнения выбранных областей разорванного растрового рисунка:

1 | Выберите разорванный растровый рисунок в сцене.
2 | Выберите инструмент "Лассо" и щелкните модификатор "Волшебной Палочки".
3 | Щелкните модификатор настройки параметров "Волшебной Палочки" и установите следующие опции:
 | Для Порога (Threshold) введите значение между 1 и 200, это определит, как близко должен соответствовать цвет смежного пиксела, чтобы быть включенным в выбор. Более высокое число включает более широкий диапазон цветов. Если Вы вводите 0, будет выбран пиксел только точно такого-же цвета.
 | Для Сглаживания (Smoothing), выберите опцию из всплывающего меню, это определит сколько граней растрового рисунка будут сглажены.
4 | Щелкните растровый рисунок, чтобы выбрать область. Продолжайте нажимать несколько раз, чтобы добавить области к выбору.
5 | Выберите инструмент для заполнения выбранных областей в растровом рисунке. См. Определение признаков Stroke и Fill.
6 | Выберите инструмент "Ковш Краски", и щелкните где-нибудь на выбранных областях, чтобы добавить новую заливку.


Editing bitmaps

Использование импортированной графики > Редактирование растровых рисунков

Редактирование растровых рисунков

Если Вы имеете Fireworks 3 или более поздний или другое приложение для редактирования изображений, то можете запускать это приложение из Flash, чтобы редактировать импортированный растровый рисунок.

Если редактируете Fireworks PNG файл, импортированный как сглаженное изображение, можете выбрать редактирование исходного PNG файла для растрового рисунка, когда это доступно.

Обратите внимание: нельзя редактировать растровые рисунки из Fireworks PNG файлы, импортированные как доступные для редактирования объекты во внешнем редакторе изображений.

Редактирование растрового рисунка с Fireworks 3 или выше:

1 | В окне Библиотеки, щелкните правой кнопкой мыши (Windows) или Control-click(Macintosh) значок растрового рисунка.
2 | В контекстном меню растрового рисунка, выберите Edit Fireworks 3.
3 | В диалоговом окне Edit Image, определите, должны ли исходные PNG-файлы или растровые файлы быть открыты.
4 | Сделайте нужные вам изменения файла в Fireworks.
5 | Выберите File > Update.
 | Файл автоматически модифицируется во Flash.

Редактирование растрового рисунка другим внешним редактором:

1 | В окне Библиотеки, щелкните правой кнопкой мыши (Windows) или Control-click (Macintosh) значок растрового рисунка.
2 | В контекстном меню растрового рисунка, выберите Edit With.
3 | Выберите нужный вам редактор в котором будет открыт растровый файл и щелкните OK.
4 | Сделайте необходимые изменения с помощью этого редактора.
5 | Во Flash сделайте одно из следующего:
 | Выберите значок растрового рисунка в окне Библиотеки, и выберите Update из меню Library Options.
 | Щелкните правой кнопкой мыши (Windows) или Control-click (Macintosh) на значок растрового рисунка в окне Библиотеки, и выберите Update из контекстного меню.
 | Файл автоматически будет модифицирован во Flash.


Setting bitmap properties

Использование импортированной графики > Установка свойств растрового рисунка

Установка свойств растрового рисунка

Вы можете применять сглаживание (smooth) к растровому рисунку, чтобы пригладить грани в изображении. Можете также выбирать опцию сжатия, чтобы уменьшить размер файла и подготовить его для показа в сети.

Для выбора растровых свойств используется диалоговое окно Bitmap Properties.

Установка растровых свойств:

1 | Выберите растровый рисунок в окне Библиотеки.
2 | Сделайте одно из следующего:
 | Щелкните значок свойств внизу окна Библиотеки.
 | Щелкните правой кнопкой мыши (Windows) или Control-click (Macintosh) значок растрового рисунка, и выберите Properties из контекстного меню.
 | Выберите Properties из меню Options в верхнем правом углу окна Библиотеки.
3 | В диалоговом окне Bitmap Properties, выберите Allow Smoothing, чтобы пригладить грани растрового рисунка со сглаживанием.
4 | Для Сжатия, выберите одну из следующих опций:
 | Выберите Photo (JPEG), чтобы сжать изображение в формате JPEG. Чтобы использовать заданное по умолчанию качество сжатия, указанное для импортированного изображения, выберите Качество Use Document Default. Чтобы определить новую установку качества сжатия, снимите выделение Use Document Default Quality и введите значение между 1 и 100 в текстовом поле Quality. (Высшее значение сохраняет большую целостность изображения, но меньшее уменьшает размер файла.)
 | Выберите Lossless (PNG/GIF), чтобы сжать изображение с lossless сжатием, при этом типе сжатия изображение сохраняется без потерь.

Обратите внимание: Сжатие Use Photo используется для изображений со сложными цветными или тональными переходами, типа фотографий или изображений с градиентом. Lossless сжатие - для изображений с простыми формами и относительно небольшим количеством цветов.

5 | Щелкните Test, чтобы определить результаты сжатия файла. Сравните первоначальный размер файла со сжатым размером файла, чтобы определить, является ли выбранная установка сжатия приемлемой.
6 | Щелкните OK.

Обратите внимание: JPEG параметры настройки Качества, которые Вы выбираете в диалоговом окне Publish Settings, не определяют установку качества для импортированных JPEG файлов. Вы должны определить установку качества для импортированных JPEG файлов в диалоговом окне Bitmap Properties.


Placing artwork into Flash

Использование импортированной графики > Размещение графики во Flash

Размещение графики во Flash

Flash поддерживает различные векторные и растровые форматы. Можно размещать графику во Flash импортируя или вставляя ее через буфер обмена. Flash импортирует векторную, растровую графику и последовательности изображений следующим образом:

Векторные изображения из FreeHand импортируются непосредственно во Flash-клип. Можно выбирать опции для сохранения FreeHand-слоев, страниц и текстовых блоков. Чтобы импортировать FreeHand-файл, см. Импорт FreeHand файлов.
PNG изображения из Fireworks могут быть импортированы непосредственно в Flash-клип с векторными и растровыми данными, сохраненными, как доступные для редактирования объекты. Можно выбирать опции для сохранения изображений, текста и направляющих (guides). Чтобы импортировать Fireworks PNG-файлы, см. Импорт Fireworks PNG-файлов.

Обратите внимание: Если Вы импортируете PNG-файлы из Fireworks, вырезая и вставляя, файл преобразуется в растровый рисунок.

Векторные изображения форматов SWF, Adobe Illustrator и Windows Metafile форматы (WMF) импортируются как группы в текущий слой. См. Импорт форматов файлов и Импорт файлов формата Adobe Illustrator.
Точечные рисунки (сканированные фотографии, BMP-файлы) импортируются как одиночные объекты в текущий уровень. Flash сохраняет параметры настройки прозрачности импортированных растровых рисунков. Такое импортирование может увеличивать размер SWF-файла, но существует возможность сжатия импортированного битмапа. См. Установка свойств растрового рисунка.

Обратите внимание: Растровая прозрачность не может быть сохранена, когда растровые рисунки импортированы перетаскиванием. Чтобы сохранять прозрачность, используйте File > Import.

Любая последовательность изображений (например, PICT и BMP последовательности) импортируется, как последовательные кадры текущего слоя.

Для большей информации об определенных форматов файлов, см. Форматы импортируемых файлов.

Импорт файлов во Flash:

1 | Выберите File > Import.
2 | В диалоговом окне Import, выберите формат файла из появляющегося всплывающего меню.
3 | Найдите нужный файл и выделите его.
 | Если импортируемый файл имеет много слоев, Flash может создавать новые слои. Убедитесь, что в Timeline видны при импортировании файла эти новые слои.

Обратите внимание: Если импортируете Fireworks PNG-файл, см. Импорт Fireworks PNG-файлов. Если импортируете FreeHand файлы, см. Импорт FreeHand файлов.

4 | Сделайте одно из следующего:
В Windows нажмите Open.
На Macintosh нажмите Add, чтобы добавить выбранный файл к списку Import, и нажмите Import, чтобы импортировать файл или файлы списка Import.
5 | Если в конце названий импортируемых фалов присутствуют номера и в этой папке есть последовательность таких файлов, Flash спросит Вас, импортировать ли эту последовательность файлов:
Щелкните Yes, чтобы импортировать последовательные файлы.
Щелкните No, чтобы импортировать только указанный файл.
Вот примеры имен файлов, которые могут использоваться как последовательность:
Frame001.gif, Frame002.gif, Frame003.gif
Bird 1, Bird 2, Bird 3
Walk-001.ai, Walk-002.ai, Walk-003.ai

Вставка растрового рисунка из другого приложения в Flash:

1 | Скопируйте изображение в другом приложении.
2 | Во Flash выберите Edit > Paste.


Placing artwork into Flash

Использование импортированной графики > Размещение импортированой графики во Flash > Форматы импортируемых файлов

Форматы импортируемых файлов

Flash 5 может импортировать файлы различных форматов в зависимости от того, установлена у Вас QuickTime 4 или более поздняя версия. Использование Flash с установленной QuickTime 4 особенно полезно для совместных проектов, в которых работают авторы на Платформах Macintosh и Windows. QuickTime 4 расширяет поддержку для файлов некоторых форматов (включая Adobe Photoshop, PICT, QuickTime Movie и других) на обеих платформах.

Форматы файлов, которые могут быть импортированы во Flash 5, независимо от того, установлен ли QuickTime 4:
Типы файлов | Расширения | Windows | Macintosh
Adobe Illustrator (версия 6.0 или ранняя; см. Файлы Adobe Illustrator) | .eps, .ai |  |
AutoCAD DXF (см. Файлы AutoCAD DXF) | .dxf |  |
Bitmap | .bmp |  |
Enhanced Windows Metafile | .emf |  |
FreeHand | .fh7, .ft7, .fh8, .ft8, .fh9, .ft9 |  |
FutureSplash Player | .spl |  |
GIF and animated GIF | .gif |  |
JPEG | .jpg |  |
PICT | .pct, .pic |  |
PNG | .png |  |
Flash Player | .swf |  |
Windows Metafile | .wmf |  |

Форматы файлов, которые могут быть импортированы во Flash 5 если установлена QuickTime 4 или более поздняя:
Типы файлов | Расширения | Windows | Macintosh
MacPaint | .pntg |  |
Photoshop | .psd |  |
PICT | .pct, .pic | (Как растровый рисунок) |
QuickTime Image | .qtif |  |
QuickTime Movie | .mov |  |
Silicon Graphics | .sai |  |
TGA | .tgf |  |
TIFF | .tiff |  |


Placing artwork into Flash

Использование импортированной графики > Размещение импортированой графики во Flash > Импорт Fireworks PNG-файлов

Импорт Fireworks PNG-файлов

Вы можете импортировать Fireworks PNG-файлы во Flash как сглаженные изображения или как доступные для редактирования объекты. Когда импортируете PNG-файл, как сглаженное изображение, полный файл (включая любую векторную графику) - rasterized растеризуются, преобразуется к растровому изображению. Когда импортируете PNG-файл, как доступный для редактирования объект, векторная графика в файле сохраняется в векторном формате. Можно выбирать, сохранять-ли помещенные растровые рисунки, текст и направляющие (guides) в PNG-файле, когда импортируете их, как доступные для редактирования объекты.

Если импортируете PNG-файл как сглаженное изображение, можно запускать Fireworks изнутри Flash и редактировать оригинал PNG-файла (с векторными данными). См. Редактирование растровых рисунков.

Обратите внимание: Можно редактировать растровые изображения во Flash, конвертируя растровые изображения и векторную графику или разрывать (Breaking apart) отдельные растровые изображения. См. Преобразование растровых рисунков в векторную графику и Разрыв (Breaking apart) отдельного растрового рисунка.

Импорт Fireworks PNG-файлов:

1 | Выберите File > Import.
2 | В диалоговом окне Import, выберите Изображение PNG из всплывающего меню.
3 | Найдите нужный файл с Fireworks PNG изображение и выделите его.
4 | Сделайте одно из следующего:
 | Щелкните Open (Windows).
 | Щелкните Add (Macintosh), чтобы добавить выбранный файл к списку Import и щелкните Import, чтобы импортировать файл или файлы списка Import.
5 | В диалоговом окне PNG Import Settings, выберите одно из следующего:
 | Импортировать Доступные для редактирования Элементы (Import Editable Elements), импортирует PNG-файл как отдельные элементы, сохраняя векторную графику. Выберите Include Images, чтобы сохранить растровые изображения в импортированном файле. (Растровые изображения помещаются в библиотеку текущего Flash-фильма, но они не могут быть отредактированы внешним редактором изображений.) Выберите Включить Текст (Include Text), чтобы сохранить текст как доступные для редактирования текстовые блоки. Выберите Include Guides, чтобы импортировать направляющие Fireworks как draggable-направляющие.
 | Сглаживание Изображения (Flatten Image), импортирует PNG-файл как растровое изображение в текущий слой. Растровый рисунок помещается в библиотеку текущего клипа и может быть отредактирован Fireworks или другим внешним редактором изображения. См. Редактирование растровых рисунков.
6 | Щелкните OK.


Placing artwork into Flash

Использование импортированной графики > Размещение импортированой графики во Flash > Импорт FreeHand файлов

Импорт FreeHand файлов

Можно импортировать FreeHand файлы (версии 7 или позднее) непосредственно во Flash. FreeHand (скрытая реклама продукта Macromedia) - лучший выбор для создания векторной графики для импорта во Flash, потому что может сохранять слои FreeHand, текстовые блоки, символы библиотек и страницы, и выбирать диапазон страниц для импорта. Если импортированный FreeHand файл находится в режиме цвета CMYK, Flash конвертирует файл в RGB режим.

Помните следующие рекомендации при импортировании FreeHand файлов:

При импортировании файла с перекрыванием объектов, которые хотите сохранить, как отдельные объекты, размещайте объекты в отдельные слои во FreeHand, и выбирайте слои (Layers) в диалоговом окне FreeHand Import во Flash при импортировании файла. (При перекрывании объектов на одном слое импортированные во Flash накладывающиеся формы будут разделены в перекрестных точках, также, как перекрывающиеся объекты, которые Вы создаете во Flash.)
Когда импортируете файлы с градиентной заливкой, Flash может поддерживать до восьми цветов в градиенте. Если FreeHand файл имеет градиент, содержащий более восьми цветов, Flash создает пути отсечения (clipping paths), чтобы моделировать появление градиента. Они могут увеличивать размер файла. Чтобы уменьшить его размер, используйте градиенты с количеством цветов меньше восьми во FreeHand.
Когда импортируете файлы со смесями (blends), Flash импортирует каждый шаг в смеси как отдельный путь. Таким образом, чем большее количество шагов смеси имеется в FreeHand файле, тем больший размер импортированного файла будет во Flash.
Когда импортируете файлы с линиями обводки, которые имеют прямые углы, Flash конвертирует углы - скругляет их.
Когда импортируете файлы с помещенными черно-белыми (grayscale) изображениями, Flash конвертирует черно-белые изображения в цветные RGB. Это преобразование может увеличивать размер импортированного файла.
При импортировании файлов с помещенными изображениями EPS, надо сначала выбрать Доступность редактирования конвертирования EPS (Convert Editable EPS) до включения опции Imported в FreeHand, прежде чем размещаете EPS во FreeHand. Если Вы не выбираете эту опцию, изображение EPS не будет просматриваемо после импорта во Flash. Кроме того, Flash не отображает информацию для импортированного изображения EPS (независимо от параметров настройки свойств, используемых во FreeHand).

Импорт FreeHand файлов:

1 | Выберите File > Import.
2 | В диалоговом окне Import, выберите FreeHand из всплывающего меню.
3 | Найдите нужный файл FreeHand и выберите его.
4 | Сделайте одно из следующего:
 | В Windows, щелкните Open.
 | На Macintosh, щелкните Add, чтобы добавить выбранный файл к списку Import, и щелкните Import, чтобы импортировать файл или файлы списка Import.
5 | В диалоговом окне FreeHand Import Settings, для Отображения Страниц (Mapping Pages), выбирают установку:
 | Scenes - Конвертировать сцены каждой страницы во FreeHand документе на сцену в клипе.
 | Keyframes - Конвертировать каждый кадр страницы во FreeHand документе в кадры в клипе.
6 | Для слоев выберите одно из следующего:
 | Layers - Конвертировать каждый уровень во FreeHand документе на уровни в клипе.
 | Keyframes - Конвертировать каждый кадр во FreeHand документе в кадры в клипе.
 | Сглаживание (Flatten) конвертировать со всех слоев в FreeHand документе на отдельный сглаженный слой в клипе.
7 | Для Страниц выберите одно из следующего:
 | Импортировать все страницы (All imports) из FreeHand документа.
 | От (номер страницы) до (номер страницы) (From.. To..) страниц импортировать из FreeHand документа.
8 | Для Опций выберите любую из следующих опций:
 | Включить Видимые Слои (Include Visible Layers), импортирует только видимые слои (не скрытые слои) из FreeHand документа.
 | Включить Фоновый Слой (Include Background Layer), импортирует фоновый слой из FreeHand документа.
 | Поддержка Текстовых Блоков (Maintain Text Blocks), сохраняет текст в FreeHand документе как доступный для редактирования текст в клипе.
9 | Щелкните OK.


Placing artwork into Flash

Использование импортированной графики > Размещение импортированой графики во Flash > Импорта файлов формата Adobe Illustrator

Импорта файлов формата Adobe Illustrator

Flash поддерживает импорт и экспорт файлов форматов Adobe Illustrator 88, 3.0, 5.0, и 6.0. (Для информации об экспорте Illustrator-файлов, см. Adobe Illustrator.)

Когда импортируете Illustrator-файл во Flash, Вы должны разгруппировать все, что содержит Illustrator на всех слоях. Если объекты разгруппированы, ими можно манипулировать как любым другим объектом Flash.


Placing artwork into Flash

Использование импортированной графики > Размещение импортированой графики во Flash > Об импорте растровых изображений

Об импорте растровых изображений

Импорт растровых изображений в Flash-фильм может увеличивать размер файла. Чтобы уменьшать размер файла растрового изображения, можно выбирать опцию сжатия в диалоговом окне Bitmap Properties. См. Установка свойств растрового рисунка.

Можно редактировать импортированный растровый рисунок, запуская Fireworks или другой внешний редактор изображения из Flash.

Можно трассировать растровый рисунок, чтобы конвертировать его в векторное изображение. Выполнение этого преобразования дает возможность оперировать с полученной графикой также, как это делается с другими векторными рисунками во Flash и это также уменьшает размер файла. См. Преобразование растровых рисунков в векторную графику.

Можно разбивать (break apart) растровые рисунки в доступные для редактирования области. Растровый рисунок сохраняет свои первоначальные детали, но разбивается на дискретные области цвета, которые Вы можете выбирать и изменять отдельно во Flash, используя рисующие и раскрашивающие инструментальные средства Flash. При разбивке растрового рисунка также можно использовать растровый рисунок как заливку, чтобы закрашивать им объекты. См. Разрыв (break apart) отдельного растрового рисунка.

Если клип отображает импортированный растровый рисунок в большем масштабе чем оригинал, изображение может быть искажено. Делайте предварительный просмотр импортированного растрового рисунка, чтобы убедиться, что изображения выглядят должным образом.


Placing artwork into Flash

Использование импортированной графики > Размещение импортированой графики во Flash > Использование QuickTime фильмов

Использование QuickTime фильмов

Если на вашем компьютере установлен QuickTime 4 или более поздняя версия, можете импортировать QuickTime фильмы во Flash, чтобы изменить фильм. Однако, чтобы отображать QuickTime фильм, необходимо экспортировать его в формате QuickTime. Вы не можете отображать QuickTime кинофильм в формате SWF. Для получения дополнительной информации при публикации вашего файла Flash как QuickTime фильма, см. Публикация фильма QuickTime 4.

Можно масштабировать, вращать и анимировать QuickTime фильм во Flash, а так же запускать и устанавливать путь каталога фильма в библиотеке. Однако, нельзя двигать содержание QuickTime фильма во Flash. Вы можете применять любую команду, из числа перечисленных в Основной категории Действий (Basic Actions) в панели Actions к импортированному QuickTime фильму.

При импорте QuickTime фильм, отображается только первый кадр фильма. Вы должны добавить кадры в Timeline импортированного фильма, чтобы рассмотреть дополнительные кадры в Flash-фильме. QuickTime фильм, импортированный во Flash не станет частью файла Flash. Вместо этого, Flash обслуживает указатель на исходный файл.

Для предварительного просмотра QuickTime фильма:

1 | Добавьте необходимое количество кадров в Timeline, которые соответствуют длине QuickTime фильма, который Вы хотите запустить.
2 | Выберите Control > Play.

Обратите внимание: нельзя запустить предварительный просмотр QuickTime фильма используя Control > Test Movie.

Установка пути файла каталога QuickTime фильма:

1 | Выберите Window > Library и выберите QuickTime фильм, который Вы хотите редактировать.
2 | В меню Options в верхнем правом углу окна Библиотеки, выберите Properties, и щелкните Set Path в диалоговом окне Video Properties.


Placing artwork into Flash

Использование импортированной графики > Размещение импортированой графики во Flash > Файлы AutoCAD DXF

Файлы AutoCAD DXF

Flash поддерживает формат AutoCAD DXF 10 версии.

DXF файлы не поддерживают стандартные системные шрифты. Flash пробует отображать шрифты соответственно, но результаты могут быть непредсказуемы, особенно для выравнивания текста.

Так как формат DXF не поддерживает однотонную заливку цветом, заполненные области экспортируются только как каркас. По этой причине, формат DXF чаще используют, как рисунок линий, типа планов экспозиций и карт.

Можно импортировать двух-мерные DXF файлы во Flash, трехмерные DXF файлы не поддерживаются.

Хотя Flash и не поддерживает масштабирование в DXF файле, все импортированные DXF файлы производят 12-на-12-inch фильмы, которые Вы можете масштабировать используя Modify > Transform > Scale. Также, Flash поддерживает только ASCII DXF файлы. Если ваши DXF файлы двоичные, то перед импортом их необходимо сконвертировать в ASCII формат.


Adding sound overview

Добавление Звука > Добавление звука - краткий обзор

Добавление звука - краткий обзор

Flash предлагает множество способов использовать звуки. Можно использовать звуки, которые играют непрерывно, независимо от Timeline, или синхронизировать мультипликацию со звуковой дорожкой. Можно прикрепить звуки к кнопкам, чтобы сделать их более интерактивными и заставить звуки постепенно появляться или исчезать для получения более плавной звуковой фонограммы.

Вы можете использовать звуки в общедоступных библиотеках или связывать звуки из одной библиотеки с различными Flash-клипами. Также можно использовать звуки в Звуковых (Sound) объектах, управлять звуковым воспроизведением с использованием ActionScript.

Существует два типа звуков во Flash: звуки события (Event sound) и потоковые звуки (Stream sound). Звук события должен быть загружен полностью, прежде чем его нужно будет воспроизводить и он будет продолжать играть, пока не будет явно остановлен. Потоковые звуки начинают воспроизводиться, как только загружается достаточно данных для нескольких первых фреймов; потоковые звуки синхронизированы с анимацией в Timeline для воспроизведения в Web.

Вам предоставлен выбор опций сжатия звука для управления качеством и размером звуковых файлов в экспортируемом Flash-фильме. Вы можете выбирать опции сжатия для отдельных звуков в диалоговым окном Sound Properties или определять параметры настройки всех звуков во Flash-фильме в диалоговом окне Publish Settings.

Для изучения введения в использование звуков во Flash, выберите Help > Lessons > Sound.


Compressing sounds for export

Добавление Звука > Сжатие звуков для экспорта > Использование ADPCM компрессии

Использование ADPCM компрессии

Опция сжатия ADPCM устанавливает сжатие для 8-битных или 16-битных звуковых данных. Используйте ADPCM компрессию для озвучивания коротких по времени событий типа щелчков кнопки.

Использование ADPCM компрессии:

1 | В диалоговом окне Sound Properties выберите ADPCM из меню Compression.
2 | Для предварительной обработки выберите Convert Stereo to Моnо, чтобы микшировать каналы стерео в моно. (Моно звуки не активизируют эту опцию.)
3 | Выберите опцию типовой частоты (Sample Rate), чтобы управлять качеством звука и размером файла. При более низкой частоте размер файла уменьшается, но и ухудшается качество звука. Опции типовой частоты (Sample Rate) следующие:
 | 5 кГц - приемлем только для речи.
 | 11 кГц - самое низкое рекомендуемое качество для коротких музыкальных фрагментов, примерно четверть стандартного качества CD.
 | 22 кГц - популярный выбор для воспроизведения в Web - примерно половина стандартного качества CD.
 | 44 кГц - стандартное качество CD.

Обратите внимание: Flash не может увеличивать типовую частоту кГц импортированного звука выше того значения, с которой он был импортирован.


Compressing sounds for export

Добавление Звука > Сжатие звуков для экспорта > Использование MP3 компрессии

Использование MP3 компрессии

MP3 опция сжатия позволяет экспортировать звуки с MP3 компрессией. Используйте MP3 формат при экспорте длинных звуковых фонограмм.

Использование MP3 компрессии:

1 | В диалоговом окне Sound Properties, выберите MP3 из меню Compression.
2 | Из меню Bit Rate выберите степень MP3 компрессии для кодирующего устройства. Flash поддерживает степень компрессии от 8 kbps до 160 kbps CBR (постоянная степень сжатия). При экспорте музыки, устанавливайте норму 16 Kbps или выше для лучших результатов.
3 | Для предварительной обработки выберите Convert Stereo to Моnо, чтобы микшировать каналы стерео в моно. (Моно звуки не активизируют эту опцию.)

Обратите внимание: Опция Preprocessing доступна только в то случае, если Вы выбираете степень компрессии 20 Kbps и выше.

4 | Для задания скорости сжатия и качества звука выберите одну из следующих опций:
 | Fast (Быстро) - более быстрое сжатие, но снижает качество.
 | Medium (Среднее) - несколько медленнее сжимает, но более высокое звуковое качество.
 | Slow (Медленно) - самое медленное сжатие и самое высокое звуковое качество.


Compressing sounds for export

Добавление Звука > Сжатие звуков для экспорта > Использование Raw компрессии

Использование Raw компрессии

Опция сжатия Raw экспортирует звуки без компрессии.

Использование Raw компрессии:

1 | В диалоговом окне Sound Properties, выберите Raw из меню Compression.
2 | Для предварительной обработки выберите Convert Stereo to Моnо, чтобы микшировать каналы стерео в моно. (Моно звуки не активизируют эту опцию.)
3 | Выберите опцию типовой частоты (Sample Rate), чтобы управлять качеством звука и размером файла. При более низкой частоте размер файла уменьшается, но и ухудшается качество звука. Опции типовой частоты (Sample Rate) следующие:
 | 5 кГц - приемлем только для речи.
 | 11 кГц - самое низкое рекомендуемое качество для коротких музыкальных фрагментов, примерно четверть стандартного качества CD.
 | 22 кГц - популярный выбор для воспроизведения в Web - примерно половина стандартного качества CD.
 | 44 кГц - стандартное качество CD.

Обратите внимание: Flash не может увеличивать типовую частоту кГц импортированного звука выше того значения, с которой он был импортирован.


Compressing sounds for export

Добавление Звука > Сжатие звуков для экспорта > Рекомендации по экспорту звука для Flash-фильмов

Рекомендации по экспорту звука для Flash-фильмов

Кроме осуществления выборки метода и типа сжатия, есть несколько способов более эффективного использования звука в Flash-фильмах и уменьшения их размеров:

Корректируйте точки начала и окончания звуков, чтобы не сохранять в файлах Flash тишину, которая тоже занимает место.
Дорабатывайте один и тот-же звук, применяя к нему различные эффекты типа управления громкостью, перетеканием из канала в канал в различных кадрах. Вы можете добиться иллюзии воспроизведения различных звуков, используя только один звуковой файл.
Используйте петли (loop) для укороченных звуковых фрагментов или их части. Зацикливайте короткие звуки для фоновой музыки.
Не циклите потоковые звуки.


Compressing sounds for export

Добавление Звука > Сжатие звуков для экспорта > Рекомендации для экспорта звука в QuickTime-фильмы

Рекомендации для экспорта звука в QuickTime-фильмы

Экспорт QuickTime-фильмов со звуковым сопровождением Flash делает несколько иначе, чем экспорт Flash-фильмов со звуком. Рекомендации для экспорта звука с QuickTime-фильмом следующие:

Используйте так много звуков и каналов, как Вам этого хочется, не волнуясь за размера файла. При экспорте QuickTime файла все звуки объединяются в единую звуковую дорожку, поэтому количество звуков, которые Вы используете, никак не повлияет на конечный размер файла.
Используйте потоковую (Stream) синхронизацию, чтобы согласовать анимацию со звуковой дорожкой при предварительном просмотре вашей мультипликацией в редакторе. Если ваш компьютер не обладает достаточной мощностью чтобы отрисовывать все кадры анимации в соответствии со звуковой дорожкой, Flash просто пропустит некоторые кадры.


Importing Sounds

Добавление Звука > Импорт Звуков

Импорт Звуков

Используете команды File > Import, чтобы вставить WAV (Windows), AIFF (Macintosh) или MP3 (любая платформа) звуки во Flash, также, как Вы импортировали бы любой другой тип файла.

Если у Вас установлен QuickTime 4 или более поздняя версия, Вы можете импортировать дополнительные звуковые форматы:

Sound Designer II (Macintosh)
Sound Only QuickTime Movies (Windows или Macintosh)
Sun AU (Windows или Macintosh)
System 7 Sounds (Macintosh)
WAV (Windows или Macintosh)

Flash сохраняет звуки в библиотеке наряду с растровыми рисунками и символами. Как и с графическими символами, Вам нужна только одна копия звукового файла, чтобы использовать этот звук любое количество раз во Flash-фильме. Если Вы хотите использовать звуки в различных Flash-фильмах составляйте общедоступные звуковые библиотеки. См. Использование общедоступных библиотек.

Чтобы использовать звук в общедоступной библиотеке, Вы должны назначить тип звука, выбрав строку идентификатора в диалоговом окне Symbol Linkage Properties. Идентификатор также используется, чтобы обратиться к звуку, как к объекту в ActionScript. Для информации об объектах в ActionScript, см. Справку ActionScript.

Звуки могут занимать значительное количество дискового пространства и оперативной памяти. Однако, MP3-звук сжат и занимает значительно меньше места, чем звук форматов WAV или AIFF. Вообще, при использовании WAV или AIFF файлов, лучше использовать 16-битные 22 кГц моно звуки (использование стерео требует вдвое больше объема памяти), но Flash может импортировать и 8- или 16-битные звуки с типовыми частотами 11 кГц, 22 кГц или 44 кГц. Он может конвертировать звуки, для получения гораздо меньших размеров файлов при экспорте. См. Сжатие звуков при экспорте.

Обратите внимание: Звуки с типовыми частотами не кратными 11 кГц (типа 8, 32, или 96 кГц) - несоответствуют образцу после импорта во Flash.

Если Вы хотите добавить эффекты к звукам во Flash, лучше импортировать 16-битные звуки. Если объем оперативной памяти ограничен, используйте короткие звуковые файлы или работайте с 8-битными звуками.

Для импорта звука:

1 | Выберите File > Import.
2 | В диалоговом окне Import найдите и отметьте желательный звуковой файл.
 | Импортированный звук будет помещен в библиотеку текущего Flash-фильма.

Обратите внимание: Вы можете также перетащить звук из общедоступной библиотеки в библиотеку текущего Flash-фильма. См. Работа с общедоступными библиотеками.


Adding sounds to a movie

Добавление Звука > Добавление звуков во Flash-фильм

Добавление звуков во Flash-фильм

Чтобы добавить звук во Flash-фильм, выберите слой, куда он будет помещен и установите опции в панели Sound. Рекомендуется размещать каждый звук в отдельный слой.

Добавление звука во Flash-фильм:

1 | Импортируйте звук, если это еще не сделано. См. Импорт звуков.
2 | Выберите Insert > Layer, чтобы создать новый слой для звука.
3 | При выделенном новом слое для звука, перетащите звук из библиотеки в сцену. Звук будет добавлен в текущий слой.
 | Вы можете размещать много звуков в один слой или в слои, содержащие другие объекты. Однако, рекомендуется помещать каждый звук в отдельный слой. В этом случае каждый слой действует подобно отдельному звуковому каналу. При воспроизведении Flash-фильма звуки на всех слоях будут объединены.
4 | Выберите Window > Panels > Sound.
5 | В панели Sound выберите звуковой файл из всплывающего звукового меню.
6 | Выберите следующую опцию эффектов из всплывающего меню Эффектов:
 | None, чтобы не применять никаких эффектов к звуковому файлу или выберите эту опцию, чтобы удалить предварительно примененные эффекты.
 | Left Channel/Right Channel - запускает звук только в левом или правом канале.
 | Fade Left to Right/Fade Right to Left - плавный переход звука между каналами справа налево или наоборот.
 | Fade In - постепенное увеличение амплитуды звука по его продолжительности.
 | Fade Out - постепенное уменьшение амплитуды звука по его продолжительности.
 | Custom - собственный эффект, который Вы можете создавать, используя маркеры редактирования звука. См. Использование средств управления редактированием звука.
7 | Выберите опцию синхронизации в Sync-меню:
 | Event - синхронизирует звук с возникновением события. Звук начинает воспроизводится, когда стартует ключевой кадр, в котором он расположен и проигрывается полностью, независимо от длины Timeline, даже если Flash-фильм останавливается. Звуки события смешиваются, когда Вы запускаете ваш Flash-фильм.
 | Пример звука события - звук, который воспроизводится, когда пользователь нажимает кнопку.
 | Start - тот же звук события, за исключением того, что, если какой-либо звук уже воспроизводится, то может быть запущен новый звук события.
 | Stop - останавливает указанный звук.
 | Stream - синхронизирует потоковый звук для игры на Web. Flash вынуждает мультипликацию сохранять темп потокового звука. Если Flash не может прорисовывать кадры мультипликации достаточно быстро, он пропускает их. В отличие от звуков события, потоковый звук прекращается если заканчивается анимация. Также, потоковый звук никогда не может играть дольше, чем количество кадров, который он занимает. Потоковые звуки смешиваются при записи Flash-фильма.
 | Пример потокового звука - голос персонажа мультипликации, воспроизводимый в течение большого количества кадров.

Обратите внимание: Если Вы используете звук MP3 как потоковый звук, необходимо его повторно сжать для экспорта. См. Сжатие звуков для экспорта.

8 | Для зацикливания воспроизведения звука введите количество его повторов в поле Loop (петля).
 | Для непрерывного проигрывания введите достаточно больше число. Например, для 15-секундного звука, который должен звучать в течение 15 минут, введите 60.
 | Обратите внимание: Потоковые звуки не рекомендуются замыкать в петлю. Если потоковый звук зациклен, то во Flash-фильм добавляются новые кадры и размер файла увеличивается кратно количеству петель потокового звука.


Adding sounds to buttons

Добавление Звука > Добавление звуков к кнопкам

Добавление звуков к кнопкам

Можно связывать звуки с различными состояниями символа кнопки. Поскольку звуки сохраняются как символы, они работают также, как и другие символы.

Добавление звука к кнопке:

1 | Выберите кнопку в библиотеке.
2 | Выберите Редактирование (Edit) из меню Library Options.
3 | В Timeline кнопки, создайте новый слой для звука.
4 | В этом слое создайте простой или пустой кадр, соответствующий состоянию кнопки, которое Вы хотите озвучить.
 | Например, чтобы озвучить нажатие кнопки, создайте ключевой кадр во фрейме с меткой Down.
5 | Щелкните кадр, который Вы только что создали.
6 | Выберите Window > Panels > Sound.
7 | В панели Sound, выберите звуковой файл из всплывающего Звукового меню.
8 | Выберите синхронизацию Event (событие) из меню Синхронизации.
 | Чтобы связывать различные звуки с каждым из кадров кнопки, создайте пустые кадры, и добавьте другие звуковые файлы для каждого кадра. Можно использовать один и тот же звуковой файл и применять различные звуковые эффекты для каждого кадра кнопки. См. Использование средств управления редактированием звука.


Using sounds with shared libraries or with Sound objects

Добавление Звука > Использование звуков из общедоступных библиотек или как Звуковые объекты

Использование звуков из общедоступных библиотек или как Звуковые объекты

Вы можете использовать звук из одной библиотеки в различных Flash-фильмах, редактируя свойства звука и включая звук в общедоступные библиотеки. Для получения дополнительной информации по использованию общедоступных библиотек, см. Использование общедоступных библиотек.

Можно использовать Звуковой (Sound) объект в ActionScript, чтобы добавлять звуки и управлять ими в клипе. Управление звуками включает регулировку громкости и баланса во время его воспроизведения. См. "Создание средств управления звуком" в главе Справочник ActionScript.

Чтобы использовать звук из общедоступной библиотеке или Звуковые команды (Sound action), в диалоговом окне Symbol Linkage необходимо присвоить звуку идентификатор.

Для этого:

1 | Выберите звук в окне Библиотеки.
2 | Сделайте одно из следующего:
 | Выберите Linkage (привязка) из меню Library Options.
 | Щелкните правой кнопкой мыши (Windows) или Control-click (Macintosh) по названию звука в окне Библиотеки и выберите Linkage (привязка) из контекстного меню.
3 | В диалоговом окне Symbol Linkage Properties выберите опцию Export This Symbol.
4 | Введите значение идентификатора в текстовое поле и нажмите OK.


Using the sound-editing controls

Добавление Звука > Использование средств управления редактированием звука

Использование средств управления редактированием звука

Для определения точек начала и конца воспроизведения звука или управления его громкостью во время воспроизведения, используются средства управления редактированием звука в панели Sound.

Flash может изменить точки в которых звук начинает или прекращает играть. Это полезно для создания звуковых файлов меньшего объема и удаления неиспользуемых фрагментов.

Редактирование звуковых файлов:

1 | Добавьте звук в кадр (см. Добавление звуков во Flash-фильм) или выберите кадр уже содержащий звук.
2 | Выберите Window > Panels > Sound и нажмите Edit.
3 | Для редактирования звука используйте следующие возможности:
 | Чтобы изменить точки начала и конца воспроизведения звука, перетащите маркеры Time In и Time Out средств управления в панели Sound.
 | Изменение уровня громкости осуществляется путем перемещения маркеров (Envelope). Линии уровня показывают громкость звука. Чтобы создавать дополнительные маркеры (общим количеством до восьми), щелкните по линии уровня. Для удаления маркера перетащите его за пределы окна.
 | Для масштабирования изображения синусоиды звука в окне пользуйтесь кнопками Zoom In/Out.
 | Для переключения режима отображения времени между секундами и кадрами используйте кнопки Seconds и Frames.


Starting and stopping sounds at keyframes

Добавление Звука > Запуск и остановка звука в ключевом кадре

Запуск и остановка звука в ключевом кадре

Наиболее типичная задача использования звука во Flash это запуск и его остановка в ключевых кадрах и синхронизация звука с анимацией.

Остановка и запуск звука в ключевых кадрах:

1 | Добавьте звук во Flash-фильм.
 | Чтобы синхронизировать этот звук с объектами в сцене, выберите начальный ключевой кадр, который соответствует ключевому кадру события в сцене. Вы можете выбирать любую из опций синхронизации. См. Добавление звуков во Flash-фильм.
2 | Создайте ключевой кадр в Timeline звукового слоя в том месте, где Вы хотите, чтобы звук закончился.
 | Представление звукового файла появится в Timeline.
3 | Выберите Window > Panels > Sound.
4 | Выберите тот же самый звук из всплывающего Звукового меню.
5 | Выберите Stop из всплывающего меню синхронизации.
 | После запуска Flash-фильма воспроизведение звука прекратиться, когда будет достигнут ключевой кадр окончания звука.

Воспроизводить звук можно просто перемещая playhead.


Compressing sounds for export

Добавление Звука > Сжатие звуков для экспорта

Сжатие звуков для экспорта

Чтобы выбрать опции сжатия звуков, используйте настройки опций в Export Settings диалогового окна Sound Properties. Доступные опции зависят от выбираемого вами метода сжатия. Можно также использовать диалоговое окно Sound Properties для обновления звука, отредактированного во внешнем звуковом редакторе, или его тестирования.

Тип и степень сжатия дают существенное различие в качестве и размере звуков в экспортируемом Flash-фильме. Чем больше Вы сжимаете звук и выбираете более низкий разряд его битности, тем меньший размер файла и более низкое качество Вы получаете на выходе. Необходимо экспериментировать, чтобы найти оптимальное соотношение между качеством звука и размером файла.

Звуковые MP3 файлы уже сжаты еще до импорта. Однако можно повторно сжимать MP3 файлы при экспорте, если это необходимо. Например, если MP3 файл должен использоваться как потоковый звук, Вы должны повторно сжать файл, потому что звуки потока должны быть сжаты для экспорта.

Если не используются никакие экспортные параметры настройки звука, то Flash экспортирует его, используя звуковые параметры настройки из диалогового окна Publish Settings. Можно отменять экспортные параметры настройки, указанные в диалоговом окне Sound Properties, выбирая Override Sound Settings в диалоговом окне Publish Settings. Эта опция полезна, если Вы хотите создать большой аудио Flash-фильм с высоким качеством для локального использования и его облегченную версию более низкого качества для Сети. (См. Публикация Flash-фильма.)

Обратите внимание: В Windows Вы можете также экспортировать все звуки из Flash-фильма в WAV файлы, используя File > Export Movie. См. Экспорт клипов и изображений.

Установка экспортных свойств для отдельного звука:

1 | Сделайте одно из следующего:
 | Дважды щелкните значок звука в окне Библиотеки.
 | Щелкните правой кнопкой мыши (Windows) или Control-click (Macintosh) звуковой файл в окне Библиотеки и выберите Properties из контекстного меню.
 | Выберите звук в окне Библиотеки и выберите Properties из меню Library Options.
 | Выберите звук в окне Библиотеки и щелкните значок свойств внизу окна Библиотеки.
2 | Если звуковой файл, уже после его экспорта во Flash, был отредактирован внешним редактором, нажмите Update.
3 | Для сжатия выберите Default, ADPCM, MP3, или Raw. Чтобы выбирать опции для формата сжатия, выбирайте одно из следующего:
 | Опция сжатия, заданная по умолчанию (Default)
 | Использование ADPCM компрессии
 | Использование MP3 компрессии
 | Использование Raw компрессии
4 | Установите экспортные настройки.
5 | Нажмите Test, чтобы запустить или Stop, чтобы остановить звук.
6 | В случае необходимости корректируйте экспортные параметры настройки, пока не получите желаемое соотношение качество-размер звука.
7 | Нажмите OK.


Compressing sounds for export

Добавление Звука > Сжатие звуков для экспорта > Опция сжатия, заданная по умолчанию

Опция сжатия, заданная по умолчанию

При экспорте Flash-фильма, заданная по умолчанию опция сжатия использует заданные по умолчанию параметры настройки сжатия в диалоговом окне Publish Settings. Если выбираете Default, то все дополнительные экспортные параметры настройки становятся не доступны.


Working with objects overview

Работа с Объектами > Работа с объектами - краткий обзор

Работа с объектами - краткий обзор

Во Flash, объекты есть элементы в Сцене. Их можно перемещать, копировать, удалять, преобразовывать, стыковать, выравнивать и группировать, а также связывать объект с URL. Обратите внимание, что изменение линий и форм может изменить и другие линии и формы в том же самом слое. См. Рисование - краткий обзор.

Примечание: Термин объект используется в языке программирования ActionScript в другом значении. Будьте осторожны и не путайте эти два разных термина. Обратитесь к Справке по ActionScript для лучшего понимания термиина "объект" в языке программирования.


Moving, copying, and deleting objects

Работа с Объектами > Перемещение, копирование и удаление объектов > Перемещение и копирование объектов вставкой

Перемещение и копирование объектов вставкой

Когда необходимо перемещать или копировать объекты между слоями, сценами или другими Flash файлами, Вы должны использовать методику вставки. Можно вставлять объект в центре Сцены или в позицию с координатами его первоначального местонахождения.

Перемещение или копирование объектов вставкой:

1 | Выберите объект или множество объектов.
2 | Выберите Edit > Cut или Edit > Copy.
3 | Выберите другой слой, сцену или файл и сделайте одно из следующего:
 | Выберите Edit > Paste, чтобы вставить выбор в центр сцены.
 | Выберите Edit > Paste in Place, чтобы вставить выбор в ту же позицию сцены, которую он занимал раньше.


Moving, copying, and deleting objects

Работа с Объектами > Перемещение, копирование и удаление объектов > О копировании графики через Буфер обмена

О копировании графики через Буфер обмена

Элементы, скопированные в Буфер обмена, имеют сглаженные края, поэтому они будут выглядеть в других приложениях так же, как они выглядят во Flash. Это особенно полезно для кадров, которые содержат растровое изображение, градиенты, прозрачность или маскированы.

Графика, вставленная из других клипов или программ, помещается в текущий кадр текущего слоя. Как графический элемент будет вставлен во Flash, зависит от типа элемента, его источника и сделанных Вами установок:

Текст из текстового редактора становится одиночным текстовым объектом.
Векторная графика из любой программы станет группой, которая может быть разгруппирована и отредактирована подобно любому другому элементу Flash.
Растровые рисунки станут одиночным сгруппированным объектом, точно так же, как импортированные растровые рисунки. Вы можете применять к ним действие Break appart или конвертировать вставленные битмапы в векторную графику.
Для информации о преобразовании растровых рисунков в векторную графику, см. Преобразование растровых рисунков в векторную графику.

Примечание: Перед вставкой графики из FreeHand во Flash, установите экспортные установки FreeHand для конвертации цвета в CMYK и RGB для форматов Буфера обмена.


Moving, copying, and deleting objects

Работа с Объектами > Перемещение, копирование и удаление объектов > Копирование трансформированных объектов

Копирование трансформированных объектов

Для создания масштабированной, повернутой или сдвинутой копии объекта, используется панель Transform.

Создание трансформированной копии объекта:

1 | Выберите объект.
2 | Выберите Window > Panels > Transform.
3 | Введите масштаб, угол поворота или значение сдвига. См. Масштабирование объекта, Вращение объекта и Сдвиг объекта.
4 | Нажмите кнопку Create Copy в панели Transform.


Moving, copying, and deleting objects

Работа с Объектами > Перемещение, копирование и удаление объектов > Удаление объектов

Удаление объектов

Удаление объекта удаляет его из файла. Удаление объекта из Сцены не удаляет символ из библиотеки.

Удаление объекта:

1 | Выберите объект или множество объектов.
2 | Сделайте одно из следующего:
 | Нажмите Delete или Backspace.
 | Выберите Edit > Clear.
 | Выберите Edit > Cut.
 | Щелкните правой кнопкой мыши (Windows) или Control-click (Macintosh) объект и выберите Cut из контекстного меню.


Stacking objects

Работа с Объектами > Расположение объектов по глубине

Расположение объектов по глубине

В пределах слоя Flash располагает объекты в стеке в том порядке, в котором они были созданы, помещая последний созданный объект в вершине стека. Глубина расположения объектов определяет их перекрытие при пересечении.

Рисованные линии и формы всегда располагаются ниже групп и символов в стеке. Для перемещения в стеке, их необходимо группировать или сделать из них символы. Глубину расположения объектов можно изменять в любое время.

Обратите внимание, что слои также подчиняются этому порядку. Все находящееся на втором слое, располагается выше всего содержимого первого слоя и так далее. Для изменения порядка слоев перетащите название слоя в Timeline в новую позицию. См. Краткий обзор использования слоев.

Изменение глубины расположения объектов:

1 | Выберите объект.
2 | Используйте одну из следующих команд:
 | Выберите Modify > Arrange > Bring to Front или Send to Back для перемещения объекта или группы на самый верх или самый низ стека.
 | Выберите Modify > Arrange > Bring Forward или Send Backward для перемещения объекта или группы на одну позицию вверх или вниз в стека.

Если выбрана больше чем одна группа, перемещение групп происходит выше или ниже всех невыбранных групп, без изменения их взаимного порядка следования относительно друг друга.


Scaling objects

Работа с Объектами > Масштабирование объектов

Масштабирование объектов

Масштабирование объекта увеличивает или уменьшает его размер по горизонтали, вертикали или в обоих направлениях. Можно масштабировать объект перемещением или вводя соответствующие значения в панели Transform. Символы, группы и текстовые блоки масштабируются относительно их точки отсчета. См. Перемещение точки отсчета объекта.

Масштабирование объекта перемещением:

1 | Выберите объект.
2 | Выберите инструмент "Стрелка" и нажмите модификатор Масштаба (Scale) в секции Опций панели инструментов или выберите Modify > Transform > Scale.
3 | Сделайте одно из следующего:
 | Для одновременного масштабирования объекта по горизонтали и вертикали, потащите один из угловых маркеров. Пропорции объекта сохраняются.
 | Для масштабирования объекта по горизонтали или по вертикали, потащите центральные маркеры.
4 | Щелкните на пустую область в Сцене или выберите Modify > Transform > Scale, чтобы выключить маркеры масштабирования.

Примечание: Когда Вы увеличиваете размер множества элементов, некоторые границы блока могут выйти за пределы Сцены. Если это происходит, выберите View > Work Area, чтобы видеть элементы, которые выходят за ее границы.

Масштабирование объекта на панели Transform:

1 | Выделите объект.
2 | Выберите Window > Panels > Transform.
3 | Введите значение масштаба от 1 до 1000 для вертикального, горизонтального или масштабирования в обоих направлениях.
4 | Выберите Constrain для сохранения пропорциональности.
5 | Нажмите Enter (Windows) или Return (Macintosh).


Rotating objects

Работа с Объектами > Вращение объектов

Вращение объектов

Вращение объекта поворачивает его вокруг точки отсчета. По умолчанию точка отсчета располагается в центре объекта, но ее можно перемещать. См. Перемещение точки отсчета объекта. Вы можете вращать объект используя команды вращения, перемещения или определяя угол в панели Transform.

Первоначальный объект, повернутый право и повернутый влево соответственно

Вращение объекта перемещением:

1 | Выделите объект.
2 | Сделайте одно из следующего:
 | Выберите инструмент "Стрелка" и нажмите модификатор Вращения (Rotate) в секции Опций панели инструментов.
 | Выберите Modify > Transform > Rotate.
3 | Перетащите один из угловых маркеров.
4 | Щелкните на пустую область в Сцене или выберите Modify > Transform > Rotate для выключения маркеров вращения.

Вращение объекта на 90° :

1 | Выделите объект.
2 | Выберите Modify > Transform > Rotate 90° CW для вращения по часовой стрелке или Rotate 90° CCW для вращения против часовой стрелки.

Использование панели Transform для вращения объекта:

1 | Выделите объект.
2 | Выберите Window > Panels > Transform.
3 | Включите опцию Вращение (Rotate).
4 | Введите угол поворота.
5 | Нажмите Enter (Windows) или Return (Macintosh).

Одновременное вращение и масштабирование объекта:

1 | Выделите объект.
2 | Выберите Modify > Transform > Scale and Rotate.
3 | Введите значения для масштаба и поворота.
4 | Нажмите OK.


Flipping objects

Работа с Объектами > Зеркальное отражение объектов

Зеркальное отражение объектов

Можно зеркально отражать объекты по их вертикальной или горизонтальной оси, без изменения их относительной позиции в Сцене.

Оригинальный объект, зеркально отраженный по горизонтали и вертикали соответственно

Зеркальное отражение объекта:

1 | Выделите объект.
2 | Выберите Modify > Transform > Flip Vertical или Flip Horizontal.


Skewing objects

Работа с Объектами > Сдвиг объектов

Сдвиг объектов

Сдвиг трансформирует объект, наклоняя его по одной или обеим осям. Можно сдвигать объект перемещением или вводя значение в панели Transform.

Сдвиг объекта перемещением:

1 | Выделите объект.
2 | Сделайте одно из следующего:
 | Выберите инструмент "Стрелка" и нажмите модификатор Вращения (Rotate) в секции Опций панели инструментов.
 | Выберите Modify > Transform > Rotate.
3 | Перетащите центральный маркер.
4 | Щелкните на пустую область в Сцене или выберите Modify > Transform > Rotate для выключения маркеров вращения.

Использование панели Transform для сдвига объекта:

1 | Выделите объект.
2 | Выберите Window > Panels> Transform.
3 | Включите опцию Skew (Сдвиг).
4 | Введите значения углов для горизонтального и вертикального смещения.


Restoring transformed objects

Работа с Объектами > Восстановление трансформированных объектов

Восстановление трансформированных объектов

При масштабировании, вращении или сдвиге символа, группы и текста с использованием панели Transform, Flash сохраняет первоначальный размер и значения углов поворота объектов. Таким образом, можно удалять последнее преобразование и восстанавливать первоначальные значения.

Можно также отменить преобразование, выполненное в панели Transform, нажимая кнопку Undo на панели.

Восстановление трансформированного объекта в первоначальное состояние:

1 | Выделите трансформированный объект.
2 | Выберите Modify > Transform > Remove Transform.

Отмена преобразования, выполненного в панели Transform:

1 | Выбрав трансформированный объект, нажмите кнопку Undo в панели Transform.


Selecting objects

Работа с Объектами > Выделение объектов

Выделение объектов

Для изменения объекта, его необходимо сначала выделить. Flash обеспечивает разнообразие методов выделения - инструменты Стрелка (Arrow), Лассо (Lasso) и команды клавиатуры. Можно группировать отдельные объекты и управлять ими как одним объектом. См. Группировка объектов.

Flash подсвечивает объекты, которые были выделены. Линии подсвечиваются по длине, заливки по площади. У сгруппированных объектов выделяется ограничивающая их линия.

Линии и заливки подсвечиваются цветом, используемым для контура слоя, в котором они находятся. Его можно изменять в диалоговом окне Layer Properties (Свойства слоя). См. Просмотр слоев..

Можно выделять только линии или только заливки объекта. Можно скрывать подсветку выбранного объекта при его редактировании.

Может возникнуть желание предотвратить нежелательное выделение некоего объекта, дабы не внести случайно изменений в символ или группу символов. Для этого можно заблокировать символ или группу.

Выделенные растровые рисунки и символы подсвечиваются точками (растром) из которых состоят. См. Использование импортированной графики - краткий обзор. .


Aligning objects

Работа с Объектами > Выравнивание объектов

Выравнивание объектов

Панель Align дает возможность выровнять выделенные объекты по горизонтальной или вертикальной оси. Можно выравнивать объекты вертикально по правому краю, центру или левому краю выбранных объектов или горизонтально по верхнему краю, центру или нижнему краю выбора.

Используя панель Align, Вы можете распределять выделенные объекты таким образом, чтобы их центры или грани были расположены равномерно. Можно изменять размеры выделенных объектов так, чтобы горизонтальные или вертикальные размеры всех объектов соответствовали размерам самого большого из выбранных. Вы можете также выравнивать выделенные объекты в Сцене. Можно применять одну или более количество опций выравнивания к выделенным объектам.

Оригинал

Объекты, выравненные по верхнему краю наивысшего объекта.

Выравнивание объектов:

1 | Выделите объекты для выравнивания.
2 | Выберите Window > Panels > Align.
3 | В Панели Align (Выравнивание) выберите To Stage для выравнивания относительно размеров Сцены.
4 | Выберите кнопки выравнивания для преобразования выделенных объекты:
 | Для выравнивания, выберите Align Left, Align Horizontal Center, Align Right, Align Top, Align Vertical Center или Align Bottom.
 | Для равномерного распределения, выберите Distribute Top, Distribute Horizontal Center, Distribute Bottom, Distribute Left, Distribute Vertical Center или Distribute Right.
 | Для приведения размеров, выберите Match Width, Match Height, или Match Width and Height.
 | Для приведения промежутков, выберите Space Horizontally или Space Vertically.


Moving an object's registration point

Работа с Объектами > Перемещение точки отсчета объекта

Перемещение точки отсчета объекта

Все группы, символы, текстовые блоки и растровые рисунки имеют точку отсчета, которую Flash использует для позиционирования и преобразований. По умолчанию эта точка расположена в центре объекта. Перемещая точку отсчета объекта, можно позиционировать и преобразовывать объект относительно, например, нижнего левого угла объекта. Линии и формы не имеют точек отсчета и позиционируются и преобразуются относительно их верхнего левого угла.

Для редактирования положения точки отсчета символа, вы достигнете лучших результатов, если отредактируете символ, а в нем установите точку отсчета там, где вы этого хотели бы. См. Редактирование символов.

Для редактирования точки отсчета группы, символа, текстового блока или растрового рисунка:

1 | Выделите объект.
2 | Выберите Modify > Transform > Edit Center.
 | Высветится перекрестие, представляющее собой точку отсчета.
3 | Перетащите это перекрестие на новое место.
4 | Щелкните на пустую область в Сцене или выберите Modify > Transform > Edit Center для отключения опции редактирования.


Breaking apart groups and objects

Работа с Объектами > Разрыв (Breaking apart) групп и объектов

Разрыв (Breaking apart) групп и объектов

Чтобы разделить группы, текстовые блоки, символы и растровые рисунки в несгруппированные доступные для редактирования элементы, используйте команду Break Apart. Разрыв обособленных элементов значительно уменьшает размер файла использующего импортированную графику.

Разрыв не полностью обратим и воздействует на объекты следующим образом:

Разрывает связь символов с основным символом.
Отказывается от связи со всеми кадрами кроме текущего в анимированном символе.
Преобразует растровый рисунок в заливку.
Преобразует текстовые символы в их графическое представление.

Не следует путать команду Break Apart с командой Ungroup. Команда Ungroup разделяет сгруппированные объекты на дискретные компоненты, возвращая сгруппированные элементы в состояние, в котором они были до группировки. Это не влияет на растровые рисунки, символы или текст.

Разрыв групп или объектов:

1 | Выделите группу, текстовый блок, битмап или символ, который хотите разорвать на составляющие элементы.
2 | Выберите Modify > Break Apart.

Примечание: Разрыв анимированных символов или групп в пределах интерполированной мультипликации не рекомендуется и может иметь непредсказуемые результаты. Разрыв сложных символов и больших блоков текста может занять достаточно долгое время. Можно, конечно, увеличить ассигнование памяти приложения, чтобы должным образом разрывать сложные объекты.


Selecting objects

Работа с Объектами > Выделение объектов > Использование инструмента "Стрелка" (Arrow)

Использование инструмента "Стрелка" (Arrow)

Инструмент "Стрелка" позволяет выделять все объекты, путем нажатия на объект или заключив его внутрь прямоугольника выбора.

Примечание: Для выбора инструмента "Стрелка", можно также нажать клавишу V. Для временного переключения на "Стрелку", когда другой инструмент активен, удерживайте клавишу Control (Windows) или Command (Macintosh).

Для выделения линии, заливки, группы, объекта или текстового блока:

Выберите инструмент "Стрелка" и щелкните объект.

Выделение связанных линий:

Выберите инструмент "Стрелка" и дважды щелкните одну из линий.

Выделение залитой формы и ее контура:

Выберите инструмент "Стрелка" и дважды щелкните заливку.

Выделение объекта в пределах прямоугольной области:

Выберите инструмент "Стрелка" и удерживая кнопку мыши, протащите ее, создавая прямоугольную область над теми элементами, которые Вы хотите выбрать.


Selecting objects

Работа с Объектами > Выделение объектов > Изменение выбора

Изменение выбора

Можно добавлять элементы к уже выбранным, выделять или снимать выделение всех элементов на каждом слое в сцене, выбирать все элементы в ключевых кадрах, блокировать или разблокировать выбранные символы или группы.

Добавление к выбору:

Удерживайте клавишу SHIFT при создании дополнительных выборов.

Примечание: В окне основных настроек Flash (Flash General Preferences) можно отключить опцию Shift-select. См. Настройка Flash.

Выделение всего содержимого на каждом слое сцены:

Выберите Edit > Select All или нажмите Control+A (Windows) или Command+A (Macintosh). Select All не выделяет объекты на блокированных или скрытых слоях или слоях, находящихся вне текущей линейки (timeline).

Снятие выделения со всего содержимого на каждом слое:

Выберите Edit > Deselect All или нажмите Control+Shift+A (Windows) или Command+Shift+A (Macintosh).

Выделение всего содержимого на одном слое между ключевыми кадрами:

Щелкните кадр в Timeline. Для получения дополнительной информации, см. Использование Timeline.

Блокирование группы или символа:

Выделите группу или символ, и выберите Modify > Arrange > Lock.

Выберите Modify > Arrange > Unlock All для разблокирования всех ранее блокированных групп и символов.


Selecting objects

Работа с Объектами > Выделение объектов > Использование инструмента "Лассо" (Lasso)

Использование инструмента "Лассо" (Lasso)

Для выбора объектов, путем их ручной обводки контуром или контуром в виде прямых линий, можно использовать инструмент Лассо и его модификатор Poligon Mode. При использовании инструмента Лассо, можно переключаться между режимами выбора типа лассо freeform (свободный) и straight-edged (линейный).

Выделение объекта путем ручной обводки:

Выберите инструмент Лассо и обведите им необходимую область. Закончите петлю приблизительно там, где Вы ее начали или позвольте Flash автоматически замкнуть петлю прямой линией.

Выделение объекта множеством прямых линий:

1 | Выберите инструмент Лассо и включите модификатор Poligon Mode в секции Опций панели инструментов.
2 | Щелкните в том месте, где нужно установить отправную точку.
3 | Установите указатель в том месте где хотите закончить первую линию и щелкните. Продолжайте устанавливать конечные точки для наращивания обрамляющей линии.
4 | Дважды щелкните для закрытия области выбора.

Выделение объекта путем использования обоих вышеописанных методов:

1 | Выберите инструмент Лассо и выключите модификатор Poligon Mode.
2 | Обрисуйте вручную часть области выделения в сцене.
3 | Для продолжения обводки прямыми отрезками, удерживайте Alt (Windows) или Option (Macintosh) и щелкайте для установки начальной и конечной точек. Можно продолжать переключаться между плавным и линейным режимами обводки области выделения.
4 | Для закрытия области выбора, сделайте следующее:
 | Отпустите кнопку мыши, если обводите область выбора плавной линией.
 | Дважды щелкните, если обводите область выбора прямыми отрезками.


Selecting objects

Работа с Объектами > Выделение объектов > Отключение подсветки выделения

Отключение подсветки выделения

Чтобы редактировать объект без подсветки выделения, можно ее отключить. Это предоставляет возможность видеть на стадии редактирования, как графика будет выглядеть в конечном варианте.

Отключение подсветки выделения:

Выберите View > Hide Edges. Для отмены действия повторите команду.


Grouping objects

Работа с Объектами > Группировка объектов

Группировка объектов

Для управления элементами как одиночным объектом, необходимо их сгруппировать. Например, после создания рисунка дерева или цветка, можно сгруппировать элементы рисунка так, чтобы стало возможно легко выделять и перемещать рисунок целиком.

Можете редактировать группы не разгруппируя их. Можно также выбирать для редактирования отдельный объект в группе, без разгруппирования всех объектов.

Создание группы:

1 | Выберите объекты в сцене, которые хотите сгруппировать.
 | Можно выбирать формы, другие группы, символы, текст и так далее.
2 | Выберите Modify > Group или нажмите Control+G (Windows) или Command+G (Macintosh).

Разгруппирование объектов:

Выберите Modify > Ungroup.

Редактирование группы или объекта в пределах группы:

1 | При выбранной группе, выберите Edit > Edit Selected или дважды щелкните группу инструментом "Стрелка".
 | Все что не входит в данную группу изменит свою окраску на более бледную и станет недоступным для выбора.
2 | Редактируйте любой элемент в пределах группы.
3 | Выберите Edit > Edit All, или дважды щелкайте по пустому месту в сцене инструментом "Стрелка".
 | Flash восстановит статус группы, как единого объекта и Вы сможете работать с другими элементами в сцене.


Moving, copying, and deleting objects

Работа с Объектами > Перемещение, копирование и удаление объектов

Перемещение, копирование и удаление объектов

Можно перемещать объекты перетаскиванием их по сцене, вырезать и вставлять их, использовать клавиши курсора или панель Object для их точного позиционирования. Используя Буфер обмена можно также перемещать объекты между Flash и другими приложениями. Можно копировать объекты путем их перемещения или вставки или преобразовывая их.

При перемещении объекта инструментом "Стрелка", можно использовать модификатор Snap для быстрого выравнивания объекта с точками на других объектах.


Moving, copying, and deleting objects

Работа с Объектами > Перемещение, копирование и удаление объектов > Перемещение объектов

Перемещение объектов

Для перемещения объекта можно его перетаскивать, использовать клавиши курсора или использовать панель Info.

Перемещение объектов или копий объектов перетаскиванием:

1 | Выберите объект или множество объектов.
2 | Выберите инструмент "Стрелка", установите указатель поверх объекта и перемещайте его в новую позицию. Для копирования объекта и перемещения копии, Alt-drag (Windows) или Option-drag (Macintosh). Чтобы ограничить перемещение объекта направлениями кратными 45° , Shift-drag.

Перемещение объектов использованием клавиш курсора:

1 | Выберите объект или множество объектов.
2 | Нажмите клавишу курсора для задания направления, в котором хотите передвинуть объект на 1 пиксел за раз. Нажмите Shift+клавишу_курсора, чтобы переместить свой выбор на 8 пикселов за раз.

Перемещение объектов при помощи панели Info:

1 | Выберите объект или множество объектов.
2 | Выберите Window > Panels> Info.
3 | В панели Info введите значения для местоположения верхнего левого угла выбора. Отсчет ведется от верхнего левого угла сцены.

Примечание: В панели Info используются единицы измерения, указанные в опциях Ruler Units диалогового окна Movie Properties. Для их изменения см. Создание нового клипа и установка его свойств.


Краткая информация о слоях

Использование слоёв > Краткая информация о слоях

Краткая информация о слоях

Слои похожи на прозрачные листы, сложенные стопкой друг на друга. Когда вы создаёте новый клип, он содержит один слой. Вы можете добавить новые слои для удобства работы с изображениями, анимацией и другими элементами клипа. Вы можете рисовать и редактировать объекты на одном слое, не затрагивая объекты на других слоях. Через пустые места на слое вы видите то, что находится слоем ниже.

Количество слоёв, которые вы можете создать, ограничено лишь памятью вашего компьютера и слои не увеличивают размер выходного SWF-файла. Вы можете скрывать слои, блокировать или показывать только контуры содержимого слоя (outlines). И, конечно же, можете менять порядок расположения слоёв относительно друг друга.

Помимо этого, можете создавать специальные опорные слои (guide layers), которые облегчают рисование и редактирование объектов. Можно использовать слои-маски (mask layers) для создания сложных эффектов.

Хорошим тоном будет использование отдельных слоёв для звуковых эффектов, программирования (actions), меток (frame labels) и комментариев (frame comments). Такой клип будет наглядным и вам станет легче с ним работать.

Для интерактивного ознакомления со слоями выберите Help > Lessons > Layers в главном меню.


Создание слоёв

Использование слоёв > Создание слоёв

Создание слоёв

Когда вы создаёте новый слой, он появляется над текущим слоем и становится активным.

Чтобы создать слой, воспользуйтесь одним из следующих способов:

Нажмите кнопку Add Layer внизу монтажной линейки.
Выберите Insert > Layer в главном меню.
Щёлкните правой кнопкой мыши (Windows) или, удерживая Control, щёлкните (Macintosh) на названии слоя в монтажной линейке и выберите Insert Layer в ниспадающем меню.


Просмотр слоёв

Использование слоёв > Просмотр слоёв

Просмотр слоёв

Во время работы вы можете скрывать или показывать слои. Красный крест напротив названия слоя указывает на то, что слой скрыт. При публикации клипа скрытые слои сохраняются. Тем не менее, вы не сможете редактировать скрытые слои в SWF-файле, если вы импортируете его во Flash.

Чтобы вы могли легко различить, какие объекты лежат на каком слое, можно показывать только их контуры. Причем для каждого слоя можно выбрать индивидуальный цвет контуров.

Можно изменить высоту слоя в монтажной линейке, чтобы показать больше информации на слое (например звуковые дорожки). Также можно изменять количество показываемых слоев.

Слой с названием Logo имеет красные контуры.

Чтобы скрыть или показать слой, воспользуйтесь одним из следующих способов:

Щёлкните мышью на столбце Eye (Глаз) справа от названия слоя, чтобы скрыть его. Щёлкните ещё раз, чтобы его показать.
Щёлкните мышью на значке Eye (Глаз), чтобы скрыть все слои. Щёлкните ещё раз, чтобы все их показать.
Чтобы показать или скрыть сразу несколько слоёв, переместите мышь с нажатой кнопкой по столбцу Eye (Глаз).
Удерживая клавишу Alt (Windows) или Option (Macintosh), щёлкните на столбце Eye (Глаз) справа от названия слоя, чтобы скрыть все слои, кроме выбранного. Сделайте то же самое чтобы показать все слои.

Чтобы содержимое слоя показывалось как контуры, воспользуйтесь одним из следующих способов:

Щёлкните мышью на столбце Outline (Контур) справа от названия слоя, чтобы объекты на этом слое показывались как контуры. Щёлкните ещё раз, чтобы выключить режим Outline (Контур).
Щёлкните мышью на значке Outline (Контур), чтобы объекты на всех слоях показывались как контуры. Щёлкните ещё раз, чтобы выключить режим Outline (Контур) на всех слоях.
Удерживая клавишу Alt (Windows) или Option (Macintosh), щёлкните на столбце Outline (Контур) справа от названия слоя, чтобы объекты на всех слоях, кроме выбранного, показывались как контуры. Сделайте это ещё раз, чтобы выключить режим Outline (Контур) на всех слоях.

Чтобы изменить цвет контуров слоя:

1 | Сделайте одно из нижеследующего:
 | Дважды щёлкните на значке слоя (слева от названия) в монтажной линейке.
 | Щёлкните правой кнопкой мыши (Windows) или, удерживая Control, щёлкните (Macintosh) на названии слоя и выберите Properties в ниспадающем меню.
 | Сделайте активным слой в монтажной линейке и выберите Modify > Layer в главном меню.
2 | В окне Layer Properties: нажмите на Outline Color и выберите новый цвет, введите шестнадцатеричное значение цвета, либо нажмите пипетку (Color Picker) и укажите нужный цвет.
3 | Нажмите OK.

Чтобы изменить высоту слоя в монтажной линейке:

1 | Сделайте одно из нижеследующего:
 | Дважды щёлкните на значке слоя (слева от названия) в монтажной линейке.
 | Щёлкните правой кнопкой мыши (Windows) или, удерживая Control, щёлкните (Macintosh) на названии слоя и выберите Properties в ниспадающем меню.
 | Сделайте активным слой в монтажной линейке и выберите Modify > Layer в главном меню.
2 | В окне Layer Properties выберите в списке Layer Height нужную высоту, после чего нажмите OK.

Чтобы изменить количество показываемых слоёв на монтажной линейке:

Переместите границу, разделяющую монтажную линейку и рабочую область.


Редактирование слоёв

Использование слоёв > Редактирование слоёв

Редактирование слоёв

Чтобы рисовать на слое или изменять его параметры, он должен быть активным. Значок-карандаш, находящийся справа от названия слоя, указывает, что слой активен. В один момент активным может быть только один слой (однако выбранными могут быть несколько слоёв одновременно). Можно переименовывать, копировать и удалять слои. Вы можете поставить защиту от изменения (блокировать слой) и менять порядок слоёв.

По умолчанию, новые слои называются в порядке их создания: Layer 1, Layer 2, и так далее. Для удобства можно переименовать слои по собственному усмотрению.

Можно скрыть слои или включить режим контуров, пока работаете с другими слоями, чтобы не загромождать рабочую область. См. Просмотр слоёв.

Чтобы выбрать слой, сделайте одно из нижеследующего:

Щёлкните на названии слоя в монтажной линейке.
Щёлкните на кадр в монтажной линейке в том слое, который хотите выбрать.
Выберите объект на рабочей области, который находится на том слое, который хотите выбрать.

Чтобы выбрать два или больше слоёв, сделайте одно из нижеследующего:

Чтобы выбрать слои по порядку, удерживая Shift, щёлкните на названиях слоёв в монтажной линейке.
Чтобы выбрать слои по отдельности, удерживая клавишу Control (Windows) или Command (Macintosh), щёлкните на названиях слоёв в монтажной линейке.

Чтобы переименовать слой, сделайте одно из нижеследующего:

Дважды щёлкните на названии слоя и введите новое.
Щёлкните правой кнопкой мыши (Windows) или, удерживая Control, щёлкните (Macintosh) на названии слоя и выберите Properties в ниспадающем меню. Введите новое название в поле Name и нажмите OK.
Сделайте активным слой в монтажной линейке и выберите Modify > Layer в главном меню. В окне Layer Properties, введите новое название в поле Name и нажмите OK.

Чтобы скопировать слой:

1 | Щёлкните на названии слоя, чтобы выбрать его.
2 | Выберите Edit > Copy Frames в главном меню.
3 | Нажмите на кнопку Add Layer, чтобы создать новый слой.
4 | Щёлкните на созданном слое и выберите Edit > Paste Frames в главном меню.

Чтобы удалить слой:

1 | Выберите слой.
2 | Сделайте одно из нижеследующего:
 | Нажмите на кнопку Delete Layer в монтажной линейке.
 | Переместите слой на кнопку Delete Layer.
 | Щёлкните правой кнопкой мыши (Windows) или, удерживая Control, щёлкните (Macintosh) на названии слоя и выберите Delete Layer в ниспадающем меню.

Чтобы поставить/снять защиту от изменения на слой, сделайте одно из нижеследующего:

Нажмите на колонке Lock (Блокировка) справа от названия слоя, чтобы заблокировать слой. Для отключения блокировки нажмите на колонку ещё раз.
Щёлкните на значке замка чтобы поставить блокировать все слои. Для их деблокирования, нажмите еще раз.
Чтобы блокировать или деблокировать сразу несколько слоев, переместите мышь с нажатой кнопкой по столбцу Lock (Блокировка).
Удерживая клавишу Alt (Windows) или Option (Macintosh), щёлкните на столбце Lock (Блокировка) справа от названия слоя, чтобы поставить защиту от изменений на всех слоях, кроме выбранного. Сделайте то же самое чтобы снять защиту с этих слоёв.

Чтобы изменить порядок расположения слоёв относительно друг друга:

Перетащите вверх/вниз один или несколько слоёв.


Использование опорных слоёв

Использование слоёв > Использование опорных слоёв

Использование опорных слоёв

Для удобства работы вы можете использовать опорные слои (guide layers). Опорным слоем может быть любой слой. Опорные слои имеют специальный значок слева от названия слоя. Опорные слои не включаются в результирующий SWF-файл.

Также можно сделать направляющий слой (motion guide layer), чтобы контролировать анимацию движения объектов (motion tweening). См. Движение по пути.

Примечание: Если перетащить обычный слой на опорный слой (guide layer), то последний превратится в направляющий слой. Чтобы предотвратить случайную конвертацию опорных слоёв, разместите их в самом верху.

Чтобы слой сделать опорным:

Выберите слой и щёлкните правой кнопкой мыши (Windows) или, удерживая Control, щёлкните (Macintosh) на нём, затем выберите Guide в ниспадающем меню. Сделайте то же самое, чтобы слой снова стал нормальным.


Использование маскирующих слоёв

Использование слоёв > Использование маскирующих слоёв

Использование маскирующих слоёв

Для создания эффекта частичной видимости вы можете использовать маскирующий слой, его содержание будет "дыркой", через которую видно прицепленные к нему снизу слои. Вы можете сгруппировать несколько слоёв под одним маскирующим, чтобы создавать сложные эффекты. В маскировочном слое можете использовать любую анимацию (кроме движения по пути), чтобы маска двигалась и изменялась. Кнопки не могут быть маской.

Чтобы создать маскировочный (mask) слой, расположите в нем залитую любым цветом форму. Маскировочный слой показывает только лежащее в пределах залитого цветом пространства содержимое прицепленных к нему снизу слоёв, скрывая остальную их графику. Слой-маска может содержать только один объект. (Маскирующие слои во Flash по схеме работы схожи с командой Paste Inside в программе FreeHand.)

Чтобы создать маскирующий слой:

1 | Выберите или создайте слой с содержимым, которое должно быть видно через "дырки" в маске.
2 | Нажмите Insert > Layer, чтобы создать слой над текущим.
 | Маскировочный слой срабатывает сразу же, так что размещайте его в нужном месте.
3 | Поместите необходимое в слой-маску. Flash игнорирует растровые изображение, градиенты, прозрачность, цвета и стили линий в маскировочном слое. Любая залитая область будет создавать "дыру" в маске.
4 | Щелкните правой кнопкой мыши (Windows) или щелкните с клавишей Control (Macintosh) название слоя и в выпавшем меню отметьте пункт Mask.
 | Слой, работающий в режиме маски, отмечается значком со стрелочкой вниз. Слой ниже него "прицепляется" к нему и его содержимое становится видно только через залитые области слоя-маски. Имя маскируемого слоя смещается вправо и отмечается значком со стрелочкой вправо.
 | Эффект маски показывается, только когда оба слоя заблокированы.
 | Слой-маска; залитая область, которая будет "дырой" в маске; маскируемый слой; конечный результат

Чтобы после создания слоя-маски "прицепить" к нему ещё слои, сделайте одно из перечисленного:

Перетащите нужный слой прямо под слой-маску.
Создайте новый слой прямо под слоем-маской.
Нажмите Modify > Layer и отметьте флажок Masked в окне свойств слоя.

Чтобы "отцепить" слои от слоя-маски:

1 | Отметьте нужный слой.
2 | Сделайте одно из перечисленного:
 | Перетащите слой выше слоя-маски.
 | Нажмите Modify > Layer и отметьте флажок Normal.

Чтобы включить/выключить режим маскирования слоя:

Alt-клик (Windows) или Option-клик (Macintosh) на название слоя.


Работа с окном Layer Properties (свойства слоя)

Использование слоёв > Работа с окном Layer Properties (свойства слоя)

Работа с окном Layer Properties (свойства слоя)

Чтобы увидеть свойства слоя, используйте окно Layer Properties. Большая часть этих свойств может быть изменена через монтажную линейку.

Чтобы изменить свойства слоя:

1 | Двойным щелчком на значке нужного слоя откройте окно его свойств.
2 | Изменяйте свойства по своему усмотрению:
 | Поле Name позволяет вам изменить название слоя.
 | Флажком Show можно скрыть или показать слой.
 | Флажок Lock блокирует слой от редактирования; его отключение позволяет редактировать слой.
 | Отмеченная опция Normal делает слой обычным слоем, на котором вы рисуете и анимируете объекты.
 | Опция Guide делает слой опорным для облегчения выравнивания объектов на слое. См. Использование опорных слоёв.
 | Опция Guided обозначает слой, прицепленный к направляющему (guide) слою. Такой слой контролирует движение объектов в анимации. См. Перемещение объекта по пути.
 | Опция Mask делает слой маской, через которую видно содержимое прицепленных к нему снизу слоёв. Вы можете "прицеплять" к такому слою несколько обычных слоёв. См. Использование маскирующих слоёв.
 | Слой с отмеченной опцией Masked - это обычный слой, прицепленный к слою-маске (замаскированный).
 | Outline color - цвет, которым показываются контуры объектов в слое при включённом режиме View Layer as Outlines.
 | View Layer as Outlines показывает слой в виде контура.
 | Layer Height указывает высоту слоя в монтажной линейке.


Использование текста overview

Использование текста > Обзор Использования текста

Обзор Использования текста

При использовании текста во Flash роликах, можно устанавливать его размер, вид шрифта, стиль, промежутки, цвет и выравнивание. Вы можете преобразовывать текст как любой объект — вращать, масштабировать, искривлять, отражать его, а так же редактировать его символы. Ваши ролики могут включать текстовые поля для ввода текста пользователем или для отображения текста, обновляемого динамически. Так же вы можете связывать блоки текста с URL'ами.

Можно преобразовать текст в его графическое представление и менять форму его букв. Для дополнительных возможностей преобразования текста, можно обрабатывать текст во FreeHand и импортировать файл FreeHand во Flash или экспортировать из FreeHand как SWF файл.

Для интерактивного введения в создание текста во Flash, выберете Help > Lessons > Type.

Flash ролики могут использовать шрифты Type 1 PostScript, TrueType, и Bitmap шрифты (только Macintosh). Для использования PostScript шрифтов, необходимо иметь Adobe Type Manager (ATM), установленным в вашу систему (исключая системы использующие Windows 2000, которые не требуют ATM). Смотри Техническое Примечание #4105 на Сайте поддержки Macromedia Flash.

Примечание: Если вы испытываете проблемы с использованием PostScript шрифтов во Flash на Windows NT, это может быть связано с несовместимостью между ATM и Windows NT. Пожалуйста проконсультируйтесь в службе технической поддержки для ATM и Windows NT, если возникнут проблемы.

Когда вы работаете с FLA файлами, Flash использует в ролике шрифты, установленные в вашей системе. Flash также дает возможность создавать объекты (symbol) из шрифта, таким образом можно экспортировать шрифт, как часть общей библиотеки и использовать его в других Flash роликах.

Можно проверять орфографию копируя текст в Буфер обмена используя Movie Explorer и вставляя в любой внешний текстовый редактор. Смотри Использование Movie Explorer.


Создание текстовых полей для ввода пользователя или динамически обновляемого текста

Использование текста > Создание редактируемых или динамически обновляемых текстовых полей

Создание редактируемых или динамически обновляемых текстовых полей

Редактируемые текстовые поля предоставляют пользователю возможность вводить текст в формы или опросы. Динамические текстовые поля отображают динамически обновляемый текст, например котировки акций. Оба типа текстовых полей создается с использованием панели Text Options. Вы выбираете соответствующиие параметры для указания, какой тип редактируемого или динамического текста во Flash ролике вам нужен. Можно сохранять форматирование текста как в HTML. Смотрите О сохранении форматирования текста.

Когда создается текстовое поле, ему назначается переменная. Переменная это фиксированное имя, значение которое меняется. Текстовое поле похоже на окно, которое отображает значение переменной. Можно использовать команды для передачи переменной в другие части ролика, для сохранения в базе данных серверного приложения и т.д. Можно также заменять значение переменной, считая его с сервера или другой части ролика. Для большей информации о использовании переменных, смотрите Помощь по ActionScript.

Для создания редактируемого текстового поля :

1 | Для создания или выбора текстового поля, сделайте одно из предлагаемого ниже:
 | Выберите инструмент Text и потяните для создания текстового блока определенных размеров.
 | Щелкните внутри существующего текстового блока.
2 | Выберите Window > Panels > Text Options.
3 | Выберите тип текста из выпадающего меню :
 | Выберите Dynamic Text для создания текстового поля, показывающего динамический текст.
 | Выберите Input Text для создания редактируемого текстового поля, в которое пользователи могут вводить текст.


Создание текстовых полей для ввода пользователя или динамически обновляемого текста

Использование текста > Создание редактируемых или динамически обновляемых текстовых полей > О сохранении форматирования текста

О сохранении форматирования текста

Flash предоставляет возможность сохранять форматирование текста в редактируемых текстовых полях. Можно выбрать параметр HTML форматирования для динамических или редактируемых текстовых полей в панели Text Options. С выбранным HTML параметром, базовое форматирование (включая имя шрифта, стиль, цвет и размер) и гиперссылки в текстовом поле сохраняются автоматически, путем применения соответствующих HTML тегов в указанном текстовом поле. Следующие HTML теги поддерживаются в текстовых полях :

<A>
<B>
<FONT COLOR>
<FONT FACE>
<FONT SIZE>
<I>
<P>
<U>

Можно также применять HTML теги в панели Actions, как часть значения переменной текстового поля. При выборе параметра HTML форматирования, поддерживаемые HTML теги, которые вы применили в панели Actions, сохраняются при экспорте ролика в SWF файл.


Создание текстовых полей для ввода пользователя или динамически обновляемого текста

Использование текста > Создание редактируемых или динамически обновляемых текстовых полей > Установка параметров динамического текста

Установка параметров динамического текста

Управление динамическим текстом осуществляется через задание его параметров.

Для установки параметров динамического текста:

1 | Выберите Window > Panels > Text Options.
2 | Выберите Dynamic Text из выпадающего меню Text Type.
3 | Установите любой из предложенных параметров:
 | Из выпадающего меню Line Display, выберите Multiline для отображения текста в несколько строчек, или Single Line для отображения одной строкой.
 | Пометьте HTML для сохранения HTML-форматирования.
 | Пометьте Draw Border and Background для отображения границы и фона текстового поля.
 | Если вы выбрали Multiline выше, пометьте Word Wrap для автоматического перевода строки в конце текстового поля.
 | Пометьте Selectable (помечено по умолчанию) для возможности выделения пользователем динамического текста.
 | Для переменной, введите ее имя.
 | Для встраиваемых шрифтов, выберите одну или больше кнопок для указания какие символы из шрифта, используемые в динамическом тексте, будут экспортированы в SWF файл. Выберите кнопку Full Font (слева) для экспорта полного набора символов шрифта.


Создание текстовых полей для ввода пользователя или динамически обновляемого текста

Использование текста > Создание редактируемых или динамически обновляемых текстовых полей > Установка параметров вводимого текста

Установка параметров вводимого текста

Управление редактируемым текстовым полем осуществляется через задание его параметров.

Для установки параметров вводимого текста :

1 | Выберите Window > Panels > Text Options.
2 | Выберите Input Text из выпадающего меню Text Type.
3 | Все параметры аналогичны разделу Установка параметров динамического текста, кроме двух :
 | Из выпадающего меню Line Display, выберите Password для отображения текста в виде звездочек в целях сохранения секретности.
 | Примечание: Выбор параметра Password дает эффект только на отображении текста.
 | В поле Maximum Characters, введите максимальное число символов, которое может ввести пользователь.


Редактирование текста

Использование текста > Редактирование текста

Редактирование текста

Вы можете использовать стандартную технику редактирования во Flash, применяя Cut, Copy и Paste команды для перемещения текста внутри Flash файла и между Flash и другими приложениями.

Для проверки правописания, можно скопировать текст в буфер обмена, используя Movie Explorer, и вставить во внешний редактор. Смотрите Использование Movie Explorer.


Редактирование текста

Использование текста > Редактирование текста > Выделение текста

Выделение текста

Во время редактирования или изменения атрибутов текста, вы должны сначала выделить символы, которые хотите изменить.

Для выделения символов в текстовом блоке :

1 | Выберите инструмент Text.
2 | Сделайте одно из предложенного :
 | Потяните для выделения символов.
 | Щелкните два раза чтоб выделить слово.
 | Щелкните на начале выделения и удерживая Shift на конце выделения.
 | Нажмите Ctrl+A (Windows) или Command+A (Macintosh) для выделения всех символов в блоке.

Для выделения текстовых блоков :

Выберите инструмент Arrow (стрелка) и щелкните на блоке. Щелкайте, удерживая Shift, для выделения нескольких блоков.


О преобразовании текста

Использование текста > О преобразовании текста

О преобразовании текста

Можно преобразовывать текст такими же путями, как другие объекты - масштабировать, вращать, искажать и отражать текстовые блоки для создания интересующих эффектов. Когда вы масштабируете текстовый блок как объект, это не отражается в панели Character.

Текст в преобразованном блоке может редактироваться, однако преобразования могут сделать сложным его чтение.

Для большей информации о преобразовании текстовых блоков, смотрите Обзор работы с объектами.


Изменение формы текста

Использование текста > Изменение формы текста

Изменение формы текста

Для изменения формы, стирания и других манипуляций, текст конвертируется в его графическое представление. Как с любой другой формой, можно индивидуально группировать конвертированные текстовые символы или преобразовать их во Flash-элементы (symbols) и анимировать. После конвертирования текста, редактировать его как текст уже невозможно.

Можно конвертировать только текстовые блоки целиком, но не отдельные символы внутри блока.

Для конвертирования:

1 | Выберите инструмент Arrow (стрелка) и щелкните на текстовом блоке.
2 | Выберите Modify > Break Apart. Символы выбранного блока будут сконвертированы в графические формы на рабочем поле.

Примечание: Break Apart применяется только к векторным TrueType шрифтам, Bitmap шрифты исчезнут с экрана. PostScript шрифты могут быть преобразованы только на Macintosh системах, использующих Adobe Type Manager (ATM).


Связывание текстовых блоков с URL'ами

Использование текста > Связывание текстовых блоков с URL'ами

Связывание текстовых блоков с URL'ами

Вы можете связать текстовые блоки с URL'ами, чтобы пользователи могли переходить на другие файлы щелкая на текст, как на ссылку.

Для связывания текстового блока с URL:

1 | Используйте инструмент Arrow (стрелка) для выделения текстового блока на рабочем поле.
2 | Выберите Window > Panels > Character.
3 | Для связывания, введите URL который вы хотите связать.


О embedded и device шрифтах

Использование текста > О встраиваемых и device шрифтах

О встраиваемых и device шрифтах

Когда вы используете установленные в вашей системе шрифты в клипе, Flash встраивает шрифт в SWF файл, поэтому этот штифт отображается правильно во Flash Player клиента. Не все шрифты видимые во Flash могут быть экспортированы с роликом. Для проверки возможности экспорта шрифта, используйте команду View > Antialias Text для предварительного просмотра текста; искаженный текст показывает, что Flash не может определить очертание шрифта и не будет экспортировать текст.

Как альтернативу встраиванию шрифта, можно использовать специальные шрифты, называемые device шрифты. Device шрифты не экспортируются в SWF file. Поэтому, Flash Player использует какой-нибудь шрифт на локальном компьютере похожий на исходный device шрифт. Так как шрифт не встраивается, использование device шрифтов дает возможность уменьшить размер Flash ролика. Так же, device шрифты более удобны чем embedded (вставленные) при маленьком размере шрифта (менее 10 points). Однако, так как шрифт не экспортируются, то если пользователь не имеет на своем компьютере такого шрифта или другого похожего на device шрифт, текст может выглядеть по другому или некорректно.

Flash включает три device шрифта, названые _sans (подобные Helvetica or Arial), _serif (подобные Times Roman), and _typewriter (подобные Courier). Для использования шрифта как device шрифт, выберите один из этих шрифтов в панели Character или выберите Use Device Fonts в панели Text Options. У текста с device шрифтом можно включить опцию возможности выделения, что позволяет пользователю копировать и вставлять текст, применяемый в ролике. Смотрите Использование device шрифтов.

Можно использовать device шрифты для статического (static) текста (текст, который вставляется при создании ролика и не изменяется в процессе его воспроизведения) или динамического (dynamic) текста (текст, обновляемый периодически, например информация о погоде). Для информации о динамическом тексте, смотрите Создание редактируемых или динамически обновляемых текстовых полей.


Создание текста

Использование текста > Создание текста

Создание текста

Для помещения текстового блока на рабочее поле, используйте инструмент Text. Можно расположить текст в одну линию, которая расширяется по мере того, как вы печатаете или в блоке фиксированной длины, слова в нем будут переносится автоматически. Flash отображает кружочек в верхнем правом углу, когда блок расширяющийся и квадратик, если блок имеет фиксированный размер.

У текстовых полей Flash показывает квадратик в нижнем правом углу поля, показывающий что вы можете менять размер текстового поля, в зависимости от объема текста, который будет введен.

Для создания текста :

1 | Выберите инструмент Text.
2 | Выберите Window > Panels > Character и Window > Panels > Paragraph для показа панелей Character и Paragraph и установите атрибуты текста, как описано в Установка атрибутов текста.
3 | Сделайте одно из описанного ниже:
 | Для создания текстового блока подстраивающегося под текст, щелкните там, где хотите разместить текст.
 | Для создания текстового блока с фиксированной длиной, щелкните курсором на начале текста и тащите для указания нужной длины.

Примечание: Если вы создали текст, который вышел за пределы рабочей области, текст не потерян. Чтобы сделать его доступным снова, добавьте переводы строк и переместите текстовый блок, или выберите View > Work Area.

Для изменения размеров текстового блока :

Потяните его за уголок.

Для переключения между расширяющимся и фиксированным текстовым блоком :

Щелкните два раза на уголке.


Установка атрибутов текста

Использование текста > Установка атрибутов текста

Установка атрибутов текста

Можно устанавливать атрибуты шрифта или параграфа текста. Шрифт это набор алфавитно-цифровых символов определенного вида. Атрибуты шрифта включают семейство шрифта, размер, стиль, цвет, промежуток, авто кернинг, и смещение базовой линии. (Можно использовать встраиваемые или device шрифты. Смотрите О встраиваемых и device шрифтах.) Атрибуты параграфа включают выравнивание, отступы, отступ абзаца и расстояние между строками.

Для изменения атрибутов шрифта и параграфа используйте панели Character и Paragraph. Чтобы указать Flash использовать device шрифты, используйте панель Text Options.

Во время создания текста Flash использует текущие атрибуты. Для изменения атрибутов имеющегося текста, вы должны сначала выделить его.

Для использование панели Character :

Выберите Window > Panels > Character.

Для использование панели Paragraph :

Выберите Window > Panels > Paragraph.


Установка атрибутов текста

Использование текста > Установка атрибутов текста > Выбор шрифта, размера, стиля и цвета

Выбор шрифта, размера, стиля и цвета

Вы можете установить шрифт, размер, стиль и цвет для выбранного текста, используя панель Character.

При установлении цвета текста, можно использовать только однотонный цвет, но не градиент. Для применения градиента вы должны конвертировать текст в его компоненты, линии и заливки. Смотрите Изменение формы текста.

Используйте панель Character для выбора шрифта, размера, стиля и цвета:

1 | Если панель Character не показана, выберите Window > Panels > Character.
2 | Щелкните на треугольничке рядом с названием шрифта и выберите шрифт из списка или введите имя шрифта вручную.

Примечание: Шрифты _sans, _serif, и _typewriter являются device шрифтами. Эти шрифты не встраиваются в SWF файл. Смотрите О встраиваемых и device шрифтах.

3 | Щелкните на треугольничке рядом с размером шрифта и потяните движок для выбора значения или введите значение вручную.
 | Размер шрифта устанавливается в поинтах, относительно текущих единиц измерения.
4 | Для применения жирного стиля или курсива, нажмите кнопку Bold или Italic.
5 | Для выбора цвета текста, нажмите на цветной квадратик и сделайте одно из предложенного:
 | Выберите цвет из палитры.
 | Введите цвет в шестнадцатиричном виде в текстовое поле.
 | Нажмите кнопку Color Picker и выберите цвет таким образом.
 | Для большей информации по выбору цвета смотри Обзор работы с цветом.


Установка атрибутов текста

Использование Текста > Установка атрибутов текста > Установка промежутков, кернинга, базового смешения

Установка промежутков, кернинга, базового смешения

Промежуток указывает сколько свободного пространства находится между рядом стоящими символами. Можно задавать промежутки для выделенных символов или разом для целого блока текста.

Кернинг контролирует расстояние между некоторыми парами символов. Многие шрифты имеют встроенную информацию о кернинге. К примеру, расстояние между A и V часто меньше чем между A и D. Для использования встроенного кернинга, используйте параметр Kern.

Базовое смещение контролирует расположение текста относительно его базовой линии.

Параметры промежуток, кернинг, и базовое смешение находятся в панели Character.

Для установки промежутков, кернинга, базового смешения :

1 | Если панель Character не показана, выберите Window > Panels > Character.
2 | На панели Character установите следующие опции:
 | Для указания промежутков, щелкните на треугольничке рядом со значением Tracking и потяните движок для выбора значения, либо введите нужное значение вручную.
 | Для использования встроенного в шрифт кернинга, выберите Kern.
 | Для указания базового смещения, щелкните на треугольничке рядом с параметром Baseline Shift и выберите позицию из меню: Normal - текст на базовой линии, Superscript - под базовой линией, и Subscript - над базовой линией.


Установка атрибутов текста

Использование текста > Установка атрибутов текста > Установка выравнивания, отступов, отступа абзаца и расстояния между строками

Установка выравнивания, отступов, отступа абзаца и расстояния между строками

Выравнивание определяет позицию каждой строки текста в параграфе относительно левого и правого краев текстового блока. Текст может быть выровнен по левому или правому краю, центрирован внутри текстового блока или выровнен по обоим краям.

Отступы определяют пространство между границей текстового блока и параграфом текста. Отступ абзаца определяет дистанцию между границей параграфа и началом первой строки. Расстояние между строками определяет дистанцию между соседними линиями в параграфе.

Для указания выравнивания, отступов, отступа абзаца и расстояния между строками, используйте панель Paragraph.

Для установки выравнивания, отступов, отступа абзаца и расстояния между строками :

1 | Если панель Paragraph не показана, выберите Window > Panels > Paragraph.
2 | На панели Paragraph установите следующие параметры :
 | Для установки выравнивания, нажмите кнопку Left, Center, Right или Full.
 | Для установки левого или правого отступа, нажмите треугольничек рядом со значением Left Margin или Right Margin и потяните движок для выбора значения или введите значение вручную.
 | Для установки отступа абзаца, нажмите треугольничек рядом со значением Indent и потяните движок для выбора значения или введите значение вручную.
 | Для установки расстояния между строками, нажмите треугольничек рядом со значением Line Spacing и потяните движок для выбора значения или введите значение вручную.


Установка атрибутов текста

Использование текста > Установка атрибутов текста > Использование device шрифтов

Использование device шрифтов

Используя панель Text Options, можyj указать Flash Player использовать device шрифты для показа определенных текстовых блоков, ы этом случае Flash не будет встраивать шрифт для этого текста. Это может уменьшить размер файла ролика и улучшить читаемость мелкого текста.

Можно указать, что текст в device шрифтах может быть выделен пользователем.

Для назначения тексту device шрифтов:

1 | Используйте инструмент Text для выделения текстового блока на рабочем поле.
2 | Выберите Window > Panels > Text Options.
3 | Выберите Static Text из выпадающего меню.
4 | Пометьте Use Device Fonts.

Чтобы предоставить пользователю возможность выделеня текста:

1 | Выделите текстовый блок.
2 | Выберите Window > Panels > Text Options.
3 | Выберите Static Text из выпадающего меню.
4 | Если текст не в device шрифтах, пометьте Use Device Fonts.
5 | Включите опцию Selectable.


Создание символов из шрифта

Использование текста > Создание символов из шрифта

Создание символов из шрифта

Чтобы использовать шрифт как элемент общей библиотеки, можно создать символ из шрифта (шрифт-символ) в окне Library. Это дает возможность связывать шрифт и использовать его во Flash роликах без встраивания шрифта в ролик. (Смотрите Использование общих библиотек.)

Для использования шрифт-символа в общей библиотеке, ему назначается строка идентификатор. Идентификатор так же может быть использован для доступа к символу как к объекту в ActionScript. Для информации о объектах в ActionScript, смотрите Помощь по ActionScript.

Для создания шрифт-символа:

1 | Откройте библиотеку, в которой вы хотите добавить шрифт-символ.
2 | Выберите New Font из меню Options в окне Library.
3 | В диалоговом окне Font Symbol Properties, введите имя шрифт-символа.
4 | Выберите шрифт из выпадающего меню или введите название шрифта вручную.
5 | Если необходимо, пометьте Bold или Italic для применения выбранного стиля к шрифту.
6 | Нажмите OK.

Для назначения строки идентификатора шрифт-символу:

1 | Выберите шрифт-символа в окне Library.
2 | Сделайте одно из предлагаемого:
 | Выберите Linkage из меню Options в окне Library.
 | Right-click (Windows) или Control-click (Macintosh) на имени шрифт-символа в окне Library и выберите Linkage из контекстного меню.
3 | В диалоговом окне Symbol Linkage Properties, выберите Export This Symbol.
4 | Введите строку идентификатор и нажмите OK.


Using symbols and instances overview

Использование символов и их экземпляров > Обзор использования символов и их экземпляров

Обзор использования символов и их экземпляров

Символом может быть картинка, кнопка или мувиклип (анимация), которые Вы создаете, а потом используете в своем клипе или клипах. Любой созданный символ автоматически помещается в библиотеку. Экземпляр (instance) - это копия символа, расположенного на сцене или вложенного в другой символ. Экземпляр может сильно отличаться от самого символа цветом, размером и назначением. При редактировании символа изменения касаются и его экземпляров, но если редактируется экземпляр символа, то изменения касаются только его.

Примечание: Можно также создавать шрифтовые символы во Flash. Смотри Создание шрифтовых символов.

Использование символов в клипах значительно уменьшают размер файла, несколько экземпляров одного символа занимают меньше места, чем то же количество схожих отдельных элементов. Например, Вы можете уменьшить размер своего клипа, если сконвертируете статическую графику, например фон, в символ, который сможете использовать и в дальнейшем. Использование символов также увеличивает скорость, с которой воспроизводится Ваш клип, т.к. браузер скачивает символ только один раз за сеанс.

Вы также можете поместить свои символы в библиотеку, чтобы использовать их в других клипах. При этом их не нужно импортировать в клип, достаточно просто указать на их место в библиотеке. Смотри Использование общих библиотек.

Чтобы посмотреть интерактивный ролик по использованию символов и их экземпляров, выберите в меню Help > Lessons > Symbols.

Символ в библиотеке и два его экземпляра на сцене


Changing instance properties

Использование символов и их экземпляров > Изменение свойств экземпляра

Изменение свойств экземпляра

Каждый экземпляр символа имеет свои собственные свойства. Можно менять тон, прозрачность и яркость экземпляра, переопределять тип поведения экземпляра (например, изменить символ графики на анимацию) и устанавливать поведение анимации внутри графического экземпляра. Вы также можете наклонять, вращать или масштабировать экземпляр, не влияя на сам символ.

Вдобавок, Вы можете дать название экземпляру мувиклипа, чтобы использовать его в скриптах ActionScript.

Чтобы подредактировать свойства, пользуйтесь панелью Instance (Windows > Panels > Instance) и панелью Effect (Windows > Panels > Effect).

Свойства экземпляра хранятся вместе с ним. Если Вы редактируете символ или переключаете экземпляр на другой символ, любые свойства экземпляра, которые Вы изменили, остались в силе.

Оригинальный символ и два измененных экземпляра


Changing instance properties

Использование символов и их экземпляров > Изменение свойств экземпляра > Изменение цвета и прозрачности экземпляра

Изменение цвета и прозрачности экземпляра

Каждый экземпляр символа может иметь собственный цветовой эффект. Для установки цвета и прозрачности экземпляра используйте панель Effect, прикрепленную к панели Instance. Установки в панели Effect также действуют на растровые картинки, расположенные в символах.

Экземпляры символов, каждый со своим собственным цветовым эффектом

Когда Вы меняете цвет и прозрачность экземпляра в отдельном кадре, Flash показывает изменения как только этот кадр отображается. Чтобы сделать постепенное изменения цвета, Вы должны использовать твининг (последовательность кадров с постепенными изменениями). Когда Вы делаете твининг цвета, нужно внести различные установки эффекта в начальный и конечные кадры экземпляра, и затем применить твининг для постепенного изменения цвета во времени. См. Построение промежуточных отображений для экземпляров, групп и текста.

Твининг постепенно изменяет цвет или прозрачность экземпляра.

Примечание: Если Вы применяете цветовой эффект к клипу, который содержит множество кадров, Flash применяет эффект к каждому кадру в этом клипе.

Для изменения цвета и прозрачности экземпляра:

1 | Выделите экземпляр на сцене и выберите Window > Panels > Effect.
 | Вы также можете применить Alt-двойной клик (Windows) или Option-двойной клик (Macintosh) к экземпляру на сцене, чтобы вывести панель Instance вперед, затем нажать закладку Effect.
2 | Выберите одну из следующих опций в панели Effect:
 | Brightness (Яркость) применяет относительное осветление или затемнение картинки, измеренное шкалой от черного (-100%) до белого (100%).
 | Tint (Окраска) окрашивает экземпляр одинаковым оттенком. Используйте бегунок Tint вверху панели, для установки процента оттенка, от прозрачного (1%) до интенсивного (100%). Для выбора цвета, введите значения красного, зеленого и синего в текстовые окошки или выставьте цвет бегунками, или пипеткой (Color Picker).
 | Alpha (Прозрачность) изменяет прозрачность экземпляра.
 | Advanced (Продвинутый) отдельно применяет значение красного, зеленого, синего и прозрачность экземпляра. Это очень удобно, когда Вы хотите создать и анимировать утонченные цветовые эффекты на объектах типа растровых картинок. Элементы управления слева позволяют Вам уменьшить цветность или прозрачность на определенный процент. Элементы управления справа позволяют Вам уменьшить или увеличить цветность или прозрачность на постоянное значение.
 | Текущие значения красного, зеленого, синего и прозрачности умножены на значения процента в правой колонке, в результате получаются новые цвета. Например, если текущее значение красного 100, установка левого бегунка на 50% и правого бегунка на 100 дает новое значение красного 150 ((100 x .5) + 100 = 150).
 | Любые изменения вступают в силу автоматически.

Также возможно изменение цвета с помощью объекта ActionScript Color. За дополнительной информацией обращайтесь к ActionScript Help.


Changing instance properties

Использование символов и их экземпляров > Изменение свойств экземпляра > Замена экземпляра другим символом

Замена экземпляра другим символом

Назначение экземпляру другого символа в результате дает отображение другого экземпляра на сцене, однако сохраняя все свойства предыдущего экземпляра (такие как цветовые эффекты и реакцию на кнопки).

Скажем, например, Вы создаете мультик с символом Крысы и ее характером, но вдруг решаете изменить героя на Кота. Вы можете переключить символ Крысы на Кота и Кот будет во всех тех кадрах мультика, где была Крыса.

Чтобы переназначить символ для экземпляра:

1 | Выделите экземпляр на сцене и выберите Window > Panels > Instance или Alt-двойной клик (Windows) или Option-двойной клик (Macintosh) на экземпляре в сцене чтобы вывести панель Instance вперед.
2 | Нажмите кнопку Swap Symbol (Поменять символ) внизу панели Instance.
3 | В диалоговом окне Swap Symbol, выделите символ, которым замените текущий, ранее назначенный экземпляру. Чтобы сдублировать выделенный символ, нажмите кнопку Duplicate Symbol внизу диалогового окна.
 | Дублирование позволит сделать новый символ на основе существующего в библиотеке. Это удобно, если нужно сделать несколько символов, которые незначительно отличаются друг от друга.


Changing instance properties

Использование символов и их экземпляров > Изменение свойств экземпляра > Изменение типа экземпляра

Изменение типа экземпляра

Возможно изменение типа экземпляра для переопределения его поведения в клипе. Например, если графический экземпляр содержит анимацию, которую Вы хотите воспроизводить независимо от основной линейки клипа, можете переопределить графический экземпляр, как экземпляр мувиклипа.

Чтобы изменить тип экземпляра:

1 | Выделите экземпляр на сцене и выберите Window > Panels > Instance или Alt-дважды кликните (Windows) или Option-дважды кликните (Macintosh) экземпляр на сцене, чтобы вывести панель Instance на передний план.
2 | Для изменения типа поведения, выберите Графику (Graphic), Кнопку (Button) или Мувиклип (Movie Clip).


Changing instance properties

Использование символов и их экземпляров > Изменение свойств экземпляра > Анимирование экземпляров графики

Анимирование экземпляров графики

Можно определить порядок воспроизведения анимационных последовательностей внутри графического экземпляра во время воспроизведения основного клипа путем установки опций в панели Instance.

Анимированный графический символ связан с линейкой клипа в котором он расположен. Символ-мувиклипа, однако, имеет собственную независимую линейку времени. Анимированные графические символы показываются в режиме редактирования символа, т.к. они используют линейку основного клипа. Символы-мувиклипа показываются как статические объекты на сцене и не показываются как анимация в среде Flash-редактора.

Чтобы сделать анимацию графического экземпляра:

1 | Выделите графический экземпляр на сцене и выберите Window > Panels > Instance или Alt-двойной клик (Windows) или Option-двойной клик (Macintosh) на экземпляре в сцене для вывода панели Instance на передний план.
2 | Выберите опцию анимации из всплывающего меню ниже типа экземпляра:
 | Loop зацикливает все анимационные последовательности, содержащиеся в текущем экземпляре на количество кадров, которое занимает экземпляр.
 | Play Once проигрывает анимационную последовательность, начиная с указанного Вами кадра до конца, затем останавливается.
 | Single Frame показывает один кадр из анимационной последовательности. Укажите который кадр показывать.


Breaking apart instances

Использование символов и их экземпляров > Разделение экземпляров

Разделение экземпляров

Чтобы разорвать связь между экземпляром и символом и сделать из экземпляра коллекцию несвязанных форм и линий, Вам нужно разбить экземпляр. Это удобно для изменения конкретного экземпляра без воздействия на любой другой экземпляр. Если Вы измените исходный символ после разделения экземпляра, изменения не коснутся этого экземпляра.

Чтобы разделить экземпляр символа:

1 | Выделите экземпляр на сцене.
2 | Выберите Modify > Break Apart.
 | Это разделит экземпляр на графические компоненты.
3 | Используйте инструменты рисования и закраски для изменения этих элементов по желанию.


Getting information about instances on the Stage

Использование символов и их экземпляров > Получение информации об экземпляре на сцене

Получение информации об экземпляре на сцене

В только что созданном клипе бывает трудно определить, что за экземпляр символа расположен на сцене, особенно если Вы работаете со множеством экземпляров одного символа. Эти трудности можно преодолеть, используя панели Экземпляра (Instance), Информации (Info) или Инспектора клипов (Movie Explorer).

Все панели показывают имя выделенного экземпляра и значок, указывающий на его тип — графика, кнопка или мувиклип. Вдобавок, Вы можете посмотреть следующую информацию:

В панели Instance, можете посмотреть тип экземпляра и установки: для графики - режим зацикливания и длину символа в кадрах; для кнопок - опции отслеживания движения мышки; и для мувиклипов, длину клипа.
В панели Info, можете посмотреть координаты и размер выделенного экземпляра.
В Movie Explorer, можете просматривать содержимое текущего клипа, включая экземпляры и символы. См. Использование Movie Explorer.

Вдобавок, в панели Actions, можете просмотреть любые действия, назначенные символам графики, кнопке или мувиклипу.

Чтобы получить информацию об экземпляре на сцене:

1 | Выделите экземпляр на сцене.
2 | Чтобы вывести панель, которой Вы хотите воспользоваться:
 | Чтобы показать панель Instance, выберите Window > Panels > Instance или Alt-двойной клик (Windows) или Option-двойной клик (Macintosh) на выделенном экземпляре.
 | Чтобы показать панель Info, выберите Window > Panels > Info.
 | Чтобы показать панель Actions, выберите Window > Actions.
 | Чтобы показать Movie Explorer, выберите Window > Movie Explorer.
 | Чтобы узнать больше о Movie Explorer, смотри Использование Movie Explorer.
 | Выделенный экземпляр кнопки и информация отображается в панелях Instance, Info, Movie Explorer и Actions

Чтобы посмотреть описание для выделенного символа в окне Movie Explorer:

1 | Нажмите Show Buttons, Movie Clips и Graphics кнопки вверху окна Movie Explorer.
2 | Щелкните правой кнопкой мышкой (Windows) или Control-click (Macintosh) и выберите Show Symbol Instances (Показать экземпляры символа) и Go to Symbol Definition из контекстного меню или просто выберите эти опции из всплывающего меню в верхнем правом углу окна Movie Explorer.

Чтобы перейти к сцене, содержащей экземпляры выделенного символа:

1 | Выведите описание символа, как указано в предыдущей процедуре.
2 | Щелкните правой кнопкой мышкой (Windows) или Control-click (Macintosh) и выберите Show Movie Elements и Select Symbol Instances из контекстного меню или выберите эти опции из всплывающего меню в правом верхнем углу окна Movie Explorer.


Types of symbol behavior

Использование символов и их экземпляров > Типы поведения символа

Типы поведения символа

Каждый символ имеет уникальную линейку (Timeline) и сцену (Stage). Когда Вы создаете символ, то выбираете, как он будет себя вести, в зависимости от того, какую роль в клипе Вы ему отвели.

Используйте символ-графику для неподвижных картинок, часто используемых частей анимации, связанных с линейкой основного мувиклипа. Символы Графики действуют синхронно линейке основного мувиклипа. Интерактивные элементы и звуки не будут работать в графических символах.
Используйте символы-кнопки для создания интерактивных меню, реагирующих на нажатия или другие действия мыши. Вы определяете графику, связанную с различными состояниями кнопки, а потом назначаете действия для ее экземпляра. Смотрите Назначение действий объектам.
Используйте мувиклипы (символы анимации) для создания анимированных кусочков. Мувиклипы имеют свою собственную линейку (Timeline), не зависящую от линейки основного мувиклипа. Представьте себе, что в основном клипе есть мини-клипы, содержащие интерактивные элементы управления, звуки, даже экземпляры других мувиклипов. Вы также можете разместить экземпляры мувиклипов внутри символов-кнопок, чтобы сделать анимированные кнопки.
Вы можете назначать параметры клипов (переменные с их значениями) чтобы создавать "умные" (smart) клипы. Также можно добавить действия и скрипты для "умного" клипа чтобы он сам создавал элементы интерфейса, например радио-кнопки, всплывающие меню или подсказки, реагирующие на нажатия мыши либо другие события. За дополнительной информацией обращайтесь к ActionScript Help.

Примечание: Интерактивность и анимация мувиклипов не работают при воспроизведении клипа в среде Flash-редактора. Чтобы увидеть анимацию и почувствовать интерактивность, выберите в меню Control > Test Movie или Control > Test Scene. Смотрите Просмотр и тестирование клипов.


Creating symbols

Использование символов и их экземпляров > Создание символов

Создание символов

Вы можете создать символ из выделенных объектов на сцене или создать пустой символ и нарисовать или скопировать его содержимое в режиме редактирования символа.

При использовании символов, содержащих анимацию, Вы можете создать клипы со множеством движений, не увеличивая при этом размера файла клипа. Рассмотрим создание анимации в символе, когда в нем используются повторяющиеся или циклические движения — взмахивание крыльями птицы, например.

Чтобы создать новый символ из выделенных элементов:

1 | Выделите элемент или несколько элементов на сцене и выберите Insert > Convert to Symbol (Вставка > Сконвертировать в символ).
2 | В диалоговом окне Symbol Properties (Свойства символа) укажите имя символа и его назначение (the behavior) — Графика, Кнопка или Анимация (Graphic, Button, or Movie Clip). Смотрите Типы поведения символа.
3 | Нажмите OK.
 | Flash добавит символ в библиотеку. Выделенное Вами на сцене станет экземпляром символа. Теперь Вы более не сможете редактировать объект прямо на сцене, а должны открыть его в режиме редактирования символа. Смотрите Редактирование символов.

Чтобы создать пустой символ:

1 | Убедитесь, что Вы ничего не выделили на сцене и сделайте одно из следующего:
 | Выберите Insert > New Symbol.
 | Нажмите кнопку New Symbol, расположенную слева внизу окна библиотеки (Library).
 | Выберите New Symbol из меню Library Options в верхнем правом углу библиотеки (Library).
2 | В диалоговом меню Symbol Properties напишите имя символа и выберите его назначение (the behavior) — Графика, Кнопка или Анимация (Graphic, Button, or Movie Clip). Смотрите Типы поведения символов.
3 | Нажмите OK.
 | Flash добавит символ в библиотеку и переключится в режим редактирования символа. В этом режиме название символа находится над верхним левым углом окна, над линейкой, а крестик показывает точку отсчета символа.
4 | Чтобы создать содержимое символа, используйте линейку, рисуйте, импортируйте картинки, звуки или создавайте экземпляры других символов.
5 | Когда Вы закончите создание содержимого символа, сделайте одно из следующего, чтобы вернуться в режим редактирования клипа:
 | Выберите из меню Edit > Edit Movie.
 | Нажмите на кнопку Scene в верхнем левом углу окна сцены.
 | Нажмите кнопку редактирования сцены Edit Scene в верхнем правом углу документа и выберите сцену из меню.


Creating symbols

Использование символов и их экземпляров > Создание символов > Конвертация анимации на сцене в мувиклип

Конвертация анимации на сцене в мувиклип

Если Вы только что создали последовательность анимации на сцене и хотите использовать ее не только на ней, а еще где-то в клипе или если хотите поуправлять этой последовательностью как каким-нибудь экземпляром, можете выделить и сохранить ее как мувиклип.

Чтобы сконвертировать анимацию на сцене в мувиклип:

1 | На основной линейке (Timeline), выделите каждый кадр в каждом слое анимации, которую Вы хотите использовать.
2 | Чтобы скопировать кадры, сделайте одно из следующего:
 | Нажмите правую кнопку мышки (Windows) или Control-click (Macintosh) на любом выделенном кадре и выберите Copy Frames из контекстного меню.
 | Выберите Edit > Copy Frames.
3 | Снимите Ваше выделение(я) и убедитесь, что на сцене больше нигде ничего не выделено. Затем выберите Insert > New Symbol.
4 | В диалоговом окне свойства символа (Symbol Properties), как-нибудь обзовите символ. В качестве поведения выберите Movie Clip, потом OK.
 | Flash откроет окно редактирования нового символа.
5 | На линейке нажмите правой кнопкой мышки на первом кадре первого слоя и выберите Edit > Paste Frames.
 | Это вставит кадры, скопированные из основной линейки сцены, в линейку данного мувиклипа. Любая анимация, кнопки или элементы интерактивности из скопированных кадров теперь становятся независимой анимацией (мувиклипом), который вы можете использовать где угодно в своем творении.
6 | Чтобы выйти из режима редактирования символа:
 | Выберите Edit > Edit Movie.
 | Нажмите на кнопку сцены в верхнем левом углу окна документа.
 | Нажмите на кнопку сцены в верхнем правом углу окна документа и выберите сцену из меню.
7 | Удалите анимацию из основного клипа путем выделения всех кадров и всех слоев на линейке и выбора Insert > Remove Frame.


Creating symbols

Использование символов и их экземпляров > Создание символов > Дублирование символов

Дублирование символов

Дублирование символов позволяет использовать старый символ в качестве основы для создания нового символа.

Дублирование символов:

1 | Выберите символ в библиотеке (Library).
2 | Чтобы сдублировать символ сделайте одно из следующего:
 | Нажмите правую кнопку мышки (Windows) или нажмите Control-click (Macintosh) и выберите Duplicate из контекстного меню.
 | Выберите Duplicate из меню Options библиотечки.


Creating instances

Использование символов и их экземпляров > Создание экземпляров объектов

Создание экземпляров объектов

Единожды создав символ, Вы можете создавать до черта его (прим. переводчика: в общем много ;)) экземпляров где и когда хотите, даже внутри других символов.

Чтобы создать новый экземпляр символа:

1 | Выберите слой на линейке.
 | Flash может размещать экземпляры символов только в ключевых кадрах (keyframes), всегда в текущем слое!. Если Вы поленились выделить для этого нужного дела ключевой кадр, экземпляр (бедненький!) добавится к первому ключевому кадру слева от текущего кадра.
2 | Выберите Window > Library чтобы открыть библиотеку (library).
3 | Затащите этот упрямый символ прямо на сцену (пусть попляшет! ;)
4 | Если Вы умудрились создать экземпляр символа-графики, выберите Insert > Frame чтобы добавить нужное количество кадров, в котором он (символ) будет содержаться.

После создания экземпляра символа Вы можете попользовать панель (Instance panel) экземпляров (Windows > Panels > Instance) чтобы определить то огромное количество эффектов, действий, режимов отображения, поведения экземпляра, которые позволит Вам выбрать его(ее) величество Macromedia Inc. Поведение (behavior) экземпляра созвучно поведению символа, если только Вам не взбредет в голову определить его для этого экземпляра самостоятельно. Любые изменения, которые Вы сделаете, вступят в силу только для данного экземпляра (а никак не для символа - он папа (или мама - не суть)). См. Изменение цвета и прозрачности экземпляра символа.

От переводчика: в общем, пробило меня на лирику; эта (в смысле часть про инстансы и символы) РЕДАКТИРОВАЛАСЬ С ПОМОЩЬЮ MACROMEDIA DREAMWEAVER 90 DAY'S TRIAL EDITION, чтобы там VM не говорил в russian-flash-news на www.egroups.com Ж;-))
ЗЫ: F10 еще никто не отменял ;)

От редактора: Стиль перевода сохранен в неприкосновенности :)
По большому счету не суть важно в чем делалось, главное владеть инструментом!


Creating buttons

Использование символов и их экземпляров > Создание кнопок

Создание кнопок

Кнопки - это на самом деле интерактивные 4-х кадровые клипы. Когда вы выбираете тип символа кнопка, Flash создает линейку из 4-х кадров. Первые три кадра отражают три состояния кнопки, четвертый кадр определяет область реакции на мышь. Линейка на самом деле не проигрывается, она просто реагирует на движение курсора и действия (нажатие/отжатие кнопки, наезд/отъезд и т.д.) выбором соответствующего кадра.

Чтобы кнопка приобрела элементы интерактивности, Вы должны расположить ее экземпляр на сцене и назначить ему определенные команды. Они должны быть назначены экземпляру кнопки, а не кадру на линейке самой кнопки.

Каждый кадр на линейке кнопки имеет свою функцию:

Первый кадр - Up, отражает состояние кнопки, когда курсор не наведен на нее.
Второй кадр - Over, отражает состояние кнопки, когда курсор находится над кнопкой.
Третий кадр - Down, отражает состояние нажатой кнопки.
Четвертый - Hit, определяет область реакции на мышь. Он не отражается в клипе.
Типичное содержание Up, Over, Down и Hit кадров (собранных в третьем кадре)

Хотите посмотреть интерактивный урок по созданию кнопок во Flash? Идите сюда Help > Lessons > Buttons.

Чтобы создать кнопку:

1 | Выберите Edit > Deselect All чтобы быть уверенными в том, что Вы ничего не выделили на сцене.
2 | Выберите Insert > New Symbol или нажмите Control+F8 (Windows) или Command+F8 (Macintosh).
 | Чтобы создать кнопку, Вы делаете кадры кнопки ключевыми (F6).
3 | В диалоговом окне Symbol Properties (Свойства символа), введите имя новой кнопки и тип ее поведения (Behavior) - Button (кнопка).
 | Flash переключится в режим редактирования символа. Заголовок линейки изменится: теперь он будет отражать четыре последовательных кадра Up, Over, Down и Hit. Первый кадр Up - пустой ключевой.
4 | Чтобы создать картинку для кадра Up, используйте инструменты рисования, импортируйте графику или располагайте экземпляр другого символа на сцене.
 | Вы можете использовать статический или анимационный символ (graphic или movie clip symbol) в кнопке, но нельзя использовать "кнопку в кнопке". Используйте анимационный символ, если Вам захотелось, чтобы кнопка была "живой".
5 | Нажмите второй кадр - Over, и выберите Insert > Keyframe.
 | Flash вставит ключевой кадр, скопировав содержимое предыдущего кадра - Up.
6 | Измените содержимое кадра Over как Вам заблагорассудится.
7 | Повторите шаги 5 и 6 для оставшихся кадров - Down и Hit.
 | Маленькая ремарка - этакая "нота бене": кадр Hit не отображается на сцене - он "невидим", но он определяет область реакции на мышь. Убедитесь, что то, что Вы запихнули в этот кадр имеет достаточно широкую непрерывную область, перекрывающую все графические элементы кадров Up, Down, и Over. Не смущайтесь, если эта область больше, нежели самый большой видимый элемент кнопки. Хинт: если Вы все-таки умудрились ничего не нарисовать в кадре Hit, то не расстраивайтесь: его роль сыграет кадр Up. Так что думайте, что там рисовать.
 | Вы можете создать разделенные области реакции на мышь, поместив кадр Hit в другое место (вдали от других кадров).
8 | Для того, чтобы назначить звук состоянию кнопки, выберите кадр этого состояния на линейке, выберите Modify > Frame чтобы отразить панель кадров (Frame panel), а затем нажмите закладку звука (Sound tab) в панели кадров. См. Озвучивание кнопок.
9 | Когда вы закончите, выберите Edit > Edit Movie. Вытаскивайте Вашу кнопку из библиотеки на сцену или в мувиклип чтобы создать ее экземпляр.


Enabling, editing, and testing buttons

Использование символов и их экземпляров > Включение, редактирование и тестирование кнопок

Включение, редактирование и тестирование кнопок

По умолчанию, Flash отключает кнопки во время редактирования, чтобы облегчить работу с ними и их выделение. Когда кнопка отключена, нажатие на ней выделяет ее. Когда кнопка включена, она реагирует на события, которые Вы определили так, как будто клип воспроизводится. Вы все еще можете выделить включенные кнопки, однако, обычно лучше отключить их во время редактирования и включать только для тестирования их поведения.

Для включения/выключения кнопок:

Выберите Control > Enable Simple Buttons. Галочка на команде меню показывает, включены ли кнопки. Выберите команду снова, чтобы отключить кнопки.

Любая кнопка на сцене теперь реагирует на мышь. Когда Вы двигаете курсор над кнопкой, Flash отражает кадр Over, когда Вы нажимаете на активной области кнопки, Flash показывает кадр Down.

Чтобы выделить включенную кнопку:

Используйте инструмент "Стрела" (Arrow) чтобы выделить прямоугольную область вокруг кнопки.

Чтобы переместить или отредактировать включенную кнопку:

1 | Выделите кнопку как было описано выше.
2 | Сделайте одно из следующего:
 | Используйте клавиши курсора, чтобы переместить кнопку.
 | Выберите Window > Panels > Instance для редактирования кнопки или Alt-двойной щелчок мышью (Windows) или Option-двойной щелчок мышью (Macintosh).

Чтобы проверить кнопку, сделайте одно из следующего:

Выберите Control > Enable Simple Buttons. Подвигайте курсор над включенной кнопкой, чтобы протестировать ее.
Выберите кнопку в библиотечке (Library) и нажмите кнопку Play в окне просмотра библиотечки.
Анимация в кнопках не видна, пока Вы находитесь в среде Flash-редактора. Смотрите Просмотр и тестирование клипов.
Выберите Control > Test Scene или Control > Test Movie.


Editing symbols

Использование символов и их экземпляров > Редактирование символов

Редактирование символов

При редактировании символа Flash обновляет все его экземпляры в клипе. Можно редактировать символ наряду с другими объектами на сцене используя команду Edit in Place. Другие объекты недоступны для редактирования ("засерены"), чтобы отличить их от редактируемого объекта.

Также возможно редактирование символа в отдельном окне, используя команду Edit in New Window или режим редактирования символа. Редактирование символа в отдельном окне позволяет одновременно видеть линейку символа и главную линейку.

В режиме редактирование символа окно переключается с вида сцены на вид только символа, а крестик показывает точку отсчета. Вдобавок панель Instance засерена и имя символа находится над верхним левым углом окна, выше линейки.

Для редактирования символа в основном окне:

Дважды щелкните экземпляр на сцене.
Выберите экземпляр на сцене и щелкните правой кнопкой (Windows) или Control-кликните (Macintosh) и выберите Edit in Place из контекстного меню.

Для редактирования символа в новом окне:

Выберите экземпляр символа на сцене и щелкните правой кнопкой (Windows) или Control-кликните (Macintosh) и выберите Edit in New Window из контекстного меню.
Дважды щелкните на значке символа в окне библиотеки.

Для редактирования символа в режиме редактирования символа:

Выделите экземпляр символа на сцене и нажмите кнопку Edit Symbol внизу панели Instance.
Выберите экземпляр символа на сцене, выберите Edit > Edit Symbols или щелкните правой кнопкой (Windows) или Control-кликните (Macintosh) или выберите Edit из контекстного меню.
Дважды щелкните символ в библиотеке, затем выберите Edit из меню опций библиотеки или щелкните правой кнопкой (Windows) или Control-кликните (Macintosh) и выберите Edit из контекстного меню.

Символ, привязанный к экземпляру, откроется в режиме редактирования символа. Теперь Вы можете его редактировать. Все экземпляры символа в клипе обновятся, отражая внесенные изменения.

Во время редактирования символа можно использовать инструменты рисования, импортировать звуки и изображения или создавать экземпляры других символов.

Чтобы вернуться из режима редактирования символа к редактированию клипа:

Выберите Edit > Edit Movie.
Щелкните название сцены в левом верхнем углу окна документа.
Нажмите кнопку Edit Scene в верхнем правом углу окна документа и выберите сцену из меню.


Создание анимации: краткий обзор

Создание анимации > Создание анимации: краткий обзор

Создание анимации: краткий обзор

Анимация создается изменением содержимого ключевых кадров. Вы можете перемещать объект по сцене, уменьшать или увеличивать его, вращать, изменять оттенок или форму. Изменения могут происходить независимо или в зависимости от других событий. Например, можно заставить объект вращаться и исчезать по мере его передвижения по сцене.

Flash использует два вида анимации: покадровую и автоматическую (tweened) анимацию. При создании покадровой анимации Вы прорисовываете каждый кадр, шаг за шагом. При создании автоматической анимации, задаете начальный и конечный кадры, а Flash создает кадры между ними.

Автоматическая анимация эффективна для перемещения и изменения объектов при минимальном размере файла, так как Flash сохраняет значения параметров объектов только в ключевых кадрах. В покадровой анимации Flash сохраняет все значения в каждом кадре.

Для прохождения интерактивного урока по анимации нажмите Help > Lessons > Animation.

Примечание: Также можно создавать анимацию используя команду Set Property. См. ActionScript Help.


Анимация форм

Создание анимации > Анимация форм

Анимация форм

Анимируя формы, вы можете создавать эффект, подобный морфингу, заставляя одну форму "перетекать" в другую. Flash также может анимировать местонахождение, размер и цвет форм.

Анимация одного объекта в один момент времени даёт наилучший результат. Если вы анимируете несколько форм, то они должны быть на одном слое.

Flash не может анимировать формы групп, символов, блоков текста или растровых изображений. Используйте разбивку на части (Modify > Break Apart), чтобы анимировать формы таких объектов. См. Разбивка на части групп и объектов.

Чтобы контролировать сложные или неправильные изменения формы, используйте на форме специальные метки - хинты (shape hints). Эти хинты определяют, каким именно образом одна форма трансформируется в другую. См. Использование хинтов на форме.

Для анимации формы:

1 | Выберите нужный слой и встаньте в начальный ключевой кадр.
2 | Создайте изображение для первого кадра анимации.
 | Используйте необходимые инструменты для создания нужной формы.
3 | Создайте второй ключевой кадр через нужное количество кадров после первого.
4 | Создайте изображение для второго ключевого кадра. Вы можете изменять форму, размер или положение рисунка, созданного в первом ключевом кадре (пункт 2).
5 | Нажмите Window > Panels > Frame.
6 | В списке Tweening, жмите Shape.
7 | Нажмите кнопку со стрелочкой рядом с надписью Easing и тяните вверх или вниз (или введите цифру вручную), чтобы установить замедление или ускорение анимации:
 | Чтобы начать анимацию медленно и убыстрить её к концу, тащите бегунок вниз или установите вручную значение от -1 до -100.
 | Чтобы начать анимацию быстро и замедлить её к концу, тащите бегунок вверх или установите вручную значение от 1 до 100.
 | По умолчанию, скорость изменения величин в анимации постоянна, и функция Easing часто позволяет добиться необходимого эффекта.
8 | Также выберите значение для поля Blend:
 | Значение Distributive делает анимацию в промежуточных кадрах более мягкой и плавной.
 | Значение Angular делает анимацию в промежуточных кадрах более угловатой, сохраняя прямые линии.

Примечание: Значение Angular более подходит для форм с углами и прямыми линиями. Если форма не содержит углов, используйте Distributive.


Анимация форм

Создание анимации > Анимация форм > Использование хинтов на форме

Использование хинтов на форме

Чтобы контролировать сложные изменения контуров и исправлять неправильные, используйте хинты (shape hints). Ими метятся точки, которые должны соответствовать друг другу в начальной и конечной формах. К примеру, если вы делаете анимацию лица, которое изменяет выражение, можете пометить хинтами каждый глаз. После этого в процессе анимации, контуры лица не смешиваются беспорядочно и каждый глаз изменяется отдельно.

Сравните: анимация формы без хинтов и с ними.

Хинты визуально представлены как разноцветные кружки с буквами от a до z внутри для идентификации соответствующих пар точек. Можно использовать до 26 точек.

Хинты рисуются жёлтым цветом в начальном ключевом кадре и зелёным - в конечном. Будучи ещё не поставленными на кривую, точки отображаются красным.

Для получения наилучших результатов, имейте ввиду следующее:

В сложных длинных превращениях рисуйте промежуточные ключевые кадры.
Не нарушайте логику расстановки точек. Например, анимируя треугольник и используя три хинта, сохраняйте порядок их расстановки - a-b-c в первом и a-b-c во втором ключевых кадрах.
Хинты работают лучше, если расставлены против часовой стрелки начиная с верхнего левого угла контура.

Для использования хинтов:

1 | Выберите первый ключевой кадр анимации.
2 | Нажмите Modify > Transform > Add Shape Hint.
 | Первый хинт появится где-то на сцене, окрашенный в красный цвет и с буквой a внутри.
3 | Переместите его на точку, которую хотите замаркировать.
4 | Перейдите в конечный ключевой кадр анимации.
 | Конечный зелёный хинт, помеченный буквой a, уже находится на сцене.
5 | Перетащите его в место, которое должно соотноситься с местом точки замаркированной в начальном кадре.
6 | Запустите анимацию снова, чтобы увидеть, как хинты влияют на процесс трансформации формы. Перемещайте хинты для точной подстройки анимации.
7 | Повторяйте процесс для добавления новых хинтов. Они будут появляться с буквами b, c, d и так далее.

Работая с хинтами, вы имеете дополнительные возможности:

Чтобы увидеть все хинты, нажмите View > Show Shape Hints. Слой и ключевой кадр, содержащий их, должны быть текущими.
Чтобы удалить хинт, "вытащите" её со сцены.
Чтобы убрать сразу все хинты, нажмите Modify > Transform > Remove All Hints. (Прим.пер.: По нажатию правой кнопки мыши на хинт выскакивает контекстное меню со следующими возможностями: убрать хинт, убрать все хинты, добавить хинт, показать/скрыть хинты. Это удобно.


Создание покадровой анимации

Создание анимации > Создание покадровой анимации

Создание покадровой анимации

В покадровой анимации содержание сцены изменяется в каждом кадре (Прим.пер.: т.е. каждый кадр является ключевым). Она подходит для анимации, в которой кадры изменяются значительно, а не просто содержат перемещающиеся объекты. Такая анимация сильно увеличивает размер flash-клипа.

Используйте покадровую анимацию, когда вам надо менять изображение в каждом кадре.

Чтобы создать покадровую анимацию:

1 | Щелкните на имени слоя чтобы сделать его текущим и перейдите на кадр, в котором должна начинаться анимация.
2 | Если кадр ещё не является ключевым, сделайте его ключевым - нажмите Insert > Keyframe.
3 | Создайте изображение в первом ключевом кадре анимации.
 | Вы можете использовать инструменты для рисования, вставлять графику из буфера обмена или импортировать файл.
4 | Щелкните на кадр справа от только что нарисованного и нажмите Insert > Keyframe, или щелкните правой кнопкой мыши (Windows) или с клавишей Control (Macintosh), а потом в выпавшем меню нажмите Insert Keyframe.
 | Это действие добавляет новый ключевой кадр, который содержит то же, что и предыдущий.
5 | Измените содержание второго кадра в соответствии с требованиями вашей анимации.
6 | Чтобы закончить покадровую анимацию, повторяйте шаги 4 и 5 до достижения нужного результата.
7 | Протестировать полученную анимацию можно, нажав Control > Play или нажав на кнопку Play в окне Controller.
 | Полезно периодически просматривать анимацию в процессе её создания.


Редактирование анимации

Создание анимации > Редактирование анимации

Редактирование анимации

После того, как вы создали кадр или ключевой кадр, можете перемещать его в текущем или в других слоях, удалять его, и производить другие изменения. Только ключевые кадры поддаются прямому редактированию. Вы видите промежуточные кадры, но нельзя редактировать их напрямую. Вы можете редактировать их, редактируя ключевые кадры, от которых они зависят или вставляя новые ключевые кадры между старыми. Вы также можете перетаскивать объекты из окна библиотеки (Library) прямо на сцену.

Чтобы просмотреть и отредактировать более одного кадра в единицу времени, используйте onion skinning.

Чтобы вставить кадры в монтажную линейку (Timeline), сделайте одно из перечисленного:

Чтобы вставить новый кадр, нажмите Insert > Frame.
Чтобы создать новый ключевой кадр, нажмите Insert > Keyframe или используйте выпадающее по правой клавише мыши меню.
Чтобы создать новый пустой ключевой кадр, нажмите Insert > Blank Keyframe или нажмите правой кнопкой мыши в нужном кадре, и используйте команду Insert Blank Keyframe.

Чтобы удалить или отредактировать кадр или ключевой кадр, сделайте одно из нижеследующего:

Чтобы удалить кадр, ключевой кадр, или последовательность кадров, нажмите Insert > Remove Frame или выберите Remove Frame из выпадающего по правой кнопке мыши контекстного меню (Control-клик на Macintosh). Окружающие кадры остаются нетронутыми.
Чтобы переместить кадр или последовательность кадров, просто "перетащите" их мышкой.
Чтобы удлинить продолжительность ключевого кадра, нажмите клавишу Alt (Option на Маке) и перетащите его вправо на нужное расстояние.
Чтобы скопировать ключевой кадр или последовательность кадров, выделите необходимый фрагмент, начните его тащить, нажмите Alt, и отпустите в нужном месте. (Прим.пер.: на курсоре при этом появляется плюсик.)
Чтобы скопировать выделенные кадры в буфер, нажмите Edit > Copy Frames. Выберите кадр или последовательность кадров, и нажмите Edit > Paste Frames, чтобы заменить их содержимым буфера.
Чтобы сконвертировать выбранный ключевой кадр в обычный кадр, нажмите Insert > Clear Keyframe или выберите Clear Keyframe из контекстного выпадающего по правой кнопке мыши меню. (Прим.пер.: Юзеры MacOS уже, я думаю, догадались, что вместо правой кнопки мыши, которой у них нет, им надо нажать Control-клик :) Очищенный ключевой кадр и все кадры до следующего ключевого кадра заменятся содержимым предшествующего очищенному кадра.
Чтобы удлинить анимационную последовательность, "перетащите" начальный ключевой кадр влево или конечный кадр вправо. Чтобы изменить длину покадровой анимации, см. Создание покадровой анимации.
Чтобы добавить объект из библиотеки в текущий ключевой кадр, просто перетащите его из окна Library на сцену.
Чтобы "отзеркалить" анимацию во времени (начало сделать концом, и наоборот), выберите необходимые кадры в одном или более слоях, и нажмите Modify > Frames > Reverse. Естественно, в начале и в конце должны быть ключевые кадры.


Редактирование анимации

Создание анимации > Редактирование анимации > Применение эффекта "Onion skinning"

Применение эффекта "Onion skinning"

Как правило, Flash отображает на сцене содержимое одного кадра анимации в один момент времени. Чтобы лучше спозиционировать относительно друг друга объекты, разнесённые по времени или получить более полный контроль при создании покадровой анимации, вы можете вывести на сцену изображение сразу нескольких кадров. Текущий кадр показывается в полном цвете, а соседние приглушены, как сквозь полупрозрачную бумагу. Приглушенные кадры редактировать нельзя.

Чтобы одновременно видеть несколько кадров анимации на сцене:

Нажмите кнопку Onion Skin (полупрозрачные кадры). Все кадры между метками Start Onion Skin и End Onion Skin (они находятся в верхней части линейки) будут задействованы в показе.

Для контроля за полупрозрачными кадрами предусмотрено следующее:

Чтобы показать приглушенные кадры как силуэты, нажмите кнопку Onion Skin Outlines.
Чтобы сменить область захвата кадров для полупрозрачного показа, "перетащите" onion skin маркер в необходимый кадр.
Чтобы редактировать кадры вокруг текущего, используйте режим Edit Multiple Frames (Редактирование Множества Кадров). Режим onion skinning позволяет вам редактировать только текущий кадр.

Примечание: Закрытые (locked (с замочком)) слои не показываются в режиме полупрозрачных кадров. Чтобы не запутаться при многокадровом редактировании, закрывайте или отключайте не нужные в данный момент слои.

Чтобы настроить отображение полупрозрачных слоёв:

Нажмите кнопку Modify Onion Markers и выберите пункт из меню:

Always Show Markers всегда показывает маркеры на монтажной линейке, даже если режим не включен.
Anchor Onion Marks "замораживает" маркеры на монтажной линейке в текущих позициях. Обычно маркеры смещаются по линейке в соответствии с текущей позицией. "Замораживая" их, вы запрещаете им двигаться вместе с указателем текущей позиции.
Onion 2 показывает по два кадра слева и справа от текущего кадра.
Onion 5 показывает по пять кадров слева и справа от текущего кадра.
Onion All показывает все кадры слева и справа от текущего кадра.


Редактирование анимации

Создание анимации > Редактирование анимации > Перемещение всей анимации

Перемещение всей анимации

Если вам нужно переместить всю анимацию по сцене, необходимо взять много кадров на многих слоях за раз, чтобы ничего не пропустить.

Чтобы переместить всю анимацию по сцене:

1 | Разблокируйте все слои.
 | Если нужно переместить объекты выборочно, заблокируйте или выключите то, что должно остаться на месте.
2 | Включите режим редактирования множества кадров (кнопка Edit Multiple Frames в монтажной линейке).
3 | Растяните маркеры onion skin на все необходимые кадры, или нажмите кнопку Modify Onion Markers и выберите Onion All.
4 | Нажмите Edit > Select All.
5 | Перетащите всю анимацию в нужное место на сцене.


Создание ключевых кадров

Создание анимации > Создание ключевых кадров

Создание ключевых кадров

Ключевой кадр (keyframe) - это кадр, где вы определяете изменения в анимации. Когда вы пользуетесь покадровой анимацией, то каждый кадр является ключевым. В автоматической анимации вы задаете два ключевых кадра, а Flash создает кадры между ними. Flash закрашивает промежуточные кадры автоматической анимации синим или зеленым цветом со стрелкой, растянутой между ключевыми кадрами. Flash изменяет формы в каждом ключевом кадре. Вы должны вставлять ключевые кадры только в тех точках, где что-либо изменяется.

Обозначение ключевых кадров на монтажной линейке (timeline): ключевой кадр, содержащий объект, обозначается закрашенным кружочком, а пустой кадр отделяется вертикальной линией перед кадром. Кадры, которые Вы будете добавлять далее в тот же слой, будут иметь то же содержание, что и ключевой кадр перед ними.

Чтобы создать ключевой кадр, сделайте одно из нижеследующего:

Выделите кадр на монтажной линейке и нажмите Insert > Keyframe.
Щелкните правой кнопкой мыши (Windows) или с клавишей Control (Macintosh) на кадре в монтажной линейке и в появившемся меню выберите Insert Keyframe.


Представление анимации на монтажной линейке

Создание анимации > Представление анимации на монтажной линейке

Представление анимации на монтажной линейке

Flash показывает различные виды анимации на монтажной линейке следующим образом:

Автоматическая анимация движения (Motion-tweened): ключевые кадры показываются как чёрные точки, промежуточные кадры подсвечиваются синим и имеют стрелочку слева направо.
Автоматическая анимация формы (Shape-tweened): ключевые кадры показываются как чёрные точки, промежуточные кадры подсвечиваются зелёным и имеют стрелочку слева направо.
Пунктирная линия обозначает, что отсутствует конечный ключевой кадр.
Одиночный ключевой кадр показывается чёрной точкой. Светло-серые кадры после одиночного ключевого кадра имеют то же содержание без изменений и заканчиваются чёрной черточкой с маленьким квадратиком в последнем кадре.
Маленькая a показывает, что в в данном кадре прописаны определённые команды через панель Actions.
Красный флажок обозначает, что в кадре есть метка (label) или комментарий.


О слоях в анимации

Создание анимации > О слоях в анимации

О слоях в анимации

Каждая сцена во Flash-клипе может состоять из нескольких слоёв. В процессе создания анимации используйте разные слои для организации компонентов анимации и разделяйте объекты так, чтобы они не перекрывались, не соединялись и не обрезали друг друга. Если вы хотите анимировать движение разных символов в разные стороны, то вы должны разделить их каждый на отдельный слой. Как правило, на заднем (нижнем) слое нарисован статичный фон, а остальные слои содержат по одному анимированному объекту в каждом.

На монтажной линейке слои представлены как "строки".

Когда в сцене много слоёв, редактирование одного из них может быть затруднено. Задача упрощается, если вы работаете только с содержимым нужного вам слоя. См. Использование слоёв: общий обзор.


Про частоту кадров

Создание анимации > О частоте кадров

О частоте кадров

Слишком маленькая частота кадров (fps - frame-per-second) даёт слишком медленную анимацию, слишком большая - размазывает объекты из-за слишком быстрого движения. 12 кадров в секунду обычно наилучшая установка для Интернет. QuickTime и AVI ролики в Интернет обычно имеют именно такой fps, в то время как в кинофильмах используется значение 24 кадра в секунду. (Прим. пер. : Как правило, возросшая мощность компьютеров позволяет сейчас использовать во flash-клипах скорость 20-30 кадров в секунду. Лично я всегда смело выставляю 25 кадров в секунду, это даёт отличные результаты.)

С возрастанием сложности анимации плавность воспроизведения клипа уменьшается, так что тестируйте свои ролики на разных машинах, чтобы достичь оптимального значения.

Так как вы определяете значение fps для всего flash-клипа, рекомендуется выставлять это значение заранее, до создания анимации. См. Создание нового клипа и редактирование его установок.


Удлинение статичных картинок

Создание анимации > "Удлинение" статичных картинок

"Удлинение" статичных картинок

Когда вы создаёте фон для анимации, как правило, необходимо "растянуть" его на определённое количество кадров. Добавление новых кадров (не ключевых!) в слой "удлиняет" во времени картинку в ключевом кадре.

Чтобы "растянуть" изображение во времени на несколько кадров:

1 | Создайте изображение в первом ключевом кадре.
2 | Отметьте кадр справа от ключевого, в том месте, до которого изображение должно "удлиниться".
3 | Нажмите Insert > Frame.

Чтобы делать это быстро:

1 | Создайте изображение в первом ключевом кадре.
2 | С нажатой клавишей Alt перетащите мышкой ключевой кадр вправо (в том же слое). Flash создаст последовательность кадров без ключевого кадра в конце.


Об автоматической анимации

Создание анимации > Об автоматической анимации

Об автоматической анимации

Flash может создавать два типа анимации. При автоматической анимации движения (motion tweening) вы определяете размер, местоположение, угол наклона и т.д. для объекта, группы или текстового блока в какой-то момент времени, а потом изменяете эти значения в другой точке времени. При автоматической анимации формы (shape-tweening) вы рисуете фигуру в какой-то момент времени и изменяете её форму в другой момент. В обоих случаях Flash просчитывает значения в кадрах между ключевыми кадрами и создаёт анимацию.


Автоматическая анимация объектов, групп и текста

Создание анимации > Автоматическая анимация объектов, групп и текста

Автоматическая анимация объектов, групп и текста

Чтобы анимировать изменения в параметрах объектов, групп или текста, используйте анимацию движения. Flash может анимировать местоположение, размер, угол поворота и skew-искажение объектов. Также Flash может анимировать цвет объектов, создавая плавные переходы цвета и прозрачности. Для анимации цвета, объект должен быть конвертирован в элемент (symbol). См. Создание элементов.

Если вы изменяете число кадров (расстояние) между двумя ключевыми кадрами или изменяете что-либо в одном из них, Flash автоматически пересчитывает промежуточные кадры.

Можно создавать анимацию движения одним из двух способов:

Создайте начальный и конечный ключевые кадры анимации и в панели Frame Properties выберите опцию Motion Tweening.
Создайте первый ключевой кадр анимации, нажмите Insert > Create Motion Tween и переместите объект в новое место. Flash автоматически создаст второй ключевой кадр.

В процессе анимации местоположения объекта, можно заставить его двигаться не по линии от одной точке к другой, а по заданному пути. См. Перемещение объекта по пути.

Второй, третий и четвёртый кадры - результат автоматической анимации между первым и последним ключевыми кадрами.

Для создания автоматической анимации движения используется опция Motion Tweening:

1 | Щелкните на название слоя, чтобы сделать его текущим и выделите на монтажной линейке в этом слое кадр, с которого бы хотели начать анимацию.
2 | Создайте какой-нибудь объект на сцене или перетащите его на сцену из окошка библиотеки (Library).
 | Автоматическая анимация движения оперирует только объектами, являющимися элементами (symbols).
3 | Создайте второй ключевой кадр в том месте, где ваша анимация должна кончаться.
4 | Сделайте любые из действий над элементом в конечном (втором) ключевом кадре:
 | Переместите его по сцене.
 | Измените его размер, угол поворота или skew-деформации.
 | Измените его цвет (только образцы (instances) и текстовые блоки).
 | Для анимации цвета других элементов, используйте анимацию формы. См. Анимация форм (shape tweening).
5 | Выберите окно Window > Panels > Frame.
6 | В поле Tweening, выберите Motion.
7 | Если вы изменяли размер объекта (пункт 4), отметьте флажок Scale, чтобы анимировать изменение размера. (Прим.пер.: Этот флажок отмечен по умолчанию, не думаю, что у вас будет большая необходимость отключать его.)
8 | Встаньте на первый ключевой кадр, нажмите и потяните кнопку с треугольничком около надписи Easing или введите значение вручную в окошке, чтобы установить величину изменения между промежуточными кадрами:
 | Чтобы начать движение медленно и убыстрить его к концу анимации, потяните бегунок вверх или введите значение от -1 до -100.
 | Чтобы начать движение быстро и замедлить его к концу анимации, потяните бегунок вниз или введите значение от 1 до 100.
 | По умолчанию, степень изменения значений между промежуточными кадрами постоянна и функция Easing позволяет добиться чёткого контроля появления или исчезания объектов, создавая необходимый эффект. (Прим.пер.: поэкспериментируйте с функцией Easing, она очень полезна.)
9 | Чтобы контролировать поворот объекта в анимации, используются опции из списка Rotate:
 | Выбирайте None (стоит по умолчанию) чтобы объект не поворачивался. (Прим.пер.: на самом деле по умолчанию там стоит Auto, что логичнее.)
 | Выбирайте Auto, чтобы направление поворота объекта выбиралось автоматически. (Прим.пер.: подходит, если вы поворачиваете объект менее чем на 180 градусов.)
 | Выбирайте поворот по часовой стрелке (CW) или против часовой стрелки (CCW) чтобы поворачивать объект как вам необходимо, можете ввести количество поворотов вручную.

Примечание: Поворот, введённый вручную, прибавляется к повороту объекта, сделанному в сцене (Пункт 4).

10 | Если для движения объекта вы используете нарисованный вручную путь, то отметьте флажок Orient to Path. См. Перемещение объекта по пути.
11 | Отметьте флажок Synchronizе чтобы быть уверенным, что клипы, вставленные в главную сцену, будут правильно зацикливаться.
 | Используйте synchronize, если количество кадров во вложенной в мувик (movie clip) анимации не совпадает с его количеством кадров в сцене.
12 | Если вы используете движение по пути, отметьте флажок snap, чтобы присоединить объект к пути.

Для создания автоматической анимации движения используется команда Create Motion Tween:

1 | Встаньте на пустой ключевой кадр и нарисуйте на сцене объект или перетащите его из библиотеки (Library).
2 | Жмите Insert > Create Motion Tween. (Прим.пер.: или правой кнопкой на кадре.)
 | Если вы нарисовали новый объект, Flash автоматически сконвертирует его в символ (symbol) и назовёт его tween1. Если вы создаёте таким образом ещё объекты, они называются tween2, tween3 и так далее. (Прим.пер.: Не очень-то это удобно, верно? Проще вручную tween на кадры делать - см. выше.)
3 | Щелкните на кадре, в котором бы хотели закончить вашу анимацию, а потом нажмите Insert > Frame.
4 | Перемещайте объект, изменяйте его размер, поворачивайте объект, как вам надо. Когда все необходимые изменения будут внесены, снимите его выделение (щелкните в любое другое место рабочего поля).
 | Ключевой кадр добавлен автоматически.
5 | Выберите ключевой кадр в конце анимации и загляните в Window> Panels > Frame. Motion Tweening должен быть выставлен автоматически.
6 | Если вы изменяли размер объекта, проверьте чтобы флажок Scale был отмечен.
7 | Нажмите и потяните кнопку с треугольничком около надписи Easing или введите значение вручную в окошке, чтобы установить величину изменения между промежуточными кадрами:
 | Чтобы начать движение медленно и убыстрить его к концу анимации, потяните бегунок вверх или введите значение от -1 до -100.
 | Чтобы начать движение быстро и замедлить его к концу анимации, потяните бегунок вниз или введите значение от 1 до 100.
 | По умолчанию, степень изменения значений между промежуточными кадрами постоянна, и функция Easing позволяет добиться чёткого контроля появления или исчезания объектов, создавая необходимый эффект. (Прим.пер.: поэкспериментируйте с функцией Easing, она очень полезна.)
8 | Для контроля поворота объекта в анимации, используются опции из списка Rotate:
 | Выбирайте None (стоит по умолчанию) чтобы объект не поворачивался. (Прим.пер.: на самом деле по умолчанию там стоит Auto, что логичнее.)
 | Выбирайте Auto, чтобы направление поворота объекта выбиралось автоматически. (Прим.пер.: подходит, если вы поворачиваете объект менее чем на 180 градусов.)
 | Выбирайте поворот по часовой стрелке (CW) или против часовой стрелки (CCW) чтобы поворачивать объект как вам необходимо, можете ввести количество поворотов вручную.

Note: Поворот, введённый вручную, прибавляется к повороту объекта, сделанному в сцене (Пункт 4).

9 | Если для движения объекта вы используете нарисованный вручную путь, то отметьте флажок Orient to Path. См. Перемещение объекта по пути.
10 | Отметьте флажок Synchronizе чтобы быть уверенным, что клипы, вставленные в главную сцену, будут правильно зацикливаться.
 | Используйте synchronize, если количество кадров во вложенной в мувик (movie clip) анимации не совпадает с его количеством кадров в сцене.
11 | Если вы используете движение по пути, отметьте флажок snap, чтобы присоединить объект к пути.


Перемещение объекта по пути

Создание анимации > Перемещение объекта по пути

Перемещение объекта по пути

Слои типа Guide (направляющие) позволяют рисовать пути, по которым могут двигаться объекты в процессе анимации. Можете подключить несколько слоёв к слою guide, чтобы несколько объектов двигались по одному и тому же пути. Обычный слой, подключённый к направляющему (guide) слою, становится ведомым (guided) слоем.

В этом примере два объекта на разных слоях двигаются по одному пути.

Чтобы создать путь для движения:

1 | Создайте автоматическую анимацию движения в соответствии с разделом Автоматическая анимация объектов, групп и текста.
 | Если Вы отметите флажок Orient to Path, ось объекта будет сориентирована по нарисованному пути (т.е. объект будет поворачиваться, перемещаясь по пути). Если Вы отметите флажок Snap, центр объекта "прицепится" к пути.
2 | Сделайте одно из нижеследующего:
 | Выделите слой, содержащий нужный объект и нажмите Insert > Motion Guide.
 | Щелкните правой кнопкой мыши (Windows) или Control-клик (Macintosh) слой, содержащий объект, и выберите Add Motion Guide из контекстного меню.
 | Flash создаст направляющий слой над выбранным слоем с "motion guide"-значком слева от названия слоя.
3 | Используя инструменты, нарисуйте в этом слое необходимый вам путь.
4 | "Прицепите" объект к началу пути в первом кадре анимации и к концу пути в конце анимации.
 | Примечание: Для получения наилучшего результата "цепляйте" объект за центр.
5 | Чтобы "спрятать" направляющий слой и путь, нарисованный в нём, щелкните кнопку с глазом в этом слое.
 | Объект при воспроизведении анимации двигается по пути.

Для присоединения других слоев к направляющему (guide) слою, сделайте одно из следующих действий:

Перетащите нужный слой под только что созданный направляющий слой. Слой станет ведомым (guided) и все объекты этого слоя будут "прицеплены" к пути в направляющем слое.
Создайте новый слой под направляющим. Объекты, создаваемые в нём, автоматически будут анимированы в соответствии с путём на направляющем слое.
Выделите слой под направляющим слоем и нажмите Modify > Layer. В появившемся окне отметьте флажок Guided.
Щелкните слой с клавишей Alt (Windows) или с клавишей Option (Macintosh).

Чтобы "отсоединить" слои от направляющего (guide) слоя:

1 | Выделите слой, который хотите отключить.
2 | Сделайте одно из нижеперечисленного:
 | Перетащите слой "выше" направляющего слоя.
 | Нажмите Modify > Layer и в появившемся окне выберите тип слоя Normal, отметив соответствующий флажок.
 | Щелкните слой с клавишей Alt (Windows) или с клавишей Option (Macintosh).


Creating interactive movies overview

Создание интерактивных клипов > Обзор

Создание интерактивных клипов. Обзор

В простейшей анимации Flash последовательно проигрывает сцены и кадры клипа. В интерактивной анимации можно воспользоваться клавиатурой, мышкой для перемещения по различным частям клипа, для ввода информации в формах и просто для выполнения каких-нибудь действий.

Интерактивность создается при помощи команд (скриптов), написанных на языке ActionScript, которые выполняются после совершения определенных событий.

Прописываются они в панели команд (Actions panel), этих скриптов существуют три типа: для кнопок, для экземпляров муви-клипа и для кадров. В панели команд есть два режима: нормальный (Normal Mode), где вы используете только предопределенные во FLASH скрипты, и продвинутый (Expert Mode), в котором вы можете определять и писать свои собственные команды. Команды могут быть одиночными, такие как остановка воспроизведения клипа, либо состоять из последовательности команд, например, выполнение определенного действия при заданном условии. Написание многих команд требуют некоторого опыта в программировании, для дополнительной информации о таких акциях см. ActionScript Help.


Using basic actions for navigation and interaction

Создание интерактивных клипов > Основные команды для навигации и интерактивности > Переход на кадр или сцену

Переход на кадр или сцену

Для перехода на определенный кадр или сцену используйте команду Go To. При этом клип может начать воспроизведение с этого кадра (по умолчанию), либо остановиться на нем. Клип также может перейти на другую сцену и играть с заданного кадра, или с первого в следующей или предыдущей сцене.

Как это сделать:

1 | Выделите кадр, кнопку или мувик - то, чему вы будете присваивать команды.
2 | Вызовите панель команд Window > Actions.
3 | В Basic Actions выделите команду Go To.
Flash вставит ее в окно команд.
4 | Чтобы после перехода на кадр клип продолжал играть, выберите Go To and Play параметр (по умолчанию). Для остановки снимите флажок с Go To and Play. Команда станет командой Go To and Stop.
5 | В поле параметров выберите нужную сцену: Current или Named Scene (текущая) определяет кадры в данной линейке, Next или Previous - Flash переходит на первый кадр следующей или предыдущей сцены соответственно.
6 | Там же выберите необходимый кадр:
Next (следующий) или Previous (предыдущий).
Frame Number (номер кадра), Frame Label (метка кадра), или выражение, определяющее кадр. Выражением называются любые операторы, результат вычисления которых имеет значение, например 1+1. 1
7 | Если вы выбрали Frame Number, Frame Label, или Expression на шаге 6, введите этот номер, метку и т.д.
В следующем примере команда останавливает клип в кадре, отстоящем впереди текущего в пяти кадрах:
gotoAndStop(_currentframe + 5);
О том, как писать выражения, см. ActionScript Help.

От редактора:

  1. Не обязательно число, может быть и строка, если необходимо оcуществить переход на метку (label). Например на кадр, замаркированный как "Obana_7":

    i=7;
labelName="Obana_"+i;
gotoAndStop (labelName);


Using basic actions for navigation and interaction

Создание интерактивных клипов > Основные команды для навигации и интерактивности > Воспроизведение и остановка клипов

Воспроизведение и остановка клипов

Когда клип стартует, он начинает воспроизводить каждый кадр в линейке. Вы можете его остановить и запустить в любом месте, используя команды Play и Stop. Например, вы вольны остановить клип в конце сцены, чтобы он не перешел на следующую. Когда клип остановлен, его воспроизведение может быть возобновлено командой Play.

Команды Play и Stop используются чаще всего для управления мувиками с помощью кнопок или управления главной линейкой. Мувик, поведением которого вы хотите управлять, должен иметь имя на сцене. См. Управление другими клипами.

Запуск или остановка клипа:

1 | Выделите на сцене кнопку, мувик или кадр.
2 | Вызовите панель команд Window > Actions.
3 | В Basic Actions выберите команду Stop.
Если скрипт назначается мувику, вы увидите что-то подобное:
onClipEvent (load) {
    stop ();
}
Эта конструкция означает, что когда мувик будет загружен, он остановится.

Примечание: Если круглые скобки оставить пустыми, то будет показано сообщение, что данная команда не имеет параметров.

Запуск клипа:

1 | Точно так же выделите клип или кнопку.
2 | Вызовите панель команд Window > Actions.
3 | В Basic Actions выберите команду Play.
Будет что-то подобное:
on (release) {
    play ();
}
Конструкция означает, что когда вы щелкните по кнопке в клипе, Flash выполнит команду play, запускающую воспроизведение клипа.


Using basic actions for navigation and interaction

Создание интерактивных клипов > Основные команды для навигации и интерактивности > Установка качества отображения клипа

Установка качества отображения клипа

Сглаживание картинок требует быстрого процессора, т.к. Flash сглаживает каждый кадр перед выводом его содержимого на экран. Вы можете запретить этот процесс выключив сглаживание (anti-aliasing). Чтобы включать/выключать этот режим, используйте команду Toggle High Quality. Команда эта распространяется на все мувики в плеере.

Команда Toggle High Quality, назначенная кнопке, позволяет пользователям управлять качеством клипа. Команда просто переключает клип между двумя состояниями, т.е. нажав кнопку, вы отключите сглаживание, нажав еще раз, включите.

Для доп. информации об установках скорости клипа см. параметр QUALITY в Редактирование Flash установок в HTML.

Для настройки скорости или качества:

1 | Выделите на сцене кнопку, мувик или кадр.
Выбрав мувик, вы управляете его скоростью, кнопку - качеством отображения.
2 | Вызовите панель команд Window > Actions.
3 | В Basic Actions выберите команду Stop Toggle High Quality.
Появится команда:
toggleHighQuality ();


Using basic actions for navigation and interaction

Создание интерактивных клипов > Основные команды для навигации и интерактивности > Остановка всех звуков

Остановка всех звуков

Для остановки звука в линейке без остановки воспроизведения самого клипа, используйте команду Stop All Sounds. (Команда не просто уменьшает громкость.) Команда Stop All Sounds распространяется на все мувики в плеере. Воспроизведение потоковых звуков будет продолжено по мере дальнейшего воспроизведения клипа, прикрепленных звуков нет.

Для доп. информации см. Запуск и остановка звука в ключевом кадре.

Остановка всех звуков:

1 | Выделите на сцене кнопку, мувик или кадр.
2 | Вызовите панель команд Window > Actions.
3 | В Basic Actions выберите команду Stop All Sounds.
Появится команда:
stopAllSounds ();


Using basic actions for navigation and interaction

Создание интерактивных клипов > Основные команды для навигации и интерактивности > Переход на различные URL

Переход на различные URL

Для загрузки документа с определенного адреса в окно браузера, либо для посылки переменных другому приложению, используйте команду Get URL. Например, вы можете посылать данные CGI скрипту для обработки, точно так же, как это делается в HTML формах. Отправятся переменные только текущего мувика.

В простейшем случае, вы используете эту команду для загрузки в браузер Web странички, при этом во Flash projector окно браузера откроется автоматически.

Об отправке переменных см. ActionScript Help.

Для перехода по URL:

1 | Выделите на сцене кнопку, мувик или кадр.
2 | Вызовите панель команд Window > Actions.
3 | В Basic Actions выберите команду Get URL.
4 | В панели параметров введите URL, руководствуясь следующим:
Используйте относительную адресацию, например mypage.html, либо абсолютную, например http://www.mydomain.com/mypage.html.
Относительные пути позволяют Flash перемещаться по дереву каталогов вверх/вниз, начиная с текущего. Абсолютный адрес требует имя сервера, полный путь к документу и его имя.
Для задания URL, название которого основано на каком-то значении, воспользуйтесь режимом Expression и введите выражения, вычисляющее адрес.
Например, URL есть значение переменной dynamicURL:
getURL(dynamicURL);
Для доп. информации см. ActionScript Help.
5 | Чтобы задать в каком окне будет грузиться документ, сделайте следующее:
Выберите одно из зарезервированных слов:
_self определяет, что документ будет загружаться в текущее окно браузера.
_blank определяет, что документ будет загружаться в новое окно браузера.
_parent определяет, что документ будет загружаться в родительское, по отношению к текущему фрейму окно.
_top загружает во фрейм верхнего уровня текущего окна.
Введите имя фрейма или окна.
Выберите Expression и введите выражение, вычисляющее расположение окна.
6 | Для переменных выберите метод отсылки:
Выберите Send Using Get для отправки небольшого числа переменных, например, для обработки серверным скриптом.
Выберите Send Using Post для отправки переменных в отдельном заголовке HTTP; используется для передачи длинных строк или больших по объему данных.
Выберите Don't Send, если переменные отсылать не нужно
См. ActionScript Help.
У вас получится что-то подобное:
getUrl ("page2.html", "blank");
Документ "page2.html" загрузится в новое окно браузера.


Using basic actions for navigation and interaction

Создание интерактивных клипов > Основные команды для навигации и интерактивности > Управление Flash-плеером

Управление Flash-плеером

Используйте команду FSCommand для управления Flash-плеером.

Вы также можете посылать сообщения приложениям, содержащим Flash Player — например, JavaScript в Web браузере, Director, Visual Basic, Visual C++ и другие программы, содержащие ActiveX. Для дополнительной информации см. ActionScript Help.

Выполните следующие шаги:

1 | Выделите на сцене кнопку, мувик или кадр.
2 | Вызовите панель команд Window > Actions.
3 | В Basic Actions выберите команду FSCommand.
4 | В поле параметров в окошке для stand-alone player выберите из списка:
 | Quit, чтобы закрыть прожектор.
 | Exec, чтобы запустить выполнение приложения из прожектора. В строке Arguments введите путь к приложению.
 | Fullscreen [True/False] - окно на весь экран или нет.
 | Allowscale [True/False] - можно или нельзя изменить размер окна.
 | Showmenu [True/False] - показывать или нет меню.
 | В строках Commands и Arguments также введите параметры. Для дополнительной информации см. ActionScript Help.


Using basic actions for navigation and interaction

Создание интерактивных клипов > Основные команды для навигации и интерактивности > Загрузка и выгрузка дополнительных клипов

Загрузка и выгрузка дополнительных клипов

Для воспроизведения дополнительных клипов без закрытия Flash Player, либо для переключения между клипами без загрузки нового HTML документа, используйте команду Load Movie.

Команда Unload Movie удаляет клипы, загруженные ранее командой Load Movie.

Простейшие примеры:

Воспроизведение последовательности баннеров, путем добавления в конце каждого клипа команды Load Movie, загружающего следующий.
Разработка "ветвящегося" интерфейса, позволяющего пользователю переключаться между разными SWF файлами.
Разработка навигации, когда в level0 находятся кнопки, загружающие в него другие, загрузка при этом происходит более плавно, чем в HTML страницах.

Как загрузить клип:

1 | Выделите на сцене кнопку, мувик или кадр.
2 | Вызовите панель команд Window > Actions.
3 | В Basic Actions выберите команду Load Movie.
4 | В панели параметров задайте путь к SWF файлу.
При воспроизведении клипа во Flash Player или при тестировании, все SWF файлы должны лежать в той же директории, что и сам клип и путь к ним должен прописываться без имен дисков и папок.
5 | В поле Location выберите Level (уровень) или Target (мувик на сцене) из выпадающего меню.
6 | Если вы выбрали уровень, введите его номер, руководствуясь следующим:
Чтобы новый клип подгружался в дополнению к уже существующему, введите номер, отличный от номера уровня существующего клипа, чтобы новый не заместил старый. Для дополнительной информации см. ActionScript Help.)
Чтобы заменить существующий, введите тот же номер уровня.
Чтобы заместить исходный клип и выгрузить все остальные уровни, загружайте клип в уровень 0.
Клип, загруженный первым, грузится в самый нижний уровень. Клип на уровне 0 задает частоту кадров, цвет фона, размер окна для всех остальных подгружаемых клипов.
Для дополнит. информации см. ActionScript Help.
7 | Если вы выбрали Target, назначьте мувик, который будет замещен подгружаемым.
Подгруженный мувик наследует позицию в кадре, поворот и масштаб клипа, которого заместил. Верхний левый угол подгруженного мувика будет совпадать с центром замещенного (точнее, с тем местом, где находится маленький крестик, определяющий координаты мувика в режиме редактирования).
8 | В поле Variable выберите, если это необходимо, метод, с помощью которого к подгружаемому клипу будут отсылаться переменные:
Выберите Send Using Get для отправки небольшого числа переменных, например, для обработки серверным скриптом.
Выберите Send Using Post для отправки переменных в отдельном заголовке HTTP. Например, вы можете послать переменные CGI скрипту, который сгенерирует SWF файл.
Выберите Don't Send, если переменные отсылать не нужно.
См. ActionScript Help.
В следующем примере щелчок по кнопке загружает клип в уровень 0, посылая при этом переменные, используя Get метод:
loadMovie ("someFile.cgi", 0, "GET");
Где "someFile.cgi" сгенерирует SWF файл.

Для выгрузки клипа:

1 | Выделите на сцене кнопку, мувик или кадр.
2 | Вызовите панель команд Window > Actions.
3 | В Basic Actions выберите команду Unload Movie.
4 | В поле Location выберите:
Для клипа загруженного на уровень, выберите Level и введите его номер.
Для выгружаемого мувика выберите Target и введите путь к нему. Например:
unloadMovie ("m3");
будет выгружен мувик с именем "m3".

Тестирование команд Load Movie и Unload Movie:

1 | Когда вы будете проверять работу клипа, убедитесь, что все подгружаемые клипы на месте.
2 | Выберите Control > Test Movie.


Using basic actions for navigation and interaction

Создание интерактивных клипов > Основные команды для навигации и интерактивности > Управление другими клипами

Управление другими клипами

Вы можете управлять клипом или мувиком, подгруженным командой Load Movie, указав на него.

Вы назначаете команды кнопкам, кадрам или мувикам, а затем указываете на нужный клип (target movie clip), который будет получать и исполнять команды. Для этого нужно использовать команду Tell Target. В другом случае, если необходимо выполнить несколько команд объектам, находящимся по одному и тому же пути, воспользуйтесь командой With для временного изменения контекстного пути, при этом к этим объектам можно будет обращаться напрямую.

Чтобы управлять мувиками, необходимо следующее:

Цель (target) должна быть определена. Вы можете воспользоваться диалоговым окном Insert Target Path для выбора нужного мувика.
Мувик при этом должен иметь имя (instance name). Для этого воспользуйтесь панелью Instance (Window > Panels > Instance).
В момент обращения к мувику он должен быть на сцене. Например, если клип A в кадре 5 обращается к клипу B, клип В должен уже находиться в пятом кадре.

Для дополнительной информации см. ActionScript Help.

Как управлять клипом:

1 | Выделите на сцене кнопку, мувик или кадр.
2 | Вызовите панель команд Window > Actions.
3 | В Basic Actions выберите команду Tell Target.
4 В правом нижнем углу щелкните значок прицела - кнопку Insert Target.
Появится диалоговое окно Insert Target Path, показывающее иерархию мувиков в текущем клипе. Используйте это окно для выбора мувика, к которому хотите обратиться.
5 | В поле Notation выберите тип записи (по умолчанию Dots - точки, как в JavaScript). Slash - обращение через косую черту, как в старых версиях Flash 4 и HTML.
6 | В поле Mode выберите, как будет отображаться иерархия клипов:
Relative (Относительный, по умолчанию) отображает только те мувики, которые находятся в текущем кадре текущей линейки и вложенные. Префикс this указывает на текущую линейку.
Absolute (Абсолютный) режим показывает все клипы. В этом режиме используются префикс _root (или _level) для указания уровня, на котором находится клип.
Примечание: Поскольку в режиме Absolute видны все клипы с запутанными связями, некоторые команды могут не выполняться или выполняться некорректно.
7 | Выберите нужный клип. В окне вы увидите путь к нему. Нажмите OK.
8 | Затем выберите команды, которые должен выполнять мувик.
Например:
tellTarget (_root.plane){
    stop();
}


Using basic actions for navigation and interaction

Создание интерактивных клипов > Основные команды для навигации и интерактивности > Проверка загрузки кадра

Проверка загрузки кадра

Чтобы ваш клип сначала полностью загрузился и лишь потом запустился, делают прелоадеры, для этого используйте команду If Frame Is Loaded. Прелоадер обычно содержит какую-нибудь простенькую анимацию, которая воспроизводится, пока грузится основной клип. Команда If Frame Is Loaded проверяет, загружен или нет кадр, содержащий большой объем информации (битмап, звук и т.д.). Вы можете также использовать _framesloaded (вместе с командой If) для проверки того, доступно ли локально содержимое определенных кадров.

Назначив одну из этих команд, вы тут же начинаете проигрывать вашу простую анимацию.

Обычно команда If Frame Is Loaded используется в кадрах, но может быть назначена и кнопке. Для проверки команды If Frame Is Loaded используйте опцию Streaming в команде Test Movie. В этом случае загрузка будет эмулировать загрузку с Web сайта. Для дополнительной информации см. Testing movie download performance.

Для проверки загрузки кадра:

1 | Выделите на сцене кнопку, мувик или кадр.
2 | Вызовите панель команд Window > Actions.
3 | В Basic Actions выберите команду If Frame Is Loaded.
4 | В панели параметров, в Scene, выберите сцену, содержащую нужный фрейм - текущая или имя сцены.
5 | В Type, выберите номер кадра, метку или выражение.
6 | В Frame выберите предложенный номер или метку, в зависимости от того, что вы выбрали в предыдущем шаге.
7 | Затем введите команду, которая выполнится, если нужный кадр загружен.
Например:
ifFrameLoaded (100) {
        gotoAndPlay (10);
}

Если вы хотите, чтобы во время загрузки проигрывалась какая-то анимация, сделайте следующее:

1 | Создайте небольшую зацикленную анимацию, например, мигающую надпись "Идет загрузка..."
2 | Пропишите команду, которая останавливает эту анимацию, когда кадр будет загружен.
Например, 30-кадровый клип в первых двух кадрах содержит прелоадер, а в 3-м начинается основной клип, кадр 1 выглядит так:
ifFrameLoaded (30) {
        gotoAndPlay (3);
Кадр 2 просто зацикливается на кадр 1:
gotoAndPlay (1);
Когда 30-й кадр будет загружен, клип перейдет на 3-й кадр.

Как использовать команду _framesloaded:

1 | Создайте небольшую зацикленную анимацию в начале клипа.
2 | Присвойте кадру команду, которая выходит из этой анимации, когда вся сцена загрузится.
Например, в кадре 2 клипа, содержащего двухкадровую начальную анимацию, должно быть следующее:
if(_framesloaded==100) {
    gotoAndPlay (3);
} else {
    gotoAndPlay (1);
}

Для дополнительной информации см. ActionScript Help.


About ActionScript

Создание интерактивных клипов > Язык ActionScript

Язык ActionScript

Flash использует язык ActionScript для добавления интерактивности в ваш клип. Подобно языку JavaScript, язык ActionScript объектно-ориентированный. В таком языке информация организуется в группы, которые называются классами. В своих скриптах вы вольны создавать множество экземпляров класса, называемых объектами. Вы также можете использовать предопределенные классы, либо создавать свои собственные.

Когда вы создаете класс, вы должны описать все свойства (properties) и поведение (методы, или methods) каждого объекта; например, класс, характеризующий свойства человека, названный, допустим, "person", должен содержать переменные для возраста, роста, цвета волос и т.д. и методы, такие как разговор, передвижение и т.п. В этом случае "person" есть класс, а каждый индивидуальный человек становится объектом этого класса.

Объекты должны содержать данные, либо графику.

Для дополнительной информации см. ActionScript Help.


Using the Actions panel

Создание интерактивных клипов > Использование панели команд

Использование панели команд

Панель команд позволяет создавать и редактировать скрипты объектов или кадров, предоставляя при этом работу в двух различных режимах. Вы можете выделять команды на панели справа, перетаскивать их, использовать кнопки для их перестановки. В обычном режиме (Normal Mode) используются специальные поля для ввода параметров команд, в продвинутом (Expert Mode) скрипты можно писать напрямую, как в обычном текстовом редакторе.

Чтобы узнать о том, как изменять настройки панели и как переключаться между режимами, см. ActionScript Help.

Отображение панели команд:

Зайдите в Window > Actions.

При выделении кадра, кнопки или экземпляра муви-клипа панель становится активной, при этом ее заголовок изменяется на "Object Actions" либо на "Frame Actions", в зависимости от того, объекту или кадру вы присваиваете команды.

Выбор режима редактирования:

1 | Вызовите меню, нажав на стрелку в правом верхнем углу панели.
2 | Выберите Normal Mode либо Expert Mode.
 | Каждый скрипт "запоминает" свой режим. Например, если экземпляру кнопки вы присвоили команды в одном режиме, а еще одному экземпляру в другом, переключение между ними вызовет переключение режимов в панели команд.


Using the Actions panel

Создание интерактивных клипов > Использование панели команд > Использование панели команд в обычном режиме

Использование панели команд в обычном режиме

В обычном режиме вы пишете программу, выбирая команды из списка (Toolbox list) с левой стороны панели. Список этот содержит все основные скрипты, операторы, функции и свойства. Категория Basic Actions включает в себя самые простые Flash скрипты, доступные только в этом режиме. Выбранные команды располагаются в окошке справа (Actions list), в нем вы можете добавлять, удалять, менять порядок команд, а также в специальных окошках внизу панели задавать командам аргументы.

Выбор команды:

1 | Зайдите в раздел Actions в списке команд слева.
2 | Дважды щелкните на нужной вам команде, либо просто перетащите ее в окошко команд.

Задание параметров:

1 | Щелкните по треугольнику в правом нижнем углу панели, появится секция параметров (Parameters pane).
2 | Выделите команду и в окошках для ввода параметров задайте нужные значения.

Задание пути к экземпляру клипа:

1 | Щелкните по кнопке Target Path в правом нижнем углу панели (значок прицела) для вызова диалогового окна Target Path.
2 | Выделите необходимый вам мувик.
 | Для доп. информации см. Управление другими клипами.

Изменение порядка следования команд:

1 | Выделите команду.
2 | Щелкайте по стрелочкам в правом верхнем углу панели для перемещения этой команды вверх либо вниз.

Удаление команды:

1 | Выделите команду.
2 | Нажмите кнопку Delete (-).

Изменение размеров списка команд и окна команд:

Потаскайте вертикальный разделитель между этими окнами.
Двойной щелчок по разделителю сворачивает/восстанавливает окно списка команд.
То же самое происходит, если вы щелкаете по стрелочке разделителя.

Когда список команд скрыт, скрипты можно выбирать, используя кнопку Add (+) в левом верхнем углу панели.


Using the Actions panel

Создание интерактивных клипов > Использование панели команд > Использование панели команд в продвинутом режиме

Использование панели команд в продвинутом режиме

В продвинутом режиме вы можете непосредственно писать скрипты в окне команд, либо, как и в обычном режиме, воспользоваться списком команд в окне слева. Редактирование команд, задание параметров, удаление, перемещение происходит напрямую, как в текстовом редакторе.

Expert Mode позволяет пользователям, хорошо знакомым с языком ActionScript, работать в редакторе точно так же, как и с языками, например, JavaScript или VBScript. Есть несколько отличий от нормального режима:

Выбранная из списка или меню команда в редакторе появляется в указанной позиции, т.е. на том месте, где находится курсор.
Отсутствуют окошки для ввода параметров.
Работает только кнопка Добавить (Add (+)).
Кнопки перемещения команд вверх/вниз неактивны.

Для доп. информации см. ActionScript Help.


Assigning actions to objects

Создание интерактивных клипов > Назначение команд объектам

Назначение команд объектам

Вы можете назначить команду кнопке или мувику и сделать так, чтобы они выполнялись, допустим, при нажатии на кнопку, при прохождении мышки над мувиком или когда клип загрузится либо достигнет определенного кадра. Вы присваиваете команды только экземплярам кнопок или мувиков, с графическим символом такого сделать нельзя. Описание команд, которые вы можете назначать объектам, см. Основные команды для навигации и интерактивности.

Когда вы присваиваете объекту команду, Flash автоматически назначает ему специальный скрипт, называемый обработчиком (handler) — On Mouse Event для кнопок и On Clip Event для мувиков. Обработчик событий занимается обработкой событий :) мышки и мувика, и когда случается определенное событие - запускает ваш код. Название любого обработчика начинается со слова on или onClipEvent, в зависимости от типов обрабатываемых событий.

События - это, по сути, те же команды для обработчиков, происходящие во время воспроизведения клипа — например, мувик загрузился - событие, юзер нажал кнопку на клавиатуре - событие, клип достиг определенного кадра - все это события. Вы можете для каждого действия мышью и для каждой клавиши на клавиатуре назначить по собственному обработчику, см. Обработка событий мыши. Также см. ActionScript Help.

Следующие инструкции показывают, как назначить команды объектам в обычном режиме. Для доп. информации см. ActionScript Help.

Назначение команды кнопке или мувику:

1 | Выделите на сцене экземпляр кнопки или мувика и вызовите панель команд (Window > Actions).
 | Если выделен не мувик и не кнопка (а также не кадр), или группа объектов, ничего не выйдет, панель команд будет неактивна.
 | (Про кадры см. Назначение команд кадрам.)
2 | В списке команд зайдите в раздел Basic Actions.
 | Описание команд, которые вы можете назначать объектам, см. Основные команды для навигации и интерактивности.
3 | Для назначения команды выполните одно из следующего:
 | Дважды щелкните на нужной команде.
 | Перетащите нужную команду.
 | Нажмите кнопку Add (+) и выберите команду из выпадающего меню.
 | Используйте клавиатурные комбинации.
 | Flash при этом автоматически запишет в окне код обработчика.
4 | Параметры обработчика меняются через панель параметров, так же, как и для любой команды.
 | Для обработчика событий клипа по умолчанию стоит обработка is Load, для мыши Release. См. Основные команды для навигации и интерактивности.
5 | Если необходимо, повторите шаги 3 и 4 для назначения дополнительных команд.


Assigning actions to objects

Создание интерактивных клипов > Назначение команд объектам > Обработка событий мыши

Обработка событий мыши

При обработке действий над кнопкой на каждое действие автоматически назначается обработчик событий мыши и клавиатуры.

Каждый обработчик начинается со слова on, дальше следует название обрабатываемого события.

Например:

on (release)
on (keyPress "<Space>")
on (rollOver)

Параметр release означает, что пользователь нажал и отпустил кнопку мыши.

Дальше вы определяете, что должно произойти после этого действия.

Назначение обработки события кнопке:

1 | Выделите на сцене экземпляр вашей кнопки.
2 | В списке команд зайдите в Basic Actions.
3 | Сделайте одно из предлагаемого:
 | Выберите команду On Mouse Event.
 | Выберите команду в Basic Actions.
4 | В окошке параметров в поле Event выберите нужное вам событие:
 | Press означает, что кнопка мыши нажата и курсор находится над кнопкой.
 | Release (по умолчанию) означает, что пользователь нажал и отпустил кнопку мыши. Это событие является не чем иным, как стандартным щелчком по кнопке.
 | Release Outside означает, что кнопка мыши нажата в тот момент, когда курсор находился над вашей кнопкой, потом его отодвинули за ее пределы и отпустили кнопку мыши.
 | Key Press означает, что нажата определенная клавиша на клавиатуре. Если вы выбрали эту опцию, нажмите на клавиатуре нужную вам кнопку; ее код должен появиться рядом в окошечке ввода.
 | Roll Over означает, что курсор мыши зашел на область кнопки.
 | Roll Out означает, что курсор мыши вышел за область кнопки.
 | Drag Over означает, что, находясь в области кнопки, вы нажали и удерживаете кнопку мыши, затем вышли из области и вернулись назад.
 | Drag Out означает, что, находясь в области кнопки, вы нажали и, удерживая кнопку мыши, вышли из области.
5 | Назначение нужных вам команды.

Для доп. информации см. ActionScript Help.

Тестирование работы обработчика:

1 | Зайдите в Control > Enable Simple Frame Actions.
2 | Зайдите в Control > Test Movie.


Assigning actions to frames

Создание интерактивных клипов > Назначение команд кадрам

Назначение команд кадрам

Для того, чтобы по достижению определенного кадра ваш клип выполнял какие-то действия, вы должны сделать этот кадр ключевым и прописать в нем соответствующие команды. Например, если вы хотите чтобы в клипе 20-й кадр зацикливался на 10-й, в 20-м кадре вы должны определить команду "go to Frame 10 and play."

Хорошим тоном считается размещение всех скриптов в отдельном слое.

После написания каждой команды не лишне протестировать ваш клип.

Для доп. информации см. Основные команды для навигации и интерактивности.

Следующие инструкции показывают, как назначить команды объектам в обычном режиме. Для доп. информации см. ActionScript Help.

Запись скрипта в ключевом кадре:

1 | Выделите ключевой кадр и зайдите в панель команд Window > Actions.
 | Если выделенный кадр не ключевой, в окошке команд вы увидите скрипт последнего ключевого кадра. Если вы не выделили кадр, или выделили несколько, панель будет неактивной.
 | (О назначении команд кнопкам и мувикам см. Назначение команд объектам.)
2 | В списке команд зайдите в Basic Actions.
3 | Сделайте что-нибудь из этого:
 | Дважды щелкните на нужной команде.
 | Перетащите команду в окошко редактирования.
 | Воспользуйтесь кнопкой Add (+) для вызова всплывающего меню.
 | Используйте клавиатурные комбинации.
4 | В поле параметров введите нужные вам аргументы.
 | Для каждой команды параметры различны.
5 | Если это необходимо, повторите шаги 3 и 4.

Протестируйте клип:

Control > Test Movie.


Using basic actions for navigation and interaction

Создание интерактивных клипов > Основные команды для навигации и интерактивности

Основные команды для навигации и интерактивности

Самые основные команды позволяют создать навигацию и предоставить пользователю интерактивность в вашем клипе. Эти команды включают в себя:

Go To перепрыгивает на определенный кадр в сцене.
Play и Stop запускает или останавливает воспроизведение.
Toggle High Quality регулирует качество отображения клипа.
Stop All Sounds прекращает воспроизведение всех звуков.
Get URL переходит на заданный URL адрес.
FSCommand управляет Flash плеером, который воспроизводит клип.
Load Movie и Unload Movie загружает и выгружает дополнительные клипы.
Tell Target управляет другими мувиками или клипами.
If Frame Is Loaded проверяет, загружен ли определенный кадр клипа.
On Mouse Event обрабатывает сообщения мыши и клавиатуры.

Для дополнительной информации по ActionScript см. ActionScript Help.


Creating printable movies overview

Создание клипов для печати > Создание клипов для печати. Обзор

Создание клипов для печати. Обзор

Создавая Flash-клип, можно задать в нем определенные кадры, которые пользователи могут распечатать из Flash Player'а. Вы можете использовать возможности Flash Player'а для печати каталогов, талонов, информационных ведомостей, платежей, счетов и других документов в ваших Flash-клипах.

Flash Player распечатывает содержимое Flash-клипа в виде векторной графики с высоким разрешением, возможным у принтеров и других устройств вывода. При масштабировании векторной графики во время печати, отсутствуют пикселы, которые бывают при печати растровых изображений с низким разрешением.

Печать клипа из Flash Player'а вместо печати из броузера имеет несколько преимуществ. Вы можете делать следующее:

Определять, какие кадры клипа могут быть распечатаны. Это позволяет разделить материал на печатаемый и нет.
Определять область печати кадров.
Определять, когда печатать кадры как вектор (для использования преимущества более высоких разрешений), а когда как растр (для сохранения прозрачности и цветовых эффектов).
Назначать команду Print для печати кадров из мувклипов, даже если они невидимы. Это позволяет не занимать пространство в окне браузера для отображение печатаемого материала.


Printing from the Flash Player context menu

Создание клипов для печати > Печать из контекстного меню Flash Player'а

Печать из контекстного меню Flash Player'а

Можно использовать команду Print в контекстном меню Flash Player'а для печати кадров из любого Flash-клипа.

Команда контекстного меню Print не позволяет передать при печати прозрачность или цветовые эффекты и не дает возможности печатать кадры из других мувиков, для этого надо использовать команду Print. См. Добавление команды Print.

Использование команды Print контекстного меню Flash Player'а для печати кадров клипа:

1 | Откройте клип, кадры которого будете печатать.
 | Команда печатает кадры, помеченные #b, используя Сцену для определения области печати или определенного ограниченного поля. См. Обозначение печатаемых кадров и Определение области печати.
 | Если Вы не выделили определенные кадры для печати, будут напечатаны все кадры в главной линейке.
2 | Выберите File > Publish Preview > Default или нажмите F12 для просмотра вашего Flash-клипа в броузере.
3 | Щелкните правой кнопкой мыши (Windows) или Ctrl-click (Macintosh) во Flash-клипе в окне броузера для открытия контекстного меню.
4 | Выберите Print из контекстного меню Flash Player'а для открытия диалогового окна печати.
5 | В Windows, выберите диапазон печати, чтобы установить печатаемые кадры:
 | Выберите All чтобы распечатать все кадры в клипе, если никакие определенные кадры заранее не отмечены.
 | Выберите Pages и введите диапазон, чтобы печатать помеченные кадры в том диапазоне.
 | Выберите Selection, чтобы напечатать текущий кадр.
6 | На Macintosh, в диалоговом окне Print, выберите страницы для печати:
 | Выберите All, чтобы печатать текущий кадр, если никакие кадры не помечены или печатать все помеченные кадры.
 | Выберите From и введите диапазон, чтобы печатать помеченные кадры в том диапазоне.
7 | Выберите другие опции печати, доступные вашему принтеру.
8 | Нажмите OK (Windows) или Print (Macintosh).


About publishing a movie with printable frames

Создание клипов для печати > О публикации клипа с печатаемыми кадрами

О публикации клипа с печатаемыми кадрами

Вы можете опубликовать Flash-клип с печатаемыми кадрами в Сети, используя команду Publish для создания необходимого HTML-шаблоны. Для получения дополнительной информации смотрите раздел Публикация Flash-клипов.

Пользователи должны иметь, как минимум, Flash Player 4.0.25 (Windows) или 4.0.20 (Macintosh), чтобы иметь возможность воспользоваться преимуществом возможностей печати, добавленных Вами, для печати обозначенных кадров во Flash. Вы можете установить проверку версии Flash Player'а. См. Проверка трафика Web-сайта.


Printing from the Flash Player

Создание клипов для печати > Печать из Flash Player'а

Печать из Flash Player'а

Пользователи могут распечатывать клипы непосредственно из Flash Player'а в броузере двумя способами: выбором команды Print в контекстном меню плеера или использованием команды Print. Эта команда предоставляет больше контроля над тем, что может быть распечатано и обходиться без контекстного меню.

Команда Print может печатать кадры в любой линейке (Timeline), включая главную линейку или линейку любого мувиклипа или мувика, подгруженного на уровень. Эта команда также позволяет определить область печатаемого изображения и печатать цветовые эффекты, включая прозрачность.

Контекстное меню Flash Player'а более ограничено по возможностям, оно позволяет только печать кадров в главной линейке и не позволяет передать при печати прозрачность или цветовые эффекты.

Примечание: версии Flash Player'а до 4.0.25 (Windows) или 4.0.20 (Macintosh) не поддерживают прямую печать кадров.


Printing from the Flash Player

Создание клипов для печати > Печать из Flash Player'а > Подготовка клипов для печати

Подготовка клипов для печати

Готовя печать из Flash Player'а, можно задать, какие кадры печатать и их печатаемую область. Для лучшего контроля над процессом, помните, что когда Вы задаете клипы для печати, то:

Корректируйте макет в тех кадрах, которые определены Вами как печатаемые. Flash Player печатает все формы, символы, растровые рисунки, текстовые блоки и текстовые поля. Слои мувика не объединяются при печати.
Flash Player использует параметры настройки HTML для изменения размера, масштабирования и выравнивания в диалоговом окне Publish Settings, появляющегося при печати. Используйте эти параметры настройки для управления печатью.
Выбранные кадры печатаются, как только они появляются в мувиклипе. Вы можете позволить пользователям печатать мувик, который невидим в броузере, присвоив свойству _visible значение false, используя панель Actions. Изменения свойств мувиклипа с помощью команды Set Property, tweening, или какого-нибудь инструмента преобразования не влияет на печать клипа.
Чтобы мувик было возможно распечатать, он должен находиться на сцене или в пределах рабочей области и ему должно быть присвоено отдельное имя (instance name).
Для печати все элементы должны быть полностью загружены. Можно использовать свойство _framesloaded или команду If Frame Is Loaded для проверки загружена ли печатаемая область или нет. Для большей информации см. Проверка загруженности кадра.


Printing from the Flash Player

Создание клипов для печати > Печать из Flash Player'а > Поддерживаемые принтеры

Поддерживаемые принтеры

Flash Player поддерживает как PostScript, так и Не-PostScript принтеры. Список поддерживаемых принтеров см. Flash Web Printing fore Business на сайте Макромедии.


Printing from the Flash Player

Создание клипов для печати > Печать из Flash Player'а > Обозначение печатаемых кадров

Обозначение печатаемых кадров

Все кадры в указанной линейке (Timeline) печатается по умолчанию. Можно ограничить число кадров, которые можно напечатать. Например, если Вы имеете длинную анимацию, то можете выделить определенные кадры в мувике, как печатаемые, чтобы печатать только их, невыделенные кадры печататься не будут.

Чтобы определить кадры как печатаемые, Вы должны маркировать их метками (label).

Для обозначения печатаемых кадров:

1 | Откройте или сделайте активным мувик, который хотите публиковать.
2 | Если панель Frame не отражена на экране, выберите Modify > Frame.
3 | Выделите в линейке кадр, который Вы хотели бы распечатать.
4 | На панели Frame, в поле Label (Метка) введите #p, чтобы определить кадр как печатаемый.
5 | Повторите шаги 3 и 4 для каждого печатаемого кадра.


Printing from the Flash Player

Создание клипов для печати > Печать из Flash Player'а > Определение области печати

Определение области печати

По умолчанию, Сцена клипа определяет область печати. Любой объект, расположенный за Сценой, отсекается и не печатается. Загруженные мувики для определения области печати используют размеры своей, а не общей Сцены.

В качестве альтернативы использования размера Сцены мувика, можно установить три различные печатаемые области:

В команде Print можно использовать составной ограничивающий прямоугольник всех печатаемых кадров в линейке (Timeline), как печатаемую площадь. Например, печатать множество кадров, совместно использующих точку отсчета (registration point). Чтобы использовать составной ограничивающий прямоугольник, выберите опцию Max в параметрах команды Print. См. Добавление команды Print.
В команде Print можно изменять печатаемую площадь изображения для каждого кадра, масштабируя объекты, чтобы приспособить печатаемую площадь. Например, иметь объекты различных размеров в каждом кадре, заполняющие печатаемую страницу. Для изменения ограничивающего прямоугольника в кадре, используйте опцию Frame в параметрах команды Print. См. Добавление команды Print.

Определение печатаемой области:

1 | Открыть мувик, кадры которого хотите установить для печати.
2 | Выбрать кадр, который Вы не определяете для печати при помощи #p метки кадра
 | Можете выбрать следующий кадр после одного помеченного #p
3 | Создать форму на Сцене, размер которой равен желаемой печатаемой площади.
 | Вы можете также выбирать кадр с любым объектом, имеющим размер соответствующим печатаемой площади, чтобы использовать ограничивающий прямоугольник того кадра.
4 | Выбрать в линейке кадр, содержащий форму, которую вы будете использовать для ограничивающего прямоугольника.
5 | Если панель Frame не открыта, выбирать Modify > Frame.
6 | На панели Frame, введите #b, чтобы определить выбранную форму, как ограничивающий прямоугольник для печатаемой области.
 | Вы можете вводить только одну #b метку в линейке (Timeline). Эта опция аналогична опции выбора ограничивающего прямоугольника для мувика в команде Print.


Printing from the Flash Player

Создание клипов для печати > Печать из Flash Player'а > Изменение цвета заднего фона при печати

Изменение цвета заднего фона при печати

Flash Player печатает цвет задний фон, установленный в диалоговом окне Movie Properties. Вы можете изменять цвет фона только для кадров, которые будут напечатаны, размещая цветной объект на самом низком слое распечатываемой линейки (Timeline).

Изменение цвета заднего фона:

1 | Разместите залитую форму, перекрывающую всю Сцену, на самом нижнем слое распечатываемой линейки.
2 | Выделите форму и выберите Modify > Movie. Выберите цвет для фона.
 | Это изменяет фоновый цвет всего клипа, включая подгружаемые мувиклипы.
3 | Выберите из следующих опций:
 | Чтобы печатать определенный цвет как фоновый, удостоверитесь, что кадр, в котором Вы размещали форму, обозначен для печати, см. Обозначение печатаемых кадров.
 | Чтобы задать различный цветовой фон для непечатаемых кадров, повторите шаги 2 и 3. Затем разместите форму на самом нижнем слое распечатываемой линейки, во всех кадрах, которые не обозначены для печати. Для инструкций см. Отключение печати.


Printing from the Flash Player

Создание клипов для печати > Печать из Flash Player'а > Отключение печати

Отключение печати

Если Вы не хотите, чтобы любые кадры в основной линейке (Timeline) можно было распечатать, замаркируйте их !#p. !#p делает клип непечатаемым и приводит к тому, что команда Print становится недоступной в контекстном меню Flash Player'а. Вы можете также удалить контекстное меню Flash Player'а.

Если Вы отключите печать, можно печатать кадры, используя команду Print браузера, ее нельзя контролировать или отключить через Flash.

Для отключения печати в контекстном меню Flash Player'а:

1 | Откройте или сделайте активным клип, который хотите публиковать.
2 | Если панель Frame не открыта, выберите Modify > Frame.
3 | Выделите первый ключевой кадр в основной линейке.
4 | На панели Frame в поле Label (метка), введите !#p для определения кадра, как непечатаемого.
 | Необходимо определить только одну !#p метку, чтобы команда Print в контекстном меню стала недоступна.

Примечание: Вы можете выбрать пустой кадр и маркировать его #p, чтобы предотвратить печать из контекстного меню Flash Player'а.

Для отключения печати путем удаления контекстного меню Flash Player'а:

1 | Откройте или сделайте активным клип, который хотите публиковать.
2 | Выберите File > Publish Settings.
3 | Откройте вкладку HTML и отключите опцию Display Menu.
4 | Нажмите OK.

Для дополнительной информации о Publish Settings, см. Публикация Flash-клипов.


Adding a Print action

Создание клипов для печати > Добавление команды Print

Добавление команды Print

Вы можете добавлять команду Print кнопке или другому элементу в вашем клипе, чтобы позволить пользователям распечатать его. Можно назначать команду Print кнопке, кадру или мувиклипу. Если Вы назначаете ее кадру, команда будет выполнена при воспроизведении этого кадра.

Команда Print позволяет печатать кадры других мувиклипов в дополнение к основной линейке (Timeline). Каждой командой Print задается только одна линейка для печати, но команда позволяет определить любое число кадров для печати в пределах этой линейки. Если Вы прописываете больше одной команды Print у одиночной кнопки или кадра, диалоговое окно Print будет доступно для каждой выполняемой команды.

Назначение команды Print кнопке, кадру или мувиклипу:

1 | Откройте клип, кадры которого хотите распечатать.
2 | Выберите желаемый для печати ключевой кадр в линейке и удостоверьтесь, что они замаркированы #p. См. Обозначение печатаемых кадров.
 | Если Вы не определите какие кадры печатать, все кадры печатаются по умолчанию.
3 | Выберите кадр, кнопку или мувиклип, которому назначите команду Print.
 | Каждая команда Print устанавливает для печати только одну линейку.
4 | Выберите Window > Actions чтобы открыть панель Actions.
5 | В левом списке выберите категорию Actions и дважды щелкните на команде Print.
 | Flash вставит команду Print в правый список команд.
6 | В поле Print выберите каким методом печатать кадр, как векторный или как растровый рисунок:
 | Векторный режим печатает кадр с более высоким качеством, но без прозрачности.
 | Объекты, содержащие прозрачность или цветовые эффекты не могут быть напечатаны как векторные данные. (Принтер не может интерпретировать альфа канал, определяющий эффект, как векторные данные.)
 | Растровая печать воспроизводит прозрачность в альфа канале или цветовые эффекты.
 | Эта опция печатает в самой высокой доступной разрешающей способности принтера.
7 | Для определения линейки для печати, выберите опцию Location:
 | Для Level укажите номер уровня основной линейки или загруженного мувика. Чтобы использовать выражение для вычисления значения уровня, включите опцию Expression и введите выражение. Для получения дополнительной информации, см. Загрузка и выгрузка дополнительного клипа.
 | Для Target введите путь к мувику или нажмите на кнопку Target Path в нижнем правом углу и используйте диалоговое окно Insert Target Path, чтобы определить и выбрать мувиклип. Чтобы использовать выражение для вычисления значения Target, включите опцию Expression и введите выражение.
8 | Чтобы установить границы печати, выберите опцию Bounding Box:
 | Movie использует Bounding Box в помеченном кадре #b, в качестве печатаемой областям для всех кадров, как это описано в Определение области печати. Например, выберите эту опцию, чтобы распечатать полностраничные данные из сети.
 | Вверху: Кадр, помеченный #p (слева) печатает область Сцены (справа). Внизу: Кадр, помеченный #p (1) и кадр, помеченный #b (2), с onion scin view (3), печатает Bounding Box (справа).
 | Max использует составной Bounding Box для всех печатаемых кадров в линейке, как область печати.
 | Frame использует Bounding Box в каждом печатаемом кадре линейки, как область печати, изменяя область изображения для каждого кадра и масштабируя объекты для заполнения печатаемой области. Например, используйте Frame, если Вы имеете объекты различного размера в каждом кадре и хотите, чтобы каждый объект заполнил напечатанную страницу.
 | Опция Frame устанавливает Bounding Box каждого кадра, как печатаемую область (вверху), масштабируя оригинал (внизу).

Примечание: Выбор опций Max или Frame Bounding Box в команде Print отменяет любые кадры, помеченные #b Bounding Box клипа.


Publishing and exporting overview

Публикация и экспорт > Публикация и экспорт. Краткий обзор

Публикация и экспорт. Краткий обзор

Когда Flash-ролик готов, возникает необходимость в публикации или экспорте FLA-файла в другой формат для воспроизведения.

Возможность публикации во Flash разработана для презентации анимации в сети. Команда Publish создаёт файл формата Flash-плеера (SWF) и HTML документ, позволяющий отобразить полученный SWF-файл в окне браузера.

Команда Export Movie позволяет создавать файл, содержимое которого может редактироваться в других приложениях, и экспортировать клип непосредственно в определённый формат. Например, вы можете экспортировать весь клип в файл формата Flash-плеера, в ряд растровых изображений (bitmap), в отдельный кадр или изображение, в динамические или статические изображения таких форматов, как GIF, JPEG, PNG, BMP, PICT, QuickTime или AVI.

Команда Publish позволяет:

выбирать форматы, в которых вы хотели бы представить ваш файл и устанавливать любые параметры настройки для определённого формата. Flash автоматически публикует файл в выбранных форматах, создаёт дополнительные файлы, основанные на выбранных настройках и сохраняет параметры настройки совместно с файлом для повторного использования.
Опции Export Movie, вообще говоря, ведут себя аналогично, но при этом не сохраняются параметры настройки для повторного использования.
создавать альтернативные файловые форматы—GIF, JPEG, PNG, QuickTime— и HTML-окружение, необходимое для отображения их в окне браузера. Альтернативные форматы позволяют браузеру отобразить анимацию вашего клипа и взаимодействие его компонентов пользователям, не имеющим установленного Flash-плеера.
создавать шаблоны генератора (Generator), для легкого обновления содержимого веб-страницы: графики и текста, без необходимости непосредственной замены файлов. Например, во Flash вы можете использовать данные генератора в качестве переменных, чтобы обеспечить непосредственную или выборочную обратную связь с посетителями вашего сетевого Flash-ресурса, сделать разработку вашего сайта более эффективной и создать такие элементы, как прокручивающиеся списки, которые вы не могли бы сделать с использованием одного только Flash. См. Генератор и Flash.

Если у вас есть достаточно опыта в HTML, то в качестве альтернативы использованию команды Publish, вы можете создать свой HTML-документ с помощью любого редактора HTML и включить теги, требуемые для отображения Flash-клипа. См. Шаблоны HTML публикации.

Если у вас есть Macromedia Dreamweaver, вы можете легко добавить Flash-клип к своему веб-сайту. Dreamweaver генерирует необходимый HTML-код. См. документацию к Dreamweaver для подробной информации.

Прежде, чем публиковать ваш клип, важно проверить его работу, используя команды Test Movie и Test Scene. Более подробно см. Тестирование процесса загрузки клипа.


Publishing Flash movies

Publishing and Exporting > Публикация Flash-клипов > Публикация GIF-файлов

Публикация GIF-файлов

GIF-файлы обеспечивают простой способ экспорта изображений и простейшей анимации, используемых на веб-страницах. Стандартные файлы GIF не что иное, как сжатые растровые изображения (bitmaps).

Динамический анимированный GIF (иногда упоминаемый как GIF89a) позволяет экспортировать простые анимационные последовательности. Flash оптимизирует такой GIF, запоминая только изменения от кадра к кадру.

Flash экспортирует первый кадр клипа в формат GIF, если вы не помечаете другой экспортируемый ключевой кадр как #Static. Flash экспортирует все кадры клипа в анимированный GIF, если вы не определили область экспортируемых кадров введением меток #First и #Last в соответствующих ключевых кадрах.

Flash может генерировать карту изображения для формата GIF, чтобы обеспечить связь URL-ссылок с кнопками в оригинальном ролике. Поместите метку #Map в ключевой кадр, где бы вы хотели создать карту изображения. Если вы не создадите такой метки, то Flash сделает карту изображения, используя кнопки в последнем кадре клипа. Создание карты возможно только в случае, когда переменная $IM присутствует в выбранном вами шаблоне. См. Создание карты изображения.

Чтобы опубликовать GIF-файл совместно с Flash-файлом:

1 | Выберите File > Publish Settings.
2 | Выберите GIF в качестве типа изображения. Введите уникальное имя файла в поле Filename или выберите Use Default Name, чтобы созданный файл имел то же, что и Flash-файл и расширение .gif.
3 | Щёлкните курсором по закладке GIF, чтобы рассмотреть доступные настройки.
4 | Укажите размеры (Dimensions), введите ширину (Width) и высоту (Height) экспортируемого растрового изображения в пикселах или выберите Match Movie, чтобы сделать GIF такого же размера, как и Flash-клип и поддерживать соответствующее отношение геометрических размеров, как и в первоначальном изображении.
5 | Выберите опцию воспроизведения (Playback), чтобы определить создаёт ли Flash статическое изображение (Static) или анимацию (Animation). Если выбрана анимация, выберите непрерывный цикл (Loop Continuously) или введите количество повторений.
6 | Выберите соответствующую опцию, чтобы задать действие тех или иных настроек для экспортируемого GIF:
 | Optimize Colors (Оптимизация цвета) удаляет все неиспользованные цвета из таблицы цветов GIF-файла. Эта опция уменьшает размер файла на до 1000-1500 байтов без потери качества изображения, но несколько увеличивает требования к памяти. Опция не влияет на адаптивную палитру (Adaptive Palette). Адаптивная палитра анализирует цвета изображения и создаёт уникальную таблицу для выбранного GIF.
 | Interlace (Чередование) экспортируемый GIF будет постепенно отображаться в браузере по мере загрузки. Такой GIF демонстрирует пользователю графическое содержание раньше, чем файл полностью загрузится и может загружаться быстрее при медленном сетевом подключении. Не используйте эту опцию для анимированных GIF.
 | Smooth (Сглаживание) применяет эффект сглаживания к экспортируемому растровому изображению для получения высококачественного изображения и улучшения качества отображения текста. Однако, сглаживание может приводить к появлению ореола серых пикселей вокруг сглаженных изображений, расположенных на цветном фоне, что увеличивает объём файла. Экспортируйте изображения без сглаживания, если ореол имеет место, или, если прозрачный GIF помещён на многоцветный фон.
 | Dither Solids (Размытие) осуществляет размытие однотонных цветов так же, как и градиентов. См. опцию размытия (Dither) в пункте 8.
 | Remove Gradients (Удаление градиентов), выключенная по умолчанию, конвертирует все градиенты, используемые в клипе, в однотонные цвета, беря за основу первый цвет градиента. Градиенты увеличивают объём GIF'а и часто имеют низкое качество. Если вы используете эту опцию, аккуратно выбирайте первый цвет градиентов, дабы избежать неожиданных результатов.
7 | Задайте Transparent (прозрачность), чтобы определить её для фона ролика и указать способ преобразования альфа-установок в GIF'е:
 | Opaque (Непрозрачный), чтобы сделать фон однотонным.
 | Transparent (Прозрачный), чтобы сделать фон прозрачным.
 | Alpha (Альфа) для установки частичной прозрачности. Затем введите пороговое (Threshold) значение между 0 и 255, чтобы сделать все цвета ниже этого значения полностью прозрачными (невидимыми), цвета над ним частично прозрачными. Значение 128 соответствует 50%-ой альфе.
8 | Выберите опцию Dither (размытия), чтобы определить, как пикселы доступных цветов объединяются для имитации отсутствующих в данной палитре цветов. Размытие может улучшить качество цвета, но при этом увеличит объём файла. Выберите необходимые опции для настройки:
 | None выключает размытие и заменяет цвета вне основной таблицы цветов на наиболее близкие к ним однотонные, входящие в таблицу. Отмена размытия может дать выигрыш в размере файла, но привести к неудовлетворительным цветам.
 | Ordered обеспечивает размытие хорошего качества с наименьшим увеличением размера файла.
 | Diffusion обеспечивает самое лучшее качество, но заметно увеличивает объём файла и время обработки по сравнению с заказанным (Ordered) размытием. Эта опция работает только с 216-цветовой Web-палитрой.
9 | Выберите Palette Type (тип палитры) для определения цветовой палитры изображения:
 | Палитра Web 216 использует стандартную предопределённую в браузерах 216-цветовую палитру для создания GIF, изображений хорошего качества и наиболее быстрой обработки на сервере.
 | Адаптивная (Adaptive) палитра анализирует цвета изображения и создаёт уникальную таблицу цветов для выбранного GIF. Эта опция наиболее подходит для систем, работающих в режиме отображения тысяч или миллионов цветов; она создаёт наиболее точные цвета изображения, но при этом результатом является файл, больший, чем тот же файл, созданный в палитре Web 216. Чтобы уменьшить его объём, сохранив адаптивную палитру, используйте опцию Max Colors в пункте 10, приводящую к уменьшению количества цветов в палитре.
 | Web Snap Adaptive - это то же, что и адаптивная палитра, за исключением того, что она преобразовывает очень близкие цвета к палитре Web 216. Полученная палитра оптимизирована для изображения, но по возможности Flash использует цвета из палитры Web 216. Результатом будут лучшие цвета изображения, если палитра Web 216 активна в системе с 256 цветами.
 | Custom (Заказная или выборочная) палитра определяет палитру, оптимизированную вами для выбранного изображения. Эта опция имеет скорость обработки, равную скорости в палитре Web 216. Чтобы использовать эту опцию, вы должны знать, как создавать и использовать такие палитры. Для выбора заказной палитры щёлкните курсором по кнопке, помеченной (...) справа от поля выбора палитр Palette внизу диалогового окна и вызовите нужный файл палитры. Flash поддерживает палитры, сохранённые в формате ACT, экспортируемом Macromedia Fireworks и другими ведущими графическими приложениями. Для получения более подробной информации см. Импорт и экспорт цветовых палитр.
10 | Если вы выбрали адаптивную палитру или Web Snap Adaptive в пункте 9, введите значение для максимального количества цветов (Max Colors), чтобы установить число цветов, используемых в GIF-изображении. Выбор меньшее количество цветов приведёт к небольшому файлу, но деградации цветов изображения.
11 | Чтобы сохранить настройки, нажмите OK.


Publishing Flash movies

Публикация и экспорт > Публикация Flash-клипов > Публикация JPEG-файлов

Публикация JPEG-файлов

Формат JPEG позволяет сохранять 24-х битные растровые изображения с высокой степенью сжатия. Как правило, формат GIF предпочтительней для экспорта контурных рисунков с четкими краями и малым количеством цветов, в то время как JPEG лучше подходит, если картинка содержит полутона - фотографии, градиенты и т.п.

Flash экспортирует первый кадр клипа как JPEG, пока вы не пометите другой ключевой кадр (keyframe) меткой #Static.

Для публикации файла JPEG выполните следующие шаги:

1 | Зайдите в File > Publish Settings.
2 | Выберите JPEG Image type. Введите имя будущего файла или включите флажок Use Default Name, при этом имя файла будет то же самое, что и у клипа, только с расширением .jpg.
3 | Зайдите в панель настройки JPEG.
4 | В поле Dimensions (Размеры), введите ширину (Width) и высоту (Height) в пикселах будущего имиджа, или же выберите Match Movie для того, чтобы картинка JPEG была того же размера, что и Flash-клип, при этом будут сохранены пропорции.
5 | В поле Quality (Качество), подвигайте ползунок, чтобы добиться оптимального соотношения качество/сжатие.

Замечание: Вы можете установить качество экспорта для каждого объекта, используя диалоговое окно Bitmap Properties для изменения качества сжатия. Выбранная по умолчанию компрессия (default compression), как раз и есть опция диалогового окна Publish Settings JPEG Quality. См. Установка свойств растрового рисунка.

6 | Выберите Progressive, если хотите, чтобы картинка в браузере по мере загрузки отображалась постепенно от низкого качества к высокому.
 | Эта установка подобна чередованию (interlacing) в GIF и PNG форматах.
7 | Для сохранения установок текущего файла щелкните OK.


Publishing Flash movies

Публикация и экспорт > Публикация Flash-клипов > Публикация PNG-файлов

Публикация PNG-файлов

PNG является межплатформенным форматом, поддерживающим прозрачность (альфа-канал). Он также является "родным" форматом для пакета Macromedia Fireworks.

Flash экспортирует первый кадр клипа как PNG, пока вы не пометите другой ключевой кадр (keyframe) меткой #Static.

Для публикации PNG-файла выполните следующие шаги:

1 | Зайдите в File > Publish Settings.
2 | Выберите PNG Image type. Введите имя будущего файла, или включите флажок Use Default Name, при этом имя файла будет то же самое, что и у клипа, только с расширением .png.
3 | Зайдите в панель настройки PNG.
4 | В поле Dimensions (Размеры), введите ширину (Width) и высоту (Height) в пикселах будущего имиджа, или же выберите Match Movie для того, чтобы картинка PNG была того же размера, что и Flash-клип, при этом будут сохранены пропорции.
5 | Выберите глубину цвета (Bit Depth), чтобы установить число бит на пиксел для будущей картинки:
 | 8-bit для 256-цветной картинки.
 | 24-bit для полноцветной картинки.
 | 24-bit with Alpha для полноцветной картинки с прозрачностью (32 bits).
 | Чем больше глубина цвета, тем больше будет размер файла картинки.
6 | В Options задайте установки экспорта PNG:
 | Optimize Colors убирает неиспользуемые цвета из палитры картинки. Опция позволяет уменьшить размер файла примерно на 1-1,5 Kb без потери качества, но немного увеличивает требования к памяти. Эта опция не оказывает эффекта на Adaptive палитру.
 | Interlace обеспечивает постепенную загрузку PNG в окошке браузера. Interlaced PNG дает представление пользователю о картинке, даже если она еще не загрузилась. Не используйте эту опцию для анимированных PNG.
 | Smooth применяется для сглаживания изображения, что иногда повышает качество изображения и текста. При этом возрастает величина PNG-файла. Не используйте эту опцию, если вам не требуется размытие четких линий картинки, а также если вы намерены помещать картинку с прозрачным фоном на многоцветную подложку.
 | Dither Solids применяет размытие к однотонным цветам и градиентам. См. опции Dither в пункте 7.
 | Флажок Remove Gradients, по умолчанию снятый, преобразует все градиентные заливки в однотонные цвета, используя первый цвет градиента. Градиенты увеличивают конечный размер PNG и часто ухудшают качество. Если вы используете эту опцию, то осторожно выбирайте базовый цвет, чтобы избежать неожиданных результатов.
7 | Выберите опции Dither, чтобы определить, как будут смешиваться пикселы доступных цветов, для имитации цветовых оттенков, недоступных в данной палитре. Dithering улучшает восприятие, однако увеличивает размер файла. Доступные опции:
 | None отключает размытие и заменяет внетабличные цвета наиболее подходящим однотонным цветом. При этом получается минимальный размер файла и неудовлетворительное качество цвета.
 | Ordered обеспечивает хорошее качество с незначительным увеличением размера файла.
 | Diffusion обеспечивает наивысшее качество, увеличивая при этом размер файла. Он также работает, если выбрана 216-цветовая Web-палитра.
8 | Выберите Palette Type, чтобы определить тип палитры PNG-картинки:
 | Web 216 - стандартная вебовская палитра, хорошее качество PNG и самая быстрая его обработка на сервере.
 | Adaptive анализирует цвета в картинке и создает уникальную таблицу цветов для нее. Эта опция является лучшей для экранов, работающих в режимах high и true color. Однако размер файла получается больше, чем при использовании Web палитры.
 | Web Snap Adaptive подобна Adaptive, за исключением того, что очень похожие цвета конвертируются в цвета палитры Web 216.
 | Для уменьшения размера PNG-файла с использованием adaptive палитры, выберите опцию Max Colors, чтобы снизить число цветов, так, как описано в следующем шаге.
 | Заказная (Custom) позволяет определять палитру, которую Вы оптимизировали для текущего изображения. Чтобы использовать эту опцию, Вы должны быть знакомы с созданием и использованием таких палитр. Чтобы выбирать заказную палитру, нажмите кнопку, помеченную знаком (...) справа от поля Palette внизу диалогового окна и выберите файл палитры. Flash поддерживает палитры, сохраненные в формате ACT, экспортируемым Macromedia Fireworks и другими ведущими графическими пакетами, см. Импорт и экспорт цветовых палитр.
9 | Если вы выбрали Adaptive или Web Snap Adaptive палитру в п. 8, введите значение Max Colors, чтобы установить число цветов, используемых PNG картинкой.
10 | Поэкспериментируйте с Filter Options, чтобы выбрать наилучший метод построчной фильтрации для большего сжатия картинки:
 | None выключает фильтрацию.
 | Sub передает различие между каждым байтом и значением соответствующего байта предшествующего пиксела.
 | Up передает различие между каждым байтом и значением соответствующего байта последующего пиксела.
 | Average (среднее число) использует среднее число из двух соседних пикселов (левый и верхний) чтобы предсказать значение пиксела.
 | Path вычисляет простую линейную функцию из трех соседних пикселов (левый, верхний, верхний левый), затем выбирает как прогнозатор соседний пиксел, самый близкий к вычисленному значению.
 | Adaptive анализирует цвета картинки и создает собственную цветовую таблицу. Эта опция является лучшей для экранов, работающих в режимах high и true color. Однако размер файла получается больше, чем при использовании Web палитры. Вы можете уменьшить размер файла путем уменьшения цветов в палитре.
11 | Для сохранения установок текущего файла, нажмите OK.


Publishing Flash movies

Публикация и экспорт > Публикация Flash клипов > Публикация клипов QuickTime 4

Публикация клипов QuickTime 4

Опция QuickTime Publish создает клип в формате QuickTime 4, копируя Flash-клип на отдельную дорожку QuickTime. Flash-клип воспроизводится в QuickTime-клипе точно так же, как и во Flash-плеере, сохраняя все его интерактивные особенности. Если Flash-клип содержит QuickTime-клип, Flash копирует его на собственную дорожку в новом QuickTime файле. Для подробной информации смотри документацию по QuickTime.

Для публикации клипа QuickTime 4:

1 | Зайдите в File > Publish Settings.
2 | Выберите QuickTime Image type. Введите имя будущего файла или включите флажок Use Default Name, при этом имя файла будет то же самое, что и у клипа, только с расширением .mov.
3 | Зайдите в панель настройки QuickTime.
4 | В поле Dimensions (Размеры), введите ширину (Width) и высоту (Height) в пикселах будущего имиджа или же выберите Match Movie для того, чтобы окно QuickTime-клипа было того же размера, что и Flash-клип, при этом будут сохранены пропорции.
5 | Alpha задает прозрачность, опция не влияет на настройки прозрачности в самом Flash клипе:
 | Alpha Transparent делает прозрачной дорожку Flash. Будет видимым любое содержимое дорожек, находящихся позади дорожки с Flash.
 | Copy делает дорожку Flash непрозрачной. Все содержимое дорожек позади дорожки Flash будет маскировано.
 | Auto делает дорожку Flash прозрачной, если она находится выше любых других дорожек, но делает ее непрозрачной, если эта дорожка лежит в основании или она единственная дорожка в клипе.
6 | Choose a Layer определяет, куда дорожка Flash будет помещена в QuickTime фильме:
 | Top помещает Flash-трэк выше всех дорожек QuickTime-клипа.
 | Bottom помещает Flash-трэк ниже всех дорожек QuickTime-клипа.
 | Auto помещает Flash-трэк выше других дорожек, если имеется объект Flash перед объектами видео в пределах Flash-клипа, иначе размещает Flash-клип позади всех других дорожек.
7 | Выбор Streaming Sound заставит Flash экспортировать все потоковые звуки во Flash-клипе на звуковую дорожку QuickTime. Это повторно сжимает звуки, используя стандартные параметры настройки звука QuickTime. Нажмите Audio Settings, чтобы изменить эти параметры. См. QuickTime документацию.
8 | Controller определяет, какой тип QuickTime контроллера будет запускать экспортируемый клип — None, Standard или QuickTime VR.
9 | Используйте опции Playback для управления воспроизведением QuickTime-клипа:
 | Looping повторяет воспроизведение непрерывно.
 | Paused at Start включает паузу при открытии клипа.
 | Play Every Frame показывает каждый кадр клипа не пропуская их и не воспроизводит звук.
10 | Выбор File Flatten (Make Self-Contained) Комбинирует содержание Flash и импортированное содержание видео в новый QuickTime-клип. Когда эта опция не установлена, новый QuickTime-клип требует импорта внешних файлов, если этих файлов не будет, клип не будет работать должным образом.
11 | Для сохранения установок текущего файла, нажмите OK.


Previewing the publishing format and settings

Публикация и экспорт > Предварительный просмотр

Предварительный просмотр

Чтобы посмотреть Flash-клип с новыми установками, используйте команду Publish Preview. Эта команда экспортирует файл и открывает его в браузере. Если вы просматриваете клип QuickTime, Publish Preview запускает QuickTime Movie Player. Если просматриваете прожектор (projector), Flash запустит его.

Для просмотра файла с помощью Publish Preview:

1 | Установите опции экспорта файла; см. Публикация Flash-клипов.
2 | Далее выполните одно из следующих действий:
 | Зайдите в File > Publish Preview и из подменю выберите формат файла, который хотите просмотреть.
 | Нажмите F12 чтобы просмотреть формат по умолчанию.
 | Используя текущие Publish Settings установки, Flash создаст файл с определенным ранее названием, расположенный в том же каталоге, что и Flash файл.


Using the stand-alone player

Публикация и экспорт > Использование автономного плеера

Использование автономного плеера

Автономный плеер воспроизводит Flash-клипы точно так же, как и веб-браузер или приложение, использующее ActiveX. Плеер инсталлируется в процессе установки Flash (файл FlashPla.exe в Windows и FlashPlayer на Macintosh). По двойному щелчку плеер запустится и далее в нем можно прогрывать клипы.

Вы можете управлять клипами в плеере, используя команды меню и FScommand команды. Например, чтобы открыть плеер на весь экран, назначьте FScommand команду в кадре или в кнопке и выберите для Fullscreen аргумент True. Для дополнительной информации смотри Управление внешними клипами.

В автономном плеере вы можете:

Открыть новый или ранее созданный файл File > New или File > Open.
Поменять вид используя View > Magnification, и из подменю выбрать Show All, Zoom In, Zoom Out, или 100%.
Управление воспроизведением клипа: Control > Play, Rewind, Loop, Step Forward или Step Backward.


Exporting movies and images

Публикация и экспорт > Экспорт клипов и изображений

Экспорт клипов и изображений

Для использования содержимого Flash в других приложениях или для экспорта в специфический формат, используйте команды Export Movie и Export Image. Эти команды экспорта не сохраняют настройки отдельно для каждого файла, так, как команды Publish. (Используйте Publish при подготовке Flash клипа для Web. См. Публикация Flash-клипов.)

Команда Export Movie позволяет сохранить содержимое Flash-клипа в виде последовательности пронумерованных картинок (каждая картинка-отдельный кадр). Вы можете также сохранить звук клипа в виде WAV файла (только для Windows).

Для экспорта содержимого текущего кадра или текущих выбранных изображений в один из графических форматов или однокадровый Flash файл, используйте команду Export Image.

Когда экспортируете изображение из Flash в векторный формат (Adobe Illustrator), вы сохраняете его векторную информацию. Вы можете его затем редактировать в других векторных редакторах, но не сможете импортировать в большинство текстовых процессоров.
Когда сохраняете Flash изображение как GIF, JPEG, PICT (Macintosh) или BMP (Windows) файл, изображение теряет свою векторную информацию и сохраняется в виде растра. Затем можете открывать их в редакторах, подобных Adobe Photoshop, но в векторных программах редактировать уже не получится.

Для экспорта клипа или картинки:

1 | Если экспортируете картинку, выделите кадр или изображение, которое вас интересует.
2 | Зайдите в File > Export Movie или File > Export Image.
3 | Введите имя файла.
4 | Выберите формат.
5 | Нажмите Save.
 | Если выбранный формат требует дополнительных настроек, появится диалоговое окно экспорта.
6 | Установите опции экспорта, как описано ниже.
 | Опции экспорта и установки публикации идентичны Flash-клипам и Generator-шаблонам. Для информации см. Поддерживаемые форматы файлов.
7 | Нажмите OK, затем Save.


About export file formats

Публикация и экспорт > Форматы экспортируемых файлов

Форматы экспортируемых файлов

Вы можете экспортировать Flash клипы и изображения в более дюжины различных форматов, представленных в таблице. Клипы сохраняются в виде последовательности, изображения в виде отдельного файла. PNG - межплатформенный формат, поддерживающий прозрачность.

Поддерживаемые форматы файлов:
Тип файла | Расширение | Windows | Macintosh
Adobe Illustrator | .ai |  |
Анимированные GIF, GIF-последовательности и GIF-изображения | .gif |  |
Bitmap (BMP) | .bmp |  |
DXF-последовательность и AutoCAD DXF-изображение | .dxf |  |
Enhanced Metafile | .emf |  |
EPS (Версии 6.0 или ранее) | .eps |  |
FutureSplash Player | .spl |  |
Generator template | .swt |  |
JPEG-последовательность и JPEG-изображение | .jpg |  |
PICT-последовательность (Macintosh) | .pct |  |
PNG-последовательность и PNG-изображение | .png |  |
Публикация клипов QuickTime 4 | .mov |  |
QuickTime Video (Macintosh) | .mov |  |
WAV audio (Windows) | .wav |  |
Windows AVI (Windows) | .avi |  |
Windows Metafile | .wmf |  |


About export file formats

Публикация и экспорт > Форматы экспортируемых файлов > Adobe Illustrator

Adobe Illustrator

Формат Adobe Illustrator является идеальным форматом для переноса изображений в другие векторные пакеты, например FreeHand. Формат очень точно преобразует кривые, линии и заливки. Flash поддерживает импорт и экспорт Adobe Illustrator 88, 3.0, 5.0 и 6.0 форматы. (См. Файлы Adobe Illustrator.) Flash не поддерживает формат Photoshop EPS или EPS файлы, полученные с помощью Print.

Версии Adobe Illustrator ниже 5 не поддерживают градиентные заливки и только версия 6 поддерживает битмапы.

Диалоговое окно экспорта в Adobe Illustrator позволяет выбрать версию Adobe Illustrator - 88, 3.0, 5.0 или 6.0.

Чтобы сделать Flash файлы совместимыми с Adobe Illustrator 8.0 или выше, используйте Macromedia Flashwriter или Adobe Illustrator плагин, входящий в Flash.


About export file formats

Публикация и экспорт > Форматы экспортируемых файлов > Анимированные GIF, GIF-последовательности и GIF-изображения

Анимированные GIF, GIF-последовательности и GIF-изображения

Эта опция позволяет вам экспортировать файлы в формат GIF. Установки те же самые, что и на вкладке GIF в диалоговом окне Publish Settings, за некоторыми исключениями:

Resolution устанавливается в точках на дюйм (dpi). Вы можете ввести разрешение или выбрать Match Screen для использования разрешения экрана.

Include позволяет экспортировать картинку, минимальную по площади, либо полный размер документа.

Colors позволяет выбрать количество используемых цветов - black-and-white; 4-, 8-, 16-, 32-, 64-, 128- или 256- битный цвет, или Standard Color (стандартная 216-цветовая Web-палитра).

Вы можете также выбрать interlace (чередование), smooth (сглаживание), transparent (прозрачность) или dither (размытие) однотонный цветов. Для доп. информации об этих установках, см. Публикация GIF-файлов.

Animation доступна в Animated GIF и позволяет определить число повторений, где 0 означает непрерывное воспроизведение.


Воспроизведение Flash-клипов

Публикация и экспорт > Воспроизведение Flash-клипов

Воспроизведение Flash-клипов

Основным форматом исходного файла Flash является формат Flash-плейера (Flash Player, SWF). Этот формат единственный поддерживает все функциональные интерактивные возможности Flash.

Существуют следующие способы воспроизведения SWF-ролика:

в браузерах (таких, как Netscape Navigator и Internet Explorer) с установленным Flash-плейером
с помощью Flash Xtra в Director'е и Authorware
с помощью Flash ActiveX компонентов в Microsoft Office и других ActiveX приложениях
как часть QuickTime-клипа
в качестве автономного приложения, называемого прожектором (projector)

Этот формат является открытым стандартом, поддерживаемым другими приложениями. См. сайт фирмы Macromedia для получения более полной информации.


About export file formats

Публикация и экспорт > Форматы экспортируемых файлов > Bitmap (BMP)

Bitmap (BMP)

Данный формат позволяет создавать растровые картинки для дальнейшего использования их в других приложениях. Диалоговое окно Bitmap Export содержит настройку следующих опций:

Dimensions устанавливает размер картинки в пикселах. Flash гарантирует сохранение пропорций картинки.

Resolution устанавливает разрешение будущей картинки в точках на дюйм (dpi), после чего Flash автоматически пересчитает размеры. Для установки разрешения монитора, выберите Match Screen.

Color Depth определяет глубину цвета. Некоторые приложения Windows не поддерживают новый 32-битный стандарт; если у вас возникли проблемы, используйте 24-битный.

Smooth применяется сглаживание (anti-aliasing) к картинке. Повышается качество, однако в некоторых случаях может возникнуть эффект ореола серого цвета у объектов, помещенных на цветную подложку.


About export file formats

Публикация и экспорт > Форматы экспортируемых файлов > DXF-последовательность и AutoCAD DXF-изображение

DXF-последовательность и AutoCAD DXF-изображение

Данный 3D формат позволяет экспортировать элементы вашего клипа как файлы AutoCAD DXF release 10, также могут быть приведены к DXF-совместимому формату для дополнительного редактирования.

Опции не определены.


About export file formats

Публикация и экспорт > Форматы экспортируемых файлов > Enhanced Metafile (Windows)

Enhanced Metafile (Windows)

Формат Enhanced Metafile (EMF) является графическим форматом для Windows 95 и Windows NT, хранящем растровую и векторную информацию. EMF поддерживает кривые, используемые Флэшем, лучше, чем старый формат Windows Metafile (WMF). Однако, множество приложений еще не понимают EMF.

Опции не определены.


About export file formats

Публикация и экспорт > Форматы экспортируемых файлов > EPS 3.0 с предварительным просмотром

EPS 3.0 с предварительным просмотром

Вы можете экспортировать текущий кадр как файл EPS 3.0 для размещения в другом приложении, таком как документа разметки страниц. EPS файл включает возможность распечатки на PostScript-принтере, а также предварительный просмотр.

Опции не определены.


About export file formats

Публикация и экспорт > Форматы экспортируемых файлов > FutureSplash Player

FutureSplash Player

Данный формат использовался Flash до приобретения его Макромедией. Установки экспорта подобны установкам публикации Flash. См. Публикация Flash клипа.


About export file formats

Публикация и экспорт > Форматы экспортируемых файлов > JPEG-последовательность и JPEG-изображение

JPEG-последовательность и JPEG-изображение

Опции экспорта JPEG подобны опциям публикации JPEG, за одним исключением: установка экспорта Match Screen подгоняет разрешение и размер картинки под тот, каким он виден на вашем экране.

Для дополнительной информации см. Публикация JPEG-файлов.


About export file formats

Публикация и экспорт > Форматы экспортируемых файлов > PICT (Macintosh)

PICT (Macintosh)

Формат PICT является стандартным форматом для компьютеров Macintosh, содержащим растровую и векторную информацию. Используйте диалоговое окно Export PICT для установки опций:

Dimensions размер экспортируемого растрового изображения в пикселах. Flash обеспечивает сохранение пропорций.

Resolution устанавливает разрешение будущей картинки в точках на дюйм (dpi), после чего Flash автоматически пересчитает размеры. Для установки разрешения монитора, выберите Match Screen. Растровый PICT обычно использует 72 dpi.

Color Depth ) Определяет тип PICT файла, основанного на объектах или растре. Основанные на объектах изображения смотрятся лучше при печати и масштабирование не меняет их вид. Растровый PICT обычно выглядит лучше на экране и может обрабатываться в приложениях типа Adobe Photoshop. Можете также выбирать из ряда разрядностей цвета к файлам растровых PICT.

Include Postscript доступен только для основанного на объектах PICT файла, включает информацию, которая оптимизирует печать на PostScript принтере. Эта информация увеличивает размер файла и не распознается некоторыми приложениями.


About export file formats

Публикация и экспорт > Форматы экспортируемых файлов > PNG-последовательность и PNG-изображение

PNG-последовательность и PNG-изображение

Установки экспорта PNG подобны установкам публикации, кроме некоторых исключений:

Dimensions задает размер картинки в пикселах.

Resolution позволяет задать разрешение в точках на дюйм (dpi). Для установки разрешения монитора, выберите Match Screen.

Colors глубина цвета: 8-bit для 256-цветной картинки, 24-bit для полноцветной картинки, 24-bit with Alpha для полноцветной картинки с прозрачностью (32 bits).

Include позволяет задать размер включаемого пространства документа.

Filter подобны аналогичным установкам публикации.

Возможно задать Interlace (постепенную прорисовку в браузере), Smooth (сглаживание), Dither Solid Colors (размытие сплошных цветов).

Для дополнительной информации см. Публикация PNG-файлов.


About export file formats

Публикация и экспорт > Форматы экспортируемых файлов > QuickTime

QuickTime

Установки экспорта QuickTime позволяют создать клип с Flash анимацией в формате QuickTime 4. Отдельные слои Flash экспортируются как отдельные дорожки (track). Данный формат позволяет комбинировать интерактивные свойства Flash с особенностями QuickTime.

Установки идентичны установкам публикации QuickTime. См. Публикация клипов QuickTime 4.


About export file formats

Публикация и экспорт > Форматы экспортируемых файлов > QuickTime Video (Macintosh)

QuickTime Video (Macintosh)

Формат QuickTime Video преобразует проект Flash в последовательность изображений на видеодорожке (video track). Содержимое Flash преобразуется в растровые картинки без интерактивности. Формат используется для редактирования содержимого Flash в приложениях видеообработки.

Диалоговое окно Export QuickTime Video содержит следующие поля:

Dimensions указывает ширину и высоту кадров QuickTime-ролика в пикселах. По умолчанию вам надо указать только высоту или только ширину - и другой размер будет подставлен автоматически, чтобы сохранить пропорции оригинала. Если вы отключите Maintain Aspect Ratio, то сможете задать и ширину и высоту.

Format задает глубину цвета.

Smooth включает сглаживание Flash в экспортируемом QuickTime-ролике. Это улучшает отображение растровых кадров. Однако, растровые изображения могут иметь фантомный контур при помещении на цветную подложку.

Compressor выбирает стандартное QuickTime-сжатие (QuickTime-компрессор).

Quality управляет качеством сжатия ролика, эффект зависит от типа компрессора.

Sound Format устанавливает частоту сэмплирования звука в ролике. Чем выше - тем качественнее звук и тем больше объем файла.


Optimizing movies

Публикация и экспорт > Оптимизация клипов

Оптимизация клипов

Чем объёмнее файл вашего клипа, тем больше продолжительность его загрузки и медленнее воспроизведение. Вы можете принять некоторые меры, чтобы подготовить ваш клип для оптимального воспроизведения. Flash автоматически проводит некоторую оптимизацию клипов, как часть издательского процесса, обнаруживая продублированные объекты при экспорте, помещая их в файл лишь однажды и конвертируя вложенные группы в самостоятельные.

Перед экспортом вы можете оптимизировать клип, используя различные методы уменьшения его размера. После выполнении изменений, проверьте ваш клип на ряде различных компьютеров, операционных систем и Интернет-соединений.

Общие идеи оптимизации:

Используйте символы (symbols), анимированные или иные, для всех элементов, появляющихся более одного раза.
По возможности используйте автоматическую (tweened) анимацию, требующую меньшего объёма, чем ряд ключевых кадров.
Для анимационных последовательностей используйте мувиклипы (movie clips) вместо графических символов (symbols).
Ограничьте область изменений в каждом ключевом кадре, старайтесь сделать её наименьшей.
Избегайте анимировать растровые элементы, используйте растровые изображения в качестве фоновых или статичных элементов.
По возможности используйте наиболее ёмкий на данный момент звуковой формат - МP3.

Основы оптимизации элементов и линий:

Группируйте элементы в максимально возможной степени.
Используйте слои, чтобы отделить элементы, которые изменяются в течение анимации от тех которые не изменяются.
Используйте Modify > Curves > Optimize , чтобы минимизировать число отдельных линий, которые используются для описания объекта.
Ограничьте количество специальных типов линий, таких как: штриховая, пунктирная, неровная и так далее. Сплошные линии требуют меньшего объёма памяти. Линии, созданные инструментом "Карандаш" (Pencil tool) занимают меньше памяти, чем мазки кисти.

Принципы оптимизации текста:

Ограничьте количество используемых шрифтов и их начертаний. Разумно используйте шрифты, так как они увеличивают размер файла.
Для опций Embed Fonts, выбирайте только необходимые символы вместо включения всего шрифта.

Оптимизация цвета:

Используйте панель Effect (Window > Panels > Effect) для создания множества различно окрашенных образцов (instances) одного и того же элемента (symbol).
Используйте панель Mixer (Window > Panels > Mixer), чтобы согласовать цветовую палитру клипа к палитре, определенной в браузере.
Разумно используйте градиенты. Заполнение области цветом с градиентом требует памяти приблизительно на 50 байт больше, чем её заполнение однотонным цветом.
Разумно используйте альфа-прозрачность - она может замедлить воспроизведение.


About export file formats

Публикация и экспорт > Форматы экспортируемых файлов > WAV audio (Windows)

WAV audio (Windows)

Опция WAV Export Movie экспортирует все звуки в текущем ролике в один WAV-файл. Вы можете выбрать звуковой формат для нового файла.

Выберите Sound Format, чтобы определить частоту сэмплирования, разрешение и стерео или моно для экспортируемого звукового файла. Выбор Ignore Event Sounds исключает звуки, привязанные к событиям.


About export file formats

Публикация и экспорт > Форматы экспортируемых файлов > Windows AVI (Windows)

Windows AVI (Windows)

Экспортирует клип как Windows video, при этом утрачивается любая интерактивность. Windows AVI, стандартный для Windows формат, хорошо подходит для обработки Flash ролика в видеоредакторах. Поскольку AVI основывается на растровой графике, ролик с высоким разрешением очень быстро растет в размере.

Диалоговое окно Export Windows AVI содержит следующие поля:

Dimensions размеры кадров AVI-ролика в пикселах. По умолчанию вам надо указать только высоту или только ширину - и другой размер будет подставлен автоматически, чтобы сохранить пропорции оригинала. Если вы отключите Maintain Aspect Ratio, то сможете задать и ширину и высоту.

Video Format глубина цвета. Некоторые приложения еще не поддерживают формат изображений Windows с глубиной 32 бита. Если при использовании этого формата возникли проблемы, используйте старый формат в 24 бита.

Compress Video отображает диалог выбора настроек стандартного AVI-сжатия.

Smooth включает Flash-сглаживание в экспортируемых AVI-роликах. Сглаживание улучшает качество изображений, однако может давать серый фантомный контур при помещении изображений на цветную основу. В этом случае отключите опцию.

Sound Format задает частоту сэмплирования, разрешение и стерео или моно для звуковой дорожки. Для доп. информации см. Сжатие звука при экспорте.


About export file formats

Публикация и экспорт > Форматы экспортируемых файлов > Windows Metafile

Windows Metafile

Формат Windows Metafile является стандартным графическим форматом Windows и поддерживается большинством приложений. Импорт и экспорт файлов в этом формате дает хорошие результаты. Опции отсутствуют. См. Enhanced Metafile (Windows).


About HTML publishing templates

Публикация и экспорт > HTML-шаблоны для публикации

HTML-шаблоны для публикации

HTML шаблоны позволяют управлять процессом отображения и воспроизведения клипов в браузере. Шаблон представляет собой текстовый файл, содержащий HTML код и код или переменные шаблона. Когда происходит публикация Flash клипа, Flash заменяет переменные шаблона соответствующими HTML установками.

Flash включает в себя различные шаблоны, подходящие для нужд разных пользователей.

Очень просто использовать шаблоны, подгонять их под себя и публиковать клип. Если вы хорошо владеете HTML, вы можете сами создавать собственные шаблоны в любом HTML редакторе. Создание шаблона ничем не отличается от написания стандартной HTML страницы, за исключением того, что переменные шаблона начинаются со знака доллара ($).

Шаблоны Flash имеют следующие характеристики:

Однострочный заголовок, который видно в списке выбора шаблона
Длинное описание, появляющееся при нажатии на кнопку Info
Шаблонные переменные, начинающиеся со знака $, указывающие какой параметр должен подставляться при генерации
Примечание: Используйте \$, если собираетесь использовать этот знак в других целях.
Теги HTML OBJECT и EMBED соответствуют требованиям Microsoft Internet Explorer и Netscape Communicator/Navigator. Internet Explorer открывает Flash клип, используя тег OBJECT, Netscape использует тег EMBED. Для доп. информации см. Использование OBJECT и EMBED.


Customizing HTML publishing templates

Публикация и экспорт > Настройка HTML-шаблонов публикации

Настройка HTML-шаблонов публикации

Если вы хорошо знакомы с HTML, вы можете вручную править переменные HTML шаблона для создания карты изображений, отчета об используемом тексте, отчета об используемых ссылках или для задания собственных значений параметров тегов OBJECT и EMBED.

Flash шаблон может включать любое HTML-содержимое или код для специальных интерпретаторов типа Cold Fusion, ASP и т.п.

Для модификации HTML шаблона:

1 | Используя редактор HTML, откройте HTML шаблон, который хотите править, расположенный в папке Macromedia Flash 5/HTML.
2 | Нет необходимости включать в шаблон все шаблонные переменные. Flash просто не вставит значения для отсутствующих переменных, оставив значения по умолчанию.
 | Для информации о поддерживаемых переменных смотри таблицу.
 | Для информации о создании карты изображения или отчета об используемом тексте, отчета об используемых ссылках, смотри соответствующие разделы.
3 | Сохраните шаблон в той же папке Macromedia Flash 5/HTML.
 | Flash сохраняет модифицированные шаблоны с тем же именем, что и swf-файл.
4 | Для введения изменений в силу, зайдите в File > Publish Settings и в панели HTML выберите свой шаблон.
 | В выбранном в Publish Settings шаблоне Flash меняет только шаблонные переменные.
5 | Для доп. информации см. Публикация Flash-клипов.

Следующая таблица показывает все переменные, распознаваемые Flash. Для определения всех тегов, с которыми работают эти переменные, смотрите раздел Редактирование Flash установок в HTML.
Параметр | Шаблонная переменная
Заголовок шаблона | $TT
Начало описания шаблона | $DS
Конец описания шаблона | $DF
Ширина | $WI
Высота | $HE
Movie (Ролик) | $MO
HTML выравнивание | $HA
Looping (Зацикливание) | $LO
Параметры для OBJECT | $PO
Параметры для EMBED | $PE
Play (Воспроизведение) | $PL
Quality (Качество) | $QU
Scale (Масштаб) | $SC
Salign | $SA
Window mode | $WM
Devicefont | $DE
Bgcolor | $BG
Movie text (Текст, используемый в ролике) | $MT
Movie URL (ссылки, используемые в ролике) | $MU
Image width (Ширина изображения неуказанного типа) | $IW
Image height (Высота изображения неуказанного типа) | $IH
Image file name (Имя файла изображения неуказанного типа) | $IS
Image map name (Имя карты изображения) | $IU
Image map tag location (Месторасположение карты) | $IM
QuickTime width (Ширина ролика QuickTime) | $QW
QuickTime height (Высота ролика QuickTime) | $QH
QuickTime file name (Имя файла с роликом QuickTime) | $QN
GIF width (Ширина GIF-файла) | $GW
GIF height (Высота GIF-файла) | $GH
GIF file name (Имя GIF-файла) | $GS
JPEG width (Ширина JPG-файла) | $JW
JPEG height (Высота JPG-файла) | $JH
JPEG file name (Имя JPG-файла) | $JN
PNG width (Ширина PNG-файла) | $PW
PNG height (Высота PNG-файла) | $PH
PNG file name (Имя PNG-файла) | $PN
Переменные генератора для тега OBJECT | $GV
Переменные генератора для тега EMBED | $GE


Customizing HTML publishing templates

Публикация и экспорт > Выбор HTML шаблона > Создание карты изображения

Создание карты изображения

Flash может сгенерировать карту изображения (image map) для любой картинки и сохранять функции кнопок, даже если изображение будет заменено на другое. Flash вставляет код карты изображения в шаблон, когда находит шаблонную переменную $IM. Переменная $IU идентифицирует имя GIF, JPEG или PNG файла.

Для создания карты изображения:

1 | В Flash ролике выделите keyframe, в котором будет находиться карта изображения и пометьте его (label) как #Map (Windows > Panels > Frame).
 | Можете использовать любой ключевой кадр с кнопками, имеющими команды Get URL.
 | Если вы не пометите кадр, Flash создаст карту изображения в последнем кадре клипа.
2 | В редакторе HTML откройте HTML-шаблон, который хотите редактировать. Flash хранит HTML-шаблоны в папке Macromedia Flash 5/HTML.
3 | Сохраните шаблон.
4 | Выберите File > Publish Settings, зайдите в закладку Format и выберите тип карты изображения - GIF, JPEG или PNG.
5 | Нажмите OK для сохранения установок.

Например, эта вставка:

$IM
<IMG SRC=$IS usemap=$IU WIDTH=$IW HEIGHT=$IH BORDER=0>

создаст такой HTML-код при использовании Publish:

<MAP NAME="mymovie">
<AREA COORDS="130,116,214,182" HREF="http://www.macromedia.com">
</MAP>
<IMG SRC="mymovie.gif" usemap="#mymovie" WIDTH=550 HEIGHT=400 BORDER=0>


Customizing HTML publishing templates

Публикация и экспорт > Выбор HTML шаблона > Создание отчета об используемом тексте

Создание отчета об используемом тексте

Шаблонная переменная $MT вставляет весь текст, используемый в ролике, в виде комментария в HTML-код. Это полезно для целей индексирования содержимого ролика и делает его видимым для поисковых машин.


Customizing HTML publishing templates

Публикация и экспорт > Выбор HTML шаблона > Создание отчета об используемых ссылках

Создание отчета об используемых ссылках

Шаблонная переменная $MU генерирует список ссылок (URL), которые используются в данном ролике и вставляет этот список в указанном месте в виде комментария. Это позволяет верификаторам ссылок проверить их правильность.


Customizing HTML publishing templates

Публикация и экспорт > Выбор HTML шаблона > Использование сокращенных шаблонных переменных

Использование сокращенных шаблонных переменных

Шаблонные переменные $PO (для тега OBJECT) и $PE (для тега EMBED) являются полезными сокращенными элементами. Обе эти переменные вставляют в шаблон значения не по умолчанию для некоторых из большинства общих для OBJECT и EMBED параметров, включая PLAY ($PL), QUALITY ($QU), SCALE ($SC), SALIGN ($SA), WMODE ($WM), DEVICEFONT ($DE) и BGCOLOR ($BG). Для примера смотри стандартный шаблон в следующем подразделе.


Customizing HTML publishing templates

Публикация и экспорт > Выбор HTML шаблона >Пример шаблона

Пример шаблона

Здесь приведен пример шаблона, который включает многие из используемых переменных шаблона.

$TTFlash Only (Значение по умолчанию)
$DS
Используйте теги OBJECT и EMBED для отображения Flash.
$DF
<HTML>
<HEAD>
<TITLE>$TI</TITLE>
</HEAD>
<BODY bgcolor="$BG">

<!-- URL используемые в ролике-->
$MU
<!-- Текст используемый в ролике-->
$MT

<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"

 codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0"
 ID=$TI WIDTH=$WI HEIGHT=$HE>
 $PO
<EMBED $PE WIDTH=$WI HEIGHT=$HE
 TYPE="application/x-shockwave-flash"
PLUGINSPAGE="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash"></EMBED>
</OBJECT>

</BODY>
</HTML>


Testing movie download performance

Публикация и экспорт > Тестирование процесса загрузки клипа

Тестирование процесса загрузки клипа

Для обнаружения возможных мест возникновения пауз во время загрузки вы можете протестировать отдельную сцену или ролик целиком, используя соответствующие команды Test Scene и Test Movie или просто попробовать воспроизвести существующий SWF-файл. Если необходимые данные не загрузятся к определённому времени, клип, достигнув соответствующего кадра, остановится пока они ни будут загружены.

Для отображения процесса загрузки в графическом виде, используйте диаграмму Bandwidth Profiler, которая показывает сколько данных передаётся каждому кадру клипа при определённой скорости соединения (пропускной способности канала). Моделируя скорость загрузки, Bandwidth Profiler использует оценочные значения стандартного сетевого процесса, а не конкретную скорость соединения. Например, 28.8 Kbps-модем теоретически может загружать данные со скоростью 3.5 Kбайт/с. Но если вы выберете 28.8 в соответствующем меню, Flash установит фактическое значение, равное 2.3 Kбайт/с, для более точного моделирования процесса.

Вы также можете сгенерировать отчёт для обнаружения кадров, замедляющих воспроизведение, а затем оптимизировать или удалить в них часть содержимого. Для этого воспользуйтесь опцией Select Generate Report в диалоговом окне Publish Settings.

Чтобы изменить настройки для SWF-файла, созданного вызовом Test Movie или Test Scene, выберите File > Publish Settings. См. Предварительный просмотр и тестирование клипов.

Чтобы проверить процесс загрузки:

1 | Используйте один из следующих вариантов:
 | выберите Control > Test Scene или Control > Test Movie.
 | Flash откроет окно Output, которое поможет обнаружить и отладить ошибки в вашем ActionScript. Можете воспользоваться функцией Trace для вывода комментариев в окно Output, помогающих при отладке. Для более детальной информации, см. соответствующий раздел в Справочнике по ActionScript.
 | выберите File > Open и вызовите ваш SWF-файл.
 | Если тестируете сцену или клип, Flash публикует выбранный фрагмент как SWF-файл, используя установки в диалоговом окне Publish Settings. (См. Публикация Flash-клипов.) SWF-файл открывается в новом окне и тут же начинается его воспроизведение.
2 | В меню Flash-плейера Debug, выберите скорость загрузки, которая будет моделироваться Flash: 14.4 Kbps, 28.8 Kbps, 56 Kbps. Для ввода персональных настроек, выберите Customize.
3 | Во Flash-плейере выберите View > Bandwidth Profiler для графического отображения процесса загрузки:
 | Левая часть диаграммы содержит информацию о клипе, его настройки и состояние. Секция Movie отражает геометрические размеры, частоту кадров, объём в килобайтах и байтах, продолжительность (в кадрах и секундах) и количество предварительно загруженных кадров и затраченных на это секунд.
 | Правая секция диаграммы содержит временную линейку и график. На графике каждая полоса представляет собой определённый кадр клипа. Размер полосы соответствует объёму кадра в байтах. Нижняя красная линия внизу временной линейки указывает, возможно ли потоковое воспроизведение данного кадра в реальном времени на скорости соединения, выбранной в меню Control. Если полоса её пересекает, клипу придется дожидаться загрузки соответствующего кадра.
4 | Выберите View > Show Streaming для включения и выключения потокового режима.
 | Линейка в верхней части графика указывает количество загруженных кадров в момент воспроизведения текущего кадра, обозначаемого бегунком.
5 | С помощью щелчка кнопкой мыши на определённой полосе графика вы можете просмотреть установки для соответствующего кадра и остановить воспроизведение.
6 | При желании внешний вид графика может быть изменён:
 | Выберите View > Streaming Graph для отображения кадров, приводящих к возникновению пауз.
 | Этот внешний вид (установка по умолчанию) представляет собой чередующиеся светло- и тёмно-серые блоки, соответствующие определённым кадрам. Размер блока отражает относительный объём кадра в байтах. Первый кадр хранит информацию о символах, поэтому он обычно больше, чем остальные.
 | Выберите View > Frame by Frame Graph для отображения размера каждого кадра.
 | Этот вид помогает увидеть, какие кадры приводят к потоковым задержкам. Если какие-либо блоки пересекают красную линию на графике, это означает, что Flash-плейер прекратит воспроизведение до полной загрузки соответствующих им кадров.
 | Bandwidth Profiler показывает потоковую линейку и покадровый график
7 | Закройте тестовое окно, для того чтобы вернуться в режим редактирования.

Настроив однажды тестовые установки, включающие и Bandwidth Profiler, вы можете открывать SWF-файл непосредственно в тестовом режиме. Файл откроется в окне плейера совместно с Bandwidth Profiler и другими выбранными опциями просмотра.

Для более детальной информации по отладке клипов, см. раздел, посвящённый поиску и устранению ошибок в Справочнике по ActionScript.

Для того, чтобы сгенерировать отчёт, содержащий покадровую информацию об окончательном файле в формате Flash-плейера:

1 | Выберите File > Publish Settings.
2 | Выберите Generate Size Report.
3 | Нажмите кнопку Publish.
 | Flash сгенерирует текстовый файл, имеющий то же имя, что и экспортируемый клип, но с расширением .txt. Полученный отчёт содержит запрошенную покадровую информацию.


Editing Flash HTML settings

Публикация и экспорт > Редактирование Flash установок в HTML

Редактирование Flash установок в HTML

Документ HTML требуется для воспроизведения Flash-клипа в браузере, а также для задания ему некоторых установок. Если вы опытны в написании HTML-документов, можете вручную описывать или менять эти параметры в HTML-редакторе или создавать HTML-файлы для управления Flash-клипом.

Для информации об автоматическом создании HTML во время публикации см. Публикация Flash-клипов. Для информации о выборе HTML-шаблона см. Выбор HTML-шаблона.


Editing Flash HTML settings

Публикация и Экспорт > Редактирование установок Flash HTML > Использование OBJECT и EMBED

Использование OBJECT и EMBED

Для демонстрации Flash-ролика в броузере, HTML-документ должен содержать теги OBJECT и EMBED с соответствующими параметрами.

С тегом OBJECT непосредственно используются четыре атрибута (HEIGHT, WIDTH, CLASSID, и CODEBASE), все остальные параметры передаются через тег PARAM. Например:

<OBJECT CLASSID="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" WIDTH="100"
HEIGHT="100" CODEBASE="http://active.macromedia.com/flash5/cabs/
swflash.cab#version=5,0,0,0">
<PARAM NAME="MOVIE" VALUE="moviename.swf">
<PARAM NAME="PLAY" VALUE="true">
<PARAM NAME="LOOP" VALUE="true">
<PARAM NAME="QUALITY" VALUE="high">
</OBJECT>

С тегом EMBED непосредственно используются все атрибуты (такие как HEIGHT, WIDTH, QUALITY, и LOOP), например:

<EMBED SRC="moviename.swf" WIDTH="100" HEIGHT="100" PLAY="true"
LOOP="true" QUALITY="high"
PLUGINSPAGE="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash">
</EMBED>

При использовании двух тегов вместе, просто вставляйте тег EMBED перед закрытием тега OBJECT, например:

<OBJECT CLASSID="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" WIDTH="100"
HEIGHT="100" CODEBASE="http://active.macromedia.com/flash5/cabs/
swflash.cab#version=5,0,0,0">
<PARAM NAME="MOVIE" VALUE="moviename.swf">
<PARAM NAME="PLAY" VALUE="true">
<PARAM NAME="LOOP" VALUE="true">
<PARAM NAME="QUALITY" VALUE="high">

<EMBED SRC="moviename.swf" WIDTH="100" HEIGHT="100" PLAY="true"
LOOP="true" QUALITY="high"
PLUGINSPAGE="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash">
</EMBED>

</OBJECT>

Замечание: Если вы используете оба тега OBJECT и EMBED, присваивайте одинаковые значения идентичным атрибутам, что обеспечит корректное воспроизведение клипа в различных броузерах. Параметр swflash.cab#version=5,0,0,0 необязательный, и вы можете опустить его, если не хотите проверять номер версии.

Все рассмотренные теги и их атрибуты присутствуют в HTML-коде, созданном с помощью команды Publish. При создании собственного HTML документа вы можете справляться с данным примером. За исключением упомянутых атрибутов, все параметры применимы к обоим тегам OBJECT и EMBED. Необязательные параметры оговорены. При использовании шаблона, вы просто можете заменять значение параметров на свои. См. Настройка издательских HTML шаблонов.


Editing Flash HTML settings

Публикация и Экспорт > Редактирование установок Flash HTML > SRC

SRC

Значение

movieName.swf

Переменная шаблона: $MO

Описание

Задает имя загружаемого клипа. Только для тега EMBED.


Editing Flash HTML settings

Публикация и Экспорт > Редактирование установок Flash HTML > MOVIE

MOVIE

Значение

movieName.swf

Переменная шаблона: $MO

Описание

Задает имя загружаемого клипа. Только для тега OBJECT.


Editing Flash HTML settings

Публикация и Экспорт > Редактирование установок Flash HTML > CLASSID

CLASSID

Значение

clsid:D27CDB6E-AE6D-11cf-96B8-444553540000

Описание

Устанавливает ActiveX управление браузера. Значение должно быть введено точно так, как показано выше. Только для тега OBJECT.


Editing Flash HTML settings

Публикация и Экспорт > Редактирование установок Flash HTML > WIDTH

WIDTH

Значение

n или n%

Переменная шаблона: $WI

Описание

Задает ширину клипа в окне браузера в пикселах или процентах.


Editing Flash HTML settings

Публикация и Экспорт > Редактирование установок Flash HTML > HEIGHT

HEIGHT

Значение

n или n%

Переменная шаблона: $HE

Описание

Задает высоту клипа в окне браузера в пикселах или процентах.

Поскольку Flash клипы масштабируемы, их качество не зависит от размера, пока соблюдается нужное соотношение ширина/высота. (Например, следующие размеры имеют соотношение 4:3: 640 на 480 пикселов, 320 на 240 пикселов, и 240 на 180 пикселов.)


Editing Flash HTML settings

Публикация и Экспорт > Редактирование установок Flash HTML > CODEBASE

CODEBASE

Значение

http://active.macromedia.com/flash5/cabs/swflash.cab#version=5,0,0,0"

Описание

Указывет местоположение в сети Flash Player, чтобы браузер смог автоматически подгрузить его, если плагин не установлен. Значение должно быть прописано точно так, как показано выше. Только для тега OBJECT.


Editing Flash HTML settings

Публикация и Экспорт > Редактирование установок Flash HTML > PLUGINSPAGE

PLUGINSPAGE

Значение

http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash

Описание

Указывет местоположение в сети Flash Player, чтобы пользователь смог загрузить его, если плагин не установлен. Значение должно быть прописано точно так, как показано выше. Только для тега EMBED.


Editing Flash HTML settings

Публикация и Экспорт > Редактирование установок Flash HTML > SWLIVECONNECT

SWLIVECONNECT

Значение

true | false

Описание

(Необязательный параметр) Определяет, должен ли броузер запустить Java при загрузке Flash плеера впервые. По умолчанию значение false. Если вы используете JavaScript и Flash на одной странице, Java должна быть запущена для работы FSCommand. Однако, если вы используете JavaScript только для обнаружения программы просмотра или некоторых других целей, не связанных с FS Commands, можно запретить старт Java, устанавливая значение SWLIVECONNECT в false. Можно также принудительно запускать Java, даже если не используете JavaScript совместно с Flash, устанавливая SWLIVECONNECT в true. Java существенно увеличивает время запуска Flash ролика, применяйте значение true для этого тэга лишь в случае необходимости. Только для тега EMBED.

Используйте Exec FS Command, чтобы запустить Java для автономного Flash плеера. См. Управление Flash Player.


About Generator and Flash

Публикация и экспорт > Генератор и Flash

Генератор и Flash

Генератор позволяет расширить первоначальные возможности Flash, предоставляя возможность дизайнерам разрабатывать богатые мультимедийные проекты с использованием широкого спектра статических и динамических форматов.

Любой объект, созданный во Flash — библиотечные элементы, символы, анимация, Timelines и публикуемый полученный файл, может быть преобразован в объект генератора, используя символы и переменные генератора. Переменные генератора - это текст, заключённый в фигурные скобки, например, {text}. Используя генератор для создания мультимедийных сетевых приложений реального времени, вы можете выбрать наиболее удобное визуальное представление информации в доступных средствах просмотра, таких как: прокручивающиеся списки, диаграммы и графики (основной, pie, резервный, фрагментированный), таблицы, ряд различных графических форматов, звук и клипы.

Если Generator 2 установлен, вы можете создавать во Flash шаблоны, содержащие переменные элементы генератора (графика, текст и звук), которые могут замещаться содержимым какого-либо источника данных (текстовые файлы, базы данных и т.д.). Сгенерированный таким образом проект может быть воспроизведён в клиентском браузере в качестве клипа Flash-плейера или как JPEG, PNG, GIF, анимационный GIF или QuickTime-файл.

Во Flash генератор может быть использован следующими способами:

В панели генератора (Generator) диалогового окна Publish Settings, вы можете определить способ взаимодействия Flash-клипа и генератора, а именно: установленные по умолчанию частота кадров, его размеры и цвет фона. См. Публикация шаблонов генератора.
Вы можете редактировать HTML-шаблоны Flash для работы с генератором. См. Настройка HTML-шаблонов публикации.
Вы можете обновлять пары имя/значение для генератора, используя Movie Explorer. Эти пары не что иное, как имена, связанные со значениями, такими как параметры URL. Для более детальной информации о Movie Explorer, см. Использование Movie Explorer.

Для получения более подробной информации о генератору посетите сайт, посвящённый генератору или см. документацию к вашему Generator 2.


Editing Flash HTML settings

Публикация и Экспорт > Редактирование установок Flash HTML > PLAY

PLAY

Значение

true | false

Переменная шаблона: $PL

Описание

(Необязательный параметр) Определяет, будет ли ролик воспроизводиться немедленно после загрузки в браузер. Если ролик интерактивный, можно позволить пользователю инициировать воспроизведение, например, после клика по кнопке. В этом случае установите аттрибут PLAY в false для предотвращения автоматического воспроизведения. По умолчанию установлено значение true.


Editing Flash HTML settings

Публикация и Экспорт > Редактирование установок Flash HTML > LOOP

LOOP

Значение

true | false

Переменная шаблона: $LO

Описание

(Необязательный параметр) Определяет, будет ли ролик после завершения воспроизводиться заново или останавливаться при достижении последнего фрейма. По умолчанию установлено значение true.


Editing Flash HTML settings

Публикация и Экспорт > Редактирование установок Flash HTML > QUALITY

QUALITY

Значение

low | high | autolow | autohigh | best

Переменная шаблона: $QU

Описание

(Необязательный параметр) Определяет уровень сглаживания экранных неровностей (anti-aliasing) во время воспроизведения клипа. Поскольку сглаживание требует быстрого процессора, выбирайте значение исходя из того, что для вас наиболее важно: скорость или качество прорисовки:

Low - Полное отсутствие сглаживания.
Autolow - Устанавливается больший приоритет скорости воспроизведения, потом, где возможно, улучшается прорисовка. воспроизведение начинается с отключенным anti-aliasing. Если Flash Player определяет, что процессор в состоянии справиться с этим - anti-aliasing включается..
Autohigh - Сначала устанавливаются приоритеты скорости воспроизведения и прорисовки равными, потом, если необходимо, прорисовка приносится в жертву скорости. Воспроизведение начинается с включенным anti-aliasing. Если фактический статус фрейма падает ниже определенного уровня - эффект anti-aliasing отключается для повышения скорости воспроизвеления. Используйте эту установку для эмуляции View > Antialias установки во Flash.
Medium - Применяется anti-aliasing ко всему, кроме растровых картинок. Качество находится в промежутке между установками Low и High.
High - Везде применяется anti-aliasing. Если клип содержит анимацию, растровые картинки не сглаживаются.
Best - Наилучшее качество, скорость воспроизведения не принимается в расчет, ко всему применяется anti-aliasing.

По умолчанию Quality установлен в high .


Editing Flash HTML settings

Публикация и Экспорт > Редактирование установок Flash HTML > BGCOLOR

BGCOLOR

Значение

#RRGGBB (hexadecimal RGB value)

Переменная шаблона: $BG

Описание

(Необязательный параметр) Устанавливает цвет фона ролика. Используйте этот атрибут для перерисовки цвета фона, определенного в Flash файле. Этот аттрибут не влияет на цвет фона вашей HTML страницы.


Editing Flash HTML settings

Публикация и Экспорт > Редактирование установок Flash HTML > SCALE

SCALE

Значение

showall | noborder | exactfit

Переменная шаблона: $SC

Описание

(Необязательный параметр) Определяет, как ролик будет размещен в окне браузера, когда значения WIDTH и HEIGHT установлены в процентах.

Show all - значение по умолчанию, делает ролик видимым в определенной области, при этом сохраняются исходное соотношение сторон. Не происходит никакого искажения. Могут появиться границы с обеих сторон ролика.
No Border - масштабирует ролик, заполняя определенную область при сохранении исходного соотношения. Не происходит никакого искажения. Части ролика могут быть обрезаны.
Exact Fit - делает ролик видимым в определенной области, не делается никакой попытки сохранения исходного соотношения и может произойти искажение.

По умолчанию используется showall, если WIDTH и HEIGHT установлены в процентах.


Editing Flash HTML settings

ALIGN

Значение

L | R | T | B

Переменная шаблона: $HA

Описание

Определяет аттрибуты ALIGN у тегов OBJECT, EMBED и IMG, а также определяет, как окно Flash ролика будет располагаться в окне браузера.

По умолчанию ролик располагается в центре окна браузера, а в случае, если размеры окна браузера меньше чем у ролика, происходит обрезание краев.
Left, Right, Top и Bottom - располагает ролик, выравнивая его по соответствующему краю, обрезая остальные, если это необходимо.


Editing Flash HTML settings

Публикация и Экспорт > Редактирование установок Flash HTML > SALIGN

SALIGN

Значение

L | R | T | B | TL | TR | BL | BR

Переменная шаблона: $SA

Описание

(Необязятельный параметр) Задает расположение Flash ролика, масштабированного в соответствии с установками WIDTH и HEIGHT. См. SCALE для доп. информации.

L, R, T, и B - выравнивает ролик по соответствующему краю (L - левый, R - правый, T - верхний, B - нижний), при необходимости обрезая остальные.
TL и TR - располагает ролик в верхнем левом и в верхнем правом углах соответственно, при необходимости обрезая нижний край и правый или левый.
BL and BR - располагает ролик в нижнем левом и в нижнем правом углах соответственно, при необходимости обрезая верхний край и правый или левый.

Если этот аттрибут опущен, ролик располагается по центру окна браузера. При необходимости может произойти обрезание краев или могут появиться границы с любой стороны.


Editing Flash HTML settings

Публикация и Экспорт > Редактирование установок Flash HTML > BASE

BASE

Значение

base directory or URL

Описание

(Необязательный параметр) Определяет основную директорию или URL при относительной адресации файлов. Атрибут также полезен, если ролики располагаются в разных директориях и вызываются из раных файлов.


Редактирование установок Flash HTML

Публикация и Экспорт > Редактирование установок Flash HTML > MENU

MENU

Значение

true | false

Переменная шаблона: $ME

Описание

(Необязательный параметр) Определяет тип контекстного меню, появляющегося при щелчке правой кнопкой мышки (Windows) или при command-clicking (Macintosh) в области ролика, просматриваемого в браузере.

True показывает полное меню, позволяющее пользователю воспользоваться всеми доступными функциями Flash Player.
False меню будет содержать только пункт About Flash.

По умолчанию true.


Editing Flash HTML settings

Публикация и Экспорт > Редактирование установок Flash HTML > WMODE

WMODE

Значение

Window | Opaque | Transparent

Переменная шаблона: $WM

Описание

(Необязательный параметр) Позволяет воспользоваться преимуществами прозрачного фона, абсолютного позиционирования и возможностями послойного позиционирования в Internet Explorer 4.0. Этот тег работает только под Windows с управлением Flash Active X.

Window - воспроизводитт ролик в отдельном прямоугольном окне страницы.
Opaque - помещает ролик на задний план страницы.
Transparent - позволяет фону HTML страницы просвечивать через все прозрачные места ролика. При использовании этой опции преобразования с анимацием могут быть замедлены.

По умолчанию установлено Window. Только для тега Object.


Publishing Flash movies

Публикация и экспорт > Публикация Flash-клипов

Публикация Flash-клипов

Публикация Flash-клипов в сети (Web) является двухступенчатым процессом. Сначала, вы должны подготовить все файлы, необходимые для завершённого Flash-приложения с помощью команды Publish Settings. Затем, вы публикуете клип и все его файлы с помощью команды Publish. Чтобы подготовить содержимое вашего клипа для использования в других приложениях, существует команда Export; см. Экспорт клипов и изображений.

Команда Publish Settings позволяет выбрать форматы и определить параметры настройки для конкретных файлов в составе вашего клипа, таких как GIF, JPEG или PNG, а затем сохранить выбранные установки с самим клипом.

В зависимости от того, что вы установили в диалоговом окне Publish Settings, команда Publish создаёт следующие файлы:

Flash-клип для Web (SWF-файл).
Дополнительные (альтернативные) изображения различных форматов, появляющиеся автоматически, если Flash-плеер недоступен (GIF, JPEG, PNG и QuickTime).
HTML-документ, требуемый для отображения клипа (или альтернативного изображения) в браузере и управления параметров настройки браузера.
Автономные прожекторы как для Windows, так и для Macintosh, а также QuickTime-видео (EXE, HQX или MOV, соответственно).

Для изменения или обновления клипа созданного командой Publish, вы должны редактировать первоначальный Flash-клип, а потом снова использовать команду Publish во избежание потери оригинальной информации. Клип импортированный обратно во Flash в формате Flash-плейера теряет часть первоначальной информации.

Для установки опций публикации файлов Flash-клипа:

1 | Определите, где вы будете публиковать свои файлы:
 | Создайте папку, в которую хотите поместить публикуемые файлы и сохранить файл вашего клипа.
 | Откройте существующую папку и сохраните файл клипа.
2 | Выберите Choose File > Publish Settings.
3 | Выберите опцию для каждого файлового формата, который вы хотите создать.
 | HTML-формат выбирается автоматически, потому что он необходим для отображения вашего клипа в браузере. Кроме того, если выбранный формат имеет параметры настройки, в верхней части активной панели в диалоговом окне появляется соответствующая закладка. Выбор таких форматов изображений, как GIF, JPEG или PNG автоматически добавляет необходимый HTML-код для отображения этого изображения, если Flash-плеер недоступен.
 | Для более детальной информации по параметрам настройки для конкретных форматов см. последующие разделы.
4 | Для выбора имени (Filename), используйте одну из следующих опций:
 | Use default names - переключатель, указывающий на использование имён по умолчанию.
 | Снимите пометку Use Default Name. Затем введите ваше уникальное имя файла.
 | Вы можете выбрать, куда вы будете публиковать файлы и использовать для каждого уникальный путь (например, если вы хотите сохранить SWF-файлы в одной папке, а HTML в другой). Работая с ОС Windows, используйте символ обратного слэша (\) для указания иерархии каталог/папка/файл; при работе с Macintosh, используйте знак двоеточия (:). Для указания относительного пути используйте ..\, определяя путь на жёстком диске; для абсолютного пути, укажите имя диска. Например:
 | для Windows, абсолютный путь указывается следующим образом: C:\Folder\filename.swf, где C: - имя диска, \Folder - имя папки и filename.swf - имя самого файла.
 | Для Macintosh, абсолютный путь будет выглядеть HardDrive name:Folder:filename.swf.
5 | Для создания прожектора, выберите Windows Projector или Macintosh Projector.
 | Хотя вы можете создать Macintosh-прожектор с помощью Windows-версий Flash, вы должны использовать файл-транслятор такой, как BinHex, чтобы полученный файл был виден как файл приложения в Macintosh Finder. Версия Flash для Windows создает файлы Macintosh-прожектора с расширением .hqx.
6 | Введите уникальное имя файла (Filename) или выберите Use Default Name для создания файлов с использованием имён, предложенных Flash, с соответствующим расширением для определённого формата.
7 | Если вы хотите поменять опции формата, выберите мышью соответствующую закладку в верхней части активной панели в диалоговом окне. Определение настроек для каждого формата описано более детально в последующих разделах.
8 | По окончании редактирования параметров настройки сделайте одно из двух:
 | Для того чтобы сгенерировать все выбранные файлы, нажмите Publish, затем ОК для закрытия диалогового окна.
 | Для того чтобы сохранить настройки с вашим файлом и закрыть диалоговое окно без публикации, нажмите ОК

Для публикации Flash-клипа:

1 | Если необходимо, установите опции для файлов, как описано выше.
2 | Выберите File > Publish, чтобы создать файлы указанных в диалоговом окне Publish Settings форматов, расположенные в соответствующих папках.


Configuring a Web server for Flash

Публикация и Экспорт > Конфигурирование web сервера для Flash

Конфигурирование web сервера для Flash

Когда файлы располагаются на сервере, он должен корректно определить их, как файлы Flash Player. Если MIME тип отсутствует или неправильно определен сервером, браузер может выдать сообщение об ошибке или пустое окно с иконкой.

Возможно ваш сервер уже настроен должным образом. Для проверки конфигурации см. TechNote #12696 Macromedia Flash Support Center. Если же сервер настроен неправильно, то вы или администратор вашего сервера должны добавить тип Flash Player MIME в файл конфигурации сервера и ассоциировать этот MIME тип с расширением Flash Player:

MIME type application/x-shockwave-flash has the .swf file extension.
MIME type application/futuresplash has the .spl file extension.

Если вы администрируете ваш сервер, посмотрите в документации программного обеспечения сервера инструкцию по добавлению или конфигурированию MIME типов. Если вы не являетесь администратором сервера, свяжитесь с вашим провайдером, вебмастером, отделом информационных технологий и узнайте у них необходимую информацию о MIME типах.

Если ваш сайт располагается на сервере Macintosh, вы должны установить следующие параметры: Action: Binary; Type: SWFL; и Creator: SWF2.


Screening traffic to your Web site

Публикация и Экспорт > Проверка трафика Web-сайта

Проверка трафика Web-сайта

Когда делаете Flash-публикацию для Web, вы можете настроить ваш Web-сервер так, чтобы автоматически определялось, имеет ли пользователь Flash Player плагин или поддержку ActiveX. Воспользуйтесь Macromedia Flash Dispatcher, который входит в Macromedia Flash (SWF) Deployment Kit, в папке Macromedia Flash 5/Goodies. 1

Dispatcher представляет из себя комбинацию JavaScript, VBScript и данных Flash. Он определяет, есть ли у пользовательского броузера установленный Flash-плагин или ActiveX и если да, то какой версии. Можно сконфигурировать Dispatcher для загрузки Flash содержимого документа, загрузить другое содержимое или заметить обновление или инсталляцию плагина.

Для дополнительной информации см. файл ReadMe и документацию к Flash (SWF) Deployment Kit в папке Macromedia Flash 5/Goodies.

От редактора:

  1. Гораздо эффективнее можно это сделать, воспользовавшись рекомендациями, приведенными на http://polar-lights.com/fla/detection.html


Публикация Flash-клипов

Публикация и экспорт > Публикация Flash-клипов > Публикация Flash-клипов в формате Flash-плейера

Публикация Flash-клипов в формате Flash-плейера

Публикуя клип в формате Flash-плейера, вы можете установить опции сжатия звука и изображения и опцию защиты вашего клипа от импорта обратно во Flash-редактор. Используйте соответствующие элементы настройки в панели диалогового окна Publish Settings, чтобы задать необходимые параметры.

Чтобы опубликовать клип в формате Flash-плейера:

1 | Выберите File > Publish Settings и щёлкните курсором по закладке Flash.
2 | Задайте порядок загрузки (Load Order), согласно которому Flash будет загружать слои (leyers) клипа для отображения его первого кадра: снизу вверх (Bottom Up) или сверху вниз (Top Down).
 | Эта опция указывает часть клипа, которая прорисуется в первую очередь в случае медленного сетевого или модемного соединения.
3 | Выберите Generate Size Report, чтобы сгенерировать отчёт, содержащий информацию об объёме данных в окончательном файле Flash-плейера. См. Тестирование процесса загрузки клипа.
4 | Чтобы отладка публикуемого SWF-файла стала возможной, выберите любую из следующих опций:
 | Omit Trace Actions - Flash будет игнорировать команду Trace в данном ролике, что предотвращает вывод комментариев в окне Output.
 | Для получения более подробной информации, см. соответствующий раздел в Справочнике по ActionScript.
 | Protect from Import - запрещает импортировать SWF-файл обратно во Flash-редактор и преобразовать его во Flash-файл (FLA).
 | Debugging Permitted - активирует отладчик и позволяет производить удалённую отладку Flash-клипа. Если вы выберете эту опцию, то сможете защитить дебагер паролем.
 | Если эта опция выбрана, в поле Password введите ваш пароль для предотвращения несанкционированного доступа к отладке клипа, для которого установлена опция разрешения отладки. После выбора пароля отладка возможна лишь при верном его вводе. Чтобы удалить пароль, оставьте поле Password пустым.
 | Для более детальной информации об отладчике см. соответствующий раздел в Справочнике по ActionScript.
5 | Для управления сжатием растровых изображений установите с помощью слайдера качества JPEG или непосредственно введите нужное значение.
 | Чем ниже качество изображения, тем меньше размер файла и наоборот, высокое качество ведёт к большим размерам. Попробуйте различные установки для определения наилучшего соотношения между размером и качеством, значение 100 соответствует самому высокому качеству и наименьшему сжатию.
6 | Если вы не задали частоту и сжатие для конкретного звука в диалоговом окне Sound Properties или хотите изменить текущие настройки, выберите следующую опцию:
 | Нажмите Set Audio Stream для установки экспортируемых значений для всех звуков клипа, затем воспользуйтесь диалоговым окном Sound Properties для установки звукового потока. Потоковый звук начинает воспроизводиться, как только подгружено достаточно данных для первых нескольких кадров, такой звук синхронизуется с линейкой (Timeline) для воспроизведения на вебсайте.
 | Нажмите Set Audio Event, чтобы экспортировать частоту и сжатие для всех звуков клипа, затем воспользуйтесь диалоговым окном Sound Properties для установки звуков события. Звук события должен быть загружен полностью до начала воспроизведения и он воспроизводится, пока не будет остановлен явно или проигран до конца.
 | Выберите Override Sound Settings, чтобы отменить настройки в диалоговом окне Sound Properties для определённых звуков и создать высококачественный звуковой ролик большого объёма для локального использования и небольшой файл с низким качеством звука для Web.
 | Для получения инструкций по изменению этих настроек, см. Сжатие звука для экспорта.
7 | Выберите версию Flash. Не все характеристики Flash 5 работают в клипах, опубликованных как более ранние версии Flash.
8 | Чтобы сохранить настройки, нажмите OK.


Publishing Flash movies

Публикация и экспорт > Публикация Flash-клипов > Публикация HTML для файлов Flash-плейера

Публикация HTML для файлов Flash-плейера

Воспроизведение Flash-клипа в Web-браузере требует наличия HTML-документа, активизирующего ролик и задающего настройки браузера. Этот документ генерируется автоматически с помощью команды Publish из HTML-параметров шаблона.

Параметры HTML определяют, где в окне размещается Flash-клип, цвет фона, размеры клипа и т.д. и устанавливают атрибуты для тегов OBJECT и EMBED. Вы можете изменить их и другие настройки в панели HTML диалогового окна Publish Settings. Изменение параметров автоматически отменит опции, определённые вами ранее.

Ваши настройки вносятся в шаблонный документ. Этот шаблон может быть любым текстовым файлом, содержащим соответетствующие переменные, а именно: простой HTML-файл, файл, имеющий коды для специальных интерпретаторов, таких как ColdFusion или Active Server Pages (ASP) или шаблон, включающий Flash (для более подробной информации см. HTML-шаблоны для публикации).

Вы можете также модифицировать шаблоны (см. Настройка HTML-шаблонов публикации) или вести необходимые параметры HTML вручную с помощью любого HTML-редактора (см. Редактирование Flash установок в HTML).

Чтобы опубликовать HTML-документ, отображающий Flash-файл:

1 | Выберите File > Publish Settings.
 | HTML-файл установлен по умолчанию.
2 | Введите уникальное имя файла в поле Filename или выберите Use Default Name, чтобы создать файл с именем исходного Flash-файла и расширением .html
3 | Щёлкните курсором по закладке HTML, чтобы рассмотреть доступные настройки.
4 | Выберите один из установленных шаблонов из выпадающего меню Template, нажав справа на кнопку Info можно просмотреть описание выбранного шаблона.
 | Меню содержит все файлы шаблонов из директории Macromedia Flash 5/HTML. Основной шаблон просто отображает клип в браузере, а наиболее продвинутые шаблоны содержат коды для определения типа браузера и других характеристик. Если вы не выбрали ни один шаблон, Flash использует шаблон по умолчанию —Default.html— или, если этот шаблон отсутствует, Flash возьмёт первый указанный в списке шаблон.
 | Flash сохраняет изменённый шаблон, используя имя файла Flash-клипа с расширением шаблона. Например, если вы выбрали шаблон, называющийся Standard.asp для использования совместно с Flash-роликом с именем MyMovie.swf, то окончательным файлом будет MyMovie.asp.
5 | Выберите положение опции размеров (Dimensions) для установки величин атрибутов WIDTH и HEIGHT в тегах OBJECT и EMBED:
 | Выберите Match Movie (установка по умолчанию) для использования реального размера клипа.
 | Выберите Pixels, чтобы в поля Width и Height указать размер в пикселах.
 | Выберите Percent, чтобы использовать процентное соотношение к окну браузера.
6 | Выберите опцию воспроизведения (Playback), управляющую воспроизведением клипа и его характеристиками, следующим образом:
 | Paused at Start останавливает воспроизведение ролика, пока пользователь не нажмёт кнопку в клипе или выберет Play из контекстного меню. По умолчанию эта опция не отмечается и клип начинает воспроизводиться, как только он загрузится (параметр PLAY установлен в значение true).
 | Loop повторяет клип, когда тот достигает последнего кадра. Отключите эту опцию, чтобы ролик останавливался, достигнув последнего кадра (параметр LOOP включен по умолчанию).
 | Display Menu показывает контекстное меню, когда пользователь делает щелчок правой кнопкой мыши (Windows) или щелчок мыши с удерживаемым Control (Macintosh) в клипе. Отключите эту опцию, чтобы в контекстном меню был только пункт About Flash. По умолчанию эта опция включена (параметр MENU установлен в значение true).
 | Только для Windows, выберите Device Font, чтобы заменить системные шрифты со сглаживанием (anti-aliasing) на шрифты, не установленные в системе пользователя. Использование встроенных шрифтов увеличивает удобочитаемость символов при их небольшом размере и может уменьшить объём самого клипа. Эта опция оказывает эффект только на ролики, содержащие статический текст (текст, созданный вами во время разработки клипа и с тех пор не изменённый при отображении), установленный отображаться с помощью встроенных шрифтов. Для получения более детальной информации см. Использование встроенных шрифтов.
 | Выберите Quality, чтобы установить оптимальное соотношение между временем обработки и применением эффекта сглаживания (anti-aliasing) каждого кадра перед его отображением на экране. Эта опция устанавливает значение параметра QUALITY в тегах OBJECT и EMBED.
 | Low делает скорость воспроизведения более приоритетной, чем отображение, и не использует сглаживание.
 | Auto Low в первую очередь делает акцент на скорости воспроизведения, но, по возможности, улучшает и отображение. Воспроизведение начинается с выключенным эффектом сглаживания. Если Flash-плейер обнаруживает, что процессор может им управлять, то сглаживание включается.
 | Auto High уравнивает приоритеты скорости воспроизведения и отображения, но жертвует отображением ради скорости, если необходимо. Воспроизведение начинается с включённым сглаживанием. Если фактическая частота кадров падает ниже заданной, то сглаживание выключается для увеличения скорости воспроизведения. Используйте эту установку для эмуляции View > Antialias настроек во Flash.
 | Medium применяет определённым образом сглаживание, но не сглаживает растровые изображения. В результате имеем качество лучшее по сравнению с установкой Low, но хуже, чем High.
 | High (установка по умолчанию) делает отображение более приоритетным, чем скорость воспроизведения и всегда использует сглаживание. Если клип не содержит анимации, растровые изображения сглаживаются, в противном случае нет.
 | Best обеспечивает самое лучшее качество отображения и не учитывает скорость воспроизведения. Сглаживание всегда включено, все растровые изображения сглаживаются.
7 | Для Windows, Internet Explorer версии 4.0 с управлением Flash ActiveX, выберите опцию режима окна (Window Mode) для установки прозрачности, позиционирования и расположения по слоям. Эта опция определяет атрибут ALIGN для тегов OBJECT, EMBED и IMG.
 | Window - ролик в формате Flash-плейера воспроизводится в своём прямоугольном окне на Web-странице, что обеспечивает самую быструю анимацию. Опция устанавливает параметр WMODE тега OBJECT в WINDOW.
 | Opaque Windowless - элементы располагаются позади Flash-клипа (например, в случае с динамическим HTML), чтобы их не было видно через клип. Параметр WMODE устанавливается в OPAQUE (непрозрачно).
 | Transparent Windowless - фон HTML-страницы, в которую вставлен ролик, будет виден сквозь все прозрачные области клипа, но возможна замедленная анимация. Опция устанавливает WMODE в TRANSPARENT (прозрачно).
8 | Выберите опцию HTML-выравнивания (HTML Alignment) для размещения Flash-клипа в окне браузера:
 | Default - размещает клип по центру окна браузера и обрезает края ролика, если окно браузера меньше геометрических размеров клипа.
 | Left, Right, Top и Bottom - выравнивают клип вдоль соответствующего края окна браузера и обрезают оставшиеся три стороны, если необходимо.
9 | Выберите опцию масштаба (Scale), чтобы разместить клип в определённых границах, если будут изменены первоначальные геометрические размеры. Эта опция устанавливает параметр SCALE в тегах OBJECT и EMBED.
 | Default (Show All) - отображает клип целиком в отведённой области без искажения, поддерживая первоначальное соотношение геометрических размеров ролика. Границы могут появляться с двух сторон клипа.
 | No Border - масштабирует клип так, что он заполняет отведённую область, сохраняя соотношения размеров без искажения, но обрезая ролик в случае необходимости.
 | Exact Fit - отображает клип целиком в определённой области, без сохранения первоначального соотношения размеров, что может привести к искажению.
10 | Выберите опцию Flash-выравнивания (Flash Alignment), чтобы задать, как ролик располагается в окне клипа и как он обрезается в случае необходимости. Эта опция устанавливает параметр SALIGN в тегах OBJECT и EMBED.
 | Для выравнивания по горизонтали (Horizontal alignment) выберите Left, Center или Right.
 | Для вертикального выравнивания ( Vertical alignment) выберите Top, Center или Bottom.
11 | Выберите Show Warning Messages, чтобы отображать сообщения об ошибках при конфликте настроек того или иного тега. Например, если код ссылается на альтернативное (дополнительное) изображение, которое неопределено.
12 | Чтобы сохранить настройки, нажмите OK.


Publishing Flash movies

Публикация и экспорт > Публикация Flash-клипов > Публикация шаблонов генератора

Публикация шаблонов генератора

Генератор позволяет добавить динамическое содержимое - текст, графику и звук во Flash-клип. Вы можете настроить опции для публикации в панели генератора диалогового окна Publish Settings.

Для того чтобы опубликовать шаблон генератора с Flash-файлом:

1 | Выберите File > Publish Settings.
2 | Задайте тип Generator Template. Введите уникальное имя файла или выберите Use Default Name, чтобы создать файл с именем соответствующего Flash-файла и расширением .swf.
3 | Щёлкните мышью по закладке генератора, чтобы просмотреть его настройки.
4 | Укажите размеры (Dimensions), введите ширину (Width) и высоту (Height) в пикселах, чтобы задать геометрические размеры клипа, если файл преобразуется в другой файл или поток, или выберите Match Movie, чтобы сделать публикуемый клип такого же размера, как и оригинальный ролик и сохранять пропорции.
5 | Выберите цвет фона (Background color) для сцен вашего клипа, чтобы отменить цвет, установленный с помощью команды Modify > Movies. Это делается следующим образом:
 | Установите предопределённое для Web название цвета, например, "чёрный" (black). Безопасная палитра использует 216 цветов, общих для Windows и Macintosh системных палитр.
 | Установите шестнадцатеричное значение цвета в стандарте Web (например, #3434aa).
 | Установите шестнадцатеричное значение в математическом стандарте (например, 0x232356).
6 | Задайте частоту кадров (Frame Rate), чтобы определить насколько быстро будут сменяться кадры рассматриваемого клипа во время воспроизведения и отменить частоту, установленную с помощью команды Modify > Movies.
 | Частота задаётся в кадрах в секунду (fps). Если вы зададите частоту равную 10 fps, каждый кадр будет появляться на экране на 1/10 секунды; таким образом, воспроизведение 100-кадровой анимации займёт 10 секунд.
7 | Определите порядок загрузки (Load Order), чтобы установить очерёдность, в которой Flash будет загружать слои клипа для отображения первого кадра вашего клипа: снизу вверх (Bottom Up) или сверху вниз (Top Down).
 | Эта опция указывает часть клипа, которая прорисуется в первую очередь в случае медленного сетевого или модемного соединения.
8 | Выберите кодировку данных (Data Encoding), чтобы установить систему кодирования при чтении всех источников данных, упомянутых в файле шаблона.
 | Установка по умолчанию использует метод кодировки той системы, с которой обслуживается шаблон. Вам следует использовать одну и ту же систему кодировки символов для всех источников данных. Для подробной информации см. руководство Использование Generator 2 , прилагающееся к самому генератору.
9 | Выделите Create External Font Files (создание файлов для внешних шрифтов), чтобы генератор создал необходимые файлы шрифтов.
 | Генератор версии Enterprise Edition кэширует эти шрифты для ускорения процесса выполнения, когда клип использует множество шрифтов.
10 | Выберите External Media (внешние источники информации), чтобы задать имя шаблона генератора, содержащего символы и включить его библиотеку в выбранный файл.
 | Эта опция позволяет вам иметь доступ к символам, как если бы они находились в вашем файле. Если символ будет определён как во внешнем так и в вашем файле, будет использован внешний символ.
11 | Задайте Parameters (параметры), чтобы определить переменные, затем введите имена переменных и их значения.
 | Эта опция позволяет вам локально проверить, как вы реализовали ваши шаблоны или протестировать работу переменных.
12 | Для сохранения настроек к данному файлу нажмите OK.


 Trademarks & Disclaimers

Trademarks
Afterburner, AppletAce, Attain, Attain Enterprise Learning System, Attain Essentials, Attain Objects for Dreamweaver, Authorware, Authorware Attain, Authorware Interactive Studio, Authorware Star, Authorware Synergy, Backstage, Backstage Designer, Backstage Desktop Studio, Backstage Enterprise Studio, Backstage Internet Studio, Design in Motion, Director, Director Multimedia Studio, Doc Around the Clock, Dreamweaver, Dreamweaver Attain, Drumbeat, Drumbeat 2000, Extreme 3D, Fireworks, Flash, Fontographer, FreeHand, FreeHand Graphics Studio, Generator, Generator Developer's Studio, Generator Dynamic Graphics Server, Knowledge Objects, Knowledge Stream, Knowledge Track, Lingo, Live Effects, Macromedia, Macromedia M Logo & Design, Macromedia Flash, Macromedia Xres, Macromind, Macromind Action, MAGIC, Mediamaker, Object Authoring, Power Applets, Priority Access, Roundtrip HTML, Scriptlets, SoundEdit, ShockRave, Shockmachine, Shockwave, Shockwave Remote, Shockwave Internet Studio, Showcase, Tools to Power Your Ideas, Universal Media, Virtuoso, Web Design 101, Whirlwind and Xtra are trademarks of Macromedia, Inc. and may be registered in the United States or in other jurisdictions including internationally. Other product names, logos, designs, titles, words or phrases mentioned within this publication may be trademarks, servicemarks, or tradenames of Macromedia, Inc. or other entities and may be registered in certain jurisdictions including internationally.

This guide contains links to third-party Web sites that are not under the control of Macromedia, and Macromedia is not responsible for the content on any linked site. If you access a third-party Web site mentioned in this guide, then you do so at your own risk. Macromedia provides these links only as a convenience, and the inclusion of the link does not imply that Macromedia endorses or accepts any responsibility for the content on those third-party sites.

Apple Disclaimer
APPLE COMPUTER, INC. MAKES NO WARRANTIES, EITHER EXPRESS OR IMPLIED, REGARDING THE ENCLOSED COMPUTER SOFTWARE PACKAGE, ITS MERCHANTABILITY OR ITS FITNESS FOR ANY PARTICULAR PURPOSE. THE EXCLUSION OF IMPLIED WARRANTIES IS NOT PERMITTED BY SOME STATES. THE ABOVE EXCLUSION MAY NOT APPLY TO YOU. THIS WARRANTY PROVIDES YOU WITH SPECIFIC LEGAL RIGHTS. THERE MAY BE OTHER RIGHTS THAT YOU MAY HAVE WHICH VARY FROM STATE TO STATE.

Copyright © 2000 Macromedia, Inc. All rights reserved. These Help Pages may not be copied, photocopied, reproduced, translated, or published in any electronic or machine-readable form in whole or in part without prior written approval of Macromedia, Inc.

First Edition: July 2000

Macromedia, Inc.
600 Townsend St.
San Francisco, CA 94103


RuFlash

Мейл-Конференция "RuFlash"

Перевод справки к пакету Flash 5 на русский язык сделан силами участников Мейл-Конференции "RuFlash"

Мейл-Конференция "RuFlash" ("RUSSIAN FLASH NEWS") предназначена для оперативного обмена новостями, мнениями между русскоязычными пользователями пакета Macromedia Flash, обсуждения технологии работы в этом и других аналогичных или связанных с ним пакетах и утилитах. Разрешается обсуждение вопросов близких к тематике рассылки или каким либо образом влияющих на развитие и распространение Flash технологии.

Подписчиком конференции может быть любой без каких либо ограничений "житель" Сети, имеющий адрес электронной почты, если он согласен с ее Правилами и соблюдает их при общении с другими подписчиками. Ознакомиться с Правилами конференции и подписаться на нее можно на http://www.vmstudio.com/web-designer/flash/mail-list.asp

Удачи,
VM
модератор "RuFlash"
Редактор перевода


Help Contents

Начало

Учебник

Основы Flash

Рисование

Работа с цветом

Использование импортированной графики

Добавление звука

Работа с объектами

Использование слоев

Использование текста

Использование символов и их экземпляров

Создание анимации

Создание интерактивных клипов

Создание клипов для печати

Публикация и экпорт

Выходные данные справки


Help Contents

Начало
Что нового во Flash 5
Расширенная интеграция с другими приложениями
Путеводитель по учебным приложениям

Учебник

Основы Flash

Рисование

Работа с цветом

Использование импортированной графики

Добавление звука

Работа с объектами

Использование слоев

Использование текста

Использование символов и их экземпляров

Создание анимации

Создание интерактивных клипов

Создание клипов для печати

Публикация и экпорт

Выходные данные справки


Help Contents

Начало

Учебник
Краткий обзор
Что Вы должны знать
Просмотр готового клипа
Установка свойств Flash-клипа
Создание содержания
Импорт содержания
Организация библиотеки
Озвучивание кнопки
Использование Сцены и Линейки
Анимация элементов
Использование команд для вывода результата
Публикация клипа
Следующие шаги

Основы Flash

Рисование

Работа с цветом

Использование импортированной графики

Добавление звука

Работа с объектами

Использование слоев

Использование текста

Использование символов и их экземпляров

Создание анимации

Создание интерактивных клипов

Создание клипов для печати

Публикация и экпорт

Выходные данные справки


Help Contents

Начало

Учебник

Основы Flash
Основы Flash, краткий обзор
Работа во Flash
Изображения во Flash
Анимация во Flash
Интерактивность во Flash
Настройка веб-сервера для Flash-Player'а
О векторной и растровой графике
Векторная графика
Растровая графика
Рабочая среда Flash
Сцена и Монтажная линейка
Символы и экземпляры
Символы и интерактивные клипы
Библиотека
Панели
Создание нового клипа и определение его свойств
Предварительный просмотр и тестирование клипов
Предварительный просмотр клипа в рабочем окружении
Тестирование клипов
Сохранение файлов клипа
Использование панели инструментов
Использование линеек инструментов (Windows)
Использование панелей
Использование контекстных меню
Использование Монтажной линейки
Настройка внешнего вида Монтажной линейки
Перемещение ползунка
Изменение отображения кадров на Монтажной линейке
Создание меток кадров и комментариев к клипам
Работа с кадрами на Монтажной линейке
Использование сцен
Использование библиотек
Работа с папками в окне библиотеки
Сортировка объектов в окне библиотеки
Редактирование объектов библиотеки
Переименование объектов библиотеки
Удаление объектов библиотеки
Поиск неиспользуемых объектов библиотеки
Обновление импортированных файлов в окне библиотеки
Работа с общими библиотеками
Использование подключаемых библиотек
Использование Movie Explorer
Просмотр Сцены
Масштабирование
Прокрутка сцены
Использование сетки, направляющих и линеек
Настройка горячих клавиш
Печать Flash изображений
Разрешение проблем печати
Увеличение скорости отображения клипа
Настройки Flash

Рисование

Работа с цветом

Использование импортированной графики

Добавление звука

Работа с объектами

Использование слоев

Использование текста

Использование символов и их экземпляров

Создание анимации

Создание интерактивных клипов

Создание клипов для печати

Публикация и экпорт

Выходные данные справки


Help Contents

Начало

Учебник

Основы Flash

Рисование
Обзор рисования
Инструменты Flash для рисования и заливки
Перекрытие объектов во Flash
Рисование инструментом Pencil (карандаш)
Рисование прямых линий, овалов и прямоугольников
Использование инструмента Pen (Перо)
Настройка параметров инструмента Pen (Перо)
Рисование прямых линий инструментом Pen (Перо)
Рисование кривых инструментом Pen (Перо)
Настройка узловых точек
Корректировка сегментов
Рисование инструментом Brush (кисть)
Изменение формы и стиля линий
Изменение формы с помощью инструмента Arrow (Стрелка)
Выпрямление и скругление линий
Оптимизация кривых
Стирание
Изменение фигур
Привязка
Выбор настроек рисования

Работа с цветом

Использование импортированной графики

Добавление звука

Работа с объектами

Использование слоев

Использование текста

Использование символов и их экземпляров

Создание анимации

Создание интерактивных клипов

Создание клипов для печати

Публикация и экпорт

Выходные данные справки


Help Contents

Начало

Учебник

Основы Flash

Рисование

Работа с цветом
Краткий обзор работы с цветом
Определение атрибутов цвета линий и заливки
Использование средств управления линий и заливки в комплекте инструментов
Определение цвета линии, стиля и толщины в панели Stroke
Работа с однотонными и градиентными цветами, заливка растровым рисунком в панели Fill
Использование инструмента "Ковш Краски" (Paint Bucket)
Использование инструмента "Бутылка Чернил" (Ink Bottle)
Использование инструмента "Пипетка" (Eyedropper)
Блокировка градиента или растрового рисунка при заливке рабочей области
Создание и редактирование однотонных цветов на панели Mixer
Изменение цветовых палитр
Дублирование или удаление цвета из палитры
Использование заданной по умолчанию палитры и безопасной сетевой палитры
Сортировка палитры
Импорт и экспорт цветовых палитр

Использование импортированной графики

Добавление звука

Работа с объектами

Использование слоев

Использование текста

Использование символов и их экземпляров

Создание анимации

Создание интерактивных клипов

Создание клипов для печати

Публикация и экпорт

Выходные данные справки


Help Contents

Начало

Учебник

Основы Flash

Рисование

Работа с цветом

Использование импортированной графики
Краткий обзор использования импортированной графики
Размещение графики во Flash
Форматы импортируемых файлов
Импорт Fireworks PNG-файлов
Импорт FreeHand файлов
Импорта файлов формата Adobe Illustrator
Об импорте растровых изображений
Использование QuickTime фильмов
Файлы AutoCAD DXF
Преобразование растровых рисунков в векторную графику
Разрыв (Breaking apart) отдельного растрового рисунка
Редактирование растровых рисунков
Установка свойств растрового рисунка

Добавление звука

Работа с объектами

Использование слоев

Использование текста

Использование символов и их экземпляров

Создание анимации

Создание интерактивных клипов

Создание клипов для печати

Публикация и экпорт

Выходные данные справки


Help Contents

Начало

Учебник

Основы Flash

Рисование

Работа с цветом

Использование импортированной графики

Добавление звука
Добавление звука - краткий обзор
Импорт звуков
Добавление звуков во Flash-фильм
Добавление звуков к кнопкам
Использование звуков из общедоступных библиотек или как Звуковые объекты
Использование средств управления редактированием звука
Запуск и остановка звука в ключевом кадре
Сжатие звуков для экспорта
Опция сжатия, заданная по умолчанию
Использование ADPCM компрессии
Использование MP3 компрессии
Использование Raw компрессии
Рекомендации по экспорту звука для Flash-фильмов
Рекомендации для экспорта звука в QuickTime-фильмы

Работа с объектами

Использование слоев

Использование текста

Использование символов и их экземпляров

Создание анимации

Создание интерактивных клипов

Создание клипов для печати

Публикация и экпорт

Выходные данные справки


Help Contents

Начало

Учебник

Основы Flash

Рисование

Работа с цветом

Использование импортированной графики

Добавление звука

Работа с объектами
Работа с объектами - краткий обзор
Выделение объектов
Использование инструмента "Стрелка" (Arrow)
Изменение выбора
Использование инструмента "Лассо" (Lasso)
Отключение подсветки выделения
Группировка объектов
Перемещение, копирование и удаление объектов
Перемещение объектов
Перемещение и копирование объектов вставкой
О копировании графики через Буфер обмена
Копирование трансформированных объектов
Удаление объектов
Расположение объектов по глубине
Масштабирование объектов
Вращение объектов
Зеркальное отражение объектов
Сдвиг объектов
Восстановление трансформированных объектов
Выравнивание объектов
Перемещение точки отсчета объекта
Разрыв (Breaking apart) групп и объектов

Использование слоев

Использование текста

Использование символов и их экземпляров

Создание анимации

Создание интерактивных клипов

Создание клипов для печати

Публикация и экпорт

Выходные данные справки


Help Contents

Начало

Учебник

Основы Flash

Рисование

Работа с цветом

Использование импортированной графики

Добавление звука

Работа с объектами

Использование слоев
Краткая информация о слоях
Создание слоёв
Просмотр слоёв
Редактирование слоёв
Использование опорных слоёв
Использование маскирующих слоёв
Работа с окном Layer Properties (свойства слоя)

Использование текста

Использование символов и их экземпляров

Создание анимации

Создание интерактивных клипов

Создание клипов для печати

Публикация и экпорт

Выходные данные справки


Help Contents

Начало

Учебник

Основы Flash

Рисование

Работа с цветом

Использование импортированной графики

Добавление звука

Работа с объектами

Использование слоев

Использование текста
Обзор Использования текста
О встраиваемых и device шрифтах
Создание текста
Установка атрибутов текста
Выбор шрифта, размера, стиля и цвета
Установка промежутков, кернинга, базового смешения
Установка выравнивания, отступов, отступа абзаца и расстояния между строками
Использование device шрифтов
Создание символов из шрифта
Создание редактируемых или динамически обновляемых текстовых полей
О сохранении форматирования текста
Установка параметров динамического текста
Установка параметров вводимого текста
Редактирование текста
Выделение текста
О преобразовании текста
Изменение формы текста
Связывание текстовых блоков с URL'ами

Использование символов и их экземпляров

Создание анимации

Создание интерактивных клипов

Создание клипов для печати

Публикация и экпорт

Выходные данные справки


Help Contents

Начало

Учебник

Основы Flash

Рисование

Работа с цветом

Использование импортированной графики

Добавление звука

Работа с объектами

Использование слоев

Использование текста

Использование символов и их экземпляров
Обзор использования символов и их экземпляров
Типы поведения символа
Создание символов
Конвертация анимации на сцене в мувиклип
Дублирование символов
Создание экземпляров объектов
Создание кнопок
Включение, редактирование и тестирование кнопок
Редактирование символов
Изменение свойств экземпляра
Изменение цвета и прозрачности экземпляра
Замена экземпляра другим символом
Изменение типа экземпляра
Анимирование экземпляров графики
Разделение экземпляров
Получение информации об экземпляре на сцене

Создание анимации

Создание интерактивных клипов

Создание клипов для печати

Публикация и экпорт

Выходные данные справки


Help Contents

Начало

Учебник

Основы Flash

Рисование

Работа с цветом

Использование импортированной графики

Добавление звука

Работа с объектами

Использование слоев

Использование текста

Использование символов и их экземпляров

Создание анимации
Создание анимации: краткий обзор
Создание ключевых кадров
Представление анимации на монтажной линейке
О слоях в анимации
О частоте кадров
"Удлинение" статичных картинок
Об автоматической анимации
Автоматическая анимация объектов, групп и текста
Перемещение объекта по пути
Анимация форм
Использование хинтов на форме
Создание покадровой анимации
Редактирование анимации
Применение эффекта "Onion skinning"
Перемещение всей анимации

Создание интерактивных клипов

Создание клипов для печати

Публикация и экпорт

Выходные данные справки


Help Contents

Начало

Учебник

Основы Flash

Рисование

Работа с цветом

Использование импортированной графики

Добавление звука

Работа с объектами

Использование слоев

Использование текста

Использование символов и их экземпляров

Создание анимации

Создание интерактивных клипов
Создание интерактивных клипов. Обзор
Язык ActionScript
Использование панели команд
Использование панели команд в обычном режиме
Использование панели команд в продвинутом режиме
Назначение команд объектам
Обработка событий мыши
Назначение команд кадрам
Основные команды для навигации и интерактивности
Переход на кадр или сцену
Воспроизведение и остановка клипов
Установка качества отображения клипа
Остановка всех звуков
Переход на различные URL
Управление Flash-плеером
Загрузка и выгрузка дополнительных клипов
Управление другими клипами
Проверка загрузки кадра

Создание клипов для печати

Публикация и экпорт

Выходные данные справки


Help Contents

Начало

Учебник

Основы Flash

Рисование

Работа с цветом

Использование импортированной графики

Добавление звука

Работа с объектами

Использование слоев

Использование текста

Использование символов и их экземпляров

Создание анимации

Создание интерактивных клипов

Создание клипов для печати
Создание клипов для печати. Обзор
Печать из Flash Player'а
Подготовка клипов для печати
Поддерживаемые принтеры
Обозначение печатаемых кадров
Определение области печати
Изменение цвета заднего фона при печати
Отключение печати
Добавление команды Print
Печать из контекстного меню Flash Player'а
О публикации клипа с печатаемыми кадрами

Публикация и экпорт

Выходные данные справки


Help Contents

Начало

Учебник

Основы Flash

Рисование

Работа с цветом

Использование импортированной графики

Добавление звука

Работа с объектами

Использование слоев

Использование текста

Использование символов и их экземпляров

Создание анимации

Создание интерактивных клипов

Создание клипов для печати

Публикация и экпорт
Публикация и экпорт, краткий обзор
Воспроизведение Flash-клипов
Оптимизация клипов
Тестирование процесса загрузки клипа
Генератор и Flash
Публикация Flash-клипов
Публикация Flash-клипов в формате Flash-плейера
Публикация HTML для файлов Flash-плейера
Публикация шаблонов генератора
Публикация GIF-файлов
Публикация JPEG-файлов
Публикация PNG-файлов
Публикация клипов QuickTime 4
Предварительный просмотр
Использование автономного плеера
Экспорт клипов и изображений
Форматы экспортируемых файлов
Adobe Illustrator
Анимированные GIF, GIF-последовательности и GIF-изображения
Bitmap (BMP)
DXF-последовательность и AutoCAD DXF-изображение
Enhanced Metafile (Windows)
EPS 3.0 с предварительным просмотром
FutureSplash Player
JPEG-последовательность и JPEG-изображение
PICT (Macintosh)
PNG-последовательность и PNG-изображение
QuickTime
QuickTime Video (Macintosh)
WAV audio (Windows)
Windows AVI (Windows)
Windows Metafile
HTML-шаблоны для публикации
Настройка HTML-шаблонов публикации
Создание карты изображения
Создание отчета об используемом тексте
Создание отчета об используемых ссылках
Использование сокращенных шаблонных переменных
Пример шаблона
Редактирование Flash установок в HTML
Использование OBJECT и EMBED
SRC
MOVIE
CLASSID
WIDTH
HEIGHT
CODEBASE
PLUGINSPAGE
SWLIVECONNECT
PLAY
LOOP
QUALITY
BGCOLOR
SCALE
ALIGN
SALIGN
BASE
MENU
WMODE
Конфигурирование web сервера для Flash
Проверка трафика Web-сайта

Выходные данные справки


Help Contents

Начало

Учебник

Основы Flash

Рисование

Работа с цветом

Использование импортированной графики

Добавление звука

Работа с объектами

Использование слоев

Использование текста

Использование символов и их экземпляров

Создание анимации

Создание интерактивных клипов

Создание клипов для печати

Публикация и экпорт

Выходные данные справки
Acknowledgments
Trademarks & Disclaimers
Мейл-конференция "RuFlash"


Welcome to Using Flash Help!

РУССКАЯ РЕДАКЦИЯ

Перевод сделан силами участников мейл-конференции
"RuFlash"