Welcome to ActionScript Dictionary Help!

РУССКАЯ РЕДАКЦИЯ

Перевод сделан силами участников мейл-конференции
"RuFlash"


% (modulo)

Операторы > % (modulo)

% (модуль)

Синтаксис

expression1 % expression2

Аргументы

expression1, expression2 Целые числа, числа с плавающей запятой или строки, которые нужно конвертировать в числовое значение.

Описание

Оператор (арифметический); подсчитывает остаток от деления expression1 на expression2. Если один из аргументов expression нечисловой, оператор пытается конвертировать его в число.

Player

Flash 4 или более поздней версии. В файлах Flash 4, оператор % расширен в SWF файле как x - int(x/y) * y, и может работать не так быстро и точно, как тот, который реализован во Flash 5 Player.

Пример

Ниже пример использования оператора % для работы с числами:

12 % 5 возвращает 2

4.3 % 2.1 возвращает 0.1


Date.setDate

Date > Date.setDate

Date.setDate

Синтаксис

myDate.setDate(date);

Аргументы

date Целое от 1 до 31.

Описание

Метод; выставляет день месяца объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.setFullYear

Date > Date.setFullYear

Date.setFullYear

Синтаксис

myDate.setFullYear(year [, month [, date]] );

Аргументы

year Четырехзначное число, обозначающее год; например, 99 - это не 1999 год, а 99 год.

month Целое от 0 (январь) до 11 (декабрь). Аргумент необязателен.

date Целое от 1 до 31. Аргумент необязателен.

Описание

Метод; выставляет полную дату объекта Date согласно системному времени. Если month и date определены, они также привязываются к системному времени.

Результаты вызовов getUTCDay и getDay могут быть изменены вызовом этой функции.

Player

Flash 5 или выше.


Date.setHours

Date > Date.setHours

Date.setHours

Синтаксис

myDate.setHours(hour);

Аргументы

hour Целое от 0 (полночь) до 23 (11 вечера).

Описание

Метод; выставляет час объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.setMilliseconds

Date > Date.setMilliseconds

Date.setMilliseconds

Синтаксис

myDate.setMilliseconds(millisecond);

Аргументы

millisecond Целое от 0 до 999.

Описание

Метод; выставляет количество миллисекунд объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.setMinutes

Date > Date.setMinutes

Date.setMinutes

Синтаксис

myDate.setMinutes(minute);

Аргументы

minute Целое от 0 до 59.

Описание

Метод; выставляет количество минут объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.setMonth

Date > Date.setMonth

Date.setMonth

Синтаксис

myDate.setMonth(month [, date ]);

Аргументы

month Целое от 0 (январь) до 11 (декабрь).

date Целое от 1 to 31. Необязательный аргумент.

Описание

Метод; выставляет месяц объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.setSeconds

Date > Date.setSeconds

Date.setSeconds

Синтаксис

myDate.setSeconds(second);

Аргументы

second Целое от 0 до 59.

Описание

Метод; выставляет количество секунд объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.setTime

Date > Date.setTime

Date.setTime

Синтаксис

myDate.setTime(millisecond);

Аргументы

millisecond Целое от 0 до 999.

Описание

Метод; выставляет дату указанного объекта Date в миллисекундах.

Player

Flash 5 или выше.


Date.setUTCDate

Date > Date.setUTCDate

Date.setUTCDate

Синтаксис

myDate.setUTCDate(date);

Аргументы

date Целое от 1 до 31.

Описание

Метод; выставляет дату указанного объекта Date согласно глобальному времени. Вызов этого метода не обновляет другие поля объекта Date, в отличие от getUTCDay и getDay методов, которые в соответствии с изменением выставляют другой день недели.

Player

Flash 5 или выше.


Date.setUTCFullYear

Date > Date.setUTCFullYear

Date.setUTCFullYear

Синтаксис

myDate.setUTCFullYear(year [, month [, date]]);

Аргументы

year Четырехзначный год, например 2000.

month Целое от 0 (январь) до 11 (декабрь); необязательный аргумент.

date Целое от 1 до 31; необязательный аргумент.

Описание

Метод; выставляет год указанного объекта Date (mydate) в глобальном времени.

Метод может также выставить месяц и дату объекта; метод не обновляет значений в других полях, однако вызов getUTCDay и getDay позволяет видеть измененные значения, если, например, поменялся день недели.

Player

Flash 5 или выше.


%= (modulo assignment)

Операторы > %= (modulo assignment)

%= (присваивание модуля)

Синтаксис

expression1 %= expression2

Аргументы

expression1,expression2 Целые числа и переменные.

Описание

Оператор присваивания; присваивает expression1 значение expression1 % expression2.

Player

Flash 4 или более поздней версии.

Пример

Этот пример показывает, как использовать оператор %= с переменными и числами:

x %= y то же самое, что x = x % y

Если x = 14 и y = 5 то

x %= 5 возвращает 4

Смотри также

% (modulo)


Date.setUTCHours

Date > Date.setUTCHours

Date.setUTCHours

Синтаксис

myDate.setUTCHours(hour [, minute [, second [, millisecond]]]));

Аргументы

hour Целое от 0 (полночь) до 23 (11 вечера).

minute Целое от 0 до 59; необязательный аргумент.

second Целое от 0 до 59; необязательный аргумент.

millisecond Целое от 0 до 999; необязательный аргумент.

Описание

Метод; выставляет час указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.setUTCMilliseconds

Date > Date.setUTCMilliseconds

Date.setUTCMilliseconds

Синтаксис

myDate.setUTCMilliseconds(millisecond);

Аргументы

millisecond Целое от 0 до 999.

Описание

Метод; выставляет миллисекунды указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.setUTCMinutes

Date > Date.setUTCMinutes

Date.setUTCMinutes

Синтаксис

myDate.setUTCMinutes(minute [, second [, millisecond]]));

Аргументы

minute Целое от 0 до 59.

second Целое от 0 до 59; необязательный аргумент.

millisecond Целое от 0 до 999; необязательный аргумент.

Описание

Метод; выставляет минуты указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.setUTCMonth

Date > Date.setUTCMonth

Date.setUTCMonth

Синтаксис

myDate.setUTCMonth(month [, date]);

Аргументы

month Целое от 0 (январь) до 11 (декабрь).

date Целое от 1 до 31; необязательный аргумент.

Описание

Метод; выставляет месяц и, если необходимо, день (дату), указанного объекта Date согласно глобальному времени. Метод не обновляет значений в других полях, однако вызов getUTCDay и getDay позволяет видеть измененные значения, если, например, поменялся день недели.

Player

Flash 5 или выше.


Date.setUTCSeconds

Date > Date.setUTCSeconds

Date.setUTCSeconds

Синтаксис

myDate.setUTCSeconds(second [, millisecond]));

Аргументы

second Целое от 0 до 59.

millisecond Целое от 0 до 999; необязательный аргумент.

Описание

Метод; выставляет секунды указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.setYear

Date > Date.setYear

Date.setYear

Синтаксис

myDate.setYear(year);

Аргументы

year Четырехзначный год, например, 2000.

Описание

Метод; выставляет год указанного объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.toString

Date > Date.toString

Date.toString

Синтаксис

myDate.toString();

Аргументы

Нет.

Описание

Метод; возвращает строку, представляющую дату и время, содержащиеся в объекте Date.

Player

Flash 5 или выше.

Пример

Получаем в виде строчки информацию, содержащуюся в dateOfBirth:

var dateOfBirth = newDate(74, 7, 7, 18, 15);
trace (dateOfBirth.toString());

На выходе:

Wed Aug 7 18:15:00 GMT-0700 1974


Date.UTC

Date > Date.UTC

Date.UTC

Синтаксис

Date.UTC(year, month [, date [, hour [, minute [, second [, millisecond ]]]]]);

Аргументы

year Четырехзначный номер, например, 2000.

month Целое от 0 (январь) до 11 (декабрь).

date Целое от 1 до 31; необязательный аргумент.

hour Целое от 0 (полночь) до 23 (11 вечера).

minute Целое от 0 до 59; необязательный аргумент.

second Целое от 0 до 59; необязательный аргумент.

millisecond Целое от 0 до 999; необязательный аргумент.

Описание

Метод; возвращает количество миллисекунд, прошедших с 00.00 1 января 1970 г. по глобальному времени до заданного времени. Это статичный метод, активизирующийся через конструктор объекта Date, а не через данный объект Date. Метод позволяет создавать объект Date на основании глобального времени, в то время как конструктор объекта Date основывается на системном.

Player

Flash 5 или выше.

Пример

Создаем новый объект Date gary_birthday, определенным в глобальном времени:

gary_birthday = new Date(Date.UTC(1974, 7, 8));


delete

De-I > delete

delete

Синтаксис

delete (reference);

Аргументы

reference имя переменной или объекта, подлежащего удалению.

Описание

Оператор; уничтожает объект или переменную, имя которой указывает reference, и возвращает true если объект был успешно удален; в противном случае возвращает false. Этот оператор полезен для высвобождения памяти, используемой скриптами, хотя, delete - оператор, который обычно применяется в формулировке:

delete x;

оператор delete может не сработать и возвратить false если reference не существует, или не может быть удален. Предопределенные функции и объекты, также как и переменные, объявленные с помощью var, не могут быть удалены.

Версия плугина

Flash 5 или более новый.

Примеры

В следующих примерах создается объект, используется, а затем удаляется за ненадобностью:

account = new Object();
    account.name = 'Jon';
    account.balance = 10000;
    ...
    delete account;

В следующем примере удаляется свойство (property) объекта:

// создаем новый объект "account"
account = new Object();
// назначаем свойство name объекту account
    account.name = 'Jon';
// удаляем свойство
delete account.name;

Еще один пример удаления свойства объекта:

// создаем массив длиной 0
array = new Array();
// теперь его длина - 1
    array[0] = "abc";
// добавляем еще один элемент - длина - 2
    array[1] = "def";
// теперь - 3
    array[2] = "ghi";
// удаляем array[2] но длина массива не меняется,
    delete array[2];

Следующие примеры демонстрируют действие delete на объектные ссылки:

// создаем объект, присваиваем переменной ref1 значение ссылки на него
ref1 = new Object();
ref1.name = "Jody";
// копируем ссылочную переменную, а затем удаляем ref1
ref2 = ref1;
delete ref1;

Если бы ref1 не была бы скопирована в ref2, то и объект был бы удален, так как на него не осталось бы ни одной ссылки. Когда же мы удалим ref2, больше не останется ссылок на объект, и он будет удален, так как на него не будет ссылаться ни одна переменная.

См. также

var


do... while

De-I > do... while

do... while

Синтаксис

do {
statement;
} while (condition);

Аргументы

condition Условие для продолжения итерирования.

statement Этот блок выполняется до тех пор, пока результат вычисления condition равен true.

Описание

Оператор; выполняет statements, потом вычисляет condition. Так - до тех пор, пока condition возвращает true.

Версия плугина

Flash 4 или более новый.

См. также


& (bitwise AND)

Операторы > & (bitwise AND)

& (побитовое И)

Синтаксис

expression1 & expression2

Аргументы

expression1, expression2 Любое число.

Описание

Оператор (побитовый); конвертирует expression1 и expression2 в 32-битные целые числа, и выполняет операцию "булево И" над каждым битом аргумента целого числа. В результате мы имеем новое беззнаковое целое число.

Player

Flash 5 или более поздней версии. Во Flash 4, оператор & использовался для объединения строк. Во Flash 5 оператор & является "побитовым И" оператором, а операторы add и + объединяют строки. Файлы Flash 4, использующие оператор &, автоматически обновляются для использования add во время переноса в рабочую среду Flash 5.


_droptarget

De-I > _droptarget

_droptarget

Синтаксис

draggableInstanceName._droptarget

Аргументы

draggableInstanceName Имя экземпляра мувика, который являлся target'ом команды startDrag.

Описание

Свойство (только для чтения); возвращает абсолютный путь (используя "/" в качестве разделителей) экземпляра мувика, на который draggableInstanceName был, собственно, положен (dropped). Свойство _droptarget всегда возвращает путь, начинающийся с /. Чтобы превратить _droptarget в ссылку на объект, необходимо использовать eval, который возвратит необходимую ссылку.

Версия плугина

Flash 4 или более новый.

Примеры

Следующий пример получает свойство _droptarget экземпляра мувика garbage и использует eval чтобы получить путь с "." в качестве разделителей. Ссылка на garbage затем сравнивается с экземпляром мувика trash. Если они равны, то garbage делаем невидимым (Visibility -> false). Если они не равны, то восстанавливаем изначальное положение garbage.

if (eval(garbage._droptarget) == _root.trash) {
    garbage._visible = false;
} else {
    garbage._x = x_pos;
    garbage._y = y_pos;
}

The variables x_pos and y_pos are set on frame 1 of the movie with the following script:

x_pos = garbage._x;
y_pos = garbage._y;

См. также

startDrag


duplicateMovieClip

De-I > duplicateMovieClip

duplicateMovieClip

Синтаксис

duplicateMovieClip(target, newname, depth);

Аргументы

target Путь мувика, который необходимо размножить.

newname Уникальный идентификатор для нового экземпляра мувика.

depth Глубина для нового мувика. Это - порядковый номер, который определяет, как мувики перекрывают друг-друга. Первый мувик, который вы создали имеет глубину - 0, дальше - больше. Вы должны присвоить каждому новому мувику уникальную глубину, так как если вы присвоите уже имеющуюся, то новый мувик заменит старый.
Комментарий: собственно, это иногда и надо.

Описание

Команда; создает экземпляр муви-клипа во время проигрывания фильма. Дублирование всегда начинается с кадра номер 1, вне зависимости от того, на каком кадре был клип. Переменные, содержащиеся в родительском мувике не копируются в дублируемый. Если удаляется родительский мувик, то дублированный - тоже удаляется. Используйте команду или метод removeMovieClip чтобы удалить экземпляр муви-клипа, созданного командой duplicateMovieClip.

Версия плугина

Flash 4 или более новый.

Примеры

Следующие строчки множат flower десять раз. Переменная i используется для того, чтобы создать уникальное имя и положить новый мувик на уникальную глубину.

on(release) {
    amount = 10;
    while(amount>0) {
        duplicateMovieClip (_root.flower, "mc" + i, i);
        setProperty("mc" + i, _x, random(275));
        setProperty("mc" + i, _y, random(275));
        setProperty("mc" + i, _alpha, random(275));
        setProperty("mc" + i, _xscale, random(50));
        setProperty("mc" + i, _yscale, random(50));
        i = i + 1;
        amount = amount-1;
    }
}

См. также


else

De-I > else

else

Синтаксис

else {statement(s)};

Аргументы

statement(s) Альтернативная серия команд, которая выполняется, если условие (condition), указанное в if - false.

Описание

Команда; указывает те команды, которые необходимо выполнить, если условие в if является ложным (возвращает false).
Примечание: На самом деле, конструкция if-else дополнена еще одним компонентом, получается if-else if-else. Операторы в else выполняются только в том случае, если неверны все условия, как в if, так и в else if.

Версия плугина

Flash 4 или более новый.

См. также

if


eq (equal—string specific)

De-I > eq (equal—string specific)

eq (equal—string specific)

Синтаксис

expression1 eq expression2

Аргументы

expression1, expression2 Числа, строки или переменные.

Описание

Оператор сравнения; сравнивает два выражения на равенство и возвращает true, если expression1 равно expression2; иначе возвращает false.

Версия плугина

Flash 1 или более новый. Этот оператор является устаревшим в Flash 5; рекомендуется использование нового оператора == (оператор равенства).

См. также

== (equality)


escape

De-I > escape

escape

Синтаксис

escape(expression);

Аргументы

expression Выражение, которое надо перевести в строку и преобразовать в формат для передачи в URL.

Описание

Функция; преобразует аргумент в строку и переводит ее в формат URL-encoded, где все знако-числовые значения кодируются шестнадцатеричными %-последовательностями.

Версия плугина

Flash 5 или более новый.

Примеры

escape("Hello{[World]}");

Результат будет следующим:

Hello%7B%5BWorld%5D%7D

См. также

unescape


eval

De-I > eval

eval

Синтаксис

eval(expression);

Аргументы

expression Строка, содержащая имя переменной, свойства, объекта или муви-клипа, ссылку на который необходимо получить.

Описание

Функция; предоставляет доступ к переменным, свойствам, объектам и мувикам по их имени. Если expression - это переменная или свойство, будет возвращено значение переменной или свойства. Если же expression - объект или мувик, возвращается ссылка на него. Если элемент, имя которого указано в expression не найден, возвращается неопределенное значение (undefined).

В Flash 4, функция eval использовалась для эмуляции массивов. В Flash 5 рекомендуется вместо этого использовать объект Array.

Note: Действие ActionScript eval - не то же самое, что функция eval в JavaScript, и не может быть использована для вычисления выражений.

Версия плугина

Flash 5 или более новый - для полной работоспособности. Вы можете использовать eval, когда экспортируете в Flash 4 Player, но Вы должны использовать "/" - запись и можете получить доступ таким образом только к переменным, но не к свойствам или объектам.

Примеры

Следующий пример использует eval, чтобы определить значение переменной x, и приравнять его к значению переменной y:

x = 3;
y = eval("x");

Этот пример использует eval, чтобы сослаться на объект с именем Ball:

eval("_root.Ball");

См. также

Array (object)


evaluate

De-I > evaluate

evaluate

Синтаксис

statement;

Аргументы

None.

Описание

Действие; создает новую пустую строку, и вставляет ; для того, чтобы можно было ввести свой код в строку Expression панели Actions. Действие evaluate позволяет вызывать свои функции пользователю, который редактирует скрипт в режиме Normal Mode.

Версия плугина

Flash 5 или более новый.


_focusrect

De-I > _focusrect

_focusrect

Синтаксис

_focusrect = Boolean;

Аргументы

Boolean true или false.

Описание

Свойство (глобальное); Указывает, показывать ли вокруг активной кнопки желтенький прямоугольничек. Значение по умолчанию - true (не ноль) - указывает, что надо прорисовывать его вокруг активной кнопки или текстового поля и перемещать его, когда пользователь нажимает кнопку. Укажите false, чтобы показывать активное состояние только кадром кнопки "over" (если вообще он определен) по мере того, как пользователь перемещается по странице..

Версия плугина

Flash 4 или более новый.


for

De-I > for

for

Синтаксис

for(init; condition; next); {
statement;
}

Аргументы

init Выражение, которое надо вычислить перед началом цикла, обычно - присваивание (см. пример). Также возможно var - выражение в качестве этого аргумента.

condition Выражение, которое возвращает true или false. Сondition вычисляется перед каждой итерацией. Цикл оканчивается, когда возвращается false.

next Выражение, которое надо вычислять при каждой итерации в цикле. Обычно представляет собой оператор инкремента ++ (increment) или декремента -- (decrement).

statement Код, который надо выполнять в цикле.

Описание

Действие; циклическая конструкция, в которой сначала вычисляется выражение init (initialize), а потом начинается цикл, на каждом шаге которого проверяется, возвращает ли condition значение true и, если это так, то выполняется statement. Иначе цикл завершается

Некоторые свойства не могут быть перечислены с помощью команд for или for..in. Например, встроенные методы объекта Array (Array.sort и Array.reverse) не включены в перечисление объекта Array (массив), как и такие свойства мувика, как _x и _y, .

Версия плугина

Flash 5 или более новый.

Примеры

Следующие примеры используют for, чтобы добавить элементы в массив:

for(i=0; i<10; i++) {
array [i] = (i + 5)*10;
}

Returns the following array:

[50, 60, 70, 80, 90, 100, 110, 120, 130, 140]

А здесь цикл нужен для того, чтобы некоторое действие повторить несколько раз. В данном случае - сложить числа от одного до 100:

var sum = 0;
    for (var i=1; i<=100; i++) {
        sum = sum + i;
    }

См. также


for..in

De-I > for..in

for..in

Синтаксис

for(variableiterant in object){
statement;
}

Аргументы

variableiterant Имя переменной, которая выступает в роли итератора, ей последовательно присваивается каждое свойство объекта или элемента массива.

object Имя объекта, который подлежит итерированию.

statement Выражение, которое необходимо выполнять каждую итерацию.

Описание

Действие; циклически обрабатывает свойства объекта или элементы массива, выполняя для каждого из них statement.

Некоторые свойства не могут быть перечислены с помощью команд for или for..in. Например, встроенные методы объекта Array (Array.sort и Array.reverse) не включены в перечисление объекта Array (массив), как и такие свойства мувика, как _x и _y, .

Цикл for...in итерирует по свойствам объекта, объявленным в прототипе. Итерирование по дочернему прототипу ведет за собой и итерирование по родительскому.

Версия плугина

Flash 5 или более новый.

Примеры

Далее представлены примеры использования for..in для итерирования по свойствам объекта:

myObject = { name:'Tara', age:27, city:'San Francisco' };
for (name in myObject) {
    trace ("myObject." + name + " = " + myObject[name]);
}

The output of this Примеры is as follows:

myObject.name = Tara
myObject.age = 27
myObject.city = San Francisco

The following is an Примеры of using the typeof operator with for..in to iterate over a particular type of child:

for (name in myMovieClip) {
    if (typeof (myMovieClip[name]) = "movieclip") {
        trace ("I have a movie clip child named " + name);
    }
}

Следующий пример перечисляет дочерние объекты мувика и делает им всем и каждому GotoAndStop(2), то есть заставляет их перейти на 2 кадр. Мувик RadioButtonGroup - родительский клип с несколькими дочерними: _RedRadioButton_, _GreenRadioButton_ and _BlueRadioButton.

for (var name in RadioButtonGroup) {
    RadioButtonGroup[name].gotoAndStop(2);
}


&& (short-circuit AND)

Операторы > && (short-circuit AND)

&& (короткое И)

Синтаксис

expression1 && expression2

Аргументы

expression1, expression2 Числа, строки, переменные или функции.

Описание

Логический оператор; производит булеву операцию над значениями одного или обоих выражений. Интерпретатор Flash анализирует левое expression1 и возвращает false, если выражение оценивается как false. Если expression1 оценивается как true, то рассматривается правое expression2. Если и expression2 оценивается как true, то окончательный результат - true, в противном случае результат - false.

Player

Flash 4 или более поздней версии.

Пример

В этом примере переменным winner и loser присваивается соответствующие значения, как результат оценки правых частей выражений:

winner = (chocolateEggs >=10) && (jellyBeans >=25);
loser = (chocolateEggs <=1) && (jellyBeans <= 5);
if (winner) {
    alert = "You Win the Hunt!";
    if (loser) {
        alert = "Now THAT'S Unhappy Hunting!";
    }
} else {
    alert = "We're all winners!";
}


_framesloaded

De-I > _framesloaded

_framesloaded

Синтаксис

instancename._framesloaded

Аргументы

instancename Имя мувика, который необходимо обработать.

Описание

Свойство (только для чтения); количество кадров мувика, которые были загружены с сервера. Это свойство полезно для определения, загружен ли определенный кадр и все кадры перед ним и, следовательно, могут ли они быть проиграны. Полезно для слежения за процессом загрузки больших мувиков. Например, можно выводить на экран количество кадров, которое уже загружено. (Простейший и не очень полезный прелоадер)

Версия плугина

Flash 4 или более новый.

Примеры

Этот пример показывает, как скоординировать количество кадров, которое уже загружено с моментом его запуска:

if (_framesloaded >= _totalframes) {
gotoAndPlay ("Scene 1", "start");
} else {
setProperty ("_root.loader", _xscale, (_framesloaded/_totalframes)*100);
}


fscommand

De-I > fscommand

fscommand

Синтаксис

fscommand(command, arguments);

Аргументы

command Строка, которая передается для использования приложению, запустившему муви-клип.

arguments Строка, которая передается для использования приложению, запустившему муви-клип.

Описание

Действие; позволяет муви-клипу Flash передавать данные программе, которая запустила этот клип. В браузере fscommand вызывает функцию на JavaScript с именем moviename_Dofscommand, находящуюся на странице, содержащую муви-клип. Здесь moviename - имя клипа, которое присваивается в атрибуте NAME тэга EMBED, или свойства ID тэга OBJECT. Например, если присвоено имя theMovie, функция JavaScript должна называться theMovie_Dofscommand.

Версия плугина

Flash 3 или более новый.


function

De-I > function

function

Синтаксис

function functionname ([argument0, argument1,...argumentN]){
statement(s)
}
function ([argument0, argument1,...argumentN]){
statement(s)
}

Аргументы

functionname Название новой функции.

argument строки, числа или объекты в количестве, большем, либо равным нулю, которые передаются функции.

statements Ноль или более нуля операторов ActionScript, которые являются телом функции (function).

Описание

Действие; определяет набор операторов, которые вы определили для выполнения определенной задачи. Вы можете декларировать (declare), или определить (define), функцию в том же месте, где вы ее вызываете, или в любом другом месте муви-клипа. При определении функции, вы можете также определить ее аргументы. Туда можно поместить при вызове некоторые значения, которыми оперирует функция при ее вызове. Каждый раз, когда заново вызывается функция, можно вызывать ее с другими аргументами.

Используйте оператор return в теле функции statement(s), чтобы заставить функцию возвратить какое-либо значение.

Вариант использования номер раз: Определяем function с определенными functionname, arguments, и statement(s). Во время вызова имени функции, на самом деле вызывается описание этой функции с нужными параметрами. Разрешен вызов функции до того, как она определена в Action list, то есть функция может быть объявлена после того, как к ней обратились.

Вариант использования номер два: Создаем безыменную функцию и возвращаем ее. Такой вариант используется в выражениях, кроме того, он частично полезен при создании методов в объектах.

Версия плугина

Flash 5 или более новый.

Примеры

(Вариант 1) В следующем примере создается функция sqr, которая принимает один аргумент (число), возвращая его квадрат. Обратите внимание, что в этом скрипте объявление функции стоит после ее вызова.

y=sqr(3);
function sqr(x) {
return x*x;
}

(Вариант 2) Следующий пример создает объект Окружность (Circle):

function Circle(radius) {
 this.radius = radius;
}

А здесь создается безымянная функция, которая считает площадь круга и присоединяет ее значение, как метод, объекту Окружность (Circle):

Circle.prototype.area = function () {return Math.PI * this.radius * this.radius}


ge (greater than или equal to—string specific)

De-I > ge (greater than или equal to—string specific)

ge (больше или равно, характерно для строк)

Синтаксис

expression1 ge expression2

Аргументы

expression1, expression2 Числа, строки или переменные.

Описание

Оператор (сравнение); сравнивает expression1 и expression2 и возвращает true, если expression1 больше или равен expression2; иначе возвращает false.

Версия плугина

Flash 4 или более новый. Этот оператор является устаревшим в Flash 5; рекомендуется использование нового оператора >=.

См. также

>= (больше либо равно)


getProperty

De-I > getProperty

getProperty

Синтаксис

getProperty(instancename , property);

Аргументы

instancename Имя экземпляра мувика, свойство которого необходимо получить.

property Имя свойства мувика, такое, как координата x или y.

Описание

Функция; возвращает значение указанного свойства (property) указанного мувика.

Версия плугина

Flash 4 или более новый.

Примеры

Здесь мы получаем горизонтальную координату (_x) для мувика myMovie:

getProperty(_root.myMovie_item._x);


getTimer

De-I > getTimer

getTimer

Синтаксис

getTimer();

Аргументы

Нет.

Описание

Функция; возвращает количество миллисекунд, прошедших с момента старта муви-клипа.

Версия плугина

Flash 4 или более новый.


getURL

De-I > getURL

getURL

Синтаксис

getURL(url [, window [, variables]]);

Аргументы

url Адрес (URL), с которого необходимо получить документ. Должен принадлежать одному домену вместе с фильмом.

window Необязательный аргумент, определяющий окно или фрейм (frame) в HTML, куда должен быть помещен документ. Укажите здесь имя окна/фрейма, либо укажите одно из зарезервированных слов:

_self указывает на то же окно/тот же фрейм, откуда вызывается функция.
_blank указывает на новое окно.
_parent указывает на родительское по отношению к текущему окно.
_top указывает на самый верхний фрейм в окне.

variables Необязательный аргумент, указывающий на метод, которым надо пересылать переменные. Если переменные передавать не надо, пропустите этот аргумент, иначе укажите, использовать метод GET или POST. GET добавляет имена переменных вместе со значениями в конец URL, и обычно используется для небольшого количества (и небольшого суммарного объема имен+значений) переменных. POST посылает переменные в отдельном заголовке HTTP и используется для передачи длинных строк или больших по объему данных.

Описание

Действие; загружает документ с указанного адреса (URL) в окно, или передает переменные другому приложению по URL. Чтобы это действие сработало, убедитесь в наличии целевого документа. Чтобы использовать абсолютные URL (например, http://www.myserver.com), вам необходимо активное сетевое соединение.

Версия плугина

Flash 2 или более новый. Выбор типа метода доступен, начиная с 4 версии.

Примеры

Этот пример загружает документ с указанным URL в новое окно браузера. Действию getURL указана переменная incomingAd в качестве параметра url, поэтому можно менять адрес документа, который загружается, не редактируя Флэш клип. Значение переменной incomingAd берется Флэшом ранее из файла с помощью действия loadVariables.

on(release) {
    getURL(incomingAd, "_blank");
}

См. также


getVersion

De-I > getVersion

getVersion

Синтаксис

getVersion();

Аргументы

Нет.

Описание

Функция; возвращает строку, в которой содержится версия плейера и информация о платформе.

Эта функция не работает в режиме test-movie и возвращает значение только для версий 5 и выше.

Примеры

Здесь показан вариант строчки, возвращаемой функцией getVersion:

WIN 5,0,17,0

Она означает, что платформа - Windows, старшая версия плейера - 5, младшая версия - 17(5.0r17).

Версия плугина

Flash 5 или более новый.


gotoAndPlay

De-I > gotoAndPlay

gotoAndPlay

Синтаксис

gotoAndPlay(scene, frame);

Аргументы

scene Сцена, к которой применяется действие.

frame Кадр, с которого начинать проигрывание.

Описание

Действие; начинает проигрывание в указанной сцене с кадра frame. Если не указана сцена, считается, что указана текущая сцена.

Версия плугина

Flash 2 или более новый.

Примеры

Когда пользователь нажимает на кнопку, которой в действиях присвоено действие gotoAndPlay, начинается проигрывание с 16 кадра.

on(release) {
    gotoAndPlay(16);
}


gotoAndStop

De-I > gotoAndStop

gotoAndStop

Синтаксис

gotoAndPlay(scene, frame);

Аргументы

scene Сцена, к которой применяется действие.

frame Кадр, с которого начинать проигрывание.

Описание

Действие; начинает проигрывание в указанной сцене с кадра frame. Если не указана сцена, считается, что указана текущая сцена.

Версия плугина

Flash 2 или более новый.

Синтаксис

gotoAndStop(scene, frame);

Аргументы

scene Сцена, к которой применяется действие.

frame Кадр, который установить в качестве текущего.

Описание

Действие; устанавливает текущим указанный кадр. Если не указана сцена, считается, что указана текущая сцена. Проигрывание прекращается.

Версия плугина

Flash 2 или более новый.

Примеры

Когда пользователь нажимает на кнопку, которой в действиях присвоено действие gotoAndStop, активным устанавливается кадр номер 5 и клип прекращает проигрывание.

on(release) {
    gotoAndStop(5);
}


&= (bitwise AND assignment)

Операторы > &= (bitwise AND assignment)

&= (присваивание побитового И)

Синтаксис

expression1 &= expression2

Аргументы

expression1, expression2 Целые числа и переменные.

Описание

Побитовый оператор присваивает expression1 значение expression1 & expression2.

Player

Flash 5 или более поздней версии.

Пример

Ниже иллюстрации использования оператора &= с переменными и числами:

x &= y то же самое, что x = x & y

If x = 15 and y = 9 then

x &= 9 возвращает 9

Смотри также

& (bitwise AND)


gt (greater than —string specific)

De-I > gt (greater than —string specific)

gt (greater than —string specific)

Синтаксис

expression1 gt expression2

Аргументы

expression1, expression2 Числа, строки или переменные.

Описание

Оператор (сравнение); сравнивает expression1 и expression2 и возвращает true если expression1 больше, чем expression2; иначе возвращает false.

Версия плугина

Flash 4 или более новый. Этот оператор является устаревшим в Flash 5; рекомендуется использование нового оператора >=.

См. также

> (greater than)


_height

De-I > _height

_height

Синтаксис

instancename._height
instancename._height = value;

Аргументы

instancename Экземпляр мувика, для которого необходимо получить или изменить свойство _height (высота).

value Целое число, указывающее высоту мувика в пикселах.

Описание

Свойство; с его помощью можно получить или изменить высоту места, занимаемого содержимым мувика. В предыдущей версии высота и ширина ( _height и _width) были только читаемыми свойствами, их нельзя было менять, теперь - во Флэше 5 это можно делать.

Версия плугина

Flash 4 или более новый.

Примеры

В этом примере изменяются высота и ширина клипа, когда на нем кликают мышкой:

onClipEvent(mouseDown) {
    _width=200;
    _height=200;
}


_highquality

De-I > _highquality

_highquality

Синтаксис

_highquality = value;

Аргументы

value Уровень сглаживания, который применяется к фильму. Укажите 2 (BEST), чтобы получить максимальное качество сглаживания, 1 (high quality) если хотите, чтобы битмапки (растровые картинки) сглаживались в случае, если нет анимации. 0 (low quality) - чтобы предотвратить сглаживание.

Описание

Свойство (глобальное); указывает качество сглаживания, применяемого к фильму.

Версия плугина

Flash 4 или более новый.

См. также


if

De-I > if

if

Синтаксис

if(condition) {
statements;
}

Аргументы

condition Выражение, которое возвращает true или false. Например, if(name == "Erica"), смотрит переменную с именем name и сравнивает ее значение со строкой "Erica."

statements Код, который должен выполняться, если значение condition - true.

Описание

Действие; вычисляет condition, чтобы определить следующее действие. Если значение condition - true, Flash исполняет statements. Используйте if, чтобы создать ветвление в ваших скриптах.

Версия плугина

Flash 4 или более новый.

См. также


ifFrameLoaded

De-I > ifFrameLoaded

ifFrameLoaded

Синтаксис

ifFrameLoaded(scene, frame) {
statement;}
ifFrameLoaded(frame) {
statement;}

Аргументы

scene Опрашиваемая сцена.

frame Номер кадра или метка кадра, который необходимо загрузить перед тем, как исполнять statement.

Описание

Действие; проверяет, доступно ли содержимое указанного кадра локально (скачано ли уже?). Используйте для создания прелоадера, то есть небольшой анимации, пока загружается остальная часть фильма. Разница между использованием _framesloaded и ifFrameLoaded в том, что _framesloaded позволяет добавить if, или else, в то время, как ifFrameLoaded позволяет указать количество кадров в одном простом выражении.

Версия плугина

Flash 3 или более новый. Действие ifFrameLoaded устарело в Flash 5; используйте вместо него _framesloaded.

См. также

_framesloaded


#include

De-I > #include

#include

Синтаксис

#include "filename.as";

Аргументы

filename.as Имя включаемого файла; .as - рекомендованное разрешение файла.

Описание

Действие; включает содержимое файла, во время того, как клип тестируется, публикуется или экспортируется. Действие #include вызывается, когда вы тестируете, публикуете или экспортируете клип. Действие #include проверяется при проверке синтаксиса.

Версия плугина

N/A


Infinity

De-I > Infinity

Infinity

Синтаксис

Infinity

Аргументы

None.

Описание

Глобальная переменная; предопределенная для значения бесконечности ECMA-262

Версия плугина

Flash 5 или более новый.


int

De-I > int

int

Синтаксис

int(value);

Аргументы

value число, которое надо округлить.

Описание

Функция; округляет десятичное число до ближайшего целого.

Версия плугина

Flash 4 или более новый. Эта функция устарела в Flash 5; вместо нее используйте Math.floor.

См. также

Math.floor


isFinite

De-I > isFinite

isFinite

Синтаксис

isFinite(expression);

Аргументы

expression Булево выражение, переменная или другое выражение, которое необходимо проверить.

Описание

Глобальная функция; вычисляет аргумент и возвращает true, если это конечное число, и false, если результат бесконечен (плюс или минус бесконечность). Обычно бесконечность возникает при делении на 0.

Версия плугина

Flash 5 или более новый.

Примеры

Это примеры вызовов isFinite:

isFinite(56) возвращает true

isFinite(Number.POSITIVE_INFINITY) возвращает false

isNaN(Number.POSITIVE_INFINITY) возвращает false


isNaN

De-I > isNaN

isNaN

Синтаксис

isNaN(expression);

Аргументы

expression Булево выражение, переменная или другое выражение, которое необходимо проверить.

Описание

Глобальная функция; вычисляет аргумент и возвращает true, если это число, и false, если результат не является правильным числом (строка, число с допущенными ошибками).

Версия плугина

Flash 5 или более новый.

Примеры

Примеры применения isNan:

isNan("Tree") возвращает true

isNan(56) возвращает false

isNaN(Number.POSITIVE_INFINITY) возвращает false


() (parentheses)

Операторы > () (parentheses)

() (круглые скобки)

Синтаксис

(expression1, expression2);
function(functionCall1, ..., functionCallN);

Аргументы

expression1, expression2 Числа, строки, переменные или текст.

function Функция, выполняющая содержание круглых скобок.

functionCall1...functionCallN Последовательность функций, которые должны быть выполнены прежде, чем результат будет передан функции, находящейся вне круглых скобок.

Описание

Оператор (общий); выполняет операцию группировки с одним или большим количеством аргументов или окружает один или более аргументов и передаёт результат - параметр функции вне круглых скобок.

Использование 1: выполняет операцию группировки над одним или более выражениями, контролируя порядок выполнения операторов в выражении. Этот оператор игнорирует автоматическую последовательность по старшинству и даёт команду первым рассматривать выражение внутри круглых скобок. После этого Flash в первую очередь рассматривает содержимое ближайших круглых скобок, затем - следующих.

Использование 2: окружает один или более аргументов и передаёт их функции вне круглых скобок, как параметры.

Player

Flash 4 или более поздней версии.

Пример

(Использование 1) Следующие выражения иллюстрируют использование круглых скобок для контроля последовательности исполнения выражений. (Результат дан под каждым выражением.)

(2 + 3) * (4 + 5)
45
2 + (3 * (4 + 5))
29
2 + (3 * 4) + 5
19

(Использование 2) Следующий пример иллюстрируют использование круглых скобок с функцией:

getDate();
invoice(item, amount);

Смотри также

with


Key (object)

K-L > Key (object)

Key (объект)

Объект Key является объектом верхнего уровня, к которому можно обращаться без использования конструктора. Методы этого объекта полезны для построения управляемого с клавиатуры интерфейса. Свойства объекта Key - константы, представляющие коды клавиш клавиатуры, обычно используемые для управления в играх. Смотри приложение Б (Appendix B), "Клавиши клавиатуры и их коды" для получения полного перечня значений кодов.

Примеры

onClipEvent (enterFrame) {
    if(Key.isDown(Key.RIGHT)) {
        setProperty ("", _x, _x+10);
    }
}
or
onClipEvent (enterFrame) {
    if(Key.isDown(39)) {
        setProperty("", _x, _x+10);
    }
}

Обзор методов для объекта Key
Метод | Описание
getAscii; | Возвращает ASCII-код последней нажатой клавиши.
getCode; | Возвращает виртуальный код последней нажатой клавиши.
isDown; | Возвращает true, если нажата клавиша, указанная в качестве аргумента.
isToggled; | Возвращает true, если активированы клавиши Num Lock или Caps Lock.

Обзор свойств для объекта Key

Все свойства объекта Key - константы.
Property | Описание
BACKSPACE | Константа, значение которой равно коду клавиши Backspace (9).
CAPSLOCK | Константа, значение которой равно коду клавиши Caps Lock (20).
CONTROL | Константа, значение которой равно коду клавиши Control (17).
DELETEKEY | Константа, значение которой равно коду клавиши Delete (46).
DOWN | Константа, значение которой равно коду клавиши Down Arrow (40).
END | Константа, значение которой равно коду клавиши End (35).
ENTER | Константа, значение которой равно коду клавиши Enter (13).
ESCAPE | Константа, значение которой равно коду клавиши Escape (27).
HOME | Константа, значение которой равно коду клавиши Home (36).
INSERT | Константа, значение которой равно коду клавиши Insert (45).
LEFT | Константа, значение которой равно коду клавиши Left Arrow (37).
PGDN | Константа, значение которой равно коду клавиши Page Down (34).
PGUP | Константа, значение которой равно коду клавиши Page Up (33).
RIGHT | Константа, значение которой равно коду клавиши Right Arrow (39).
SHIFT | Константа, значение которой равно коду клавиши Shift (16).
SPACE | Константа, значение которой равно коду клавиши Spacebar (32).
TAB | Константа, значение которой равно коду клавиши Tab (9).
UP | Константа, значение которой равно коду клавиши Up Arrow (38).


Key.BACKSPACE

K-L > Key.BACKSPACE

Key.BACKSPACE

Синтаксис

Key.BACKSPACE

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Backspace (9).

Player

Flash 5 или более новый.


Key.CAPSLOCK

K-L > Key.CAPSLOCK

Key.CAPSLOCK

Синтаксис

Key.CAPSLOCK

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Caps Lock (20).

Player

Flash 5 или более новый.


Key.CONTROL

K-L > Key.CONTROL

Key.CONTROL

Синтаксис

Key.CONTROL

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Control (17).

Player

Flash 5 или более новый.


Key.DELETEKEY

K-L > Key.DELETEKEY

Key.DELETEKEY

Синтаксис

Key.DELETEKEY

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Delete (46).

Player

Flash 5 или более новый.


Key.DOWN

K-L > Key.DOWN

Key.DOWN

Синтаксис

Key.DOWN

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Down Arrow (40).

Player

Flash 5 или более новый.


Key.END

K-L > Key.END

Key.END

Синтаксис

Key.END

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши End (35).

Player

Flash 5 или более новый.


Key.ENTER

K-L > Key.ENTER

Key.ENTER

Синтаксис

Key.ENTER

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Enter (13).

Player

Flash 5 или более новый.


Key.ESCAPE

K-L > Key.ESCAPE

Key.ESCAPE

Синтаксис

Key.ESCAPE

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Escape (27).

Player

Flash 5 или более новый.


Key.getAscii

K-L > Key.getAscii

Key.getAscii

Синтаксис

Key.getAscii();

Аргументы

Нет.

Описание

Метод; возвращает ASCII код последней нажатой или отпущенной клавиши.

Player

Flash 5 или более новый.


- (minus)

Операторы > - (minus)

- (минус)

Синтаксис

(Отрицание) -expression

(вычитание) expression1 - expression2

Аргументы

expression1, expression2 Любое число.

Описание

Оператор (арифметический); используется для отрицания и вычитания. В случае с отрицанием он переворачивает знак числового expression. В случае с вычитанием он выполняет арифметическое вычитание над двумя числовыми выражениями, вычитая expression2 из expression1. Если оба выражения являются целыми, разность также будет целым числом. Если одно или оба выражения являются выражениями с плавающей запятой, разность будет числом с плавающей запятой.

Player

Flash 4 или более поздней версии.

Пример

(Отрицание) Этот оператор переворачивает знак выражения 2 + 3:

-(2 + 3)

Результат: -5.

(Вычитание) Этот оператор вычитает целое число 2 из целого числа 5:

5 - 2

Результат - целое число 3.

(Вычитание): Этот оператор вычитает число с плавающей запятой 1.5 из числа с плавающей запятой 3.25:

put 3.25 - 1.5

Результат: 1.75 - число с плавающей запятой.


Key.getCode

K-L > Key.getCode

Key.getCode

Синтаксис

Key.getCode();

Аргументы

Нет.

Описание

Метод; возвращает код последней нажатой клавиши. Используйте информацию из приложения Б (Appendix B) для того, чтобы определить, какой клавише назначен полученый код на стандартной клавиатуре.

Player

Flash 5 или более новый.


Key.HOME

K-L > Key.HOME

Key.HOME

Синтаксис

Key.HOME

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Home (36).

Player

Flash 5 или более новый.


Key.INSERT

K-L > Key.INSERT

Key.INSERT

Синтаксис

Key.INSERT

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Insert(45).

Player

Flash 5 или более новый.


Key.isDown

K-L > Key.isDown

Key.isDown

Синтаксис

Key.isDown(keycode);

Аргументы

keycode Код, присвоенный либо определенной клавише, либо одно из свойств объекта Key, ассоциированное с клавишей. Приложение Б (Appendix B), "Клавиши клавиатуры и их коды" дает полный список всех кодов на стандартной клавиатуре.

Описание

Метод; возвращает true, если нажата клавиша keycode. На компьютерах Macintosh, коды клавиш Caps Lock и Num Lock идентичны.

Player

Flash 5 или более новый.


Key.isToggled

K-L > Key.isToggled

Key.isToggled

Синтаксис

Key.isToggled(keycode)

Аргументы

keycode код Caps Lock (20) или Num Lock (144).

Описание

Метод, возвращает true, если активизирована Caps Lock или Num Lock. На компьютерах Macintosh коды этих двух клавиш идентичны.

Player

Flash 5 или более новый.


Key.LEFT

K-L > Key.LEFT

Key.LEFT

x20949 | IDS_ACTIONHELP_KEY_LEFT2, Key.LEFT

Синтаксис

Key.LEFT

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Left Arrow (37).

Player

Flash 5 или более новый.


Key.PGDN

K-L > Key.PGDN

Key.PGDN

Синтаксис

Key.PGDN

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Page Down (34).

Player

Flash 5 или более новый.


Key.PGUP

K-L > Key.PGUP

Key.PGUP

Синтаксис

Key.PGUP

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Page Up (33).

Player

Flash 5 или более новый.


Key.RIGHT

K-L > Key.RIGHT

Key.RIGHT

Синтаксис

Key.RIGHT

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Right Arrow (39).

Player

Flash 5 или более новый.


Key.SHIFT

K-L > Key.SHIFT

Key.SHIFT

Синтаксис

Key.SHIFT

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Shift (16).

Player

Flash 5 или более новый.


* (multiplication)

Операторы > * (multiplication)

* (умножение)

Синтаксис

expression1 * expression2

Аргументы

expression1, expression2 Целые числа или числа с плавающей запятой.

Описание

Оператор (арифметический); умножает два числовых выражения. Если оба выражения являются целыми числами, то результат - целое число. Если одно или оба выражения - числа с плавающей запятой, то результат - число с плавающей запятой.

Player

Flash 4 или более поздней версии.

Пример

Этот оператор перемножает целые числа 2 и 3:

2 * 3

Результат: 6 - целое число.

Пример

Этот оператор перемножает числа с плавающей запятой 2.0 и 3.1416:

2.0 * 3.1416

Результат - число с плавающей запятой 6.2832.


Key.SPACE

K-L > Key.SPACE

Key.SPACE

Синтаксис

Key.SPACE

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Spacebar (32).

Player

Flash 5 или более новый.


Key.TAB

K-L > Key.TAB

Key.TAB

Синтаксис

Key.TAB

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Tab (9).

Player

Flash 5 или более новый.


Key.UP

K-L > Key.UP

Key.UP

Синтаксис

Key.UP

Аргументы

Нет.

Описание

Свойство; Константа, значение которой равно коду клавиши Up Arrow (38).

Player

Flash 5 или более новый.


le (less than or equal to — string specific)

K-L > le (меньше или равно — строковой оператор)

le (меньше или равно — строковой оператор)

Синтаксис

expression1 le expression2

Аргументы

expression1,expression2 Числа, строки или переменные.

Описание

Оператор (сравнения); сравнивает expression1 с expression2 и возвращает true, если expression1 меньше чем или равно expression2, в противном случае возвращает false.

Player

Flash 4 или более новый. Этот оператор считается устаревшим в Flash 5; рекомендовано использование нового оператора <= .

См. также

<= (не больше)


length

K-L > length

length

Синтаксис

length(expression);
length(variable);

Аргументы

expression Любая строка.

variable Имя переменной.

Описание

Строковая функция; возвращает длину строки, указанной в качестве аргумента.

Player

Flash 4 или более новый. Эта функция, так же, как и другие строковые функции считаются устаревшими в Flash 5. Рекомендуется использовать метод length объекта String для выполнения операций со строками.

Примеры

Следующий примеры возвращает длину строки Hello:

length("Hello");

Результат будет равным 5.

См. также


_level

K-L > _level

_level

Синтаксис

_levelN;

Аргументы

N Неотрицательное целое, обозначающее уровень (level). По умолчанию, _level равно 0, что соответствует базовому мувику.

Описание

Свойство; возвращает ссылку на корневой (root) мувиклип в тайм-лайн (Timeline) levelN. Перед тем, как указывать мувики в свойстве _level, вы должны загрузить их с помощью команды loadMovie.

Во Flash Player каждому мувику присваевается число в соответствии с порядком, в котором они загружены. Мувику, который загружен первым на нижний уровень - 0. Этот мувик задает для всех единый фреймрейт (frame rate - кол-во кадров в секунду), цвет фона, и размер окна. Другие мувиклипы подгружаеются на уровни выше нулевого, с номерами больше 0.

Player

Flash 4 или более новый.

Примеры

Следующий пример останавливает воспроизведение клипа на нулевом уровне:

_level0.stop();

Этот пример переводит воспроизведение клипа на 4-м уровне на пятый кадр, мувиклип на 4-м уровне должен быть предварительно загружен с помощью команды loadMovie:

_level4.gotoAndStop(5);

См. также


loadMovie

K-L > loadMovie

loadMovie

Синтаксис

loadMovie(url [,location/target, variables]]);

Аргументы

url Абсолютный или относительный адрес, с которого будет загружаться SWF файл. При подгрузке в сети, файл должен находиться в том же поддомене, что и исходный клип. В случае локального использования Flash Player и тестирования мувика из Flash-редактора, все подгружаемые файлы должны находиться в том же каталоге, имена файлов не должны содержать имен дисков или каталогов 1.

target Необязательный аргумент, указывающий, какой муви-клип будет заменен вновь загруженным. Новый мувик наследует положение, свойства поворота и масштабирования. Если target такое же, как и location (level), то необязательно указывать оба параметра.

location Необязательный аргумент, указывающий, уровень, куда загружается мувик. Новый мувик наследует положение, свойства поворота и масштабирования. Чтобы добавить мувик, просто укажите здесь номер еще не занятого уровня. Чтобы заменить какой-то мувик, занимающий целый уровень, укажите его. Чтобы заменить главный мувик и выгрузить все уровни, укажите здесь 0. Мувик на уровне 0 указывает для всех остальных скорость, размер экрана и цвет фона.

variables Необязательный аргумент, указывающий метод передачи переменных. Если переменные передавать не надо, не трогайте и этот параметр. Иначе - укажите, использовать для передачи метод GET или POST. GET добавляет переменные к концу строки URL и используется для передачи небольших переменных (и небольшого их количества). POST отсылает переменные отдельно от основного файла и может передать любые мыслимые объемы.

Описание

Команда; подгружает дополнительные мувики, не закрывая Flash Player. Обычно Flash Player отображает один мувик (SWF файл) и потом закрывается. Команда loadMovie позволяет отображать несколько мувиков сразу или переключаться между ними, не загружая другой документ HTML.

Можно загружать мувик на уровень, на котором уже загружен файл SWF. Для этого укажите в качестве параметра номер уровня, занимаемого этим клипом. Чтобы заменить главный мувик и выгрузить все уровни, укажите здесь 0. Используйте команду loadVariables, чтобы сохранить мувик, но загрузить туда новые переменные.

Используйте команду unloadMovie, чтобы выгрузить мувик, загруженный с помощью loadMovie .

Player

Flash 3 или более новый.

Примеры

Это выражение loadMovie присоединено к навигационной кнопке, названной Products. В мувике существует невидимый клип, который называется dropZone. Команда loadMovie использует этот муви-клип для того, чтобы загрузить в него SWF-файл:

on(release) {
    loadMovie("products.swf",_root.dropZone);
}

См. также

unloadMovie
_level

От редактора

  1. См. комментарии на MovieClip.loadMovie


loadVariables

K-L > loadVariables

loadVariables

Синтаксис

loadVariables (url ,location [, variables]);

Аргументы

url Абсолютный или относительный адрес файла с переменными. При подгрузке в сети, файл должен находиться в том же поддомене, что и исходный клип.

location Уровень, или имя муви-клипа (target), куда необходимо заслать полученные переменные. Первый (базовый) клип находится на нулевом уровне (level0), подгруженные клипы могут находится на уровнях с другими номерами. Этот аргумент необязательный.

variables Необязательный аргумент, указывающий метод передачи переменных. Если переменные передавать не надо, не трогайте и этот параметр. Иначе - укажите, использовать для передачи метод GET или POST. GET добавляет переменные к концу строки URL и используется для передачи небольших переменных (и небольшого их количества). POST отсылает переменные отдельно от основного файла и может передать любые мыслимые объемы.

Описание

Команда; считывает данные из внешнего файла, например из текстового или файла, сгенерированный скриптом CGI, Active Server Pages (ASP) или Personal Home Page (PHP), и устанавливает значения переменных в муви-клипе. Эта команда также употребляется для обновления переменные.

указанный URL должен быть в стандартном формате MIME application/x-www-urlformencoded (стандартный формат, используемый в скриптах CGI). Главный мувик и файл с переменными должны находиться в одном поддомене. Передано может быть любое количество переменных. Например, так определяется несколько переменных:

company=Macromedia&address=600+Townsend&city=San+Francisco&zip=94103

Player

Flash 4 или более новый.

Примеры

Этот пример загружает переменные из текстового файла в базовую линейку (TimeLine) базового клипа (level 0).

on(release) {
    loadVariables("data.txt", 0);
}

См. также


lt (меньше, строковой оператор)

K-L > lt (меньше — строковой оператор)

lt (меньше — строковой оператор)

Синтаксис

expression1 lt expression2

Аргументы

expression1, expression2 Числа, строки или переменные.

Описание

Оператор (сравнения); сравнивает expression1 и expression2 и возвращает true, если expression1 меньше, чем expression2. В противном случае возвращает false.

Player

Flash 4 или более новый. Этот оператор считается устаревшим в Flash 5, рекомендовано использование нового оператора < (меньше).

См. также

< (меньше)


Math (object)

Math > Math (объект)

Math (объект)

Объект Math является объектом верхнего уровня, к которому вы можете обращаться без использования конструктора.

Используйте методы и свойства этого объекта для обращения к математическим константам и функциям и манипулирования ими. Все методы и свойства объекта Math являются статическими и должны вызываться с использованием синтаксиса Math.метод (аргумент) или Math.константа. В ActionScript константы определены с максимальной точностью по точности, определенной ИИЭР-754 для чисел с плавающей запятой с удвоенной точностью.

Объект Math полностью поддерживается во Flash 5 Player. Во Flash 4 методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5.

Некоторые методы объекта Math принимают в качестве аргумента значение угла в радианах. Вы можете использовать нижеприведенную формулу для вычисления значений в радианах или просто передать в аргумент формулу (введя значение в градусах) вычисления радианов.

Для вычисления значения в радианах используйте эту формулу:

радиан = Math.PI/180 * градус

А это пример использования передачи в аргумент формулы вычисления радианов для вычисления синуса угла 45 градусов.

Math.SIN(Math.PI/180 * 45) то же, что и Math.SIN(.7854)

Сводка методов объекта Math
Метод | Описание
abs | Вычисляет абсолютное значение.
acos | Вычисляет арккосинус.
asin | Вычисляет арксинус.
atan | Вычисляет арктангенс.
atan2 | Вычисляет угол от оси х до точки.
ceil | Округляет значение вверх до ближайшего целого.
cos | Вычисляет косинус.
exp | Вычисляет экспоненциальное значение.
floor | Округляет значение вниз до ближайшего целого.
log | Вычисляет натуральный логарифм.
max | Возвращает большее число из двух целых чисел.
min | Возвращает меньшее число из двух целых чисел.
pow | Вычисляет значение x возведенное в степень y.
random | Возвращает псевдослучайное число между 0.0 и 1.0.
round | Округляет до ближайшего целого числа.
sin | Вычисляет синус.
sqrt | Вычисляет квадратный корень.
tan | Вычисляет тангенс.

Сводка свойств объекта Math

Все свойства объекта Math являются константами.
Свойство | Описание
E | Константа Эйлера и основание натуральных логарифмов (приближенно 2.718).
LN2 | Натуральный логарифм числа 2 (приближенно 0.693).
LOG2E | Логарифм e с основанием 2 (приближенно 1.442).
LN10 | Натуральный логарифм числа 10 (приближенно 2.302).
LOG10E | Логарифм e с основанием 10 (приближенно 0.434).
PI | Отношение длины окружности к ее диаметру (приближенно 3.14159).
SQRT1_2 | Квадратный корень из 1/2 (приближенно 0.707).
SQRT2 | Квадратный корень из 2 (приближенно 1.414).


*= (multiplication assignment)

Операторы > *= (multiplication assignment)

*= (присвоение умножения)

Синтаксис

expression1 *= expression2

Аргументы

expression1, expression2 Целые числа, числа с плавающей запятой или строки.

Описание

Оператор (присваивания); присваивает expression1 значение expression1 * expression2.

Player

Flash 4 или более поздней версии.

Пример

Пример использования оператора *= с переменными и числами:

x *= y то же, что и x = x * y

If x = 5 и y = 10 , то

x *= 10 вернёт 50

Смотри также

* (multiplication)


Math.abs

Math > Math.abs

Math.abs

Синтаксис

Math.abs(x);

Аргументы

x Любое число.

Описание

Метод; вычисляет и возвращает абсолютное значение числа, заданного в аргументе x.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.acos

Math > Math.acos

Math.acos

Синтаксис

Math.acos(x);

Аргументы

x Число от -1.0 до 1.0.

Описание

Метод; вычисляет и возвращает арккосинус числа, заданного в аргументе x в радианах.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.asin

Math > Math.asin

Math.asin

Синтаксис

Math.asin(x);

Аргументы

x Число от -1.0 до 1.0.

Описание

Метод; вычисляет и возвращает значение арксинуса числа, заданного в аргументе x, в радианах.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.atan

Math > Math.atan

Math.atan

Синтаксис

Math.atan(x);

Аргументы

x Любое число.

Описание

Метод; вычисляет и возвращает значение арктангенса числа x, заданного в аргументе в радианах.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.atan2

Math > Math.atan2

Math.atan2

Синтаксис

Math.atan2(y, x);

Аргументы

x Число, определяющее координату x точки.

y Число, определяющее координату y точки.

Описание

Метод; вычисляет и возвращает значение арктангенса y/x в радианах. Возвращаемое значение представляет собой дополняющий угол того угла прямоугольного треугольника, для которого x - длина смежной стороны, y - длина противоположной стороны.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.ceil

Math > Math.ceil

Math.ceil

Синтаксис

Math.ceil(x);

Аргументы

x Число или выражение.

Описание

Метод; возвращает наименьшее целое число, большее или равное по значению x.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.cos

Math > Math.cos

Math.cos

Синтаксис

Math.cos(x);

Аргументы

x Угол, заданный в радианах

Описание

Метод; возвращает косинус (значение от -1.0 до 1.0) угла, заданного аргументом x. Угол x должен быть задан в радианах. Для вычисления значения угла в радианах используйте способ, описанный в введении к объекту Math.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.E

Math > Math.E

Math.E

Синтаксис

Math.E

Аргументы

Отсутствуют.

Описание

Константа; математическая константа, представляющая собой основание натуральных логарифмов и обозначаемая через e. Приближенное значение e равно 2.71828.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.exp

Math > Math.exp

Math.exp

Синтаксис

Math.exp(x);

Аргументы

x Экспонента; число или выражение.

Описание

Метод; возвращает значение основания натурального логарифма (е), возведенного в степень, заданного в аргументе х.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.floor

Math > Math.floor

Math.floor

Синтаксис

Math.floor(x);

Аргументы

x Число или выражение.

Описание

Метод; возвращает наибольшее целое число, меньшее или равное по значению числу или выражению, заданного аргументом х.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.

Пример

Следующее возвращает значение 12:

Math.floor(12.5);


, (comma)

Операторы > , (comma)

, (запятая)

Синтаксис

expression1, expression2

Аргументы

expression Любое число, переменная, строка, элемент массива или другие данные.

Описание

Оператор; даёт команду Flash'у проанализировать expression1, потом expression2 и затем вернуть значение expression2. Этот оператор чаще всего используется с оператором цикла for.

Player

Flash 4 или более поздней версии.

Пример

Код, использующий данный оператор:

var a=1, b=2, c=3;

Это равноценно следующий записи:

var a=1;
var b=2;
var c=3;


Math.log

Math > Math.log

Math.log

Синтаксис

Math.log(x);

Аргументы

x Число или выражение со значением больше 0.

Описание

Метод; возвращает натуральный логарифм аргумента х.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.LOG2E

Math > Math.LOG2E

Math.LOG2E

Синтаксис

Math.LOG2E

Аргументы

Отсутствуют.

Описание

Константа; математическая константа, представляющая собой значение логарифма с основанием 2 константы е (Math.E). Выражается через log2e. Приближенное значение равно 1.442695040888963387.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.LOG10E

Math > Math.LOG10E

Math.LOG10E

Синтаксис

Math.LOG10E

Аргументы

Отсутствуют.

Описание

Константа; математическая константа, представляющая собой значение логарифма с основанием 10 константы е (Math.E). Выражается через log10e. Приближенное значение равно 0.43429448190325181667.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.LN2

Math > Math.LN2

Math.LN2

Синтаксис

Math.LN2

Аргументы

Отсутствуют.

Описание.

Константа; математическая константа, представляющая собой значение натурального логарифма числа 2. Выражается через ln2. Приближенное значение равно 0.69314718055994528623.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.LN10

Math > Math.LN10

Math.LN10

Синтаксис

Math.LN10

Аргументы

Отсутствуют.

Описание

Константа; математическая константа, представляющая собой значение натурального логарифма числа 10. Выражается через ln10. Приближенное значение равно 2.3025850929940459011.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.max

Math > Math.max

Math.max

Синтаксис

Math.max(x , y);

Аргументы

x Число или выражение.

y Число или выражение.

Описание

Метод; сравнивает x и y и возвращает большее значение.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.min

Math > Math.min

Math.min

Синтаксис

Math.min(x , y);

Аргументы

x Число или выражение.

y Число или выражение.

Описание

Метод; сравнивает x и y и возвращает меньшее значение.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.PI

Math > Math.PI

Math.PI

Синтаксис

Math.PI

Аргументы

Отсутствуют.

Описание

Константа; математическая константа, представляющая собой значение отношения длины окружности к ее диаметру. Обозначется через pi. Приближенное значение равно 3.14159265358979.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.pow

Math > Math.pow

Math.pow

Синтаксис

Math.pow(x , y);

Аргументы

x Число, которое должно быть возведено в степень.

y Число, задающее степень, в которую должен быть возведен аргумент x.

Описание

Метод; вычисляет и возвращает значение х возведенное в степень y.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.random

Math > Math.random

Math.random

Синтаксис

Math.random();

Аргументы

Отсутствуют.

Описание

Метод; возвращает псевдослучайное число между 0.0 и 1.0

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.

Cм. также

random


ActionScript dictionary: Краткий обзор

Краткий обзор > Словарь ActionScript: Краткий обзор

Словарь ActionScript: Краткий обзор

Эта часть документации описывает синтаксис и использование элементов ActionScript во Flash 5 и его более поздних версиях. Чтобы использовать примеры в своем скрипте, скопируйте текст с соответствующей страницы словаря ActionScript и вставьте его в панель Actions в режиме Expert Mode.

Словарь содержит все элементы языка ActionScript: операторы, ключевые слова, выражения, команды, свойства, функции, объекты и методы. Чтобы ознакомиться со всем этим более подробно, смотрите Содержание словаря. Находящиеся там таблицы, прекрасный отправной пункт для поиска операторов или методов, объектный класс которых вы не знаете.

ActionScript соответствует стандарту ECMA-262 (спецификации написанной Европейской Ассоциацией Производителей Компьютеров), при условии, что нет других пометок.

В словаре два типа статей:

Отдельные статьи для операторов, ключевых слов, функций, переменных, свойств, методов и выражений
Статьи об объектах, описывающие основные подробности предопределённых объектов

Используйте информацию данной главы справки, для понимания структуры и принятых соглашений для этих двух типов статей.


. (dot operator)

Операторы > . (dot operator)

. (точка)

Синтаксис

object.property_or_method
instancename.variable
instancename.childinstance.variable

Аргументы

object Экземпляр объекта. Некоторые объекты должны быть созданы с использованием конструктора для этого объекта. Объектом может быть любой предопределенный объект ActionScript или специальный объект. Этот аргумент всегда находится слева от оператора точка (.).

property_or_method Имя свойства или метода, относящегося к объекту. Все валидные методы и свойства предопределенного объекта приведены в таблицах Методы и Свойства для данного объекта. Этот аргумент всегда находится справа от оператора точка (.).

instancename Имя мувиклипа.

childinstance Имя мувиклипа, являющегося дочерним по отношению к главному клипу.

variable Переменная в мувиклипе.

Описание

Оператор; используется для управления иерархией клипа, доступа к вложенным дочерним клипам, переменным или свойствам. Оператор точка (.) также используется для проверки или установки свойств объекта, для выполнения метода объекта или создания структуры данных.

Player

Flash 4 или более поздней версии.

Смотри также

[] (array access operator)

Пример

Этот оператор идентифицирует текущее значение переменной hairColor мувиклипа person:

person.hairColor

Это равноценно следующему синтаксису Flash 4:

/person:hairColor

Пример

Этот код bkk.cnhbhetn, как можно использовать оператор точка (.) для создания структуры массива:

account.name = "Gary Smith";
account.address = "123 Main St ";
account.city = "Any Town";
account.state = "CA";
account.zip = "12345";


Math.round

Math > Math.round

Math.round

Синтаксис

Math.round(x);

Аргументы

x Любое число.

Описание

Метод; округляет значение аргумента x вверх или вниз до ближайшего целого и возвращает это значение.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.sin

Math > Math.sin

Math.sin

Синтаксис

Math.sin(x);

Аргументы

x Угол, заданный в радианах.

Описание

Метод; вычисляет и возвращает синус заданного в радианах угла. Для вычисления значения угла в радианах используйте способ, описанный в введении к объекту Math.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.

См. также

Math (object)


Math.sqrt

Math > Math.sqrt

Math.sqrt

Синтаксис

Math.sqrt(x);

Аргументы

x Любое число или выражение, большее или равное по значению 0.

Описание

Метод; вычисляет и возвращает квадратный корень заданного числа.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.SQRT1_2

Math > Math.SQRT1_2

Math.SQRT1_2

Синтаксис

Math.SQRT1_2

Аргументы

Отсутствуют.

Описание

Константа; математическая константа, представляющая собой значение квадратного корня из 1/2. Приближенное значение равно 0.707106781186.

Проигрыватель

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.SQRT2

Math > Math.SQRT2

Math.SQRT2

Синтаксис

Math.SQRT2

Аргументы

Отсутствуют.

Описание

Константа; математическая константа, представляющая собой значение квадратного корня из 2. Приближенное значение равно 1.414213562373.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


Math.tan

Math > Math.tan

Math.tan

Синтаксис

Math.tan(x);

Аргументы

x Угол, заданный в радианах.

Описание

Метод; вычисляет и возвращает тангенс заданного угла. Для вычисления значения угла в радианах используйте способ, описанный в введении к объекту Math.

Player

Flash 5 или выше. Во Flash 4 Player методы объекта Math работают, но они эмулируются с использованием приближенных значений и могут быть не такими точными как неэмулированные математические функции, поддерживаемые Flash 5 Player.


maxscroll

Max-Mov > maxscroll

maxscroll

Синтаксис

variable_name.maxscroll = x

Аргументы

variable_name Имя переменной, ассоциированной с текстовым полем.

x Наибольшее значение номера строки, допустимое для свойства scroll, основанное на высоте текстового поля. Это значение "только для чтения", устанавливаемое со стороны Flash.

Описание

Свойство; свойство "только для чтения", которое работает со свойством scroll для контроля отображения информации в текстовом поле. Значение этого свойства невозможно изменить, оно может быть только считано.

Player

Flash 4 или выше.

См. также

scroll


mbchr

Max-Mov > mbchr

mbchr

Синтаксис

mbchr(number);

Аргументы

number Число, преобразуемое в многобайтный символ.

Описание

Строковая функция; преобразует число ASCII-кода в многобайтный символ.

Player

Flash 4 или выше. Эта функция нежелательна во Flash 5; рекомендуется пользоваться методом String.fromCharCode.

См. также

String.fromCharCode


mblength

Max-Mov > mblength

mblength

Синтаксис

mblength(string);

Аргументы

string Строка.

Описание

Строковая функция; возвращает длину строки многобайтных символов.

Player

Flash 4 или выше. Эта функция нежелательна во Flash 5; рекомендуется пользоваться объектом String и методами.


mbord

Max-Mov > mbord

mbord

Синтаксис

mbord(character);

Аргументы

character Символ, преобразуемый в многобайтное число.

Описание

Строковая функция; конвертирует заданный символ в многобайное число.

Player

Flash 4 или выше. Эта функция нежелательна во Flash 5; рекомендуется пользоваться методом String.charCodeAt.

См. также

String.fromCharCode


?: (conditional)

Операторы > ?: (conditional)

?: (импликация)

Синтаксис

expression1 ? expression2 : expression3

Аргументы

expression1 Выражение, оценивающееся булевым значением, обычно сравнительное выражение.

expression2, expression3 Любое значение.

Описание

Оператор (импликация); анализирует expression1 и возвращает значение expression2 если expression1 есть true, в противном случае возвращает значение expression3.

Player

Flash 4 или более поздней версии.


mbsubstring

Max-Mov > mbsubstring

mbsubstring

Синтаксис

mbsubstring(value, index, count);

Аргументы

value Многобайтная строка, из которой извлекается новая многобайтная строка.

index Номер первого извлекаемого символа.

count Количество символов, включаемые в извлекаемую строку, кроме символа index.

Описание

Строковая функция; извлекает новую строку многобайтных символов из существующей.

Player

Flash 4 или выше. Эта функция нежелательна во Flash 5; рекомендуется использовать метод string.substr.

См. также

String.substr


Mouse (object)

Max-Mov > Mouse (object)

Mouse (объект)

Для сокрытия и отображения курсора в клипе используются методы объекта Mouse. По умолчанию курсор является видимым, но его можно отклбчить и использовать свой вариант курсора, созданный в виде мувиклипа.

Список методов Mouse
Метод | Описание
hide | Отключает отображание курсора в клипе.
show | Включает отображание курсора.


Mouse.hide

Max-Mov > Mouse.hide

Mouse.hide

Синтаксис

Mouse.hide();

Аргументы

Отсутствуют.

Описание

Метод; Отключает отображание курсора мыши в клипе. По умолчанию курсор является видимым.

Player

Flash 5 или выше.

Образец

Следующий код, прописанный в мувиклипе находящемся на главной линейке, скрывает стандартный курсор и устанавливает координаты x и y мувика customCursor в позиции x и y мыши на главной линейке:

onClipEvent(enterFrame){
    Mouse.hide();
    customCursorMC_x = _root._xmouse;
    customCursorMC_y = _root._ymouse;
}

См. также


Mouse.show

Max-Mov > Mouse.show

Mouse.show

Синтаксис

Mouse.show();

Аргументы

Отсутствуют.

Описание

Метод; Включает отображение курсора мыши в клипе. По умолчанию курсор является видимым.

Player

Flash 5 или выше.

См. также


MovieClip (object)

Max-Mov > MovieClip (object)

MovieClip (object)

Методы для объекта MovieClip предоставляют те же функциональные возможности, что и стандартные команды для мувиклипов. Есть дополнительные методы, предоставляющие возможности, которые недоступны при использовании стандартных команд, перечисленных в категории Actions панели Actions. Не надо использовать способ конструирования для вызова методов объекта MovieClip; вместо этого вы обращаетесь к мувиклипу по имени, используя следующий синтаксис:

anyMovieClip.play();
anyMovieClip.gotoAndPlay(3);

Список методов объекта Movie Clip
Метод | Описание
attachMovie | Присоединяет клип в библиотеке.
duplicateMovieClip | Создает дубликат указанного мувиклипа.
getBounds | Возвращает минимальные и максимальные значения координат x и y мувиклипа в заданном координатном пространстве.
getBytesLoaded | Возвращает количество загруженных байтов для указанного мувиклипа.
getBytesTotal | Возвращает размер мувиклипа в байтах.
getURL | Загружает документ с URL.
globalToLocal | Преобразует глобальные координаты в локальные.
gotoAndPlay | Осуществляет переход в заданный кадр клипа и воспроизводит его дальше.
gotoAndStop | Осуществляет переход в заданный кадр клипа и останавливает его.
hitTest | Возвращает true если указанный мувиклип пересекается или перекрывается с другим мувиком.
loadMovie | Загружает указанный мувиклип.
loadVariables | Загружает переменные из URL или другого места в клип.
localToGlobal | Преобразует локальные координаты в глобальные.
nextFrame | Осуществляет переход на следующий кадр.
play | Воспроизводит указанный мувиклип.
prevFrame | Осуществляет переход на предыдущий кадр.
removeMovieclip | Удаляет мувиклип с линейки, если он был создан командой duplicateMovieClip или методом attachMovie.
startDrag | Определяет мувиклип как перетаскиваемым и начинает его перемещать.
stop | Останавливает воспроизведение текущего клипа.
stopDrag | Останавливает перемещение любого объекта, который является перетаскиваемым.
swapDepths | Производит замеру уровня указанного мувиклипа и мувиклипа на заданном уровне.
unloadMovie | Удаляет мувиклипа, загруженный с помощью loadMovie.


MovieClip.attachMovie

Max-Mov > MovieClip.attachMovie

MovieClip.attachMovie

Синтаксис

anyMovieClip.attachMovie(idName, newname, depth);

Аргументы

idName Имя (идентификатор) присоединяемого из библиотеки мувиклипа. Оно вводится в поле Identifier диалогового окна Symbol Linkage Properties.

newname Уникальное имя для присоединенного мувиклипа.

depth Целое число, задающее номер уровня 1, на каторый должен быть помещен мувиклип.

Описание

Метод; создает новый эталон мувиклипа в библиотеке и присоединяет его к клипу, указанному в anyMovieClip. Используйте команду или метод removeMovieClip или unloadMovie для удаления мувиклипа, присоединенного с помощью attachMovie.

Player

Flash 5 или выше.

См. также

removeMovieClip
unloadMovie
MovieClip.removeMovieClip
MovieClip.unloadMovie

От редактора

  1. Понятие "уровень" в данном контексте следует отличать от уровня, на который возможна подгрузка другого Flash-клипа по команде loadMovie. Данные уровни относятся к текущей линейке (Timeline) и не являются глобальными для всего клипа, т.е. возможно их создание как на основной линейке, так и внутри любого мувиклипа. По своему "физическому смыслу" они аналогичны слоям (lyers) линейки, и всегда, независимо от значения depth , образуются выше самого верхнего слоя текущей линейки.


MovieClip.duplicateMovieClip

Max-Mov > MovieClip.duplicateMovieClip

MovieClip.duplicateMovieClip

Синтаксис

anyMovieClip.duplicateMovieClip(newname, depth);

Аргументы

newname Уникальный идентификатор созданного дубликата мувиклипа.

depth Число, задающее уровень, на который должен быть помещен дубликат мувиклипа.

Описание

Метод; создает эталон заданного мувиклипа во время воспроизведения клипа. Дублированный мувиклип всегда начинает воспроизводиться с первого кадра, не имеет значения какой кадр является текущим в оригинальном клипе когда вызывается метод duplicateMovieClip. Переменные не копируются из оригинального мувиклипа в созданный дубль. При удалении родительского мувиклипа, его дубликат также удаляется 1. Мувиклип, добавленный с помощью duplicateMovieClip, может быть удален с помощью команды или метода removeMovieClip.

Player

Flash 5 или выше.

См. также

removeMovieClip
MovieClip.removeMovieClip

От редактора

  1. Интересно, читают ли девелоперы Макромедии свои доки? :)
    Нет, дочерний мувик не удаляется и продолжает жить своей жизнью, независимо от родителя. Достаточно сделать простенький эксперимент - создать какой-нибудь мувик в библиотеке, залинковать его с идентификатором "ааа" и в первый кадр клипа скопировать данный код:

    _root.attachMovie( "aaa", "qu", 0 );
for (n=1; n<=10; n++) {
    qu.duplicateMovieClip("a"+n, n);
    Eval("a"+n)._x=aaa._x+n*10+100; // это чтобы клоны
    Eval("a"+n)._y=aaa._y+n*10+100; // не сливались в одну проекцию
}
qu.removeMovieClip();

    В данном примере родительский мувиклип "qu" после клонирования 10 "детей" будет удален последней командой, а его "дети" остануться в неприкосновенности.


MovieClip.getBounds

Max-Mov > MovieClip.getBounds

MovieClip.getBounds

Синтаксис

anyMovieClip.getBounds(targetCoordinateSpace);

Аргументы

targetCoordinateSpace Путь к линейке (Timeline), пространство которой используется как система координат.

Описание

Метод; возвращает максимальные и минимальные значения координат x и y мувиклипа, в координатном пространстве (системе координат), заданном в аргументе. Возвращаемый объект будет содержать свойства {xMin, xMax, yMin, yMax}. Используйте методы localToGlobal и globalToLocal для преобразования локальных координат клипа в глобальные или глобальных в локальные соответственно.

Player

Flash 5 или выше.

Пример

Следующий пример использует getBounds для получения координат рамки ограничивающей мувиклип myMovieClip в системе координат основного клипа.

myMovieClip.getBounds(_root);

См. также


MovieClip.getBytesLoaded

Max-Mov > MovieClip.getBytesLoaded

MovieClip.getBytesLoaded

Синтаксис

anyMovieClip.getBytesLoaded();

Аргументы

Отсутствуют.

Описание

Метод; возвращает количество загруженных байтов, указанного мувиклипа. Поскольку внутренние клипы загружаются автоматически, то возвращаемое значение для этого метода будет равно возвращаемому значению метода MovieClip.getBytesTotal, если заданный мувиклип является внутренним. Этот метод предназначен для использования с загружаемыми клипами (например, для создания визуального прелоадера Прим. редактора). Можно сравнивать друг с другом значения getBytesLoaded и getBytesTotal для определения уже загруженной части внешнего клипа.

Player

Flash 5 или выше.


MovieClip.getBytesTotal

Max-Mov > MovieClip.getBytesTotal

MovieClip.getBytesTotal

Синтаксис

anyMovieClip.getBytesTotal();

Аргументы

Отсутствуют.

Описание

Метод; возвращает размер в байтах, указанного объекта Movie Clip. Для клипов, которые являются внешними (корневой клип или клип, подгружаемый в цель или уровень), возвращаемое значение является размером SWF файла.

Player

Flash 5 или выше.


/ (division)

Операторы > / (division)

/ (деление)

Синтаксис

expression1 / expression2

Аргументы

expression Любое число.

Описание

Оператор (арифметический); делит expression1 на expression2. Аргументы выражений и результаты деления обрабатываются и представляются, как числа с плавающей запятой с удвоенной точностью.

Player

Flash 4 или более поздней версии.

Пример

Этот оператор делит число с плавающей запятой 22.0 на 7.0 и показывает результат в окне Output:

trace(22.0 / 7.0);

Результат - число с плавающей запятой 3.1429.


MovieClip.getURL

Max-Mov > MovieClip.getURL

MovieClip.getURL

Синтаксис

anyMovieClip.getURL(URL [,window, variables]);

Аргументы

URL URL, откуда необходимо получить документ.

window Необязательный аргумент, задающий имя, фрейм или выражение, определяющие окно или фрейм HTML, в которое должен быть загружен документ. Можно также использовать одно из зарезервированных целевых имен: _self задает текущий фрейм в текущем окне, _blank задает новое окно, _parent задает родителя текущего фрейма, _top задает верхнеуровневый фрейм в текущем окне.

variables Необязательный аргумент, определяющий метод отсылки переменных из клипа на сервер. Если отсылать переменные не требуется, этот агрумент опускается. В противном случае, указывается метод ("GET" или "POST"). GET прицепляет переменные к концу URL и используется в случае малого количества переменных (длина запроса ограничена 256 символами Прим. редактора). POST отправляет переменные в отдельном HTTP заголовке и используется для длинных строковых переменных.

Описание

Метод; загружает документ с заданного URL в заданное окно. Метод getURL также может быть использован для передачи переменных другим приложениям, определенным через URL с помощью методов GET или POST.

Player

Flash 5 или выше.


MovieClip.globalToLocal

Max-Mov > MovieClip.globalToLocal

MovieClip.globalToLocal

Синтаксис

anyMovieClip.globalToLocal(point);

Аргументы

point Имя или идентификатор объекта, созданного с помощью общего объекта Object, с координатами x и y в качестве свойств.

Описание

Метод; конвертирует глобальные координаты объекта point в локальные координаты мувиклипа.

Player

Flash 5 или выше.

Пример

Следующий код преобразует глобальные координаты x и y объекта point в локальные координаты мувиклипа:

onClipEvent(mouseMove) {
    point = new object();
    point.x = _root._xmouse;
    point.y = _root._ymouse;
    globalToLocal(point);
    _root.out = _xmouse + " === " + _ymouse;
    _root.out2 = point.x + " === " + point.y;
    updateAfterEvent();
}

См. также


MovieClip.gotoAndPlay

Max-Mov > MovieClip.gotoAndPlay

MovieClip.gotoAndPlay

Синтаксис

anyMovieClip.gotoAndPlay(frame);

Аргументы

frame Номер кадра, на который должен перейти Player.

Описание

Метод; осуществляет переход и воспроизведение клипа с указанного кадра.

Player

Flash 5 или выше.


MovieClip.gotoAndStop

Max-Mov > MovieClip.gotoAndStop

MovieClip.gotoAndStop

Синтаксис

anyMovieClip.gotoAndStop(frame);

Аргументы

frame Номер кадра, на который должен перейти Player.

Описание

Метод; осуществляет переход и останавливает клип на указанном кадре.

Player

Flash 5 или выше.


MovieClip.hitTest

Max-Mov > MovieClip.hitTest

MovieClip.hitTest

Синтаксис

anyMovieClip.hitTest(x, y, shapeFlag);
anyMovieClip.hitTest(target);

Аргументы

x x-координата хит-области на сцене.

y y-координата хит-области на сцене.

Координаты x и y определены в глобальном координатном пространстве.

target Хит-область, которая может пересекаться или перекрываться с anyMovieClip. target; обычно представляет собой кнопку или динамическое текстовое поле.

shapeFlag Булево значение, указывающее воспринимать ли всю форму (площадь) мувиклипа - (true) или только его границу (рамку) - (false). Этот аргумент может быть задан только в том случае, если хит-область идентифицирована использованием координат-аргументов x и y.

Описание

Метод; вычисляет пересечение или перекрытие anyMovieClip и хит-области, указанной через target или координаты-аргументы x и y.

1-ое использование: сравнивает координаты x и y формы или ограничивающей рамки заданного мувика, в зависимости от установки shapeFlag. Если shapeFlag установлен в true, то обрабатывается только область, фактически занятая мувиком на сцене, и, если x и y совмещаются с любой точкой, возвращается значение true. Это полезно для определения находится ли мувиклип внутри указанной хит-области или нет.

2-ое использование: вычисляет пересекаются/перекрываются ли границы (рамки) target и заданного мувиклипа, если да, то возвращает true.

Player

Flash 5 или выше.

Пример

Следующий пример использует hitTest со свойствами x_mouse и y_mouse для определения местонахождения мыши:

if (hitTest( _root._xmouse, _root._ymouse, false));

Следующий пример использует hitTest чтобы определить перекрываются/пересекаются ли мувики ball и square или нет:

if(_root.ball, hittest(_root.square)){
    trace("ball intersects square");
}

См. также


MovieClip.loadMovie

Max-Mov > MovieClip.loadMovie

MovieClip.loadMovie

Синтаксис

anyMovieClip.loadMovie(url [,variables]);

Аргументы

url Абсолютный или относительный URL SWF-файла для загрузки. Относительный путь должен быть связан с SWF. URL должен быть в том же поддомене, что и URL текущего фильма. Для использования во Flash Player или в режиме теста все SWF-файлы должны быть размещены в одной папке и имена файлов не могут содержать спецификации папок или дисков 1.

variables Необязательный аргумент, определяющий способ отсылки переменных, ассоциированных с загружаемым фильмом. Аргумент должен содержать строку "GET" или "POST." Если нет необходимости отсылать переменные, опустите этот агрумент. В противном случае укажите метод загрузки переменных ("GET" или "POST"). GET прицепляет переменные к концу URL и используется в случае малого количества переменных. POST отправляет переменные в отдельном заголовке HTTP и используется для длинных строковых переменных.

Описание

Метод; загружает и воспроизводит дополнительные фильмы без закрытия Flash Player. Обычно Flash Player отображает один Flash-фильм (SWF файл) и затем закрывает. Метод loadMovie позволяет показывать одновременно несколько клипов или переключаться между ними без необходимости загрузки другого документа HTML.

Используйте команду unloadMovie для удаления клипов, загруженных с помощью команды loadMovie.

Используйте метод loadVariables для загрузки и обновления значения переменных извне.

Player

Flash 5 или выше.

См. также

MovieClip.loadVariables
MovieClip.unloadMovie

От редактора

  1. На самом деле можно иcпользовать относительную адресацию и размещать подгружаемые мувиклипы в другие директории. Необходимо только корректно прописывать путь к ним. Например, этот код подгрузит мувиклип "begin.swf" из директории movies в мувик с именем "place":

    place.loadMovie("movies/begin.swf");

    Другое дело, что если теперь сделать вызов из подгруженного begin.swf (например запросить файл со списком переменных), то надо понимать то обстоятельство, что такой вызов будет происходить из родительской, по отношению к movies директории и соответственно заранее скорректировать путь при создании begin.swf.


MovieClip.loadVariables

Max-Mov > MovieClip.loadVariables

MovieClip.loadVariables

Синтаксис

anyMovieClip.loadVariables(url, variables);

Аргументы

url Абсолютный или относительный адрес URL для внешнего файла. Хост URL должен быть в том же поддомене что и Flash-клип.

variables Метод для отсылки переменных. GET прикрепляет переменные к концу URL и используется в случае малого количества переменных. POST отправляет переменные в отдельном заголовке HTTP и используется для длинных строковых переменных.

Описание

Метод; читает данные из внешнего файла и устанавливает значения переменных во всем клипе или отдельном мувиклипе. Внешний файл может быть текстовым файлом, сгенерированным скриптами CGI, Active Server Pages (ASP) или PHP и может содержать любое количество переменных.

Этот метод также может быть использован для обновления переменных в текущем клипе их новыми значениями.

Этот метод требует, чтобы текст в URL был в стандартном формате MIME: application/x-www-urlformencoded (формат скрипта CGI).

Player

Flash 5 или выше.

См. также

MovieClip.loadMovie


MovieClip.localToGlobal

Max-Mov > MovieClip.localToGlobal

MovieClip.localToGlobal

Синтаксис

anyMovieClip.localToGlobal(point);

Аргументы

point Имя или идентификатор объекта, созданного с помощью общего объекта Object, заданного координатами x и y.

Описание

Метод; конвертирует объект point из локальных координат в глобальные координаты.

Player

Flash 5 или выше.

Образец

Следующий пример конвертирует координаты x и y объекта point из локальных в глобальные. Локальные координаты x и y определены с помощью xmouse и ymouse, считывающих координаты x и y позиции мыши.

onClipEvent(mouseMove) {
    point = new object();
    point.x = _xmouse;
    point.y = _ymouse;
    _root.out3 = point.x + " === " + point.y;
    _root.out = _root._xmouse + " === " + _root._ymouse;
    localToGlobal(point);
    _root.out2 = point.x + " === " + point.y;
    updateAfterEvent();
}

См. также

MovieClip.globalToLocal


MovieClip.nextFrame

Max-Mov > MovieClip.nextFrame

MovieClip.nextFrame

Синтаксис

anyMovieClip.nextFrame();

Аргументы

Отсутствуют.

Описание

Метод; осуществляет переход на следующий кадр и останавливает клип.

Player

Flash 5 или выше.


MovieClip.play

Max-Mov > MovieClip.play

MovieClip.play

Синтаксис

anyMovieClip.play();

Аргументы

Отсутствуют.

Описание

Метод; включает воспроизведение клипа.

Player

Flash 5 или выше.


// (comment delimiter)

Операторы > // (comment delimiter)

// (комментарий)

Синтаксис

// comment

Аргументы

comment Текст, который не является частью кода и должен игнорироваться интерпретатором.

Описание

Комментарий; указывает начало комментария. Любой текст между ограничителем и знаком конца строки является комментарием и игнорируется интерпретатором ActionScript.

Player

Flash 1 или более поздней версии.

Пример

Этот скрипт использует двойной слеш для идентификации первой, третьей, пятой и седьмой строк, как комментариев:

// set the X position of the ball movie clip
ball = getProperty(ball._x);
// set the Y position of the ball movie clip
ball = getProperty(ball._y);
// set the X position of the kitty movie clip
kitty = getProperty(kitty._x);
// set the Y position of the kitty movie clip
kitty_y = getProperty(kitty._y);

Смотри также

/* (comment delimiter)


MovieClip.prevFrame

Max-Mov > MovieClip.prevFrame

MovieClip.prevFrame

Синтаксис

anyMovieClip.prevFrame();

Аргументы

Отсутствуют.

Описание

Метод; осуществляет переход на предыдущий кадр и останавливает клип.

Player

Flash 5 или выше.


MovieClip.removeMovieClip

Max-Mov > MovieClip.removeMovieClip

MovieClip.removeMovieClip

Синтаксис

anyMovieClip.removeMovieClip();

Аргументы

отсутствуют.

Описание

Метод; удаляет мувиклип, созданный с помощью команды duplicateMovieclip или методов duplicateMovieClip и attachMovie объекта Movie Clip.

Player

Flash 5 или выше.

См. также


MovieClip.startDrag

Max-Mov > MovieClip.startDrag

MovieClip.startDrag

Синтаксис

anyMovieClip.startDrag([lock, left, right, top, bottom]);

Аргументы

lock Булево значение, определяющее является ли перемещаемый мувик прикрепленным к центру позиции мыши (true) или он будет прикреплен к точке, в которой пользователь впервые нажмет кнопку мыши (false). Этот аргумент не является обязательным.

left, top, right, bottom Значения относительно координат родительского клипа, определяющие ограниченный прямоугольник для мувиклипа. Эти аргументы необязательны.

Описание

Метод; позволяет пользователю перемещать заданный мувиклип, который является перетаскиваемым до тех пор, пока этот процесс не будет принудительно остановлен вызовом метода stopDrag или другой мувиклип не станет перемещаемым. Одновременно только один клип может быть перемещаемым.

Player

Flash 5 или выше.

См. также


MovieClip.stop

Max-Mov > MovieClip.stop

MovieClip.stop

Синтаксис

anyMovieClip.stop();

Аргументы

Отсутствуют.

Описание

Метод; останавливает воспроизведение текущего клипа.

Player

Flash 5 или выше.


MovieClip.stopDrag

Max-Mov > MovieClip.stopDrag

MovieClip.stopDrag

Синтаксис

anyMovieClip.stopDrag();

Аргументы

Отсутствуют.

Описание

Метод; прекращает процесс перемещения, начатый методом startDrag. Клип остается перемещаемым до тех пор, пока не будет вызван метод stopDrag или другой мувик не станет перемещаемым. Одновременно только один клип может быть перемещаемым.

Player

Flash 5 или выше.

См. также


MovieClip.swapDepths

Max-Mov > MovieClip.swapDepths

MovieClip.swapDepths

Синтаксис

anyMovieClip.swapDepths(depth);
anyMovieClip.swapDepths(target);

Аргументы

target Мувиклип, который должен обменять уровень своего местонахождения с уровнем клипа, заданным в anyMovieClip. Оба мувиклипа должны принадлежать одному и тому же родительскому клипу (находиться на одной линейке Прим. редактора)

depth Номер уровня, на который будет перемещен anyMovieClip.

Описание

Метод; обменивает порядок расположения, или Z-порядок (уровень глубины) данного мувиклипа с клипом, указанным в аргументе target или с клипом, который в данный момент занимает уровень depth, заданный в аргументе. Оба мувиклипа должны принадлежать к одному и тому же родительскому клипу. Обмен уровнями создает эффект перемещения одного клипа за или под другой. Если в момент вызова этого метода мувиклип находится в состоянии анимации "tweening", последняя останавливается.

Player

Flash 5 или выше.

См. также

_level


MovieClip.unloadMovie

Max-Mov > MovieClip.unloadMovie

MovieClip.unloadMovie

Синтаксис

anyMovieClip.unloadMovie();

Аргументы

Отсутствуют.

Описание

Метод; удаляет мувиклип, загруженный методом loadMovie или attachMovie.

Player

Flash 5 или выше.

См. также


_name

N-R > _name

_name

Синтаксис

instancename._name

instancename._name = value;

Аргументы

instancename Имя экземпляра (instance) мувиклипа, для которого свойство _name будет устанавливаться или определяться.

value Строка, задающая новое имя мувиклипа.

Описание

Свойство; определяет имя экземпляра мувиклипа.

Player

Flash 4 или более новый.


NaN

N-R > NaN

NaN

Синтаксис

NaN

Аргументы

Нет.

Описание

Переменная; Предопределенная переменная с IEEE-754 значением для NaN (Not a Number).

Player

Flash 5 или более новый.


ne (not equal — string specific)

N-R > ne (not equal — string specific)

ne (not equal — string specific)

Синтаксис

expression1 ne expression2

Аргументы

expression1, expression2 Числа, строки или переменные.

Описание

Оператор (сравнения); сравнивает expression1 с expression2 и возвращает true (истина), если expression1 не эквивалентно expression2, в противном случае возвращает false (ложь).

Player

Flash 4 или более новый. Этот оператор не приветствуется во Flash 5, рекомендуется использовать новый != (не эквивалентно).

См. также

!= (inequality)


/* (comment delimiter)

Операторы > /* (comment delimiter)

/* (ограничитель комментария)

Синтаксис

/* comment */
/*
* comment
* comment
*/

Аргументы

comment Любой текст

Описание

Ограничитель; указывает на одну или более строк комментария в скрипте. Любой текст между открывающим /* и закрывающим */ тегами ограничителя является комментарием и игнорируется интерпретатором ActionScript. Используйте первый тип синтаксиса, для однострочных комментариев и второй тип, для комментариев на нескольких последовательных строках. "Не закрытие" ограничителя */ при использовании этого типа синтаксиса, повлечёт за собой сообщение об ошибке, которое выдаст компилятор ActionScript.

Player

Flash 5 или более поздней версии.

Смотри также

// (comment delimiter)


new

N-R > new

new

Синтаксис

new constructor();

Аргументы

constructor Функция, сопровождаемая любыми факультативными параметрами в круглых скобках. Функция, это обычно имя типа создаваемого объекта. Например, Array, Math, Number, Object.

Описание

Оператор; создает новый, первоначально анонимный объект, вызывает функцию, идентифицированную параметром constructor , передает любые факультативные параметры в круглых скобках и передает недавно созданный объект, как значение ключевого слова this. Функция может затем использовать this для этого нового объекта.

Свойство _prototype_ конструктора объекта копируется в свойство _proto_ нового объекта. Как результат, новый объект поддерживает все методы и свойства объекта-прототипа.

Player

Flash 5 или более новый.

Пример

Следующий пример создает объекты book1 и book2, используя оператор new.

function Book(name, price)
{
    this.name = name;
    this.price = price;
}
book1 = new Book("Confederacy of Dunces", 19.95);
book2 = new Book("The Floating Opera", 10.95);

См. также

[] (array access operator)
{} (object initializer)

Раздел метода конструктора внутри объектного входа.


newline

N-R > newline

newline

Синтаксис

newline;

Аргументы

Нет.

Описание

Константа; вставляет символ возврата каретки ({) - пустую линию в ActionScript код. Использование newline создает пространство для информации, которое возвращается функцией или командой в вашем коде. 1

Player

Flash 4 или более новый.

От переводчика.

  1. На мой взгляд, это звучит довольно заумно и не очень понятно. Своими словами, newline принудительно переводит строку в значении строковой переменной. Например, у вас есть текстовое поле с именем txt и прописана такая команда:

    txt="Hello"+newline+"World";

    Значение txt, отражаемое в этом текстовом поле, будет разбито на две строки:

    Hello
World

    Для полноты картины можно добавить, что вместо newline, для этих целей, можно использовать код "\r", т.е. переменной txt присваивать следующее значение:

    txt="Hello\rWorld";

    Результат будет тем же самым, что и при использовании newline.


nextFrame

N-R > nextFrame

nextFrame

Синтаксис

nextFrame();

Аргументы

Нет.

Описание

Команда; переводит воспроизведение клипа на следующий кадр и останавливает на нем.

Player

Flash 2 или более новый.

Пример

Когда пользователь нажимает на кнопку, содержащую команду nextFrame, происходит переход на следующий кадр и остановка воспроизведения клипа.

on (release) {
    nextFrame();
}


nextScene

N-R > nextScene

nextScene

Синтаксис

nextScene();

Аргументы

Нет.

Описание

Команда; переводит воспроизведение клипа на первый кадр следующей сцены и останавливает на нем.

Player

Flash 2 или более новый.

Пример

При нажатии на кнопку, воспроизведение клипа перескакивает и останавливается на первом кадре следующей сцены.

on(release) {
    nextScene();
}


not

N-R > not

not

Синтаксис

not expression

Аргументы

expression Любая переменная или выражение, которое преобразуется в булеан (Boolean) значение.

Описание

Оператор; выполняет логическую операцию NOT (отрицание) во Flash 4 Player.

Player

Flash 4 или более новый. Этот оператор не приветствуется во Flash 5, рекомендуется использовать новый оператор ! (logical NOT).

См. также

! (logical NOT)


null

N-R > null

null

Синтаксис

null

Аргументы

Нет.

Описание

Ключевое слово; специальное значение, которое может быть назначено переменным или возвращено функцией, если она не обеспечена никакими данными. Можно использовать null для представления "пустых" переменных или переменных с неуказанным типом данных.

Player

Flash 5 или более новый.

Пример

В числовом контексте, null эквивалентен нулю. С null может производится проверка эквивалентности, как это сделано в следующем примере:

if (tree.left == null) {
    tree.left = new TreeNode();
}


Number (function)

N-R > Number (function)

Number (function)

Синтаксис

Number(expression);

Аргументы

expression Строка, булеан (Boolean) или любое выражение для конвертирования в число.

Описание

Функция; конвертирует аргумент x в число и возвращает значение как описано ниже:

Если x число, возвращает значение x.

Если x булеан (Boolean), возвращает единицу, если x есть true (истина) или ноль, если x есть false (ложь).

Если x строка, функция пытается анализировать x, как десятичное число.

Если x неопределено (undefined), возвращаемое значение равно нулю.

Эта функция используется для конвертирования файлов формата Flash 4 в формат Flash 5 и содержащих операторы, присутствие которых не рекомендовано для импорта в новую версию. Для большей информации см. описание оператора &.

Player

Flash 4 или более новый.

См. также

Number (object)


Number (object)

N-R > Number (object)

Number (object)

Объект Number - оболочка для данных типа число, позволяющая манипулировать исходными числовыми значениями, используя методы и свойства, связанные с объектом Number. Функциональные возможности этого объекта такие же, как у аналогичного объекта JavaScript Number.

Можно использовать конструктор Number при вызове методов объекта Number, но при вызове его свойств такой необходимости нет. Следующие примеры описывают синтаксис для вызова методов и свойств объекта Number:

Пример вызова метода toString объекта Number:

myNumber = new Number(1234);
myNumber.toString();

Возвращает строковое представление числа 1234.

Пример вызова свойства MIN_VALUE объекта Number:

smallest = Number.MIN_VALUE

Краткое описание методов объекта Number
Метод | Описание
toString | Возвращает строковое представление объекта Number.
valueOf | Возвращает исходное значение объекта Number.

Краткое описание свойств объекта Number
Свойство | Описание
MAX_VALUE | Константа, наибольшее возможное для представления число (с двойной точностью IEEE-754), приблизительно равно 1.7976931348623158e+308.
MIN_VALUE | Константа, наименьшее возможное для представления число (с двойной точностью IEEE-754), приблизительно равно 5e-324.
NaN | Константа, представляет значение для Not a Number (NaN).
NEGATIVE_INFINITY | Константа, представляет значение для отрицательной бесконечности.
POSITIVE_INFINITY | Константа, представляет значение для положительной бесконечности. Это значение такое же, как у глобальной переменной Infinity (Бесконечность).

Конструктор для объекта Number

Синтаксис

myNumber = new Number(value);

Аргументы

value Числовое значение создаваемого объекта Number или значение, которое будет преобразовано в число.

Описание

Конструктор; создает новый объект Number. При использовании методов toString и valueOf объекта Number, необходимо применять конструктор Number, в то же время такой необходимости нет, если использовать его свойства. Конструктор new Number прежде всего используется как оболочка. Экземпляр объекта Number не идентичен функции Number, которая преобразует аргумент в исходное значение.

Player

Flash 5 или более новый.

Пример

Следующий код создает новые объекты Number:

n1 = new Number(3.4);
n2 = new Number(-10);

См. также

Number (function)


Number.MAX_VALUE

N-R > Number.MAX_VALUE

Number.MAX_VALUE

Синтаксис

Number.MAX_VALUE

Аргументы

Нет.

Описание

Свойство; наибольшее возможное для представления число (с двойной точностью IEEE-754). Это число приблизительно равно 1.79E+308.

Player

Flash 5 или более новый.


Number.MIN_VALUE

N-R > Number.MIN_VALUE

Number.MIN_VALUE

Синтаксис

Number.MIN_VALUE

Аргументы

Нет.

Описание

Свойство; наименьшее возможное для представления число (с двойной точностью IEEE-754). Это число приблизительно равно 5e-324.

Player

Flash 5 или более новый.


/= (division assignment)

Операторы > /= (division assignment)

/= (назначение деления)

Синтаксис

expression1 /= expression2

Аргументы

expression1, expression2 Целые числа, числа с плавающей запятой или строки.

Описание

Оператор (присваивания); присваивает expression1 значение expression1 / expression2.

Player

Flash 4 или более поздней версии.

Пример

Использование оператора /= с переменными и числами:

x /= y то же самое, что и x = x /y
x = 10;
y = 2;
x /= y;
x теперь имеет значение 5


Number.NaN

N-R > Number.NaN

Number.NaN

Синтаксис

Number.NaN

Аргументы

Нет.

Описание

Свойство; IEEE-754 значение представления Not A Number (NaN).

Player

Flash 5 или более новый.


Number.NEGATIVE_INFINITY

N-R > Number.NEGATIVE_INFINITY

Number.NEGATIVE_INFINITY

Синтаксис

Number.NEGATIVE_INFINITY

Аргументы

Нет.

Описание

Свойство; возвращает IEEE-754 значение представления отрицательной бесконечности. Это значение такое же, как у глобальной переменной Infinity (Бесконечность).

Отрицательная бесконечность - специальное числовое значение, которое возвращается тогда, когда математическая операция или функция выдает отрицательное значение больше, чем может быть представлено.

Player

Flash 5 или более новый.


Number.POSITIVE_INFINITY

N-R > Number.POSITIVE_INFINITY

Number.POSITIVE_INFINITY

Синтаксис

Number.POSITIVE_INFINITY

Аргументы

Нет.

Описание

Свойство; возвращает IEEE-754 значение представления положительной бесконечности. Это значение такое же, как у глобальной переменной Infinity (Бесконечность).

Положительная бесконечность - специальное числовое значение, которое возвращается тогда, когда математическая операция или функция выдает значение больше, чем может быть представлено.

Player

Flash 5 или более новый.


Number.toString

N-R > Number.toString

Number.toString

Синтаксис

myNumber.toString(radix);

Аргументы

radix задает основание числа (от 2 до 36), используемое для number-to-string преобразования. Если аргумент radix не указан, то по умолчанию используется 10 (десятичное число).

Описание

Метод; возвращает строковое представление Number объекта (myNumber).

Player

Flash 5 или более новый.

Пример

Следующий пример использует метод Number.toString, с основанием 2 для аргумента radix:

myNumber = new Number (1000);
(1000).toString(2);

Возвращает строку, содержащую бинарное представление числа 1000.


Number.valueOf

N-R > Number.valueOf

Number.valueOf

Синтаксис

myNumber.valueOf();

Аргументы

Нет.

Описание

Метод; возвращает первоначальное значение типа определяемого объекта Number и конвертирует упакованный объект Number в первоначальное значение типа.

Player

Flash 5 или более новый.


Object (object)

N-R > Object (object)

Object (object)

Универсальный объект Object находится в корне иерархии класса ActionScript. Функциональные возможности универсального объекта Object это маленькое подмножество, обеспечиваемое объектом JavaScript Object.

Универсальный объект Object требует Flash 5 Player.

Краткое описание методов объекта Object
Метод | Описание
toString | Конвертирует определяемый объект в строку и возвращает его.
valueOf | Возвращает исходное значение объекта Object.

Конструктор для объекта Object

Синтаксис

new Object();
new Object(value);

Аргументы

value Число, Булеан или строка, конвертируемые в объект. Это необязательный аргумент. Если вы не определяете value, конструктор создаст объект без описанных свойств.

Описание

Конструктор; создает новый объект Object.

Player

Flash 5 или более новый.

См. также


Object.toString

N-R > Object.toString

Object.toString

Синтаксис

myObject.toString();

Аргументы

Нет.

Описание

Метод; конвертирует объект в строку и возвращает.

Player

Flash 5 или более новый.


Object.valueOf

N-R > Object.valueOf

Object.valueOf

Синтаксис

myObject.valueOf();

Аргументы

Нет.

Описание

Метод; возвращает первоначальное значение определяемого объекта. Если объект не имеет такого значения, возвращается сам объект.

Player

Flash 5 или более новый.


onClipEvent

N-R > onClipEvent

onClipEvent

Синтаксис

onClipEvent(movieEvent);{
...
}

Аргументы

movieEvent переключатель приводимый в действие событием и выполняющий, в зависимости от события, те или иные команды, указанные в мувиклипе. Любое из следующих значений может быть определено для аргумента movieEvent:

load Инициализация команд в момент появления мувиклипа на линейке (Timeline).
unload Инициализация команд в первом кадре в момент удаления мувиклипа с линейки. Команды, связанные с событием Unload, обрабатываются прежде любых команд прописанных в кадре.
enterFrame Инициализация команд в каждом воспроизводимом кадре, так, как если бы они были прописаны в каждом кадре мувиклипа. Команды, связанные с событием OnEnterFrame, обрабатываются после любых команд прописанных в кадрах.
mouseMove Инициализация команд при каждом перемещении мыши. Для определения текущей позиции мыши используются свойства _xmouse и _ymouse.
mouseDown Инициализация команд при нажатии левой кнопки мыши.
mouseUp Инициализация команд при отпускании левой кнопки мыши.
keyDown Инициализация команд при нажатии клавиши клавиатуры. Метод Key.getCode используется для получения информации о нажатой клавише.
keyUp Инициализация команд при отпускании клавиши клавиатуры. Метод Key.getCode используется для получения информации о нажатой клавише.
data Инициализация команд при получении данных в командах loadVariables или loadMovie. Когда это связано с командой loadVariables, событие data происходит только один раз в момент окончания загрузки последней переменной. При использовании команды loadMovie, событие data может быть многократным, по мере подхода новых данных.

Описание

Драйвер; в зависимости от события переключает (инициализирует) команды, указанные в мувиклипе.

Player

Flash 5 или более новый.

Пример

Следующий оператор вставляет скрипт из внешнего файла в тот момент, когда мувиклип загружен и появляется на линейке (Timeline):

onClipEvent(load) {
    #include "myScript.as"
}

Следующий пример использует onClipEvent с событием keyDown. Обычно событие keyDown используется совместно с одним или более количеством методов и свойств, связанных с объектом Key. Ниже key.getCode применяется для определения клавиши, нажатой пользователем.

onClipEvent(keyDown) {
    if (Key.getCode() == Key.RIGHT) {
        } _parent.nextFrame();
    else if (Key.getCode() == Key.LEFT){
        _parent.prevFrame();
}

Этот пример использует onClipEvent с событием mouseMove. Свойства xmouse и ymouse отслеживают положение курсора.

onClipEvent(mouseMove) {
stageX=_root.xmouse;
stageY=_root.ymouse;
}

См. также


on(mouseEvent)

N-R > on(mouseEvent)

on(mouseEvent)

Синтаксис

on(mouseEvent) {
statement;
}

Аргументы

statement Команды, выполняемые в момент наступления события mouseEvent.

Команда mouseEvent может иметь один из следующих аргументов:

press Кнопка мыши нажата в момент нахождения курсора над кнопкой.
release Кнопка мыши отпущена в момент нахождения курсора над кнопкой.
releaseOutside Кнопка мыши отпущена в момент нахождения курсора снаружи кнопки.
rollOver Курсор входит в границы кнопки.
rollOut Курсор выходит за границы кнопки.
dragOver В момент нахождения курсора над кнопкой, нажимается кнопка мыши, затем курсор выводится за границы кнопки и вводится обратно.
dragOut В момент нахождения курсора над кнопкой, нажимается кнопка мыши, затем курсор выводится за границы кнопки.
keyPress ("key") Определяет нажатие key. Для указания аргумента key используются любое значение, из перечисленных в Приложении B "Клавиши клавиатуры и их коды" или любая из клавишных констант, перечисленных в Описание свойств объекта Key.

Описание

Драйвер; определяет событие мыши или нажатие клавиш клавиатуры, вызывающих переключение команд.

Player

Flash 2 или более новый.

Пример

В следующем скрипте команда startDrag выполняется при нажатии кнопки мыши, а проверка условия при ее отпускании:

on(press) {
    startDrag("rabbit");
}
on(release) {
    if(getproperty("", _droptarget) == target) {
        setProperty ("rabbit", _x, _root.rabbit_x);
        setProperty ("rabbit", _y, _root.rabbit_y);
    } else {
_root.rabbit_x = getProperty("rabbit", _x);
_root.rabbit_y = getProperty("rabbit", _y);
_root.target = "pasture";
    }
    trace(_root.rabbit_y);
    trace(_root.rabbit_x);
    stopDrag();
}

См. также


[] (array access operator)

Операторы > [] (array access operator)

[] (оператор доступа к массиву)

Синтаксис

myArray["a0", "a1",..."aN"];
object[value1, value2, ...valueN];

Аргументы

myArray Имя массива.

a0, a1,...aN Элементы в массиве.

value1, 2,...N Имена свойств.

Описание

Оператор; создаёт новый объект и задействует свойства, указанные в аргументах или задействует новую массив с элементами (a0), указанными в аргументах.

Созданный объект имеет свой групповой прототип. Использование этого оператора идентично вызову new Object и заполнению свойств с использованием оператора присваивания. Использование этого оператора является альтернативой использованию оператора new, который помогает быстро и удобно создавать объекты.

Player

Flash 4 или более поздней версии.

Пример

Эти коды - два различных способа создания нового пустого объекта Array (Массив):

myArray =[];
myArray = new Array();

Ниже пример простого массива:

myArray = ["red", "orange", "yellow", "green", "blue", "purple"]
myArray[0]="red"
myArray[1]="yellow"
myArray[2]="green"
myArray[3]="blue"
myArray[4]="purple"


or

N-R > or

or

Синтаксис

condition1 or condition2

Аргументы

condition1,2 Выражение (условие), проверяемые на соответствие true (истина) или false (ложь).

Описание

Оператор; проверяет condition1 и condition2 и если любое из них соответствует true, то возвращает true, в противном случае возвращает false.

Player

Flash 4 или более новый. Этот оператор не приветствуется во Flash 5, предпочтительным является использование оператора ||.

См. также

|| (OR)


ord

N-R > ord

ord

Синтаксис

ord(character);

Аргументы

character Символ, конвертируемый в ASCII код.

Описание

Строковая функция; конвертирует текстовый символ в число, соответствующее его ASCII коду.

Player

Flash 4 или более новый. Эта функция не приветствуется во Flash 5, взамен рекомендуется использовать методы и свойства объекта String.

См. также

String (object)


_parent

N-R > _parent

_parent

Синтаксис

_parent.property = x
_parent._parent.property = x

Аргументы

property Свойство, определяемое для текущего и родительского мувиклипа.

x Значение, устанавливаемое для свойства. Это необязательный аргумент и может не нуждаться в установке, зависит от свойства.

Описание

Свойство; указывает или возвращает ссылку на мувиклип, в который вложен текущий мувик, содержащий в себе исполняемый в данный момент скрипт. Использование _parent, определяет относительный путь.

Player

Flash 4 или более новый.

Пример

В следующем примере мувиклип desk является дочерним по отношению к мувиклипу classroom. Когда скрипт внутри desk мувика будет исполнен, Flash-клип перескочит на десятый кадр линейки мувиклипа classroom.

_parent.gotoAndStop(10);

См. также


parseFloat

N-R > parseFloat

parseFloat

Синтаксис

parseFloat(string);

Аргументы

string Строка, анализируемая и конвертируемая в число с плавающей запятой.

Описание

Функция; конвертирует строку в число с плавающей запятой. Функция анализирует и возвращает числа в строке до тех пор, пока синтаксический анализатор не достигнет символа, не являющегося частью исходного числа. Если строка не начинается с числа, которое может быть проанализировано, parseFloat возвращает NaN или 0. Игнорируются пробелы, предшествующие валидному значению числа.

Player

Flash 5 или более новый.

Пример

Следующие примеры использования parseFloat анализируют различные типы чисел:

parseFloat("-2") возвращает -2

parseFloat("2.5") возвращает 2.5

parseFloat("3.5e6") возвращает 3.5e6 или 3500000

parseFloat("foobar") возвращает NaN


parseInt

N-R > parseInt

parseInt

Синтаксис

parseInt(expression, radix);

Аргументы

expression Строка, число с плавающей запятой или другое выражение для анализа и конвертации в целое.

radix Целое, представляющее для анализа основание системы счисления (базу) числа. Допустимые значения от 2 до 36. Этот параметр факультативный (необязательный).

Описание

Функция; конвертирует строку в число. Если представляемую строку нельзя перевести в число, функция возвращает NaN или ноль. Целые числа, начинающиеся нулем или определяемые по основанию 8, интерпретируются как восьмеричные числа, начинающиеся с 0x - как шестьнадцатиричные. Игнорируются пробелы, предшествующие валидному значению числа.

Player

Flash 5 или более новый.

Пример

Следующие примеры используют parseInt для анализа различных типов чисел:

parseInt("3.5") возвращает 3.5

parseInt("bar") возвращает NaN

parseInt("4foo") возвращает 4

Шестьнадцатиричное преобразование:

parseInt("0x3F8") возвращает 1016

parseInt("3E8", 16) возвращает 1000

Двоичное (бинарное) преобразование:

parseInt("1010", 2) возвращает 10 (десятичное представление бинарного 1010)

Синтаксический анализ восьмеричного числа (в этом случае восьмеричное число идентифицировано основанием 8):

parseInt("777", 8) возвращает 511 (десятичное представление восьмеричного 777)


play

N-R > play

play

Синтаксис

play();

Аргументы

Нет.

Описание

Команда; включает воспроизведение клипа на линейке (Timeline).

Player

Flash 2 или более новый.

Пример

Следующий код использует оператор if для проверки введенного значения имени пользователя. Если введено Steve, команда play включает дальнейшее воспроизведение клипа на линейке. В противном случае, в текстовом поле с переменной alert выдается соответствующее значение.

stop();
if (name = "Steve") {
    play();
} else {
    alert = "You are not Steve!";
}


prevFrame

N-R > prevFrame

prevFrame

Синтаксис

prevFrame();

Аргументы

Нет.

Описание

Команда; переводит клип на предыдущий кадр и останавливает его.

Player

Flash 2 или более новый.

Пример

При нажатии на кнопку, содержащей команду prevFrame, клип откатывает назад на предыдущий кадр и останавливается.

on(release) {
    prevFrame();
}

См. также

MovieClip.prevFrame


prevScene

N-R > prevScene

prevScene

Синтаксис

prevScene();

Аргументы

Нет.

Описание

Команда; переводит клип на перый кадр предыдущей сцены и останавливает его.

Player

Flash 2 или более новый.

См. также

nextScene


print

N-R > print

print

Синтаксис

print (target, "bmovie");
print (target, "bmax");
print (target, "bframe");

Аргументы

target Имя мувиклипа, предназначенного для печати. По умолчанию печатаются все кадры клипа. Если надо напечатать только определенных кадры, пометьте их для печати меткой (label) #P.

bmovie Определяет блок кадров, как область печати в клипе. Для обозначения границ блока, пометьте соответствующие кадры меткой (label) #b.

bmax Определяет состав всех блоков, как область печати. Укажите аргумент bmax, когда предназначенные для печати кадры изменяются по размеру.

bframe Определяет, что каждый предназначенный для печати кадр используется как область печати. Это изменяет область печати для каждого кадра и масштабирует объекты, подгоняя их размер под область печати. Используйте bframe, если имеете объекты различных размеров в каждом кадре и хотите, чтобы каждый объект заполнил напечатанную страницу.

Описание

Команда; печатает клип target согласно модификатору принтера, определенному в параметре. Если Вы хотите печатать только отдельные кадры клипа, пометьте их меткой (label) #P. Хотя команда print обеспечивает более высокое качество печати, чем printAsBitmap, она не может применяться для распечатки клипа, использующего альфа-прозрачность или специальные цветовые эффекты.

Если Вы не определяете аргумент области печати, по умолчанию она будет ограничена размером сцены загруженного клипа. Клип не наследует размер сцены основного клипа. Можно управлять областью печати, определяя bmovie, bmax или аргумент bframe.

Все предназначенные для печати элементы клипа должны быть полностью загружены до начала печати.

Flash Player поддерживает PostScript и non-PostScript принтеры. Non-PostScript преобразуют векторное изображение в растровое (bitmap).

Player

Flash 5 или более новый.

Пример

Следующий пример напечатает все предназначенные для печати кадры в myMovie с областью печати, определенной кадрами с меткой #b:

print("myMovie","bmovie");

Следующий пример напечатает все предназначенные для печати кадры в myMovie с областью печати, определенной каждым кадром:

print("myMovie","bframe");

См. также

printAsBitmap


printAsBitmap

N-R > printAsBitmap

printAsBitmap

Синтаксис

printAsBitmap(target, "bmovie");
printAsBitmap(target, "bmax");
printAsBitmap(target, "bframe");

Аргументы

target Имя мувиклипа, предназначенного для печати. По умолчанию печатаются все кадры клипа. Если надо напечатать только определенных кадры, пометьте их для печати меткой (label) #P.

bmovie Определяет блок кадров, как ограниченную область печати в клипе. Для обозначения границ блока, пометьте соответствующие кадры меткой (label) #b.

bmax Определяет состав всех блоков, как область печати. Укажите аргумент bmax, когда предназначенные для печати кадры изменяются по размеру.

bframe Определяет, что каждый предназначенный для печати кадр используется как область печати. Это изменяет область печати для каждого кадра и масштабирует объекты, подгоняя их размер под область печати. Используйте bframe, если имеете объекты различных размеров в каждом кадре и хотите, чтобы каждый объект заполнил напечатанную страницу.

Описание

Команда; печатает клип target как растровый рисунок. Используйте printAsBitmap, чтобы распечатать клип, который содержит кадры с объектами, использующие прозрачность или цветовые эффекты. Для обеспечения максимально возможного качества, команда printAsBitmap печатает в самой высокой доступной разрешающей способности принтера. Для вычисления размера файла для печати выбранного кадра, умножьте пиксельную ширину на пиксельную высоту разрешающей способностью принтера.

Если клип не содержит альфа-прозрачности или цветовых эффектов, рекомендуется использовать команду print для получения более качественных результатов.

По умолчанию, область печати определяется размером сцены загруженного клипа. Клип не наследует размер сцены основного клипа, можно регулировать область печати через аргументы bmovie, bmax или bframe.

Все предназначенные для печати элементы клипа должны быть полностью загружены до начала печати.

Flash Player поддерживает PostScript и non-PostScript принтеры. Non-PostScript преобразуют векторное изображение в растровое (bitmap).

Player

Flash 5 или более новый.

См. также

print


^(bitwise XOR)

Операторы > ^(bitwise XOR)

^ (побитовое исключающее ИЛИ)

Синтаксис

expression1 ^ expression2

Аргументы

expression1, expression2 Любое число.

Описание

Оператор; конвертирует expression1 и expression2 в 32-битные беззнаковые целые числа, и возвращает 1 в каждую битовую позицию, где соответствующие биты в выражениях expression1 или expression1, но не в обоих, представлены как 1.

Player

Flash 5 или более поздней версии.

Пример

15 ^ 9 возвращает 6
(1111 ^ 1001 = 0110)


_quality

N-R > _quality

_quality

Синтаксис

_quality
_quality = x;

Аргументы

x Строка, определяющая одно из следующих значений:

LOW Низкое качество рендеринга (отображения). Графика (имеется в виду векторная. прим.Пер.) не сглаживается, растровые (bitmap) картинки тоже.

MEDIUM Среднее качество рендеринга. Графика сглаживается с использованием сетки 2х2, но растровые картинки не сглаживаются. Это режим подходит для клипов, которое не содержат текст.

HIGH Высокое качество рендеринга. Графика сглаживается с использованием сетки 4х4 и битмапы сглаживаются тоже, если не анимированы (статические). Это качество рендеринга установлено во Flash по умолчанию.

BEST Очень высокое качество рендеринга. Графика сглаживается с использованием сетки 4х4, растр сглаживается всегда.

Описание

Свойство (global - общее для всего клипа); устанавливает или возвращает качество, используемое для рендеринга клипа.

Player

Flash 5 или более новый.

Пример

Следующий пример присваивает текущее качество рендеринга переменной oldQuality и устанавливает новое со значением HIGH:

oldQualtiy = _quality
_quality = "HIGH";

См. также

_highquality


random

N-R > random

random

Синтаксис

random();

Аргументы

value Наибольшее целое, в диапазоне которого random будет возвращать значение.

Описание

Функция; возвращает случайное целое между нулем и числом, указанным в аргументе value.

Player

Flash 4. Эта функция не приветствуется во Flash 5, рекомендуется использовать метод Math.random.

Пример

Следующее использование random возвращает значения 0, 1, 2, 3 или 4:

random(5);

См. также

Math.random


removeMovieClip

N-R > removeMovieClip

removeMovieClip

Синтаксис

removeMovieClip(target);

Аргументы

target Путь (target path) до экземпляра мувиклипа, созданного при помощи duplicateMovieClip или имя мувика, созданного методами attachMovie или duplicateMovie, объекта MovieClip.

Описание

Команда; удаляет экземпляр мувиклипа, созданного при помощи методов attachMovie или duplicateMovie объекта MovieClip или командой duplicateMovieClip.

Player

Flash 4 или более новый.

См. также


return

N-R > return

return

Синтаксис

return[expression];
return;

Аргументы

expression Тип, строка, число, массив или объект, обрабатываемые функцией и возвращаемые, как ее значение. Это необязательный аргумент (опциональный).

Описание

Команда; определяет значение, возвращаемое функцией. Когда выполняется эта команда, обрабатывается expression и возвращается, как значение функции. Команда return останавливает выполнение функции. Если Flash в течение выполнения цикла не встречает оператора return, возвращается null.

Player

Flash 5 или более новый.

Пример

function sum(a, b, c){
return a + b + c;
}

См. также

function


_root

N-R > _root

_root

Синтаксис

_root;
_root.movieClip;
_root.action;

Аргументы

movieClip Имя мувиклипа.

action Значение, задаваемое свойству. Это необязательный аргумент и может не нуждаться в установке, зависит от свойства.

Описание

Свойство; указывает или возвращает ссылку на основную линейку (Timeline) мувиклипа, а попросту - корень. Если клип имеет много уровней (levels), корневой линейкой является уровень, содержащий исполняемый в данный момент скрипт. Например, если скрипт на первом уровне определяет _root, будет возвращен уровень 1.

Определение _root то же самое, что использование слэш нотации (/) для определения абсолютного пути для текущего уровня (level).

Player

Flash 4 или более новый.

Пример

Следующий пример остановит воспроизведение уровня, содержащего текущий исполняемый скрипт:

_root.stop();

В этом примере клип перескочит на третий кадр линейки текущего уровня:

_root.gotoAndStop(3);

См. также


_rotation

N-R > _rotation

_rotation

Синтаксис

instancename._rotation
instancename._rotation = integer

Аргументы

integer Угол поворота мувиклипа в градусах.

instancename Поворачиваемый мувиклип.

Описание

Свойство; поворачивает мувиклип на указанный в градусах угол.

Player

Flash 4 или более новый.


scroll

S > scroll

scroll

Синтаксис

variable_name.scroll = x

Аргументы

variable_name Имя переменной, связанной с текстовым полем.

x Номер верхней видимой линии в текстовом поле. Если значение не указано, используется 1 по умолчанию. Flash Player обновляет это значение, когда пользователь передвигается по текстовому полю вверх и вниз.

Описание

Свойство; контролирует отображение информации в текстовом поле, связанном с переменной. Свойство scroll определяет, с какой строки текстовое поле начинает выводить содержимое и обновляется автоматически при передвижении текста через текстовое поле. Свойство scroll используется для перелистывания длинного текста или для создания тестовых полей со скроллингом. Значение этого свойства можно как считывать, так и изменять.

Player

Flash 4 или выше.

Смотрите также

maxscroll


Selection (object)

S > Selection (object)

Selection (object)

Объект Selection позволяет устанавливать и контролировать фокус в редактируемом текстовом поле. Редактируемое текстовое поле имеющее фокус, это то поле, в котором размещен указатель мыши пользователя. Индекс этого поля начинается с нуля (0 - первая позиция, 1 - вторая и т.д.)

Для объекта Selection нет конструктивного метода, поэтому одновременно только одно текстовое поле может иметь фокус

Описание методов для объекта Selection
Метод | Описание
getBeginIndex | Возвращает индекс начала выделения. Возвращает -1 если нет индекса или текущего выбранного поля.
getCaretIndex | Возвращает текущую позицию каретки в выделенном диапазоне, имеющем фокус. Возвращает -1 если нет позиции каретки или выделенного диапазона, имеющего фокус.
getEndIndex | Возвращает индекс конца выделения. Возвращает -1 если нет индекса или текущего выбранного поля.
getFocus | Возвращает имя переменной для текущего текстового поля, имеющего фокус. Возвращает null если нет текущего выбранного поля.
setFocus | Устанавливает фокус на текстовое поле, связанное с переменной, указанной в аргументе.
setSelection | Выставляет начальный и конечный индекс выделенного диапазона.


Selection.getBeginIndex

S > Selection.getBeginIndex

Selection.getBeginIndex

Синтаксис

Selection.getBeginIndex();

Аргументы

Нет.

Описание

Метод; возвращает индекс в начале выбранного промежутка . Если никакой индекс не существует или никакое поле в настоящее время не имеет фокус, метод возвращает -1. Индекс выбранного промежутка отсчитывается от нуля (где первая позиция - 0, вторая позиция - 1, и так далее).

Player

Flash 5 или выше.


Selection.getCaretIndex

S > Selection.getCaretIndex

Selection.getCaretIndex

Синтаксис

Selection.getCaretIndex();

Аргументы

Нет.

Описание

Метод; возвращает индекс мигающей позиции курсора. Если нет мигающего указателя, метод возвращает -1. Индексы промежутка выбора отсчитываются от нуля (где первая позиция - 0, вторая позиция - 1, и так далее).

Player

Flash 5 или выше.


^= (bitwise XOR assignment)

Операторы > ^= (bitwise XOR assignment)

^= (присвоение побитового исключающего ИЛИ)

Синтаксис

expression1 ^= expression2

Аргументы

expression1, expression2 Целые числа и переменные.

Описание

Оператор (составного назначения); присваивает expression1 значение expression1 ^ expression2.

Player

Flash 5 или более поздней версии.

Пример

Пример операции ^= :

// 15 decimal = 1111 binary
x = 15;
// 9 decimal = 1001 binary
x ^= y;
returns
x ^ y (0110 binary)

Пример использования оператора ^= с переменными и числами:

x ^= y то же самое, что и x = x ^ y
Если x = 15 и y = 9 , тогда
15 ^= 9  возвращает 6

Смотри также

^(bitwise XOR)


Selection.getEndIndex

S > Selection.getEndIndex

Selection.getEndIndex

Синтаксис

Selection.getEndIndex();

Аргументы

Нет.

Описание

Метод; возвращает последний индекс текущего выделенния (промежутка). Если индекса не существует или промежуток не выделен, метод возвращает -1. Индексы отсчитываются от нуля (где первая позиция - 0, вторая позиция - 1, и так далее).

Player

Flash 5 или выше.


Selection.getFocus

S > Selection.getFocus

Selection.getFocus

Синтаксис

Selection.getFocus();

Аргументы

Нет.

Описание

Метод; возвращает имя переменной доступного для редактирования текстового поля, выбранного в данный момент. Если никакое текстовое поле в настоящее время не выбрано, метод возвращает указатель null.

Player

Flash 5 или выше.

Example

Следующий код возвращает имя переменной:

_root.anyMovieClip.myTextField.


Selection.setFocus

S > Selection.setFocus

Selection.setFocus

Синтаксис

Selection.setFocus(variable);

Аргументы

variable Строка, определяющая имя переменной, связанной с текстовым полем, с использованием точечной или слэш нотацией.

Описание

Метод; устанавливает фокус на доступное для редактирования текстовое поле, связанное с указанным аргументом variable.

Player

Flash 5 или выше.


Selection.setSelection

S > Selection.setSelection

Selection.setSelection

Синтаксис

Selection.setSelection(start, end);

Аргументы

start Начальный индекс выделяемого промежутка.

end Конечный индекс выделяемого промежутка.

Описание

Метод; устанавливает промежуток, выделенный в редактируемом текстовом поле, имеющем фокус. Новый промежуток выделения начнется с индекса, указанного в параметре start и заканчиваться индексом, указанном в параметре end. Индексы промежутка отсчитываемые от нуля (где первая позиция - 0, вторая позиция - 1, и так далее). Этот метод не имеет никакого эффекта, если в настоящее время нет текстового поля, имеющего фокус.

Player

Flash 5 или выше.


set

S > set

set

Синтаксис

variable = expression;
set(variable, expression);

Аргументы

variable Имя контейнера, содержащее значение параметра expression.

expression Значение (или фраза, которая может быть приведена к значению) которое назначено переменной.

Описание

Команда; присваивает значение переменной. Переменная является контейнером, содержащим информацию. Сам контейнер, всегда тот же самый, но его содержание может изменяться. Изменяя значение переменной во время воспроизведения клипа, можно записывать и сохранять информацию о действиях пользователя, записывать значения, изменяющиеся во время воспроизведения клипа или проверять условия true или false.

Переменные могут содержать или числа или строки символов. Каждый клип имеет свой собственный набор переменных и каждая переменная имеет свое собственное значение, независимое от переменных в другом клипе.

ActionScript - язык неконтролирующий типы. Это означает, что переменные не должны быть явно определены, как содержащие или число или строку. Flash интерпретирует тип данных, как целое число или строку соответственно.

Используйте оператор set вместе с командой call для передачи или получения значений.

Player

Flash 4 или выше.

Пример

Этот пример присваивает переменной, называемой orig_x_pos, оригинальную позицию x мувиклипа ship, чтобы позже можно было вернуть корабль на его стартовую позицию в клипе:

on(release) {
    set(x_pos, getProperty ("ship", _x ));
}

Это эквивалентно следующей записи:

on(release) {
    orig_x_pos = getProperty ("ship", _x );
}

Смотрите также


setProperty

S > setProperty

setProperty

Синтаксис

setProperty(target, property, expression);

Аргументы

target Путь к экземпляру мувиклипа, чье свойство нужно изменить.

property Свойство, которое нужно изменить.

expression Значение, присваемое свойству.

Описание

Команда; изменяет свойство экземпляра мувиклипа во время его воспроизведения.

Player

Flash 4 или выше.

Пример

При нажатии кнопки, эта команда присваивает свойству _alpha мувиклипа star значение равное 30 процентам:

on(release) {
    setProperty("star", _alpha, 30);
}

Смотрите также

getProperty


Sound (object)

S > Sound (object)

Sound (object)

Объект Sound позволяет управлять звуком в отдельном экземпляре мувиклипа или на основной Timeline, если при его создании target не был указан. Для создания экземпляра звукового объекта необходимо использовать конструктор new Sound перед вызовом его методов.

Объект Sound поддерживается только Flash 5 Player.

Список методов для Sound object
Метод | Описание
attachSound | Присоединяет звук, описанный в аргументе.
getPan | Возвращает значение предыдущего вызова setPan. 1
getTransform | Возвращает значение предыдущего вызова setTransform. 1
getVolume | Возвращает значение предыдущего вызова setVolume. 1
setPan | Выставляет левый/правый баланс звука.
setTransform | Выставляет трансформацию для звука.
setVolume | Выставляет громкость звука.
start | Начинает воспроизведение звука сначала или, опционально, с определенной точки, указанной в аргументе.
stop | Останавливает определенный звук или все звуки, которые воспроизводятся в данный момент.

Конструктор для объекта Sound

Синтаксис

new Sound();
new Sound(target);

Аргументы

target Название экземпляра мувиклипа, к которому присоединяется объект Sound. Этот аргумент необязателен.

Описание

Метод; создает новый звуковой объект для определенного мувиклипа. Если target не указан, объект Sound будет контролировать все звуки на основной Timeline.

Player

Flash 5 или выше.

Пример

GlobalSound = new Sound();
MovieSound = new Sound(mymovie);

От редактора.

  1. На мой взгляд, в родном доке написано не совсем корректно. Правильнее сказать не предыдущего вызова методов set*, а текущего значения этих свойств, т.к. они могли программно и не устанавливаться до вызова метода get*. В этом случае будет возвращено значение запрашиваемого свойства, установленное Flash'ем по умолчанию.


Sound.attachSound

S > Sound.attachSound

Sound.attachSound

Синтаксис

mySound.attachSound("idName");

Аргументы

idName Имя нового экземпляра звука. Оно должно быть тоже самое, что и имя введенное для идентификации в диалоговом окне Symbol Linkage Properties. Этот аргумент должен быть заключен в кавычки (" ").

Описание

Метод; присоединяет звук, указанный в аргументе idName, к определенному объекту Sound. Звук должен быть в библиотеке текущего фильма и идентифицирован для экспорта в диалоговом окне Symbol Linkage Properties. Чтобы начать его воспроизведение, необходимо воспользоваться методом Sound.start.

Player

Flash 5 или выше.

Смотрите также

Sound.start


Sound.getPan

S > Sound.getPan

Sound.getPan

Синтаксис

mySound.getPan();

Аргументы

Нет.

Описание

Метод; возвращает значение уровня баланса, который определен последним вызовом setPan 1, на выходе - целое число от -100 до 100. Эта установка контролирует баланс между левым-правым каналом, как в текущий момент, так и для будущего воспроизведения звука в клипе.

Этот метод общий с методами setVolume и setTransform.

Player

Flash 5 или выше.

Смотрите также

Sound.setPan

Sound.setTransform

От редактора

  1. См. комментарии для Sound (object).


Sound.getTransform

S > Sound.getTransform

Sound.getTransform

Синтаксис

mySound.getTransform();

Аргументы

Нет.

Описание

Метод; возвращает информацию по превращению звука определенного объекта Sound, выставленную последним вызовом setTransform 1.

Player

Flash 5 или выше.

Смотрите также

Sound.setTransform

От редактора

  1. См. комментарии для Sound (object).


{} (object initializer)

Операторы > {} (object initializer)

{} (инициализатор объектов)

Синтаксис

object {name1: value1,
    name1: value2,
...
    nameN: valueN };

Аргументы

object Объект, который нужно создать.

name1,2,...N Имя свойства.

value1,2,...N Соответствующее значение для свойств каждого name.

Описание

Оператор; создаёт новый объект и инициализирует его с парами свойств указанного имени name и значения value. Созданный объект имеет универсальный объект Object как прототип. Использование этого оператора аналогично вызову new Object и заполнению пар свойств, посредством использования оператора назначений. Использование этого оператора - это альтернатива использованию оператора new, допускающая быстрое и удобное создание объектов.

Player

Flash 5 или более поздней версии.

Пример

Этот код показывает как можно создать пустой объект, используя оператор инициализатор объектов и new Object :

object = {};
object = new Object();

Ниже создается объект account и инициализируются свойства name, address, city, state, zip и balance:

account = { name: "John Smith",
    address: "123 Main Street",
    city: "Blossomville",
    state: "California",
    zip: "12345",
    balance: "1000" };

Этот пример показывает, как массив и инициализатор объектов можно вложить друг в друга:

person = { name: "Peter Piper",
    children: [ "Jack", "Jill", "Moe",] };

Вот ещё способ использования информации из предыдущего примера с такими же результатами:

person = new Person();
person.name = 'John Smith';
person.children = new Array();
person.children[0] = 'Jack';
person.children[1] = 'Jill';
person.children[2] = 'Moe';

Смотри также


Sound.getVolume

S > Sound.getVolume

Sound.getVolume

Синтаксис

mySound.getVolume();

Аргументы

Нет.

Описание

Метод; возвращает значение громкости звука, как целое число от 0 до 100, где 0 - нет звука, и 100 - полная громкость. Значение по умолчанию 100.

Player

Flash 5 или выше.

Смотрите также

Sound.setVolume


Sound.setPan

S > Sound.setPan

Sound.setPan

Синтаксис

mySound.setPan(pan);

Аргументы

pan Целое число, определяющее левый-правый баланс звука. Допустимые значения от -100 до 100, где -100 используется только для левого канала, 100 - только для правого и 0 - равный уровень громкости между двумя каналами.

Описание

Метод; определяет, как звук будет распределяться между левым и правым каналами (колонками). Когда этот метод используется для моно звуков, разница в его разделении между каналами будет определяться только громкостью.

Этот метод общий с методами setVolume и setTransform. Вызов этого метода удаляет и обновляет предыдущие настройки setPan и setTransform.

Player

Flash 5 или выше.

Пример

Следующий пример использует setVolume и setPan для контроля звукового объекта, с определенным именем "u2":

onClipEvent(mouseDown) {
// создаем звуковой объект и
s = new Sound(this);
// присоединяем звук из библиотеки
s.attachSound("u2");
//выставляем громкость 50%
s.setVolume(50);
//выключаем звук в правом канале
s.setPan(-100);
//начинаем воспроизведение звука с 30-й секунды и проигрываем его 5 раз
s.start(30, 5);

Смотрите также


Sound.setTransform

S > Sound.setTransform

Sound.setTransform

Синтаксис

mySound.setTransform(soundTransformObject);

Аргументы

soundTransformObject Объект, созданный с помощью универсального конструктора объекта Object.

Описание

Метод; определяет информацию для трансформирования звукового объекта. Этот метод общий с методами setVolume и setPan. Его вызов удаляет и обновляет любые предыдущие установки setPan или setVolume. Он предназначен для экспертов, которые хотят добавить звукам интересные эффекты.

Звуки используют значительный объем дискового пространства и памяти. Так как стерео звук требует вдвое больше данных, чем моно, лучше применять 22-Khz 6-bit моно звуки. Можно использовать метод setTransform для воспроизведения моно звука, как стерео, стерео звука как моно и делать интересные эффекты со звуком.

Аргумент soundTransformObject является объектом, который создается с помощью метода конструктора универсального объекта Object, с параметрами, определяющими распределение звука между левым и правым каналами (колонками).

Параметры для soundTransformObject следующие:

ll Значение характеризующее процентный уровень сигнала левого входа, воспроизводимого в левом динамике (-100 до 100).

lr Значение характеризующее процентный уровень сигнала правого входа, воспроизводимого в левом динамике (-100 до 100).

rr Значение характеризующее процентный уровень сигнала правого входа, воспроизводимого в правом динамике (-100 до 100).

rl Значение характеризующее процентный уровень сигнала левого входа, воспроизводимого в правом динамике (-100 до 100).

Новые параметры представлены в следующей формуле:

leftOutput = left input * ll + right input * lr

rightOutput = right lnput * rr + left input * rl

Значения левого и правого входов определяются типом (моно или стерео) звука в Вашем клипе.

Стерео звуки разделяются на входе равномерно между левой и правой колонками и имеют следующие установки по умолчанию:

ll = 100
lr = 0
rr = 100
rl = 0

Моно звуки воспроизводятся в левом канале и имеют следующие установки по умолчанию:

ll = 100
lr = 100
rr = 0
rl = 0

Player

Flash 5 или выше.

Пример

Следующий пример создает трансформацию звукового объекта, при которой оба канала и левый и правый воспроизводятся в левом канале:

mySoundTransformObject = new Object
mySoundTransformObject.ll = 100
mySoundTransformObject.lr = 100
mySoundTransformObject.rr = 0
mySoundTransformObject.rl = 0

Для того, чтобы передать трансформ-информацию в объект Sound, необходимо передать объект в объект Sound используя setTransform:

mySound.setTransform(mySoundTransformObject);

Следующие примеры показывают установки, которые можно определить, используя setTransform, но нельзя определить с помощью setVolume или setPan, даже их сочетанием.

Этот код воспроизводит левый и правый канал в левом канале:

mySound.setTransform(soundTransformObjectLeft);

В вышеупомянутом коде, soundTransformObjectLeft имеет следующие параметры:

11 = 100
1r = 100
rr = 0
rl = 0

Этот код воспроизводит стерео звук, как моно:

setTransform(soundTransformObjectMono);

В вышеупомянутом коде, soundTransformObjectLeft имеет следующие параметры:

ll = 50
lr = 50
rr = 50
rl = 50

Этот код воспроизводит половину громкости левого канала и добавляет остальную часть левого канала к правому каналу:

setTransform(soundTransformObjectHalf);

В вышеупомянутом коде, soundTransformObjectLeft имеет следующие параметры:

11 = 50
lr = 0
rr = 100
rl = 50

Смотрите также

Конструктор для объекта Object


Sound.setVolume

S > Sound.setVolume

Sound.setVolume

Синтаксис

mySound.setVolume(volume);

Аргументы

volume Число от 0 до 100 представляющее уровень громкости. 100 полная мощность и 0 выключить громкость. Значение по умолчанию 100.

Описание

Метод; определяет громкость звукового объекта.

Этот метод общий с методами setPan и setTransform.

Player

Flash 5 или выше.

Пример

Следующий пример определяет громкость в 50% и трансформирует звук с левого в правый канал:

onClipEvent (load) {
    i = -100;
    s = new sound();
    s.setVolume(50);
}
onClipEvent (enterFrame) {
    S.setPan(i++);
}

Смотрите также


Sound.start

S > Sound.start

Sound.start

Синтаксис

mySound.start();
mySound.start([secondOffset, loop]);

Аргументы

secondOffset Необязательный аргумент, позволяющий начать воспроизведение с определенной точки. Например, если у Вас есть 30-ти секундный звук, и Вам нужно начать его воспроизведение с середины, укажите 15 для аргумента secondOffset. Звук не задерживается на 15 секунд, а начинает играть с 15-ти секундной отметки.

loop Необязательный аргумент, позволяющий задать количество циклов воспроизведения звука.

Описание

Метод; начинает воспроизведение последнего присоединенного звука с начала, если аргумент не определен, или с точки, указанной в аргументе secondOffset.

Player

Flash 5 или выше.

Смотрите также


Sound.stop

S > Sound.stop

Sound.stop

Синтаксис

mySound.stop();
mySound.stop(["idName"]);

Аргументы

idName Необязательный аргумент, позволяющий остановить определенный звук. Аргумент idName должен быть заключен в кавычки (" ").

Описание

Метод; останавливает все звуки, воспроизводимые в настоящий момент, или только тот, который определенный аргументом idName.

Player

Flash 5 или выше.

Смотрите также

Sound.start


_soundbuftime

S > _soundbuftime

_soundbuftime

Синтаксис

_soundbuftime = integer;

Аргументы

integer Число секунд, после которых клип переходит в режим stream для музыки.

Описание

Свойство (глобальное); определяет количество секунд для буферизации потокового звука. Значение по умолчанию 5 секунд.

Player

Flash 4 или выше.


startDrag

S > startDrag

startDrag

Синтаксис

startDrag(target);
startDrag(target,[lock]);
startDrag(target [,lock [,left , top , right, bottom]]);

Аргументы

target Путь к мувиклипу, который нужно переместить.

lock Двоичное значение, определяющее как перемещаемый мувиклип будет прикреплен к указателю мыши. true - по центру, false - точкой, в которой пользователь первый раз нажал по клипу. Этот аргумент необязателен.

left, top, right, bottom Значения, указывающие на координаты родительского клипа и описывающие прямоугольник, в котором будет перемещаться мувиклип. Этот аргумент необязателен.

Описание

Команда; делает мувиклип target перетаскиваемым, во время его воспроизведения. Одновременно только один мувиклип может обладать таким свойством. Как только выполнится команда startDrag, мувиклип становится доступным для перемещения до тех пор, пока не будет остановлен командой stopDrag или пока не будет выполнена команда startDrag для другого мувиклипа.

Пример

Для создания мувиклипа, который пользователь может перемещать в любое место, пока нажата клавиша мыши, присвойте команды startDrag и stopDrag кнопке внутри этого мувика, как описано ниже

on(press) {
    startDrag("",true);
}
on(release) {
    stopDrag();
}

Смотрите также

stopDrag

_droptarget


stop

S > stop

stop

Синтаксис

stop;

Аргументы

Нет.

Описание

Команда; останавливает воспроизводимый клип. В большинстве случаев эта команда используется для управления клипами путем нажатия кнопок.

Player

Flash 3 или выше.


stopAllSounds

S > stopAllSounds

stopAllSounds

Синтаксис

stopAllSounds();

Аргументы

Нет.

Описание

Команда; останавливает все звуки, которые воспроизводятся в текущий момент, без остановки проигрывания самого клипа. Потоковый звук начнет снова играть, когда проигрыватель пройдет по кадру, в который он включен.

Player

Flash 3 или выше.

Пример

Следующий код может быть введен в кнопку, которая при нажатии выключит все звуки в клипе:

on(release) {
    stopAllSounds();
}

Смотрите также

Sound (object)


Sample entry for most ActionScript elements

Краткий обзор > Типовые заголовки для большинства элементов ActionScript

Типовые заголовки для большинства элементов ActionScript

В следующих примерах типовых заголовков объясняются принятые соглашения для всех элементов ActionScript, не являющихся объектами.

Заголовки

Все статьи словаря расположены в алфавитном порядке. Регистр, символ подчёркивания в начале и т.д. в расчёт не принимаются.

Синтаксис

Раздел "Синтаксис" содержит правильный синтаксис элементов ActionScript для вашего кода. Часть кода синтаксиса выделена монотипным шрифтом, а аргументы, которые можно назначать, монотипным курсивом 1. Необязательные аргументы заключены в скобки.

Аргументы

Этот раздел содержит описание всех аргументов, указанных в разделе синтаксиса.

Описание

В этом разделе указывается тип элемента (например оператор, метод, функция и т.д.) и объясняется, как он используется.

Player

Этот раздел содерит информацию о том, какие версии плэйера поддерживают данный элемент. Не путать с версией Flash-редактора, используемого для создания содержимого. Например, если вы создаёте содержимое для Flash 4 Player, используя при этом инструменты Flash 5, вы не сможете использовать те элементы ActionScript, которые доступны Flash 5 Player.

С появлением версии Flash 5 ActionScript, некоторые элементы Flash 4 и более ранних версий Flash ActionScript вышли из употребления. Несмотря на то, что эти элементы всё ещё поддерживаются во Flash 5 Player, рекомендуется использовать новые элементы Flash 5.

Кроме того, функциональность операторов значительно возросла в 5-й версии. Не только многие новые математические операторы, но и некоторые операторы старых версий теперь оптимизированы для работы с дополнительным объёмом данных. Для того чтобы избежать конфликта версий, файлы Flash 4 автоматически модифицируются при их импорте в среду Flash 5. Эти изменения не повлияют на функциональность первоначального скрипта. Для получения более детальной информации смотрите статьи по + (сложение), < (меньше), > (больше), <= (меньше или равно), >= (больше или равно), != (неравно) и = (равно).

Примеры

Этот раздел содержит примеры кодов, показывающие, как использовать элемент.

Смотри также

Этот раздел содержит ссылки на статьи словаря ActionScript, относящиеся к данной теме.

От редактора:

  1. Если Вам не нравится внешний вид справки в броузере, можете отредактировать файлы с описанием каскадных стилей по своему вкусу:
    help.css - стиль, которым выводится содержание страницы, например той, которую вы сейчас читаете;
    cont.css - стиль, которым выводится навигационное меню в левом фрейме.

    Эти файлы находятся вместе с HTML-файлами, в каждой из трех директорий справки.


| (bitwise OR)

Операторы > | (bitwise OR)

| (побитовое ИЛИ)

Синтаксис

expression1 | expression2

Аргументы

expression1, expression2 Любое число.

Описание

Оператор (побитовый); конвертирует expression1 и expression2 в 32-битные беззнаковые целые числа, и возвращает 1 в каждую битовую позицию, где соответствующие биты в выражении expression1 или expression2 представлены как 1.

Player

Flash 5 или более поздней версии.

Пример

Вот пример операции с побитовым ИЛИ. Примечание: 15 - это бинарное 1111:

// 15 decimal = 1111 binary
x = 15;
// 9 decimal = 1001 binary
y = 9;
// x | y = binary
z = x | y;
z = 15

Вот ещё способ выражения предыдущего примера:

15 | 9 возвращает 15
(1111 | 0011 = 1111)


stopDrag

S > stopDrag

stopDrag

Синтаксис

stopDrag();

Аргументы

Нет.

Описание

Команда; останавливает текущую операцию перетаскивания.

Player

Flash 4 или выше.

Пример

Следующие команды останавливают перетаскивание мувиклипа mc, когда пользователь отпустит кнопку мыши:

on(press) {
    startDrag("mc");
}
on(release) {
    stopdrag();
}

Смотрите также


String (function)

S > String (function)

String (function)

Синтаксис

String(expression);

Аргументы

expression Число, булеан, переменная или объект, преобразуемые в строковое представление.

Описание

Функция; Возвращает строковое представление указанного параметра следующим образом:

Если x булеан, возвращается строка true (истина) или false (ложь).

Если x число, возвращается его десятичное представление.

Если x строка, возвращается строка x.

Если x объект, возвращаемое значение - строковое представление объекта, сгенерированного вызовом строкового свойства объекта, или вызовом object.toString если такого свойства не существует.

Если x мувиклип, возвращаемое значение - путь к нему в слеш (/) нотации.

Если x неопределен, возвращаемое значение - пустая строка.

Player

Flash 3 или выше.

Смотрите также


" " (string delimiter)

S > " " (строковый разделитель)

" " (строковый разделитель)

Синтаксис

"text"

Аргументы

text Любой текст.

Описание

Строковый разделитель; при установке кавычек в начале и в конце строки, они указывают, что строка является литеральной - не переменной, числовым значением или другим ActionScript элементом.

Player

Flash 4 или выше.

Пример

Кавычки в этом операторе указывают, что строка "Prince Edward Island" является литеральной строкой, а не выражением:

province = "Prince Edward Island"

Смотрите также


String (object)

S > String (object)

String (object)

Объект String - оболочка для первоначального строкового типа данных, позволяет использовать методы и свойства объекта String для управления первоначальными строковыми значениями типов. Используя функцию String(), можно преобразовывать значение любого объекта в строку.

Все методы объекта String, за исключением concat, fromCharCode, slice и substr, являются универсальными. Это означает, что сами методы вызывают this.toString перед выполнением их операций и Вы можете использовать эти методы с другими не-строковыми объектами.

Можно вызывать любой метод объекта String, используя конструктор метода new String или литеральное строковое значение. Если Вы определяете строковый литерал, интерпретатор ActionScript автоматически конвертирует его во временный объект String, вызывает метод, а затем удаляет временный объект String. Можно также использовать свойство String.length со строковым литералом.

Важно не путать строковый литерал с экземпляром объекта String. В следующем примере в первой строке создается строковый литерал s1, а во второй, экземпляр объекта String s2.

s1 = "foo"
s2 = new String("foo")

Рекомендуется использовать строковые литералы, если Вы определенно не будете использовать объект String, поскольку объекты String могут вести себя неоднозначно.

Описание методов для объекта String
Метод | Описание
charAt | Возвращает номер, указывающий на размещение символа в строке.
charCodeAt | Возвращает значение символа по данному индексу как 16-разрядное целое число между 0 и 65535.
concat | Объединяет текст двух строк и возвращает новую строку.
fromCharCode | Возвращает строку, составленную из символов, указанных в параметрах.
indexOf | Ищите строку и возвращает индекс значения, указанного в параметрах. Если значение найдено больше чем однажды, возвращается индекс первого возникновения. Если значение не найдено, возвращается -1.
lastIndexOf | Возвращает последнее местонахождение подстроки в пределах строки, перед позицией ее начала, указанной в параметре, или -1 если не найдена.
slice | Извлекает часть строки и возвращает новую строку.
split | Разбивает объект String на массив строк, отделяя строку в подстроки.
substr | Возвращает указанное число символов в строке, начиная с местоположения, указанного в параметре.
substring | Возвращает символы между двумя индексами, указанными в параметрах, в строку.
toLowerCase | Преобразовывает строку в нижний регистр и возвращает результат.
toUpperCase | Преобразовывает строку в верхний регистр и возвращает результат.

Список свойств объекта String
Свойство | Описание
length | Возвращает длину строки.

Конструктор для объекта String

Синтаксис

new String(value);

Аргументы

value Начальное значение нового объекта String.

Описание

Конструктор; создает новый объект String.

Player

Flash 5 или выше.

Смотрите также


String.charAt

S > String.charAt

String.charAt

Синтаксис

myString.charAt(index);

Аргументы

index Номер символа в строке, который будет возвращен.

Описание

Метод; возвращает символ, указанный параметром index. Индекс первого символа в строке - 0. Если index не является числом от 0 до string.length - 1, возвращается пустая строка.

Player

Flash 5 или выше.


String.charCodeAt

S > String.charCodeAt

String.charCodeAt

Синтаксис

myString.charCodeAt(index);

Аргументы

index Номер символа, значение которого востребовано.

Описание

Метод; возвращает значение символа, указанного индексом index. Возвращенное значение - 16-разрядное целое число от 0 до 65535.

Этот метод подобен string.charAt за исключением того, что возвращается значение символа в определенном местоположении, вместо подстроки, содержащей символ.

Player

Flash 5 или выше.


String.concat

S > String.concat

String.concat

Синтаксис

myString.concat(value1,...valueN);

Аргументы

значение1,...значениеN Ноль или большее количество значений, которые будут соединены.

Описание

Метод; объединяет указанные значения и возвращает новую строку. В случае необходимости, каждый аргумент value преобразуется к строке и добавляется в конец выходной строки.

Player

Flash 5 или выше.


String.fromCharCode

S > String.fromCharCode

String.fromCharCode

Синтаксис

myString.fromCharCode(c1,c2,...cN);

Аргументы

c1,c2,...cN Символы, которые будут превращены в строку.

Описание

Метод; возвращает строку, составленную из символов, указанных в параметрах.

Player

Flash 5 или выше.


String.indexOf

S > String.indexOf

String.indexOf

Синтаксис

myString.indexOf(value);
myString.index of (value, start);

Аргументы

value Целое число или строка, определяющая подстроку, которую нужно искать в пределах myString.

start Целое число, определяющее начальную точку поиска. Этот параметр необязательный.

Описание

Метод; ищет строку и возвращает позицию первого совпадения с указанным значением. Если значение не найдено, метод возвращает -1.

Player

Flash 5 или выше.


String.lastIndexOf

S > String.lastIndexOf

String.lastIndexOf

Синтаксис

myString.lastIndexOf(substring);
myString.lastIndexOf(substring, start);

Аргументы

substring Целое число или строка, определяющая строку, которую нужно искать.

start Целое число, определяющее точку начала поиска внутри подстроки. Этот параметр необязательный.

Описание

Метод; ищет строку и возвращает индекс последнего совпадения подстроки, найденной в пределах вызываемой строки. Если подстрока не найдена, метод возвращает -1.

Player

Flash 5 или выше.


|| (OR)

Операторы > || (OR)

|| (ИЛИ)

Синтаксис

expression1 || expression2

Аргументы

expression1, expression2 Булево значение, или выражение, конвертируемое в булево значение.

Описание

Оператор (логический); анализирует expression1 и expression2. Результат есть (true), если одно или оба эти выражения оцениваются как true; результат есть (false), только если оба эти выражения оцениваются как false.

С не булевыми выражениями, логический оператор OR анализирует выражения, находящееся слева, если оно может быть конвертировано в true, результат - true. В противном случае он оценивает выражение справа и результат - это значение этого выражения.

Player

Flash 4 или более поздней версии.

Пример

Этот пример использует оператор || в операторе if:

want = true;
need = true;
love = false;
if (want || need || love){
trace("two out of 3 ain't bad");
}


String.length

S > String.length

String.length

Синтаксис

string.length

Аргументы

Нет.

Описание

Свойство; возвращает число символов в указанном объекте String. Индекс последнего символа для любой строки x - x.length-1.

Player

Flash 5 или выше.


String.slice

S > String.slice

String.slice

Синтаксис

myString.slice(start, end);

Аргументы

start Номер, определяющий индекс начальной точки сектора. Если start отрицательное число начальная точка определяется с конца строки, где -1 - последний символ.

end Номер, определяющий индекс конца сектора. Если end не определен, сектор включает все символы от начала до конца строки. Если end отрицательное число, то конечная точка определяется с конца строки, где -1 - последний символ.

Описание

Метод; извлекает сектор или подстроку, указанного объекта String, затем возвращает это как новую строку, без изменения оригинального объекта String. Возвращенная строка включает start символ и все символы до (но не включая) end символа.

Player

Flash 5 или выше.


String.split

S > String.split

String.split

Синтаксис

myString.split(delimiter);

Аргументы

delimiter Символ, используемый в качестве разделителя строки.

Описание

Метод; разбивает объект String везде, где встречается определенный аргумент delimiter и возвращает полученные подстроки в виде массива. Если никакой разделитель не определен, возвращенный массив содержит только один элемент - саму строку непосредственно. Если разделитель - пустая строка, каждый символ в объекте String становится элементом в массиве.

Player

Flash 5 или выше.


String.substr

S > String.substr

String.substr

Синтаксис

myString.substr(start, length);

Аргументы

start Целое число, которое указывает позицию первого символа в создаваемой подстроке. Если start отрицательное число, исходная позиция определяется с конца строки, где -1 - последний символ.

length Число символов в создаваемой подстроке. Если length не определен, подстрока включает все символы от начала до конца строки.

Описание

Метод; возвращает символы в строке от индекса, указанного в параметре start, длинной указанной в аргументе length.

Player

Flash 5 или выше.


String.substring

S > String.substring

String.substring

Синтаксис

myString.substring(from, to);

Аргументы

from Целое число, указывающее позицию первого символа в создаваемой подстроке. Допустимые значения для from от 0 до string.length - 1.

to Целое число, которое является 1 + индекс последнего символа в создаваемой подстроке. Допустимые значения для to от 1 до string.length. Если параметр to не определен, конец подстроки есть конец строки. Если from равно to, метод возвращает пустую строку. Если from больше чем to, параметры автоматически меняются прежде, чем функция выполняется.

Описание

Метод; возвращает строку, состоящую из символов между точками, указанными параметрами from и to.

Player

Flash 5 или выше.


String.toLowerCase

S > String.toLowerCase

String.toLowerCase

Синтаксис

myString.toLowerCase();

Аргументы

Нет.

Описание

Метод; возвращает копию объекта String, со всеми символами верхнего регистра, преобразованными в нижний регистр.

Player

Flash 5 или выше.


String.toUpperCase

S > String.toUpperCase

String.toUpperCase

Синтаксис

myString.toUpperCase();

Аргументы

Нет.

Описание

Метод; возвращает копию объекта String, со всеми символами нижнего регистра, преобразованными в верхний регистр.

Player

Flash 5 или выше.


substring

S > substring

substring

Синтаксис

substring(string, index, count);

Аргументы

string Исходная строка, из которой извлекается новая строка.

index Номер первого символа, с которого начинается извлечение.

count Число символов, которые нужно включить в извлеченную строку, не включая индексный символ.

Описание

Строковая функция; извлекает часть символьной строки.

Player

Flash 4 или выше. Эта функция нежелательна в Flash 5.

Смотрите также

String.substring


_target

T-W > _target

_target

Синтаксис

instancename._target

Аргументы

instancename имя экземпляра муви-клипа.

Описание

Свойство (только для чтения); возвращает полный путь (target path) до экземпляра муви-клипа, указанного в аргументе instancename.

Player

Flash 4 или более новый.


targetPath

T-W > targetPath

targetPath

Синтаксис

targetpath(movieClipObject);

Аргументы

movieClipObject Ссылка (например: _root или _parent) на муви-клип, до которого определяется путь (target path).

Описание

Функция; возвращает в виде строки путь (target path) до movieClipObject. Возвращаемая строка имеет дот-нотацию (разделитель параметров в виде точки - прим.перевод.). Если требуется возвращать строку в слэш-нотации, то следует использовать свойство _target.

Player

Flash 5 или более новый.

Пример

Следующие примеры эквивалентны. В первом примере используется дот-нотация, во втором - слэш.

targetPath (Board.Block[index*2+1]) {

play();

}

Это эквивалентно:

tellTarget ("Board/Block:" + (index*2+1)) {

play();

}

См. также

eval


|= (bitwise OR assignment)

Операторы > |= (bitwise OR assignment)

|= (назначение побитового ИЛИ)

Синтаксис

expression1 |= expression2

Аргументы

expression1, expression2 Целые числа и переменные.

Описание

Оператор (присваивания); присваивает expression1 значение expression1 | expression2.

Player

Flash 5 или более поздней версии.

Пример

Ниже пример использования оператора |= с переменными и числами:

x |= y то же, что и x = x | y

если x = 15 и y = 9 , то

x |= 9 вернёт 15

Смотри также

| (bitwise OR)


tellTarget

T-W > tellTarget

tellTarget

Синтаксис

tellTarget(target) {
statement;
}

Аргументы

target Строка определяющая путь (target path) до управляемой линейки (Timeline).

statement Команды, направляемые на эту линейку.

Описание

Команда; запускает команды, определенные в аргументе statements на линейке (Timeline), указанной в аргументе target. Команда tellTarget полезна для управления навигацией. Назначьте tellTarget кнопкам, которые остановят или запустят клип с какого-нибудь другого места. Можно также сделать переход на другой кадр в том клипе. Например, назначать tellTarget кнопкам, которые останавливают или запускаю воспроизведение клипа на основной линейке или указывают мувиклипам перейти на определенный кадр.

Команда tellTarget очень похожа на команду with, за исключением того, что with понимает клип или другой объект как target, а tellTarget требует указания пути до клипа и не может управлять объектами.

Player

Flash 3 или более новый. Эта команда нежелательна во Flash 5, рекомендуется использовать команду with.

Пример

Этот tellTarget управляет мувиком с именем ball, расположенном на основной линейке. Первый кадр этого мувиклипа пустой и содержит команду stop, поэтому он остается невидимым. Когда нажимается кнопка, содержащая следующую команду, tellTarget указывает мувиклипу ball перейти на второй кадр и начать воспроизводить анимацию с этого кадра.

on(release) {
    tellTarget("ball") {
        gotoAndPlay(2);
    }
}

См. также

with


this

T-W > this

this

Синтаксис

this

Аргументы

None.

Описание

Ключевое слово; ссылается на объект или экземпляр мувиклипа. Ключевое слово this имеет ту же самую цель и функцию в ActionScript, как и в JavaScript, а так же некоторые дополнительные функциональные возможности. В ActionScript, во время его исполнения, this ссылается на образец (instance) мувиклипа, в котором выполняется скрипт. Когда используется метод вызова, this ссылается на тот объект, который содержит в себе выполненный метод.

Player

Flash 5 или более новый.

Пример

В следующем примере, this ссылается на объект Circle:

function Circle(radius){
    this.radius = radius;
    this.area = math.PI * radius * radius;
}

В этом выражении назначенном кадру, this ссылается на текущий мувиклип:

//установить свойство alpha текущего мувика равным 20.
this._alpha = 20;

В этом выражении, заключенном внутри обработчика onClipEvent, this ссылается на текущий мувиклип:

//когда мувик загружен, запустить для него команду startDrag.

onClipEvent (load) {
 startDrag (this, true);
}

См. также

new


toggleHighQuality

T-W > toggleHighQuality

toggleHighQuality

Синтаксис

toggleHighQuality();

Аргументы

Нет.

Описание

Команда; включает и выключает сглаживание (antialiasing) в флеш-плеере. Это может приводить к замедлению скорости воспроизведения клипа на слабых компьютерах. toggleHighQuality оказывает влияние сразу на весь клип.

Player

Flash 2 или более новый.

Пример

Следующий код может быть вставлен в кнопку, которая при нажатии будет включать/выключють сглаживание:

on(release) {
    toggleHighQuality();
}

См. также


_totalframes

T-W > _totalframes

_totalframes

Синтаксис

instancename._totalframes

Аргументы

instancename имя муви-клипа.

Описание

Свойство (только для чтения); возвращает общее количество кадров в клипе, заданном в аргументе instancename.

Player

Flash 4 или более новый.


trace

T-W > trace

trace

Синтаксис

trace(expression);

Аргументы

expression Строка или выражение, результат обработки которого в режиме тестирования клипа выводится в окне Output.

Описание

Команда; Обрабатывает expression и отображает результаты окне Output во время тестирования клипа.

Используйте trace для создания программных меток и/или вывода в окно Output сообщений при тестировании клипа. Используйте expression параметр для проверки валидности условий или для вывода в Output каких-либо значений. Команда trace подобна функции alert в JavaScript.

Player

Flash 4 или более новый.

Пример

Этот пример взят из игры, в которой "таскаемый" мувик под названием rabbi должен находится по определенному адресу (target). Условный оператор определяет свойство _droptarget и выполняет различные действия, в зависимости от местонахождения rabbi. Команда trace, расположенная в конце скрипта, предназначена для определения местонахождения мувика rabbi и вывода результата в окно Output. Если поведение rabbi не соответствует ожидаемому (например, если указан ошибочный target), значения, выводимые в окно Output командой trace, помогут локализовать и найти ошибку в скрипте.

on(press) {
rabbi.startDrag();
}
on(release) {
if(eval(_droptarget) != target) {
      rabbi._x = rabbi_x;
      rabbi._y = rabbi_y;
} else {
rabbi_x = rabbi._x;
rabbi_y = rabbi._y;
target = "_root.pasture";
}
trace("rabbi_y = " + rabbi_y);
trace("rabbi_x = " + rabbi_x);
stopDrag();
}


typeof

T-W > typeof

typeof

Синтаксис

typeof(expression);

Аргументы

expression Строка, муви-клип, объект или функция.

Описание

Оператор; унарный оператор, помещаемый перед отдельным аргументом (выражением). Результат - строка, определяющая является ли выражение строкой, муви-клипом, объектом или функцией.

Player

Flash 5 или более новый.

Пример

a = typeof ("Hello Word!!!");

Результат:

a = "string"


unescape

T-W > unescape

unescape

Синтаксис

unescape(x);

Аргументы

x Строка с последовательностью шестнадцатеричных (НЕХ) чисел.

Описание

Высокоуровневая функция; оценивает аргумент x как строку, декодирует ее из формата URL-encoded (конвертирует все HEX-последовательности в ASCII символы) и возвращает опять в виде строки.

Player

Flash 5 или более новый.

Пример

Следующий пример иллюстрирует escape-to-unescape процесс конвертации.

escape("Hello{[World]}");

Результат будет следующим:

("Hello%7B%5BWorld%5D%7D');

Использование unescape возвращает в прежний вид:

unescape("Hello%7B%5BWorld%5D%7D")

Результат следующий:

Hello{[World]}


unloadMovie

T-W > unloadMovie

unloadMovie

Синтаксис

unloadMovie(location);

Аргументы

location Значение уровня или пути (target) до выгружаемого муви-клипа.

Описание

Команда; удаляет (выгружает) из флеш-плеера клип, который до этого был загружен с использованием команды loadMovie.

Player

Flash 3 или более новый.

Пример

Следующий пример выгрузит основной клип, оставив пустым окно плеера:

unloadMovie(_root);

Следующий пример выгрузит клип с уровня 15, когда пользователь нажмет на кнопку:

on(press) {
    unloadMovie(_level15);
}

См. также

loadMovie


updateAfterEvent

T-W > updateAfterEvent

updateAfterEvent

Синтаксис

updateAfterEvent(movie clip event);

Аргументы

movie clip event Событие мувиклипа. Можно определить одно из следующих его значений:

mouseMove Действие, инициализируемое при каждом перемещении мыши. Свойства _xmouse и _ymouse определяют текущую позицию мыши.
mouseDown Действие, инициализируемое при нажатии левой кнопки мыши.
mouseUp Действие, инициализируемое при отпускании (отжатии) левой кнопки мыши.
keyDown Действие, инициализируемое при нажатии клавиши клавиатуры. Использует метод Key.getCode для определения нажатой клавиши.
keyUp Действие, инициализируемое при отпускании (отжатии) клавиши клавиатуры. Использует метод key.getCode для определения нажатой клавиши.

Описание

Команда; независимо от значения частоты кадров в секунду (fps), установленной для клипа, обновляет экран после завершения события клипа, определенного в аргументе. Эта команда не указана в панели команд 1. Использование updateAfterEvent с командой drag, определяющей свойства _x и _y в течение перемещения мыши, позволяет объектам перемещаться более гладко, без эффекта мерцающего экрана.

Player

Flash 5 или более новый.

См. также

onClipEvent

От переводчика:
  1. На самом деле указана, находится внизу раздела функций, хотя в этом доке и называется командой (Action). Не указаны те события, которые с ее помощью можно обрабатывать, их придется запомнить и вводить руками. Впрочем, лучше запомнить все команды и их синтаксис и работать в эксперт-режиме без подсказок пакета. Это очень ускоряет написание и отладку скриптов :)


_url

T-W > _url

_url

Синтаксис

instancename._url

Аргументы

instancename имя муви-клипа.

Описание

Свойство (только для чтения); возвращает URL (адрес) SWF-файла, с которого он был загружен.

Player

Flash 4 или более новый.


~ (bitwise NOT)

Операторы > ~ (bitwise NOT)

~ (побитовое НЕ)

Синтаксис

~ expression

Аргументы

expression Любое число.

Описание

Оператор (побитовый); конвертирует expression в 32-битное целое беззнаковое число, затем инвертирует биты. Или же, проще говоря, изменяет знак числа и вычитает 1.

"Побитовый НЕ" оператор изменяет знак числа и вычитает 1.

Player

Flash 5 или более поздней версии.

Пример

Ниже числовое объяснение операции над переменной с использованием "побитового НЕ" оператора:

~a, возвращает -1, если a = 0 и возвращает -2, если a = 1, таким образом:

~0=-1 and ~1=-2


var

T-W > var

var

Синтаксис

var variableName1 [= value1] [...,variableNameN [=valueN]];

Аргументы

variableName Имя объявляемой переменной.

value Значение присваиваемое переменной.

Описание

Команда; используется для объявления локальных переменных. Если локальные переменные объявляются внутри функции, то они действуют только в ее пределах. Если переменные не объявлены внутри блока, но список команд был выполнен через вызов call, переменные являются локальными и действуют до конца текущего списка. Если переменные не объявлены внутри блока и текущий список команд не выполнялся командой call, переменные не являются локальными.

Player

Flash 5 или более новый.


_visible

T-W > _visible

_visible

Синтаксис

instancename._visible
instancename._visible = Boolean;

Аргументы

Boolean Значения true или false, определяющие будет ли клип видим или нет.

Описание

Свойство; определяет будет ли видим муви-клип, указанный в аргументе instancename. Невидимый мувик является недоступным для пользователя. Например, кнопки в муви-клипе со значением _visible равным false, не могут быть нажаты.

Player

Flash 4 или более новый.


void

T-W > void

void

Синтаксис

void (expression);

Аргументы

expression Любое выражение.

Описание

Оператор; унарный оператор отбрасывающий значение expression и возвращающий неопределенное (undefined) значение. Оператор void часто используется для оценки URL при тестировании побочных эффектов без отображения оцениваемого выражения в окне броузера (сорри, прямее не перевелось). void также используется в операциях сравнения == для тестирования undefined (неопределенных) значений.

Player

Flash 5 или более новый.

Пример

a = void(f2+15);

Результат:

a = undefined


while

T-W > while

while

Синтаксис

while(condition) {
statement(s);
}

Аргументы

condition Условие, проверяемое каждый раз при выполнении команды while. Если результат проверки соответствует истине (true), исполняется оператор(ы), указанный(е) в statement(s).

statement(s) Оператор(ы), исполняемый(е) в том случае, если условие соответствует истине (true).

Описание

Команда; выполняет оператор или серию операторов в цикле, пока условный аргумент соответствует истине (true). В конце каждого while-блока цикл перезапускается, с предварительной проверкой условия. Если условие не соответствует истине (false) или эквивалентно нулю, происходит переходит на следующую после while команду.

Цикл обычно используется для выполнения действий, пока переменная счетчика имеет значение меньше чем определенное условием. В конце каждого цикла счетчик увеличивает свое значение и цикл повторяется, и так происходит до тех пор, пока не счетчик не превысит порогового значения, определенного в условии condition, после чего цикл завершается.

Player

Flash 4 или более новый.

Пример

Это пример дублирования пяти мувиков, каждый из которых получает случайные координаты x и y, свойства xscale, yscale и _alpha. Переменная foo инициализируется со значения 0. Аргумент condition устанавливается таким, что while цикл будет выполнен пять раз или пока значение переменной foo будет меньше 5. Внутри while цикла мувик клонируется и через setProperty получает новые свойства. Последний оператор цикла увеличивает значение foo, и так происходит до тех пор, пока foo не достигнет значения 5, после чего при очередной проверке аргумента condition будет получено false и цикл завершит работу.

on(release) {
    foo = 0;
    while(foo < 5) {
        duplicateMovieClip("/flower", "mc" + foo, foo);
        setProperty("mc" + foo, _x, random(275));
        setProperty("mc" + foo, _y, random(275));
        setProperty("mc" + foo, _alpha, random(275));
        setProperty("mc" + foo, _xscale, random(200));
        setProperty("mc" + foo, _yscale, random(200));
        foo = foo + 1;
    }
}

См. также


_width

T-W > _width

_width

Синтаксис

instancename._width
instancename._width =value;

Аргументы

value Ширина клипа в пикселах.

instancename Имя муви-клипа, у которого изменяется свойство _width (ширина).

Описание

Свойство; устанавливает ширину клипа. В предыдущих версиях Flash свойства _height и _width были доступны только для чтения, во Flash 5 они могут быть заданы.

Player

Flash 4 - только для чтения. Во Flash 5 или более новом это свойство может быть задано.

Пример

Следующий код задает высоту и ширину муви-клипа когда пользователь нажимает на кнопку мыши:

onclipEvent(mouseDown) {
    _width=200;
    _height=200;
}

См. также

_height


with

T-W > with

with

Синтаксис

with (object) {
statement(s);
}

Аргументы

object Экземпляр ActionScript объекта или мувиклипа.

statement(s) Команда или группа команд, заключенных в фигурные скобки.

Описание

Команда; временно изменяет область контекстного действия (или путь), используемые для определения выражений и команд в statement(s). После выполнения команды with, область действия восстанавливается к первоначальному значению.

Object соответствует контекстной области, в которой читаются свойства, переменные и функции. Например, если object - myArray и два его свойства определены, как length и concat, эти свойства автоматически читаются как myArray.length и myArray.concat. В другом примере, если object есть state.california, то это то же самое, как если бы любая команда или операторы внутри команды with были вызваны изнутри экземпляра california.

Для нахождения значения идентификатора в statement(s), ActionScript начинает поиск в начале контекстной области, определенной object и ищет их в каждом уровне контекста в характерном порядке.

Контекстная область, используемая командой with, определяет идентификаторы начиная с первого элемента следующего списка и до последнего:

object вызванный изнутри команды with
object вызванный наиболее удаленным местом команды with
Активированный объект (временный объект, созданный автоматически, когда функция вызвана для хранения локальных переменных.)
Мувиклип, содержащий текущий исполняемый скрипт
Глобальный объект (предопределенные объекты, такие как Math, String)

Во Flash 5 команда with заменяет нежелательную команду tellTarget. Предпочтительнее использовать with вместо tellTarget, потому что стандарт ActionScript расширен к стандарту ECMA-262. Принципиальное различие между with и tellTarget командами то, что with обращается к клипу или другим объектам как к их аргументам, в то время как tellTarget обращается к пути (target path), идентифицирующем мувиклип и не может использовать объекты.

Для установки переменной внутри команды with, она должна быть объявлена снаружи или должен быть введен полный путь до линейки (Timeline) на которой необходимо разместить переменную. Если вы установили переменную в команде with без ее объявления, команда with будет искать значение согласно контексту. Если переменная уже не существует, новое значение будет установлено на линейке, с которой команда with была вызвана.

Пример

Следующий пример устанавливает свойства x и y экземпляра someOtherMovieClip и затем командует ему перейти на третий кадр и остановиться:

with (someOtherMovieClip) {
    _x = 50;
    _y = 100;
    gotoAndStop(3);
}

Следующий отрывок кода показывает, как можно написать предшествующий пример без использования команды with:

someOtherMovieClip._x = 50;
someOtherMovieClip._y = 100;
someOtherMovieClip.gotoAndStop(3);

Этот код также можно написать с использованием команды tellTarget:

tellTarget ("someOtherMovieClip") {
    _x = 50;
    _y = 100;
    gotoAndStop(3);
}

Использование команды with полезно для одновременного вызова многих элементов в контекстном листе. В следующем примере встроенный объект Math помещен в начало объектной области (контекста). Установка Math, как объекта по умолчанию, приводит идентификаторы cos, sin и PI к Math.cos, Math.sin и Math.PI соответственно. Идентификаторы a, x, y и r - не методы или свойства объекта Math, но так как они существуют в объектной области (контексте) функции polar, они приводятся к к соответствующим локальным переменным.

function polar(r){
    var a, x, y
    with (Math) {
        a = PI * r * r
        x = r * cos(PI)
        y = r * sin(PI/2)
}
trace("area = " +a)
trace("x = " + x)
trace("y = " + y)
}

Возможно использование вложенных команд with для доступа к информации во многих контекстных областях. В следующем примере экземпляры fresno и salinas являются дочерними по отношению к california. Оператор устанавливает значения _alpha для fresno и salinas без изменения значения _alpha у california.

with (california){
    with (fresno){
        _alpha = 20;
    }
    with (salinas){
        _alpha = 40;
    }
}

См. также

tellTarget


_x

X-Z > _x

_x

Синтаксис

instancename._x
instancename._x = integer

Аргументы

integer Локальная x-координата клипа.

instancename Имя экземпляра клипа.

Описание

Свойство; устанавливает x-координату клипа относительно локальных координат родительского клипа. Если клип расположен на главной монтажной линейке, то начало его системы координат (0, 0), находится в верхнем левом углу рабочего окна. Если клип вложен внутрь другого трансформированного клипа, он находится в локальной системе координат родительского клипа. Таким образом, после поворота родительского клипа на 90° против часовой стрелки, его дочерние клипы унаследуют систему координат, повернутую на 90° против часовой стрелки. Координаты клипа относятся к его точке отсчета (registration point).

Player

Flash 3 или выше.

Смотрите также


XML (object)

X-Z > XML (object)

XML (object)

Используйте методы и свойства объекта XML, чтобы загружать, анализировать, посылать, формировать и управлять XML деревьями документов.

Вы должны использовать конструктор new XML(), чтобы создать экземпляр объекта XML перед вызовом любого из методов объекта XML.

XML поддерживается Flash Player версии Flash 5 или выше.

Список методов для объекта XML
Метод | Описание
appendChild | Добавляет узел к концу дочернего списка указанного объекта.
cloneNode | Клонирует указанный узел и, опционально, рекурсивно клонирует все дочерние записи.
createElement | Создает новый элемент XML.
createTextNode | Создает новый текстовый узел XML.
hasChildNodes | Возвращает true, если указанный узел имеет подчиненные узлы, в противном случае, возвращает false.
insertBefore | Вставляет узел перед существующим узлом в дочернем списке указанного узла.
load | Загружает документ (указанный объектом XML) с адреса URL.
onLoad | Функция повторного вызова для load и sendAndLoad.
parseXML | Анализирует XML документ в указанное дерево объекта XML.
removeNode | Удаляет указанный узел из его родителя.
send | Посылает указанный объект XML на адрес URL.
sendAndLoad | Посылает указанный объект XML на адрес URL и загружает ответ сервера в другой объект XML.
toString | Преобразовывает указанный узел и любые дочерние записи в текст XML.

Список свойств объекта XML
Свойство | Описание
docTypeDecl | Устанавливает и возвращает информацию об объявлениях DOCTYPE в XML документах.
firstChild | Ссылки на первый подчиненный объект в списке для указанного узла.
lastChild | Ссылки на последний подчиненный объект в списке для указанного узла.
loaded | Проверяет загружен ли указанный объект XML.
nextSibling | Ссылки на следующего брата в дочернем списке родительского узла.
nodeName | Возвращает имя тега элемента XML.
nodeType | Возвращает тип указанного узла (XML элемента или текстового узла).
nodeValue | Возвращает текст выбранного узла, если узел является текстовым.
parentNode | Ссылки на родительскую вершину указанного узла.
previousSibling | Ссылки на предыдущего брата в дочернем списке родительского узла.
status | Возвращает числовой код состояния, указывающий успех или неудачу операции синтаксического анализа документа XML.
xmlDecl | Устанавливает и возвращает информацию об объявлениях документов в документе XML.

Список групповых операций над объектами XML
Метод | Описание
attributes | Возвращает ассоциативный массив, содержащий все атрибуты указанного узла.
childNodes | Возвращает массив, содержащий ссылки на подчиненные объекты указанного узла.

Конструктор для объекта XML

Синтаксис

new XML();
new XML(source);

Аргументы

source Анализируемый документ XML для создания нового объекта XML.

Описание

Конструктор; создает новый объект XML. Вы должны использовать конструктор для создания экземпляра объекта XML перед вызовом его любых методов.

Первый синтаксис создает новый, пустой объект XML.
Второй синтаксис создает новый объект XML, анализируя XML документ, указанный в source параметре и заполняет созданный объект XML деревом XML документа.

Примечание: Методы createElement и createTextnode являются "конструкторскими" методами для создания элементов и текстовых узлов в дереве XML документа.

Player

Flash 5 или выше.

Пример

Следующий пример создает новый пустой объект XML:

myXML = new XML();

Смотрите также


XML.appendChild

X-Z > XML.appendChild

XML.appendChild

Синтаксис

myXML.appendChild(childNode);

Аргументы

childNode Дочерний узел, добавляемый в список дочерних объектов указанного XML объекта.

Описание

Метод; добавляет указанный дочерний узел в список объекта XML. Добавляемый дочерний узел будет размещен в древовидной структуре и удален из существующего родительского узла, если такой существует.

Player

Flash 5 или выше.

Пример

Следующий пример клонирует последний узел из doc1 и добавляет его в doc2:

doc1 = new XML(src1);
doc2 = new XML();
node = doc1.lastChild.cloneNode(true);
doc2.appendChild(node);


XML.attributes

X-Z > XML.attributes

XML.attributes

Синтаксис

myXML.attributes;

Аргументы

Нет.

Описание

Совокупность (чтение - запись); возвращает ассоциативный массив, содержащий все атрибуты указанного XML объекта.

Player

Flash 5 или выше.

Пример

Следующий пример записывает, имена XML атрибутов в Окно вывода:

str = "<mytag name=\"Val\"> intem </mytage>";
doc = new XML(str);
y = doc.fristChild.attributes.name;
    trace (y);
doc.firstChild.attributes.order = "first";
z = doc.firstChild.attributes.order
    trace(z);

В окне Output будет показан следующий результат:

Val
First


+ (addition)

Операторы > + (addition)

+ (сложение)

Синтаксис

expression1 + expression2

Аргументы

expression1, expression2 Целые числа, числа с плавающей запятой или строки.

Описание

Оператор; складывает числовые выражения или связывает строки. Если одно выражение является строкой, все другие выражения конвертируются в строки и связываются.

Если оба выражения являются целыми числами, то сумма - целое число. Если одно или оба выражения являются числами с плавающей запятой, то сумма - число с плавающей запятой.

Player

Flash 4, 5 или более поздней версии. В пятой версии, + является числовым оператором или объединителем строк в зависимости от типа данных аргумента. В четвертой версии, + является только числовым оператором. Файлы Flash 4 при переносе в рабочую среду Flash 5 подвергаются преобразованию, с целью сохранить целостность типа данных. Первый из нижеприведённых примеров показывает процесс преобразования.

Пример

Этот пример показывает преобразование файла Flash 4, содержащего числовое качественное сравнение:

Файл Flash 4:

x + y

Конвертированный файл Flash 5:

Number(x) + Number(y)

В этом операторе происходит сложение целых чисел 2 и 3, результат выводится в окне Output:

trace (2 + 3);

Здесь складываются числа с плавающей запятой 2.5 и 3.25, результат, 5.7500, число с плавающей запятой, выводится в окне Output:

trace (2.5 + 3.25);

Ниже происходит объединение двух строк и результат, "today is my birthday", выводится в окне Output:

"today is my" + "birthday"

Смотри также

add


XML.childNodes

X-Z > XML.childNodes

XML.childNodes

Синтаксис

myXML.childNodes;

Аргументы

Нет.

Описание

Совокупность (только для чтения); возвращает массив указанных дочерних записей объекта XML. Каждый элемент в массиве есть ссылка на объект XML, который представляет дочернюю вершину. Это свойство только для чтения и не может использоваться для управления дочерними вершинами. Чтобы управлять ими, используйте методы appendChild, insertBefore и removeNode.

Эта совокупность неопределена для текстовых узлов (nodeType == 3).

Player

Flash 5 или выше.


XML.cloneNode

X-Z > XML.cloneNode

XML.cloneNode

Синтаксис

myXML.cloneNode(deep);

Аргументы

deep Булево значение, определяющее, клонируются ли дочерние записи указанного объекта XML рекурсивно.

Описание

Метод; создает и возвращает новый узел XML того же самого типа, имени, значения и атрибутов, как указанный объект XML. Если deep установлен в true, все дочерние вершины рекурсивно клонируются, создавая точную копию дерева документов первоначального объекта

Player

Flash 5 или выше.


XML.createElement

X-Z > XML.createElement

XML.createElement

Синтаксис

myXML.createElement(name);

Аргументы

name Тег (tag) имени создаваемого элемента XML.

Описание

Метод; создает новый XML элемент с именем, указанным в параметре. Новый элемент первоначально не имеет никакого родителя и никаких дочерних записей. Метод возвращает ссылку на недавно созданный объект XML, представляющий элемент. Этот метод и createTextNode - методы конструктора для создания узлов для объекта XML.

Player

Flash 5 или выше.


XML.createTextNode

X-Z > XML.createTextNode

XML.createTextNode

Синтаксис

myXML.createTextNode(text);

Аргументы

text Текст, используемый для создания нового текстового узла.

Описание

Метод; создает новый текстовый узел XML с указанным текстом. Новый узел первоначально не имеет никакого родителя и текстовые узлы не могут иметь дочерние записи. Этот метод возвращает ссылку на объект XML, представляющий новый текстовый узел. Этот метод и createElement - методы конструктора для создания узлов для объекта XML.

Player

Flash 5 или выше.


XML.docTypeDecl

X-Z > XML.docTypeDecl

XML.docTypeDecl

Синтаксис

myXML.XMLdocTypeDecl;

Аргументы

Нет.

Описание

Свойство; устанавливает и возвращает информацию об объявлении DOCTYPE документа XML. После анализа текста XML в объекте XML, свойство XML.docTypeDecl объекта XML устанавливается в текст объявления DOCTYPE документа XML. Например,

<!DOCTYPE greeting SYSTEM hello.dtd">.

Это свойство установлено используя текстовое представление объявления DOCTYPE, не является узлом объекта XML.

Синтаксический анализатор ActionScript XML не является анализатором достоверности. Объявление DOCTYPE читается синтаксическим анализатором и сохраняется в свойсте docTypeDecl, но никакая проверка правильности DTD не выполняется.

Если в течение операции синтаксического анализа не попалось никакого объявления DOCTYPE, XML.docTypeDecl устанавливается в неопределенный. XML.toString выводит содержимое XML.docTypeDecl немедленно после XML объявления, сохраненного в XML.xmlDecl и перед любым другим текстом в объекте XML. Если XML.docTypeDecl неопределен, никакое DOCTYPE объявление не выводится.

Player

Flash 5 или выше.

Пример

Следующий пример использует XML.docTypeDecl, чтобы установить DOCTYPE объявление для объекта XML.

myXML.docTypeDecl = "<!DOCTYPE greeting SYSTEM \"hello.dtd\">";

Смотрите также


XML.firstChild

X-Z > XML.firstChild

XML.firstChild

Синтаксис

myXML.firstChild;

Аргументы

Нет.

Описание

Свойство (только чтение); определяет заданный XML объект и указывает на первый объект в списке подчиненных объектов родительского узла. Это свойство принимает значение null, если родительский узел не имеет подчиненных объектов. Это свойство неопределенно, если узел является текстовым узлом. Это свойство только для чтения, поэтому оно не может применяться для управления подчиненными объектами, используйте для этих целей методы appendChild, insertBefore и removeNode.

Player

Flash 5 или выше.

Смотрите также


XML.haschildNodes

X-Z > XML.haschildNodes

XML.haschildNodes

Синтаксис

myXML.hasChildNodes();

Аргументы

Нет.

Описание

Метод; определяет указанный объект XML и возвращает true, если существуют подчиненные объекты, иначе возвращает false.

Player

Flash 5 или выше.

Пример

Следующий пример использует информацию из объекта XML в определенной пользователем функции:

if (rootNode.hasChildNodes()) {
    myfunc (rootNode.firstChild);
}


XML.insertBefore

X-Z > XML.insertBefore

XML.insertBefore

Синтаксис

myXML.insertBefore(childNode, beforeNode);

Аргументы

childNode Вставляемый узел.

beforeNode Узел, перед которым будет вставлен childNode.

Описание

Метод; вставляет новый подчиненный узел в список подчиненных узлов объекта XML, перед beforeNode.

Player

Flash 5 или выше.


XML.lastChild

X-Z > XML.lastChild

XML.lastChild

Синтаксис

myXML.lastChild;

Аргументы

Нет.

Описание

Свойство (только чтение); определяет заданный XML объект и указывает на последний объект в списке подчиненных объектов родительского узла. Это свойство принимает значение null, если родительский узел не имеет подчиненных объектов. Это свойство только для чтения, поэтому оно не может применяться для управления подчиненными объектами, используйте для этих целей методы appendChild, insertBefore и removeNode.

Player

Flash 5 или выше.

Смотрите также


XML.load

X-Z > XML.load

XML.load

Синтаксис

myXML.load(url);

Аргументы

url URL (ссылка) XML документа, который нужно загрузить. URL должен быть в том же поддомене, в котором находится текущий клип.

Описание

Метод; загружает XML документ с определенного адреса и замещает содержимое указанного объекта XML новыми загруженными данными XML. Процесс загрузки является асинхронным, он не заканчивается сразу после выполнения метода load. Когда метод load выполнен, свойство loaded объекта XML устанавливается в false. По окончании загрузки данных XML, свойство loaded устанавливается в true и выполняется метод onLoad. Данные XML не анализируются, пока они полностью не загружены. Если объект XML содержал любую древовидную структуру XML, она будет удалена.

Можно определить вашу собственную функцию повторного вызова на месте метода onLoad.

Player

Flash 5 или выше.

Пример

Ниже приведен простой пример, использующий XML.load:

doc = new XML();
doc.load ("theFile.xml");

Смотрите также


+= (addition assignment)

Операторы > += (addition assignment)

+= (назначение сложения)

Синтаксис

expression1 += expression2

Аргументы

expression1, expression2 Целые, числа с плавающей запятой или строки.

Описание

Оператор; присваивает expression1 значение expression1 + expression2. Этот оператор также выполняет объединение строк.

Player

Flash 4 или более поздней версии.

Пример

Это пример числового использования оператора +=:

x += y это то же, что и x = x + y

если x = 5 и y = 10, то

>x += 10 вернёт 15

Это пример использования оператора += со строковым выражением:

x = "My name is"
x += "Mary"

Результат этого кода будет следующим:

"My name is Mary"

Также смотри

+ (addition)


XML.loaded

X-Z > XML.loaded

XML.loaded

Синтаксис

myXML.loaded;

Аргументы

Нет.

Описание

Свойство (только чтение); определяет, завершен ли процесс загрузки документа, инициализированный запросом XML.load. Если процесс загрузки завершен полностью, метод возвращает true, в противном случае - false.

Player

Flash 5 или выше.

Пример

Следующий пример использует XML.loaded в простой команде.

if (doc.loaded) {
    gotoAndPlay(4)
}


XML.nextSibling

X-Z > XML.nextSibling

XML.nextSibling

Синтаксис

myXML.nextSibling;

Аргументы

Нет.

Описание

Свойство (только для чтения); оценивает объект XML и ссылки следующего брата в дочернем списке родительского узла. Этот метод возвращает null, если узел не имеет следующего братского узла. Это свойство только для чтения и не может использоваться для управления дочерними вершинами. Используйте методы appendChild, insertBefore и removeNode для управления дочерними узлами.

Player

Flash 5 или выше.

Смотрите также


XML.nodeName

X-Z > XML.nodeName

XML.nodeName

Синтаксис

myXML.nodeName;

Аргументы

Нет.

Описание

Свойство; получает или возвращает имя узла объекта XML. Если объект XML есть XML элемент (nodeType == 1), nodeName это имя тега, представляющего узел в файле XML. Например, TITLE является nodeName HTML-тега TITLE. Если объект XML является текстовым узлом (nodeType == 3), nodeName принимает значение null.

Player

Flash 5 или выше.

Смотрите также

XML.nodeType


XML.nodeType

X-Z > XML.nodeType

XML.nodeType

Синтаксис

myXML.nodeType;

Аргументы

Нет.

Описание

Свойство (только чтение); получает или возвращает значение nodeType, где 1 - элемент XML и 3 - текстовый узел.

Player

Flash 5 или выше.

Смотрите также

XML.nodeValue


XML.nodeValue

X-Z > XML.nodeValue

XML.nodeValue

Синтаксис

myXML.nodeValue;

Аргументы

Нет.

Описание

Свойство; возвращает значение узла объекта XML. Если объект XML является текстовым узлом, nodeType имеет значение 3, а nodeValue принимает значение текста узла. Если объект XML является элементом XML, он имеет null nodeValue и свойство используется только для чтения.

Player

Flash 5 или выше.

Смотрите также

XML.nodeType


XML.onLoad

X-Z > XML.onLoad

XML.onLoad

Синтаксис

myXML.onLoad(success);

Аргументы

success Булево значение, указывающее, был ли объект XML успешно загружен операцией XML.load или XML.sendAndLoad.

Описание

Метод; вызывается Flash Player'ом, когда XML документ загружен с сервера. Если документ XML загружен успешно, аргумент success принимает значение true. Если документ не загружен или произошла ошибка подключения к серверу, аргумент success принимает значение false. Заданная по умолчанию реализация этого метода не активна. Чтобы отменить действие по умолчанию, Вы должны назначить функцию, содержащую ваши собственные команды.

Player

Flash 5 или выше.

Пример

Следующий пример создает простой клип для простого приложения веб-магазина. Мы используем метод sendAndLoad для передачи XML элемента, содержащего имя пользователя и пароль, и устанавливаем обработчик onLoad, чтобы проверить ответ от сервера.

var myLoginReply = new XML();
myLoginReply.onLoad = myOnLoad;
myXML.sendAndLoad("http://www.samplestore.com/login.cgi",
                        myLoginReply);
function myOnLoad(success) {
    if (success) {
        if (e.firstChild.nodeName == "LOGINREPLY" &&
                e.firstChild.attributes.status == "OK") {
            gotoAndPlay("loggedIn")
        } else {
            gotoAndStop("loginFailed")
        }
    } else {
        gotoAndStop("connectionFailed")
    }
}

Смотрите также


XML.parentNode

X-Z > XML.parentNode

XML.parentNode

Синтаксис

myXML.parentNode;

Аргументы

Нет.

Описание

Свойство (только чтение); ссылается на родительский узел указанного объекта XML или возвращает null, если у узла нет родителя. Это свойство только для чтения и оно не может быть использовано для управления подчиненными узлами, для этих целей используйте методы appendChild, insertBefore и removeNode.

Player

Flash 5 или выше.


XML.parseXML

X-Z > XML.parseXML

XML.parseXML

Синтаксис

myXML.parseXML(source);

Аргументы

source XML текст, который нужно проанализировать и передать определенному XML объекту.

Описание

Метод; анализирует текст XML, указанный в аргументе source и вставляет указанный объект XML в XML дерево. Любые существующие деревья в объекте XML будут отвергнуты.

Player

Flash 5 или выше


XML.previousSibling

X-Z > XML.previousSibling

XML.previousSibling

Синтаксис

myXML.previousSibling;

Описание

Свойство (только для чтения); оценивает объект XML и ссылки на предыдущего брата в дочернем списке родительского узла. Возвращает null, если узел не имеет предыдущего братского узла. Это свойство только для чтения и не может быть использовано, чтобы управлять дочерними узлами, используйте методы appendChild, insertBefore и removeNode для управления дочерними узлами.

Player

Flash 5 или выше.


XML.removeNode

X-Z > XML.removeNode

XML.removeNode

Синтаксис

myXML.removeNode();

Аргументы

Нет.

Описание

Метод; удаляет указанный объект XML из его родителя.

Player

Flash 5 или выше.


< (less than)

Операторы > < (less than)

< (меньше чем)

Синтаксис

expression1 < expression2

Аргументы

expression1, expression2 Числа или строки.

Описание

Оператор (сравнения); сравнивает два выражения и определяет, меньше ли expression1 чем expression2 (true), или expression1 больше или равно expression2 (false). Строчные выражения оцениваются и сравниваются на основе числа знаков в строке.

Player

Flash 4; Flash 5 or later. In Flash 5 < is a comparison operator capable of handling various data types. In Flash 4 < is an numeric operator. Flash 4 files brought into the Flash 5 authoring environment undergo a conversion process to maintain data type integrity. The first example below illustrates the conversion process.

Flash 4, 5, или более поздней версии. В пятой версии, < - это оператор, работающий с данными различных типов. В четвертой версии, < - это числовой оператор. Файлы Flash 4, будучи перенесёнными в среду Flash 5, подвергаются преобразованию, с целью сохранить целостность типа данных. Первый из нижеприведённых примеров показывает процесс конвертации.

Пример

Это пример преобразования файла Flash 4, содержащего числовое качественное сравнение.

Файл Flash 4:

x < y

Преобразованный файл Flash 5:

Number(x) < Number(y)

Ниже примеры, показывающие возврат true и false для чисел и строк:

3 < 10 или "Al" < "Jack" возвращает true

10 < 3 или "Jack" < "Al" возвращает false


XML.send

X-Z > XML.send

XML.send

Синтаксис

myXML.send(url);
myXML.send(url, window);

Аргументы

url Адрес URL для указанного объекта XML.

window Окно броузера для отображения данных, возвращенных сервером: _self указывает на текущий фрейм текущего окна, _blank указывает новое окно, _parent указывает на родителя текущего фрейма и _top указывает на фрейм верхнего уровня текущего окна.

Описание

Метод; кодирует указанный объект XML в документ XML и посылает его на указанный адрес URL, используя метод POST.

Player

Flash 5 или выше.


XML.sendAndLoad

X-Z > XML.sendAndLoad

XML.sendAndLoad

Синтаксис

myXML.sendAndLoad(url,targetXMLobject);

Аргументы

url Адресат URL для указанного объекта XML. URL должен быть в том же поддомене, что и URL, откуда был загружен клип.

targetXMLobject Объект XML, созданный конструктивным методом XML, который будет принимать и отправлять информацию на(с) сервер(а).

Описание

Метод; Кодирует указанный объект XML в документ XML, посылает его на указанный URL, используя метод POST, загружает ответ сервера и тогда передает его в targetXMLobject, указанный в аргументе. Ответ сервера загружается тем же самым способом, который используется в методе load.

Player

Flash 5 или выше.

Смотрите также

XML.load


XML.status

X-Z > XML.status

XML.status

Синтаксис

myXML.status;

Аргументы

Нет.

Описание

Свойство; автоматически устанавливает и возвращает числовое значение, указывающее, успешно ли был проведен синтаксический анализ документа XML в объекте XML. Ниже приведен список числовых кодов состояния и описание каждого:

0 Нет ошибок; Синтаксический анализ закончен успешно
-2 Раздел CDATA не был закончен должным образом.
-3 Объявление XML не было закончено должным образом.
-4 Объявление DOCTYPE не было закончено должным образом.
-5 Комментарий не был закончен должным образом.
-6 XML элемент неверен.
-7 Не хватает памяти.
-8 Значение атрибута не было закончено должным образом.
-9 Тег начала не был согласован с конечным тегом.
-10 Конечный тег указан без соответствующего начального тега.

Player

Flash 5 или выше.


XML.toString

X-Z > XML.toString

XML.toString

Синтаксис

myXML.toString();

Аргументы

Нет.

Описание

Метод; оценивает указанный объект XML, строит тестовое представление структуры XML включая узел, дочерние записи и атрибуты, и возвращает результат как строку.

Для объектов XML верхнего уровня (созданных конструктором), XML.toString выводит объявление документа XML (сохраненное в XML.xmlDecl), объявление DOCTYPE (сохраненное в XML.docTypeDecl) и текстовое представление всех XML узлов в объекте. XML объявление не выводится, если XML.xmlDecl неопределен. DOCTYPE объявление не выводится, если XML.docTypeDecl неопределен.

Player

Flash 5 или выше.

Пример

Следующий код является примером использования метода XML.toString:

node = new XML("<h1>test</h1>");
trace(node.toString());
sends
<H1>test</H1>
to the output window

Смотрите также


XML.xmlDecl

X-Z > XML.xmlDecl

XML.xmlDecl

Синтаксис

myXML.xmlDecl;

Аргументы

Нет.

Описание

Свойство; устанавливает и возвращает информацию относительно XML объявления. После того, как документ XML проанализирован в объекте XML, это свойство устанавливается, используя объявление документа XML. Это свойство устанавливается в строковое представление объявления XML, а не в объект узла XML. Если во время операции синтаксического анализа не было никаких объявлений XML, свойство неопределено. XML.toString выводит содержимое XML.xmlDecl перед любым другим текстом в объекте XML. Если XML.xmlDecl содержит тип undefined (неопределенный), никакое объявление XML не выводится.

Player

Flash 5 или выше.

Пример

Следующий пример использует XML.xmlDecl для того, чтобы установить объявление документа XML для XML объекта:

myXML.xmlDecl = "<?xml version=\"1.0\" ?>";

Смотрите также


XMLSocket (object)

X-Z > XMLSocket (object)

XMLSocket (object)

Объект XMLSocket осуществляет связь компьютера, на котором запущен Flash Player, с сервером, идентифицируя его по IP адресу или по доменному имени.

Использование объекта XMLSocket

Чтобы использовать объект XMLSocket, компьютер-сервер должен запустить "daemon", который понимает протокол объекта XMLSocket. Протоколы следующие:

XML сообщение передается через полное дуплексное потоковое TCP/IP соединение.
Каждое сообщение XML является законченным документом XML, заканчивающееся нулевым байтом.
Неограниченное количество сообщений XML может быть передано и принято за одно соединение XMLSocket.

Объект XMLSocket полезен для клиент-серверных приложений, которые требуют малого времени ожидания, типа чат-систем реального времени. Традиционные чат-системы, основанные на HTTP, часто опрашивают сервер и загружают с него новые сообщения, используя HTTP запрос. Напротив, чат-системы основанные на XMLSocket, поддерживают открытое подключение к серверу, которое позволяет серверу немедленно посылать входящие сообщения без запроса от клиента.

Установка сервера на постоянную связь с объектом XMLSocket может быть нежелательна. Если Ваше приложение не требует интерактивности в реальном времени, используйте loadVariables или XML связь с сервером, основанную на HTTP (XML.load, XML.sendAndLoad, XML.send), вместо объекта XMLSocket.

Для использования методов объекта XMLSocket, сначала необходимо использовать конструктор new XMLSocket, чтобы создать новый объект XMLSocket.

XMLSocket и безопасность

Поскольку объект XMLSocket устанавливает и поддерживает открытое подключение к серверу, из соображений безопасности в объект XMLSocket были помещены следующие ограничения:

Метод XMLSocket.connect может соединиться только с TCP портами, номера которых больше или равны 1024. Одно последствие этого ограничения - то, что серверный "daemons", который связывается с объектом XMLSocket, должен также быть назначен на порт больше или равный 1024. Порты номерами ниже 1024 часто используются системными сервисами, такими как FTP, Telnet и HTTP, поэтому объект XMLSocket не допускается к этим портам. Ограничение номеров портов ограничивает возможность того, что к этим ресурсам будут неуместно обращаться и неправильно эксплуатировать.
Метод XMLSocket.connect может соединиться только с компьютером в том-же поддомене, где расположен файл SWF (клип). Это ограничение не применяется к клипам, выполняемым на локальном диске. (Это ограничение идентично правилам безопасности для loadVariables, XML.sendAndLoad и XML.load.)

Список методов для объекта XMLSocket
Метод | Описание
close | Закрывает открытое сокетное соединение.
connect | Устанавливает связь с указанным сервером.
onClose | Возвратная функция, которая вызывается, когда XMLSocket соединение закрыто.
onConnect | Возвратная функция, которая вызывается, когда XMLSocket соединение установлено.
onXML | Возвратная функция, которая вызывается, когда с сервера прибывает объект XML.
send | Посылает объект XML на сервер.

Конструктор для объекта XMLSocket

Синтаксис

new XMLSocket();

Аргументы

Нет.

Описание

Конструктор; создает новый объект XMLSocket. Объект XMLSocket первоначально не связан ни с каким сервером. Вы должны вызвать метод XMLSocket.connect, чтобы связать объект с сервером.

Player

Flash 5 или выше.

Пример

myXMLSocket = new XMLSocket();

Смотрите также

XMLSocket.connect


XMLSocket.close

X-Z > XMLSocket.close

XMLSocket.close

Синтаксис

myXMLSocket.close();

Аргументы

Нет.

Описание

Метод; закрывает связь, указанную объектом XMLSocket.

Player

Flash 5 или выше.

Смотрите также

XMLSocket.connect


XMLSocket.connect

X-Z > XMLSocket.connect

XMLSocket.connect

Синтаксис

myXMLSocket.connect(host, port);

Аргументы

host Полностью квалифицированное имя домена DNS или адрес IP в виде aaa.bbb.ccc.ddd. Вы также можете указать null, чтобы связаться с сервером, на котором размещен клип.

port Номер TCP порта главного компьютера для установления связи. Номер порта должен быть равен 1024 или выше.

Описание

Метод; устанавливает подключение к указанному хосту Internet, используя указанный порт TCP (должен быть 1024 или выше) и возвращает true или false, в зависимости от того, установилось ли соединение. Если Вы не знаете номер порта Вашего Internet хоста, свяжитесь с Вашим сетевым администратором. Если используется Flash Netscape плагин или ActiveX компонент, хост указанный в аргументе должен иметь тот же поддомен, что и хост, с которого загружен клип.

Если Вы укажете null для аргумента host, произойдет связь с хостом, в котором находиться клип, вызвавший XMLSocket.connect. Например, если клип загружен с http://www.yoursite.com, указать null аргументу host тоже самое, что и ввести IP адрес www.yoursite.com.

Если XMLSocket.connect возвращает значение true, значит начальная стадия процесса подключения прошла успешно, потом метод XMLSocket.onConnect вызывается для того, чтобы определить, успешно ли прошло соединение. Если XMLSocket.connect возвращает false, значит соединение не удалось.

Player

Flash 5 или выше.

Пример

Следующий пример использует XMLSocket.connect для соединения с хостом, на котором он размещен и trace для вывода значения, показывающего успешно ли прошло соединение:

function myOnConnect(success) {
    if (success) {
        trace ("Connection succeeded!")
  } else {
        trace ("Connection failed!")
    }
}
socket = new XMLSocket()
socket.onConnect = myOnConnect
if (!socket.connect(null, 2000)) {
    trace ("Connection failed!")
}

Смотрите также


XMLSocket.onClose

X-Z > XMLSocket.onClose

XMLSocket.onClose

Синтаксис

myXMLSocket.onClose();

Аргументы

Нет.

Описание

Метод; возвращающая функция, которая вызывается только в том случае, если связь закрыта сервером. Заданная по умолчанию реализация этого метода не выполняет никаких действий. Чтобы отменить заданное по умолчанию выполнение, Вы должны назначить функцию, содержащую ваши собственные действия.

Player

Flash 5 или выше.

Смотрите также


XMLSocket.onConnect

X-Z > XMLSocket.onConnect

XMLSocket.onConnect

Синтаксис

myXMLSocket.onConnect(success);

Аргументы

success Булево значение, указывающее, было ли подключение установлено успешно (true или false).

Описание

Метод; возвращающая функция, вызываемая Flash Player, когда запрос подключения, инициализированный через метод XMLSocket.connect удался или потерпел неудачу. Если связь удалась, аргумент success принимает значение true, иначе аргумент success принимает значение false.

Заданная по умолчанию реализация этого метода не выполняет никаких действий. Чтобы отменить заданное по умолчанию выполнение, Вы должны назначить функцию, содержащую ваши собственные действия.

Player

Flash 5 или выше.

Пример

Следующий пример иллюстрирует процесс определения функции замены для метода onConnect в простом чат-приложении.

Функция контролирует, какой экран показать пользователю в зависимости от того, успешно ли прошло подключение. Если соединение состоялось, пользователь получает основной экран чата в кадре с меткой startChat. Если соединение не состоялось, пользователь переходит на экран с информацией о проблеме связи в кадре с меткой connectionFailed.

function myOnConnect(success) {
    if (success) {
        gotoAndPlay("startChat")
    } else {
        gotoAndStop("connectionFailed")
    }
}

После создания объекта XMLSocket с помощью конструктивного метода, скрипт инициализирует метод onConnect с помощью оператора присвоения:

socket = new XMLSocket()
socket.onConnect = myOnConnect

Наконец, подключение инициализировано. Если connect возвращает false, клип направляется прямо на кадр c меткой connectionFailed и onConnect не вызывается. Если connect возвращает true, клип переходит на кадр с меткой waitForConnection, в котором размещен экран "Пожалуйста подождите". Клип остается на кадре waitForConnection, пока не сработает обработчик onConnect, что может произойти через некоторое время, в зависимости от скорости сети.

if (!socket.connect(null, 2000)) {
    gotoAndStop("connectionFailed")
} else {
    gotoAndStop("waitForConnection")
}

Смотрите также


<< (bitwise left shift)

Операторы > << (bitwise left shift)

<< (побитовое смещение влево)

Синтаксис

expression1 << expression2

Аргументы

expression1 Число, строка, или выражение, которое нужно сместить влево.

expression2 Число, строка, или выражение, конвертируемое в целое число от 0 до 31.

Описание

Оператор; конвертирует expression1 и expression2 в 32-битное целое число и смещает все биты expression1 влево в соответствии с числом, получающимся при преобразовании expression2. Освобождённые в результате операции битовые позиции заполняются нулями. Смещение значения на одну позицию влево идентично умножению на 2.

Player

Flash 5 или более поздней версии.

Пример

Это пример смещения целого числа 1 на десять бит влево:

x = 1 << 10

Результат этой операции есть x = 1024. Он таков потому, что десятичное число 1 равняется двоичному числу 1, двоичное число 1, смещённое на 10 бит влево, будет равняться двоичному числу 10000000000, а двоичное число 10000000000 равняется десятичному числу 1024.

Это пример смещения целого числа 7 на 8 бит влево:

x = 7 << 8

Результат этой операции есть x = 1792. Он таков потому, что десятичное число 7 равняется двоичному числу 111, двоичное число 111, смещённое на 8 бит влево, будет равняться двоичному числу 11100000000, а двоичное число 11100000000 равняется десятичному числу 1792.

Смотри также

>>= (bitwise right shift and assignment)


XMLSocket.onXML

X-Z > XMLSocket.onXML

XMLSocket.onXML

Синтаксис

myXMLSocket.onXML(object);

Аргументы

object Экземпляр XML объекта, содержащий анализируемый документ XML, принятый с сервера.

Описание

Метод; возвращающая функция, которая вызывается Flash Player, когда указанный объект XML, содержащий XML документ прибывает через открытую XMLSocket связь. Связь XMLSocket может быть использована для передачи неограниченного числа документов XML между клиентом и сервером. Каждый документ заканчивается нулевым байтом. Когда Flash Player принимает нулевой байт, он анализирует все принятые XML с последнего нулевого байта или с тех пор, как состоялось соединение, если принято первое сообщение. Каждый пакет анализируемого XML обрабатывается, как одиночный документ XML и передается методу onXML.

Заданная по умолчанию реализация этого метода не выполняет никаких действий. Чтобы отменить заданное по умолчанию выполнение, Вы должны назначить функцию, содержащую действия, которые Вы определяете.

Player

Flash 5 или выше.

Пример

Следующая функция отменяет заданное по умолчанию выполнение метода onXML в простом чат-приложении. Функция myOnXML указывает чат-приложению распознавать одиночный элемент XML, MESSAGE, в следующем формате:

<MESSAGE USER="John" TEXT="Hello, my name is John!" />.

Обработчик onXML должен сначала быть установлен в объекте XMLSocket следующим образом:

socket.onXML = myOnXML;

Функция displayMessage применена, чтобы быть определяемой пользователем функцией, которая отображает сообщение, полученное пользователем.

function myOnXML(doc) {
    var e = doc.firstChild;
    if (e != null && e.nodeName == "MESSAGE") {
        displayMessage(e.attributes.user, e.attributes.text);
    }
}

Смотрите также

function


XMLSocket.send

X-Z > XMLSocket.send

XMLSocket.send

Синтаксис

myXMLSocket.send(object);

Аргументы

object Объект XML или другие данные, которые нужно передать на сервер.

Описание

Метод; Преобразует объект XML или данные, указанные в аргументе object в строку и передает это на сервер, сопровождая нулевым байтом. Если object объект XML, строка является текстовым представлением объекта XML. Посылающая операция асинхронная, она возвращается немедленно, но данные могут быть переданы в более позднее время. Метод XMLSocket.send не возвращает значение, указывающее, были ли данные успешно переданы.

Если myXMLSocket не связан с сервером (используя XMLSocket.connect), операция XMLSocket.send не выполнится.

Player

Flash 5 или выше.

Пример

Следующий пример иллюстрирует, как Вы могли определить имя пользователя и пароль, чтобы послать XML объект myXML серверу:

var myXML = new XML();
var myLogin = myXML.createElement("login");
myLogin.attributes.username = usernameTextField;
myLogin.attributes.password = passwordTextField;
myXML.appendChild(myLogin);
myXMLSocket.send(myXML);

Смотрите также

XMLSocket.connect


_xmouse

X-Z > _xmouse

_xmouse

Синтаксис

instancename._xmouse

Аргументы

instancename Имя экземпляра клипа.

Описание

Свойство (только чтение); возвращает координату x указателя мыши.

Player

Flash 5 или выше.

Смотрите также


_xscale

X-Z > _xscale

_xscale

Синтаксис

instancename._xscale
instancename._xscale = percentage;

Аргументы

percentage Процентное значение, определяющее процент для горизонтального масштабирования клипа. Значение по умолчанию - 100.

instancename Имя экземпляра клипа.

Описание

Свойство; определяет горизонтальный масштаб (percentage) клипа, принятый от точки отсчета клипа. По умолчанию точка отсчета есть (0,0).

Масштабирование локальной системы координат воздействует на установки свойств _x и _y, которые определены в пикселах. Например, если родительский клип масштабируется на 50%, установка свойства клипа _x передвинет объект в клипе на половину числа пикселов, как если бы клип был 100%.

Player

Flash 4 или выше.

Смотрите также

_xscale


_y

X-Z > _y

_y

Синтаксис

instancename._y
instancename._y = integer;

Аргументы

integer Локальная y-координата клипа.

instancename Имя экземпляра клипа.

Описание

Свойство; устанавливает y-координату клипа относительно локальных координат родительского клипа. Если клип расположен на главной монтажной линейке, то начало его системы координат (0, 0), находится в верхнем левом углу рабочего окна. Если клип вложен внутрь другого трансформированного клипа, он находится в локальной системе координат родительского клипа. Таким образом, после поворота родительского клипа на 90° против часовой стрелки, его дочерние клипы унаследуют систему координат, повернутую на 90° против часовой стрелки. Координаты клипа относятся к его точке отсчета (registration point).

Player

Flash 3 или выше.

Смотрите также

_yscale


_ymouse

X-Z > _ymouse

_ymouse

Синтаксис

instancename._ymouse

Аргументы

instancename Имя экземпляра клипа.

Описание

Свойство (только чтение); Указывает y-координату позиции мыши.

Player

Flash 5 или выше.

Смотрите также


_yscale

X-Z > _yscale

_yscale

Синтаксис

instancename._yscale
instancename._yscale = percentage;

Аргументы

percentage Процентное значение, определяющее процент для вертикального масштабирования клипа. Значение по умолчанию - 100.

instancename Имя экземпляра клипа.

Описание

Свойство; определяет вертикальный масштаб (percentage) клипа, принятый от точки отсчета клипа. По умолчанию точка отсчета есть (0,0).

Масштабирование локальной системы координат воздействует на установки свойств _x и _y, которые определены в пикселах. Например, если родительский клип масштабируется на 50%, установка свойства клипа _y передвинет объект в клипе на половину числа пикселов, как если бы клип был 100%.

Player

Flash 4 или выше.

Смотрите также


RuFlash

Мейл-Конференция "RuFlash"

Перевод справки к пакету Flash 5 на русский язык сделан силами участников Мейл-Конференции "RuFlash"

Мейл-Конференция "RuFlash" ("RUSSIAN FLASH NEWS") предназначена для оперативного обмена новостями, мнениями между русскоязычными пользователями пакета Macromedia Flash, обсуждения технологии работы в этом и других аналогичных или связанных с ним пакетах и утилитах. Разрешается обсуждение вопросов близких к тематике рассылки или каким либо образом влияющих на развитие и распространение Flash технологии.

Подписчиком конференции может быть любой без каких либо ограничений "житель" Сети, имеющий адрес электронной почты, если он согласен с ее Правилами и соблюдает их при общении с другими подписчиками. Ознакомиться с Правилами конференции и подписаться на нее можно на http://www.vmstudio.com/web-designer/flash/mail-list.asp

Удачи,
VM
Модератор "RuFlash"
Редактор перевода


Help Contents

Краткий обзор
Словарь ActionScript: Краткий обзор
Типовые заголовки для большинства элементов ActionScript
Типовые заголовки для объектов
Содержание словаря

Операторы

A-C

Date

De-I

K-L

Math

Max-Mov

N-R

S

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы
-- (уменьшение)
++ (увеличение)
! (логическое НЕ)
!= (неравенство)
% (модуль)
%= (присваивание модуля)
& (побитовое И)
&& (короткое И)
&= (присваивание побитового И)
() (круглые скобки)
- (минус)
* (умножение)
*= (присвоение умножения)
, (запятая)
. (точка)
?: (импликация)
/ (деление)
// (комментарий)
/* (ограничитель комментария)
/= (назначение деления)
[] (оператор доступа к массиву)
^ (побитовое исключающее ИЛИ)
^= (присвоение побитового исключающего ИЛИ)
{} (инициализатор объектов)
| (побитовое ИЛИ)
|| (ИЛИ)
|= (назначение побитового ИЛИ)
~ (побитовое НЕ)
+ (сложение)
+= (назначение сложения)
< (меньше чем)
<< (побитовое смещение влево)
<<= (побитовое смещение влево и присвоение)
<= (меньше чем или равно)
<> (неравенство)
= (присвоение)
-= (присвоение отрицания)
== (равенство)
> (больше чем)
>= (больше или равно)
>> (побитовое смещение вправо)
>>= (побитовое смещение вправо и присвоение)
>>> (побитовое смещение вправо без знака)
>>>= (побитовое смещение вправо без знака и присвоение)

A-C

Date

De-I

K-L

Math

Max-Mov

N-R

S

T-W

X-Z

Выходные данные справки


<<= (bitwise left shift and assignment)

Операторы > <<= (bitwise left shift and assignment)

<<= (побитовое смещение влево и присвоение)

Синтаксис

expression1 <<= expression2

Аргументы

expression1 Число, строка, или выражение, которые нужно сместить влево.

expression2 Число, строка, или выражение, конвертируемые в целое число от 0 до 31.

Описание

Оператор; производит побитовый сдвиг влево и сохраняет содержимое, как результат в expression1.

Player

Flash 5 или более поздней версии.

Пример

Два следующих выражения эквивалентны:

A <<= B
A = (A << B)

Смотри также


Help Contents

Краткий обзор

Операторы

A-C
add
_alpha
and
Array (object)
Array.concat
Array.join
Array.length
Array.pop
Array.push
Array.reverse
Array.shift
Array.slice
Array.sort
Array.splice
Array.toString
Array.unshift
Boolean (function)
Boolean (object)
Boolean.toString
Boolean.valueOf
break
call
chr
Color (object)
Color.getRGB
Color.getTransform
Color.setRGB
Color.setTransform
continue
_currentframe

Date

De-I

K-L

Math

Max-Mov

N-R

S

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date
Date (object)
Date.getDate
Date.getDay
Date.getFullYear
Date.getHours
Date.getMilliseconds
Date.getMinutes
Date.getMonth
Date.getSeconds
Date.getTime
Date.getTimezoneOffset
Date.getUTCDate
Date.getUTCDay
Date.getUTCFullYear
Date.getUTCHours
Date.getUTCMilliseconds
Date.getUTCMinutes
Date.getUTCMonth
Date.getUTCSeconds
Date.getYear
Date.setDate
Date.setFullYear
Date.setHours
Date.setMilliseconds
Date.setMinutes
Date.setMonth
Date.setSeconds
Date.setTime
Date.setUTCDate
Date.setUTCFullYear
Date.setUTCHours
Date.setUTCMilliseconds
Date.setUTCMinutes
Date.setUTCMonth
Date.setUTCSeconds
Date.setYear
Date.toString
Date.UTC

De-I

K-L

Math

Max-Mov

N-R

S

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I
delete
do... while
_droptarget
duplicateMovieClip
else
eq (строковое равенство)
escape
eval
evaluate
_focusrect
for
for..in
_framesloaded
fscommand
function
ge (больше или равно для строк)
getProperty
getTimer
getURL
getVersion
gotoAndPlay
gotoAndStop
gt (больше для строк)
_height
_highquality
if
ifFrameLoaded
#include
Infinity
int
isFinite
isNaN

K-L

Math

Max-Mov

N-R

S

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I

K-L
Key (object)
Key.BACKSPACE
Key.CAPSLOCK
Key.CONTROL
Key.DELETEKEY
Key.DOWN
Key.END
Key.ENTER
Key.ESCAPE
Key.getAscii
Key.getCode
Key.HOME
Key.INSERT
Key.isDown
Key.isToggled
Key.LEFT
Key.PGDN
Key.PGUP
Key.RIGHT
Key.SHIFT
Key.SPACE
Key.TAB
Key.UP
le (less than or equal to — string specific)
length
_level
loadMovie
loadVariables
lt (less than — string specific)

Math

Max-Mov

N-R

S

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I

K-L

Math
Math (object)
Math.abs
Math.acos
Math.asin
Math.atan
Math.atan2
Math.ceil
Math.cos
Math.E
Math.exp
Math.floor
Math.log
Math.LOG2E
Math.LOG10E
Math.LN2
Math.LN10
Math.max
Math.min
Math.PI
Math.pow
Math.random
Math.round
Math.sin
Math.sqrt
Math.SQRT1_2
Math.SQRT2
Math.tan

Max-Mov

N-R

S

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I

K-L

Math

Max-Mov
maxscroll
mbchr
mblength
mbord
mbsubstring
Mouse (object)
Mouse.hide
Mouse.show
MovieClip (object)
MovieClip.attachMovie
MovieClip.duplicateMovieClip
MovieClip.getBounds
MovieClip.getBytesLoaded
MovieClip.getBytesTotal
MovieClip.getURL
MovieClip.globalToLocal
MovieClip.gotoAndPlay
MovieClip.gotoAndStop
MovieClip.hitTest
MovieClip.loadMovie
MovieClip.loadVariables
MovieClip.localToGlobal
MovieClip.nextFrame
MovieClip.play
MovieClip.prevFrame
MovieClip.removeMovieClip
MovieClip.startDrag
MovieClip.stop
MovieClip.stopDrag
MovieClip.swapDepths
MovieClip.unloadMovie

N-R

S

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I

K-L

Math

Max-Mov

N-R
_name
NaN
ne (not equal — string specific)
new
newline
nextFrame
nextScene
not
null
Number (function)
Number (object)
Number.MAX_VALUE
Number.MIN_VALUE
Number.NaN
Number.NEGATIVE_INFINITY
Number.POSITIVE_INFINITY
Number.toString
Number.valueOf
Object (object)
Object.toString
Object.valueOf
onClipEvent
on(mouseEvent)
or
ord
_parent
parseFloat
parseInt
play
prevFrame
prevScene
print
printAsBitmap
_quality
random
removeMovieClip
return
_root
_rotation

S

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I

K-L

Math

Max-Mov

N-R

S
scroll
Selection (object)
Selection.getBeginIndex
Selection.getCaretIndex
Selection.getEndIndex
Selection.getFocus
Selection.setFocus
Selection.setSelection
set
setProperty
Sound (object)
Sound.attachSound
Sound.getPan
Sound.getTransform
Sound.getVolume
Sound.setPan
Sound.setTransform
Sound.setVolume
Sound.start
Sound.stop
_soundbuftime
startDrag
stop
stopAllSounds
stopDrag
String (function)
" " (string delimiter)
String (object)
String.charAt
String.charCodeAt
String.concat
String.fromCharCode
String.indexOf
String.lastIndexOf
String.length
String.slice
String.split
String.substr
String.substring
String.toLowerCase
String.toUpperCase
substring

T-W

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I

K-L

Math

Max-Mov

N-R

S

T-W
_target
targetPath
tellTarget
this
toggleHighQuality
_totalframes
trace
typeof
unescape
unloadMovie
updateAfterEvent
_url
var
_visible
void
while
_width
with

X-Z

Выходные данные справки


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I

K-L

Math

Max-Mov

N-R

S

T-W

X-Z
_x
XML (object)
XML.appendChild
XML.attributes
XML.childNodes
XML.cloneNode
XML.createElement
XML.createTextNode
XML.docTypeDecl
XML.firstChild
XML.haschildNodes
XML.insertBefore
XML.lastChild
XML.load
XML.loaded
XML.nextSibling
XML.nodeName
XML.nodeType
XML.nodeValue
XML.onLoad
XML.parentNode
XML.parseXML
XML.previousSibling
XML.removeNode
XML.send
XML.sendAndLoad
XML.status
XML.toString
XML.xmlDecl
XMLSocket (object)
XMLSocket.close
XMLSocket.connect
XMLSocket.onClose
XMLSocket.onConnect
XMLSocket.onXML
XMLSocket.send
_xmouse
_xscale
_y
_ymouse
_yscale

Выходные данные справки


<= (less than or equal to)

Операторы > <= (less than or equal to)

<= (меньше чем или равно)

Синтаксис

expression1 <= expression2

Аргументы

expression1, expression2 Число или строки.

Описание

Оператор сравнивает два выражения и определяет, expression1 меньше чем или равно expression2 (true), или больше (false).

Player

Flash 4, 5, или более поздней версии. В пятой версии, <= является оператором сравнения, работающим с различными типами данных. В четвертой версии <= является числовым оператором. Файлы Flash 4, перенесённые в рабочую среду Flash 5 преобразуются для сохранения целостности типа данных. Первый из нижеприведённых примеров показывает процесс преобразования.

Пример

Это пример преобразования файла Flash 4, содержащего числовое качественное сравнение.

Файл Flash 4:

x <= y

Преобразованный файл Flash 5:

Number(x) <= Number(y)

Следующий пример показывает возврат true и false для чисел и строк:

5 <= 10 или "Al" <= "Jack" возвращает true

10<= 5 или "Jack" <= "Al" возвращает false


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I

K-L

Math

Max-Mov

N-R

S

T-W

X-Z

Выходные данные справки
Мейл-конференция "RuFlash"


Help Contents

Краткий обзор

Операторы

A-C

Date

De-I

K-L

Math

Max-Mov

N-R

S

T-W

X-Z

Выходные данные справки


Sample entry for objects

Краткий обзор > Типовые заголовки для объектов

Типовые заголовки для объектов

В следующих примерах типовых заголовков объясняются принятые соглашения для предопределённых объектов ActionScript. Объекты перечислены в алфавитном порядке наряду с другими элементами словаря.

Заголовок статьи

Заголовок статьи - это имя объекта. За ним следует параграф, содержащий общую информацию об объекте.

Сводные таблицы методов и свойств

Каждая статья с описанием объекта содержит таблицу со всеми методами, относящимися к объекту. Если объект имеет свойства (часто константы), то эти элементы приводятся в дополнительной таблице. Все методы и свойства, приводимые в таких таблицах, также имеют свои собственные словарные статьи, которые следуют за статьей с описанием объекта.

Конструктор

Если объект, для получения доступа к его свойствам и методам, требует использования конструктора, он описывается в конце статьи. Это описание включает все стандартные элементы других словарных статей (синтаксис, описание и др.)

Список методов и свойств

Методы и свойства объекта приведены в алфавитном порядке после статьи с описанием объекта.


<> (inequality)

Операторы > <> (inequality)

<> (неравенство)

Синтаксис

expression1 <> expression2

Аргументы

expression1, expression2 Числа, строки, булевы значения, переменные, объекты, массивы или функции.

Описание

Оператор (сравнения); противоположность оператору ==. Если expression1 равно expression2, то результат false. Также как и при использовании оператора ==, процесс определения зависит от типов сравниваемых данных:

Числа, строки, булевы значения сравниваются по значению.
Переменные, объекты, массивы и функции сравниваются по содержанию.

Этот оператор в 5 версии Flash неэффективен. Рекомендуется пользоваться новым оператором !=.

Player

Flash 2 или более поздней версии.

Смотри также

!= (inequality)


= (assignment)

Операторы > = (assignment)

= (присвоение)

Синтаксис

expression1 = expression2

Аргументы

expression1 Переменная, элемент массива или свойство объекта.

expression2 Любое значение.

Описание

Оператор (присваивания); присваивает тип expression2 (аргумент справа) переменной, элементу массива или свойству в expression1.

Player

Flash 4, 5, или более поздней версии. В пятой версии, = является оператором присвоения, а оператор == используется для оценки равенства. В четвертой версии = является числовым качественным оператором. Файлы Flash 4, перенесённые в рабочую среду Flash 5 преобразуются для сохранения целостности типа данных. Первый из нижеприведённых примеров показывает процесс преобразования.

Пример

Это пример, показывающий процесс преобразования файла flash 4, содержащего числовое качественное сравнение.

Файл Flash 4:

x = y

Преобразованный файл Flash 5:

Number(x) == Number(y)

Ниже показано, как использовать оператор для присвоения числа типа данных переменной x:

x = 5

Следующий пример показывает, как использовать оператор для присвоения строки типа данных переменной x:

x = "hello"


-= (negation assignment)

Операторы > -= (negation assignment)

-= (присвоение отрицания)

Синтаксис

expression1 -= expression2

Аргументы

expression1, expression2 Целые числа, числа с плавающей запятой или строки.

Описание

Оператор (присваивания); присваивает expression1 значение expression1 - expression2.

Player

Flash 4 или более поздней версии.

Пример

Это пример использования оператора -= с переменными и числами:

x -= y это то же, что и x = x - y

если x = 5 и y = 10 , то

x -= 10 вернёт -5


== (equality)

Операторы > == (equality)

== (равенство)

Синтаксис

expression1 == expression2

Аргументы

expression1,expression2 Числа, строки, булевы значения, переменные, объекты, массивы или функции.

Описание

Оператор (эквивалентности); проверяет два выражения на равенство. Результат true, если выражения равны.

Определение равенства зависит от типа данных аргумента:

Числа, строки, булевы значения сравниваются по значению и считаются равными, если имеют одно и то же значение. Например, две строки равны, если они содержат одинаковое число символов.
Переменные, объекты, массивы и функции сравниваются по содержанию. Две переменные равны, если они ссылаются на один и тот же объект, массив или функцию. Две отдельных массива никогда не считаются равными, даже если они имеют одинаковое число элементов.

Player

Flash 5 или более поздней версии.

Пример

Вот пример использования оператора == с оператором if:

a = "David" , b = "David";
if (a == b){
trace("David is David");
}


> (greater than)

Операторы > > (greater than)

> (больше чем)

Синтаксис

expression1 > expression2

Аргументы

expression1, expression2 Целые числа, числа с плавающей запятой, строки.

Описание

Оператор (равнения); сравнивает два выражения и определяет больше ли expression1 чем expression2 (true) или меньше (false) или равно (false).

Player

Flash 4, 5, или более поздней версии. В пятой версии, > является оператором сравнения, работающим с различными типами данных. В четвертой версии > является числовым оператором. Файлы Flash 4, перенесённые в рабочую среду Flash 5 преобразуются для сохранения целостности типа данных. Приведённый ниже пример показывает процесс преобразования.

Пример

Этот пример показывает процесс преобразования файла Flash 4, содержащего числовое качественное сравнение.

Файл Flash 4:

x > y

Преобразованный файл Flash 5:

Number(x) > Number(y)


>= (greater than or equal to)

Операторы > >= (greater than or equal to)

>= (больше или равно)

Синтаксис

expression1 >= expression2

Аргументы

expression1, expression2 Строки, целые числа, числа с плавающей запятой.

Описание

Оператор (сравнения); сравнивает два выражения и определяет больше ли expression1 чем expression2 (true), равно ли expression2 (true), или меньше (false).

Player

Flash 4, 5, или более поздней версии. В пятой версии, >= является оператором сравнения, работающим с различными типами данных. В четвертой версии >= является числовым оператором. Файлы Flash 4, перенесённые в рабочую среду Flash 5 преобразуются для сохранения целостности типа данных. Ниже приведён пример, показывающий процесс преобразования.

Пример

Этот пример показывает процесс преобразования файла Flash 4, содержащего числовое качественное сравнение.

Файл Flash 4:

x >= y

Преобразованный файл Flash 5:

Number(x) >= Number(y)


>> (bitwise right shift)

Операторы > >> (bitwise right shift)

>> (побитовое смещение вправо)

Синтаксис

expression1 >> expression2

Аргументы

expression1 Число, строка или выражение, которые нужно сместить вправо.

expression2 Число, строка или выражение, конвертируемые в целое число от 0 до 31.

Описание

Побитовый оператор конвертирует expression1 и expression2 в 32-битное целое число и смещает все биты в expression1 вправо на число разрядов, указанное целым числом, результирующим от преобразования expression2. Биты, смещённые вправо, игнорируются. Чтобы сохранить знак изначального expression, биты слева заполняются нулями, если самый значимый бит (самый левый) expression1 будет нулём, или заполняются единицами, если самый значимый бит будет единицей. Смещение значения вправо на одну позицию эквивалентно делению на 2, пренебрегая остатком.

Player

Flash 5 или более поздней версии.

Пример

Этот пример показывает процесс преобразования числа 65535 в 32-битное целое число и смещение этого числа на восемь битов вправо:

x = 65535 >> 8

Результатом вышеописанной операции будет:

x = 255

Результат таков, потому что десятичное число 65535 равно двоичному числу 1111111111111111 (шестнадцать единиц), двоичное число 1111111111111111, смещённое вправо на восемь бит даст нам двоичное число 11111111, а двоичное число 11111111 равняется десятичному числу 255. Самый значимый бит - 0, так как целые числа 32-битные.

Следующий пример показывает процесс преобразования числа -1 в 32-битное целое число и смещение этого числа на один бит вправо:

x = -1 >> 1

Результатом вышеописанной операции будет:

x = -1

Результат таков, потому что десятичное число -1 равно двоичному числу 11111111111111111111111111111111 (тридцать две единицы). Смещение вправо на один бит заставляет игнорировать наименее значимый бит (самый правый), и заполнить единицей наиболее значимый бит (самый левый). Результатом будет двоичное число 11111111111111111111111111111111 (тридцать две единицы), которое представляет собой 32-битное целое число -1.

Смотри также

>>= (bitwise right shift and assignment)


>>= (bitwise right shift and assignment)

Операторы > >>= (bitwise right shift and assignment)

>>= (побитовое смещение вправо и присвоение)

Синтаксис

expression1 =>>expression2

Аргументы

expression1 Число, строка или выражение, которые необходимо сместить влево.

expression2 Число, строка или выражение, конвертируемые в целое число от 0 до 31.

Описание

Оператор; производит побитовое смещение вправо и записывает содержимое, как результат в expression1.

Player

Flash 5 или более поздней версии.

Пример

Данные два выражения эквивалентны:

A >>= B
A = (A >> B)

Данный закомментированный код использует побитовый оператор >>=. Это также является примером использования всех побитовых операторов.

function convertToBinary(number)
{
var result = "";
for (var i=0; i<32; i++) {
// Extract least significant bit using bitwise AND
var lsb = number & 1;
// Add this bit to our result string
result = (lsb ? "1" : "0") + result;
// Shift number right by one bit, to see next bit
}number >>= 1;
return result;
}
convertToBinary(479)
//Returns the string
00000000000000000000000111011111
//The above string is the binary representation of the decimal number 479.

Смотри также

<< (bitwise left shift)


>>> (bitwise unsigned right shift)

Операторы > >>> (bitwise unsigned right shift)

>>> (побитовое смещение вправо без знака)

Синтаксис

expression1 >>> expression2

Аргументы

expression1 Число, строка или выражение, которые необходимо сместить вправо.

expression2 Число, строка или выражение, конвертируемые в целое число от 0 до 31.

Описание

Этот побитовый оператор ничем не отличается от побитового оператора смещения вправо (>>), кроме знака изначального expression, так как биты слева всегда заполняются нолями.

Player

Flash 5 или более поздней версии.

Пример

Следующий пример показывает процесс преобразования числа -1 в 32-битное целое число и смещение этого числа на один бит вправо:

x = -1 >>> 1

Результатом вышеописанной операции будет:

x = 2147483647

Результат таков, потому что десятичное число -1 равно двоичному числу 11111111111111111111111111111111 (тридцать две единицы). Смещение вправо на один бит без знака заставляет игнорировать наименее значимый бит (самый правый), и заполнить нулём наиболее значимый бит (самый левый). Результатом будет двоичное число 01111111111111111111111111111111, которое представляет собой 32-битное целое число 2147483647.

Смотри также

>>= (bitwise right shift and assignment)


>>>= (bitwise unsigned right shift and assignment)

Операторы > >>>= (bitwise unsigned right shift and assignment)

>>>= (побитовое смещение вправо без знака и присвоение)

Синтаксис

expression1 >>>= expression2

Аргументы

expression1 Число, строка или выражение, которые нужно сместить вправо.

expression2 Число, строка или выражение, преобразуемые в целое число от 0 до 31.

Описание

Оператор; производит побитовое смещение вправо без знака и записывает содержимое, как результат в expression1.

Player

Flash 5 или более поздней версии.

Пример

Следующие два выражения эквивалентны:

A >>>= B
A = (A >>> B)

Смотри также


Contents of the dictionary

Краткий обзор > Содержание словаря

Содержание словаря

Все словарные статьи приведены в алфавитном порядке. Однако, некоторые операторы являются символьными (не буквы) и приведены в виде соответствующих ASCII символов. Кроме того, методы, относящиеся к объектам, приведены вместе с именами этих объектов - например, метод abs объекта "Math", как Math.abs.

Следующие две таблицы помогут вам найти такие элементы. В первой таблице представлены символьные операторы в том порядке, в котором они расположены в словаре, во второй - все другие элементы ActionScript.

Обратите внимание: информацию о старшинстве и ассоциативности операторов см. в приложении А.
Символьные операторы |
-- | (decrement)
++ | (increment)
! | (logical NOT)
!= | (inequality)
% | (modulo)
%= | (modulo assignment)
& | (bitwise AND)
&& | (short-circuit AND)
&= | (bitwise AND assignment)
( ) | (parentheses)
- | (minus)
* | (multiplication)
*= | (multiplication assignment)
, | (comma)
. | (dot)
? : | (conditional)
/ | (division)
// | (comment delimiter)
/* | (comment delimiter)
/= | (division assignment)
[] | (array access)
^ | (bitwise XOR)
^= | (bitwise XOR assignment)
{} | (object initializer)
| | (bitwise OR)
|| | (logical OR)
|= | (bitwise OR assignment)
~ | (bitwise NOT)
+ | (addition)
+= | (addition assignment)
< | (less than)
<< | (bitwise left shift)
<<= | (bitwise left shift and assignment)
<= | (less than or equal to)
<> | (inequality)
= | (assignment)
-= | (negation assignment)
== | (equality)
> | (greater than)
>= | (greater than or equal to)
>> | (bitwise right shift)
>>= | (bitwise right shift and assignment)
>>> | (bitwise unsigned right shift)
>>>= | (bitwise unsigned right shift and assignment)

В следующей таблице приведены все элементы ActionScript, не являющиеся операторами.
Элемент ActionScript | См. статью
abs | Math.abs
acos | Math.acos
add | add
and | and
_alpha | _alpha
appendChild | XML.appendChild
Array | Array (object)
asin | Math.asin
atan | Math.atan
atan2 | Math.atan2
attachMovie | MovieClip.attachMovie
attachSound | Sound.attachSound
attributes | XML.attributes
BACKSPACE | Key.BACKSPACE
Boolean | Boolean (function), Boolean (object)
break | break
call | call
CAPSLOCK | Key.CAPSLOCK
ceil | Math.ceil
charAt | String.charAt
charCodeAt | String.charCodeAt
childNodes | XML.childNodes
chr | chr
cloneNode | XML.cloneNode
close | XMLSocket.close
Color | Color (object)
concat | Array.concat, String.concat
connect | XMLSocket.connect
constructor | Array, Boolean, Color, Date, Number, Object, Sound, String, XML, XMLSocket
continue | continue
CONTROL | Key.CONTROL
cos | Math.cos
createElement | XML.createElement
createTextNode | XML.createTextNode
_currentframe | _currentframe
Date | Date (object)
delete | delete
DELETEKEY | Key.DELETEKEY
docTypeDecl | XML.docTypeDecl
do...while | do... while
DOWN | Key.DOWN
_droptarget | _droptarget
duplicateMovieClip | duplicateMovieClip, MovieClip.duplicateMovieClip
E | Math.E
else | else
END | Key.END
ENTER | Key.ENTER
eq | eq (equal—string specific)
escape (function) | escape
ESCAPE (constant) | Key.ESCAPE
eval | eval
evaluate | evaluate
exp | Math.exp
firstChild | XML.firstChild
floor | Math.floor
_focusrect | _focusrect
for | for
for.. in | for..in
_framesloaded | _framesloaded
fromCharCode | String.fromCharCode
fscommand | fscommand
function | function
ge | ge (greater than or equal to—string specific)
getAscii | Key.getAscii
getBeginIndex | Selection.getBeginIndex
getBounds | MovieClip.getBounds
getBytesLoaded | MovieClip.getBytesLoaded
getBytesTotal | MovieClip.getBytesTotal
getCaretIndex | Selection.getCaretIndex
getCode | Key.getCode
getDate | Date.getDate
getDay | Date.getDay
getEndIndex | Selection.getEndIndex
getFocus | Selection.getFocus
getFullYear | Date.getFullYear
getHours | Date.getHours
getMilliseconds | Date.getMilliseconds
getMinutes | Date.getMinutes
getMonth | Date.getMonth
getPan | Sound.getPan
getProperty | getProperty
getRGB | Color.setRGB
getSeconds | Date.getSeconds
getTime | Date.getTime
getTimer | getTimer
getTimezoneOffset | Date.getTimezoneOffset
getTransform | Color.getTransform, Sound.getTransform
getURL | getURL, MovieClip.getURL
getUTCDate | Date.getUTCDate
getUTCDay | Date.getUTCDay
getUTCFullYear | Date.getUTCFullYear
getUTCHours | Date.getUTCHours
getUTCMilliseconds | Date.getUTCMilliseconds
getUTCMinutes | Date.getUTCMinutes
getUTCMonth | Date.getUTCMonth
getUTCSeconds | Date.getUTCSeconds
getVersion | getVersion
getVolume | Sound.getVolume
getYear | Date.getYear
globalToLocal | MovieClip.globalToLocal
gotoAndPlay | gotoAndPlay, MovieClip.gotoAndPlay
gotoAndStop | gotoAndStop, MovieClip.gotoAndStop
gt | gt (greater than —string specific)
hasChildNodes | XML.haschildNodes
_height | _height
hide | Mouse.hide
_highquality | _highquality
hitTest | MovieClip.hitTest
HOME | Key.HOME
if | if
ifFrameLoaded | ifFrameLoaded
#include | #include
indexOf | String.indexOf
Infinity | Infinity
INSERT | Key.INSERT
insertBefore | XML.insertBefore
int | int
isDown | Key.isDown
isFinite | isFinite
isNaN | isNaN
isToggled | Key.isToggled
join | Array.join
Key | Key (object)
lastChild | XML.lastChild
lastIndexOf | String.indexOf
le | le (less than or equal to — string specific)
LEFT | Key.LEFT
length | length, Array.length, String.length
LN2 | Math.LN2
LN10 | Math.LN10
load | XML.load
loaded | XML.loaded
loadMovie | loadMovie, MovieClip.loadMovie
loadVariables | loadVariables, MovieClip.loadVariables
localToGlobal | MovieClip.localToGlobal
log | Math.log
LOG2E | Math.LOG2E
LOG10E | Math.LOG10E
lt | le (less than or equal to — string specific)
Math | Math (object)
max | Math.max
maxscroll | maxscroll
MAX_VALUE | Number.MAX_VALUE
mbchr | mbchr
mblength | mblength
mbord | mbord
mbsubstring | mbsubstring
min | Math.min
MIN_VALUE | Number.MIN_VALUE
Mouse | Mouse (object)
MovieClip | MovieClip (object)
_name | _name
NaN | NaN, Number.NaN
ne | ne (not equal — string specific)
NEGATIVE_INFINITY | Number.NEGATIVE_INFINITY
new (operator) | new
newline | newline
nextFrame | nextFrame, MovieClip.nextFrame
nextScene | nextScene
nextSibling | XML.nextSibling
nodeName | XML.nodeName
nodeType | XML.nodeType
nodeValue | XML.nodeValue
not | not
null | null
Number | Number (function), Number (object)
Object | Object (object)
On | on(mouseEvent)
onClipEvent | onClipEvent
onClose | XMLSocket.onClose
onConnect | XMLSocket.onConnect
OnLoad | XML.onLoad
onXML | XMLSocket.onXML
or (logical OR) | or
ord | ord
_parent | _parent
parentNode | XML.parentNode
parseFloat | parseFloat
parseInt | parseInt
parseXML | XML.parseXML
PGDN | Key.PGDN
PGUP | Key.PGUP
PI | Math.PI
play | play, MovieClip.play
pop | Array.pop
POSITIVE_INFINITY | Number.POSITIVE_INFINITY
pow | Math.pow
prevFrame | prevFrame, MovieClip.prevFrame
previousSibling | XML.previousSibling
prevScene | prevScene
print | print
printAsBitmap | printAsBitmap
push | Array.push
_quality | _quality
random | random, Math.random
removeMovieClip | removeMovieClip, MovieClip.removeMovieClip
removeNode | XML.removeNode
return | return
reverse | Array.reverse
RIGHT | Key.RIGHT
_root | _root
_rotation | _rotation
round | Math.round
scroll | scroll
Selection | Selection (object)
send | XML.send, XMLSocket.send
sendAndLoad | XML.sendAndLoad
set | set
setDate | Date.setDate
setFocus | Selection.setFocus
setFullYear | Date.setFullYear
setHours | Date.setHours
setMilliseconds | Date.setMilliseconds
setMinutes | Date.setMinutes
setMonth | Date.setMonth
setPan | Sound.setPan
setProperty | setProperty
setRGB | Color.setRGB
setSeconds | Date.setSeconds
setSelection | Selection.setSelection
setTime | Date.setTime
setTransform | Color.setTransform,Sound.setTransform
setUTCDate | Date.setUTCDate
setUTCFullYear | Date.setUTCFullYear
setUTCHours | Date.setUTCHours
setUTCMilliseconds | Date.setUTCMilliseconds
setUTCMinutes | Date.setUTCMinutes
setUTCMonth | Date.setUTCMonth
setUTCSeconds | Date.setUTCSeconds
setVolume | Sound.setVolume
setYear | Date.setYear
shift (method) | Array.shift
SHIFT (constant) | Key.SHIFT
show | Mouse.show
sin | Math.sin
slice | Array.slice, String.slice
sort | Array.sort
Sound | Sound (object)
_soundbuftime | _soundbuftime
SPACE | Key.SPACE
splice | Array.splice
split | String.split
sqrt | Math.sqrt
SQRT1_2 | Math.SQRT1_2
SQRT2 | Math.SQRT2
start | Sound.start
startDrag | startDrag, MovieClip.startDrag
status | XML.status
stop | stop,MovieClip.stop,Sound.stop
stopAllSounds | stopAllSounds
stopDrag | stopDrag, MovieClip.stopDrag
String | String (function), String (object)," " (string delimiter)
substr | String.substr
substring | substring, String.substring
swapDepths | MovieClip.swapDepths
TAB | Key.TAB
tan | Math.tan
_target | _target
targetPath | targetPath
tellTarget | tellTarget
this | this
toggleHighQuality | toggleHighQuality
toLowerCase | String.toLowerCase
toString | Array.toString,Boolean.toString, Date.toString, Number.toString, Object.toString, XML.toString
_totalframes | _totalframes
toUpperCase | String.toUpperCase
trace | trace
typeof | typeof
unescape | unescape
unloadMovie | unloadMovie, MovieClip.unloadMovie
unshift | Array.shift
UP | Key.UP
updateAfterEvent | updateAfterEvent
_url | _url
UTC | Date.UTC
valueOf | Boolean.valueOf, Number.valueOf, Object.valueOf
var | var
_visible | _visible
void | void
while | while
_width | _width
with | with
_x | _x
XML | XML (object)
xmlDecl | XML.xmlDecl
XMLSocket | XMLSocket (object)
_xmouse | _xmouse
_xscale | _xscale
_y | _y
_ymouse | _ymouse
_yscale | _yscale


add

A-C > add

add

Синтаксис

string1 add string2

Аргументы

string1,2 - произвольные строки.

Описание

Оператор; "склеивает" две или более строк. Оператор add заменил оператор & , существовавший в Flash 4; Flash 4 файлы, использующие & оператор, автоматически преобразуются к использованию add оператора для сложения строк при работе в среде Flash 5 Player. Однако не рекомендуется использовать оператор add во Flash 5; вместо него лучше использовать оператор + при работе с Flash 5 Player. Используйте оператор add только в том случае, если вы работаете с Flash Player версии 4 или ниже.

Player

Flash 4 или ниже.

См. также

+ (addition)


_alpha

A-C > _alpha

_alpha

Синтаксис

instancename._alpha
instancename._alpha = value;

Аргументы

instancename Имя экземпляра (образца) муви-клипа.

value Целое число от 0 до 100, определяющее прозрачность.

Описание

Свойство муви-клипа; устанавливает прозрачность (value) муви-клипа. Диапазон от 0 (полная прозрачность) до 100 (полная видимость). Объекты в клипе с установленным _alpha в 0 остаются активными, даже если полностью невидимы. Например, кнопка в мувике с нулевым _alpha преспокойно может быть кликнута.

Player

Flash 4 или ниже.

Пример

Следующий пример показывает, что после клика по кнопке свойство _alpha экземпляра star устанавливается в 30%:

on(release) {
    setProperty(star._alpha = 30);
}

или

on(release) {
    star._alpha = 30;
}


and

A-C > and

and

Синтаксис

condition1 and condition2

Аргументы

condition1,condition2 Условия или выражения, характеризующиеся состояниями true или false.

Описание

Оператор; выполняет логическую операцию AND в Flash 4 Player. Если оба выражения установлены в true, получаем true.

Player

Flash 4 или ниже. Этот оператор не рекомендуется использовать в Flash 5, вместо него используйте новый оператор &&.

См. также

&& (short-circuit AND)


Array (object)

A-C > Array (object)

Array (object)

Объект Array позволяет вам работать с массивами. Объект Array - это объект, чьи свойства идентифицируются порядковым номером, позицией в массиве. Номер этот называют индексом. Первый элемент массива всегда имеет нулевой индекс, второй - [1], третий - [2], и т. д. В следующем примере массив myArray состоит из проиндексированных названий месяцев года.

myArray[0] = "January"

myArray[1] = "February"

myArray[2] = "March"

myArray[3] = "April"

Для создания объекта Array необходимо воспользоваться конструктором new Array. Чтобы получить доступ к отдельному элементу массива, используйте оператор [ ].

Таблица методов объекта Array
Метод | Описание
concat | Соединяет аргументы (последовательности массивов), и возвращает их уже как новый массив.
join | Объединяет элементы массива в строку.
pop | Удаляет последний элемент массива и возвращает его значение.
push | Добавляет один или больше элементов в конец массива и возвращает длину нового массива.
reverse | Выворачивает массив наизнанку, т. е. первый элемент становится последним, второй - предпоследним, и т. д ., и наоборот.
shift | Удаляет первый элемент массива и возвращает его значение.
slice | Извлекает из массива часть и возвращает ее как новый массив.
sort | Сортирует массив.
splice | Добавляет и/или удаляет элементы из массива.
toString | Возвращает значение строки, которую представляют из себя элементы массива.
unshift | Добавляет один или больше элементов в начало массива и возвращает длину нового массива.

Таблица свойств объекта Array
Свойство | Описание
length | Возвращает длину массива.

Конструктор Array объекта

Синтаксис

new Array();
new Array(length);
new Array(element0, element1, element2,...elementN);

Аргументы

length Целое число, равное количеству элементов в массиве. Если элементы не смежные, length равен индексу последнего элемента плюс 1. Для дополнительной информации смотри свойства Array.length.

element0...elementN Список двух или более произвольно выбранных значений. Это могут быть числа, имена или другие элементы. Первый элемент массива всегда имеет индекс, или позицию, равную 0.

Описание

Конструктор; позволяет создать массив и работать с ним. Индексы начинаются с нуля, и растут с ростом порядкового номера элемента.

Если аргументы не определялись, создается нулевой массив.

Player

Flash 5 или выше.

Пример

В этом примере создается нулевой объект Array:

myArray = new Array();

В этом примере создается новый объект Array A-Team, с длиной length равной 4:

A-Team = new Array("Jody", "Mary", "Marcelle", "Judy");

Ниже показана возможная инициализация элементов массива A-Team:

myArray[0] = "Jody"

myArray[1] = "Mary"

myArray[2] = "Marcelle"

myArray[3] = "Judy"

См. также

Array.length


Array.concat

A-C > Array.concat

Array.concat

Синтаксис

myArray.concat(value0,value1,...valueN);

Аргументы

value0,...valueN Числа, элементы массивов или строки, которые должны быть представлены как единый массив.

Описание

Метод; представляет элементы, определенные в качестве аргументов, как новый массив. Если аргументами являются массивы, элементы нового массива располагаются в том же порядке.

Player

Flash 5 или выше.

Пример

В этом примере складываются два массива:

alpha = new Array("a","b","c");
numeric = new Array(1,2,3);
alphaNumeric=alpha.concat(numeric);
// создается массив ["a","b","c",1,2,3]

В этом примере складываются три массива:

num1=[1,3,5];
num2=[2,4,6];
num3=[7,8,9];
nums=num1.concat(num2,num3) // создается массив [1,3,5,2,4,6,7,8,9]


Array.join

A-C > Array.join

Array.join

Синтаксис

myArray.join();
myArray.join(separator);

Аргументы

separator Символ или строка, которая будет отделять друг от друга элементы массива в возвращаемой строке. Если разделитель не указан, по умолчанию будет использоваться запятая.

Описание

Метод; преобразует элементы массива в строку, вставляет между ними символы - разделители, и возвращает ее.

Player

Flash 5 или выше.

Example

В следующем примере создается массив с тремя элементами. Затем элементы объединяются тремя способами: с разделителем по умолчанию, с запятой и пробелом, и со знаком плюс.

a = new Array("Earth","Moon","Sun")
// присваиваем значение "Earth,Moon,Sun" массиву myVar1
myVar1=a.join();
// присваиваем значение "Earth, Moon, Sun" массиву myVar2
myVar2=a.join(", ");
// присваиваем значение "Earth + Moon + Sun" массиву myVar3
myVar3=a.join(" + ");


Array.length

A-C > Array.length

Array.length

Синтаксис

myArray.length;

Аргументы

Нет.

Описание

Свойство; содержит в себе длину массива. Автоматически обновляется, когда элементы добавляются в массив. Допустим, присваиваем myArray[index] = value; если index какой-то номер, и index+1 больше, чем length , свойство length обновится до index + 1.

Player

Flash 5 или выше.

Пример

Ниже поясняется, как обновляется свойство length:

//initial length is 0
myArray = new Array();
//myArray.length обновляется до 1
myArray[0] = 'a';
//myArray.length обновляется до 2
myArray[1] = 'b';
//myArray.length обновляется до 10
myArray[9] = 'c';


Array.pop

A-C > Array.pop

Array.pop

Синтаксис

myArray.pop();

Аргументы

Нет.

Описание

Метод; удаляет последний элемент массива и возвращает его значение.

Player

Flash 5 или выше.

Пример

В примере создается массив myPets, содержащий четыре элемента, а затем последний удаляется:

myPets = ["cat", "dog", "bird", "fish"];
popped = myPets.pop();


Array.push

A-C > Array.push

Array.push

Синтаксис

myArray.push(value,...);

Аргументы

value Одно или несколько значений, добавляемых в массив.

Описание

Метод; добавляет один или больше элементов в конец массива и возвращает длину нового массива.

Player

Flash 5 или выше.

Пример

Создается массив myPets, содержащий два элемента, затем добавляются еще два, после чего pushed содержит 4 элемента.

myPets = ["cat", "dog"];
pushed = myPets.push("bird", "fish");


Array.reverse

A-C > Array.reverse

Array.reverse

Синтаксис

myArray.reverse();

Аргументы

Нет.

Description

Метод; меняет порядок следования элементов на обратный.

Player

Flash 5 или выше.

Пример

Использование метода Array.reverse:

var numbers = [1, 2, 3, 4, 5, 6];
trace(numbers.join());
    numbers.reverse();
    trace(numbers.join());

На выходе:

1,2,3,4,5,6
6,5,4,3,2,1


-- (decrement)

Операторы > -- (decrement)

-- (уменьшение)

Синтаксис

--expression
expression--

Аргументы

expression Переменная, число, элемент в массиве или свойство объекта.

Описание

Оператор; унарный оператор пре- и пост-декремента (уменьшения), вычитающий 1 из expression. Пре-декрементная форма оператора (--expression) вычитает 1 из expression и возвращает результат. Пост-декрементная форма (expression--) вычитает 1 из expression и возвращает первоначальное значение expression (результат до вычитания).

Player

Flash 4 или более поздней версии.

Пример

Пре-декрементная форма оператора уменьшает x до 2 (x - 1 = 2) и возвращает результат, как y:

x = 3;

y = --x

Пост-декрементная форма оператора уменьшает x до 2 (x - 1 = 2) и возвращает первоначальное значение (x = 3), как результат y:

If x = 3;

y = x--


Array.shift

A-C > Array.shift

Array.shift

Синтаксис

myArray.shift();

Аргументы

Нет.

Description

Метод; удаляет первый элемент массива и возвращает его значение.

Player

Flash 5 или выше.

Пример

Создаем массив myPets и удаляем из него первый элемент:

myPets = ["cat", "dog", "bird", "fish"];
shifted = myPets.shift();

Возвращаемое значение равно cat.

См. также


Array.slice

A-C > Array.slice

Array.slice

Синтаксис

myArray.slice(start, end);

Аргументы

start Целое число, определяющее индекс первого в извлекаемом сегменте элемента. Если start отрицательное число, отсчет начинается с конца массива, при этом -1 последний элемент.

end Целое число, определяющее индекс последнего в извлекаемом сегменте элемента. Если оно не указано, сегмент заканчивается на последнем элементе массива. Если end отрицательное число, сегмент заканчивается в конце массива, -1 последний элемент.

Описание

Метод; извлекает из массива часть (сегмент) и возвращает ее как новый массив, оставляя при этом основной массив без изменений. Новый массив включает в себя start элемент, и все элементы до элемента end, не включая его самого.

Player

Flash 5 или выше.


Array.sort

A-C > Array.sort

Array.sort

Синтаксис

myArray.sort();
myArray.sort(orderfunc);

Аргументы

orderfunc Произвольная сравнивающая функция, определяющая порядок сортировки. Учитывая аргументы А и В, указанная функция должна выполнять сортировку следующим образом:

-1 если A появляется прежде чем B в сортируемой последовательности
0 если A = B
1 если A появляется после B в сортируемой последовательности

Описание

Метод; сортирует массив на месте, т.е. без создания копии. Если аргумент orderfunc не указан, Flash сортирует элементы, используя оператор <.

Player

Flash 5 или выше.

Пример

Используем Array.sort без определения аргумента orderfunc:

var fruits = ["oranges", "apples", "strawberries",
                "pineapples", "cherries"];
    trace(fruits.join());
    fruits.sort();
    trace(fruits.join());

Получаем:

oranges,apples,strawberries,pineapples,cherries
apples,cherries,oranges,pineapples,strawberries

Используем Array.sort, определяя аргумент orderfunc:

var passwords = [
   "gary:foo",
   "mike:bar",
   "john:snafu",
   "steve:yuck",
   "daniel:1234"
 ];
 function order (a, b) {
   // Элементы записаны в форме
   // name:password
   // Сортируем, используя в качестве ключа
   // только часть name.
   var name1 = a.split(':')[0];
   var name2 = b.split(':')[0];
   if (name1 < name2) {
     return -1;
   } else if (name1 > name2) {
     return 1;
   } else {
     return 0;
   }
 }
 for (var i=0; i< password.length; i++) {
   trace (passwords.join());
 }
 passwords.sort(order);
 trace ("Sorted:");
 for (var i=0; i< password.length; i++) {
   trace (passwords.join());
 }

Получаем:

daniel:1234
gary:foo
john:snafu
mike:bar
steve:yuck


Array.splice

A-C > Array.splice

Array.splice

Синтаксис

myArray.splice(start, deleteCount, value0,value1...valueN);

Аргументы

start Индекс элемента массива, где начинается добавление/удаление элементов.

deleteCount Количество удаляемых элементов, включающее в себя элемент start. Если deleteCount не задан, метод удаляет все элементы от start до конца массива.

value Вставляемые в массив элементы, начиная с точки start. Не обязателен.

Описание

Метод; добавляет и/или удаляет элементы из массива. Модифицирует массив без создания копии.

Player

Flash 5 или выше.


Array.toString

A-C > Array.toString

Array.toString

Синтаксис

myArray.toString();

Аргументы

Нет.

Описание

Метод; возвращает строку, которая представляет из себя последовательность элементов массива, разделенныx запятыми.

Player

Flash 5 или выше.

Пример

Создаем массив myArray и преобразуем его в строку:

myArray = new Array();
myArray[0] = 1;
myArray[1] = 2;
myArray[2] = 3;
myArray[3] = 4;
myArray[4] = 5;
trace(myArray.toString())

Получаем:

1,2,3,4,5


Array.unshift

A-C > Array.unshift

Array.unshift

Синтаксис

myArray.unshift(value1,value2,...valueN);

Аргументы

value1,...valueN Один или больше элементов, переменных или чисел, вставляемых в начало массива.

Описание

Метод; добавляет один или больше элементов в начало массива и возвращает длину нового массива.

Player

Flash 5 или выше.


Boolean (function)

A-C > Boolean (function)

Boolean (function)

Синтаксис

Boolean(expression);

Аргументы

expression Переменная, число или строка, преобразуемая в тип Boolean.

Описание

Функция; преобразует аргумент в Boolean и возвращает его значение.

Player

Flash 5 или выше.


Boolean (object)

A-C > Boolean (object)

Boolean (object)

Объект Boolean - простейший объект, с теми же сами функциональными возможностями, как и в JavaScript. Используйте объект Boolean, чтобы получить простейший тип данных или строковое представление объекта Boolean.

Таблица методов объекта Boolean
Метод | Описание
toString | Возвращает строковое представление (true) или (false) объекта Boolean.
valueOf | Возвращает значение объекта Boolean.

Конструктор объекта Boolean

Синтаксис

new Boolean();
new Boolean(x);

Аргументы

x Число, строка, Boolean, объект, муви-клип, или другое выражение. Необязательный аргумент.

Описание

Конструктор; создает экземпляр объекта Boolean. Если аргумент x не определен, новый объект Boolean инициализируется как false. Если же x определен, объект Boolean инициализируется на основании следующих правил:

Если x число, функция возвратит true при x отличном от 0, или false если x нулевой.
Если x имеет тип Boolean, функция просто вернет его значение.
Если x - объект или муви-клип, функция вернет true при x отличном от null; иначе вернет false.
Если x - строка, функция вернет true если Number(x) не равен 0; иначе вернет false.

Замечание: Для обеспечения совместимости с Flash 4, при работе со строками не использовать ECMA-262 стандарт.

Player

Flash 5 или выше.


Boolean.toString

A-C > Boolean.toString

Boolean.toString

Синтаксис

Boolean.toString();

Аргументы

Нет.

Описание

Метод; возвращает строковое представление, true или false, булевского объекта.

Player

Flash 5 или выше.


Boolean.valueOf

A-C > Boolean.valueOf

Boolean.valueOf

Синтаксис

Boolean.valueOf();

Аргументы

Нет.

Описание

Метод; возвращает значение заданного объекта Boolean.

Player

Flash 5 или выше.


++ (increment)

Операторы > ++ (increment)

++ (увеличение)

Синтаксис

++expression
expression++

Аргументы

expression Переменная, число, элемент в массиве или свойство объекта.

Описание

Оператор; унарный оператор пре- и пост-инкремента (увеличения), добавляющий 1 к expression. Пре-инкрементная форма оператора (++expression) добавляет 1 к expression и возвращает результат. Пост-инкрементная форма оператора (expression++) добавляет 1 к expression и возвращает первоначальное значение expression (результат перед сложением).

Пре-инкрементная форма оператора увеличивает x до 2 (x + 1 = 2) и возвращает результат, как y:

x = 1;
y = ++x

Пост-инкрементная форма оператора увеличивает x до 2 (x + 1 = 2) и возвращает первоначальное значение (x = 1), как результат y:

x = 1;
y = x++;

Player

Flash 4 или более поздней версии.

Пример

Этот пример использует ++ как пост-инкрементный оператор с выражением while.

i = 0
while(i++ < 5){
// Этот цикл будет повторен 5 раз
}

Этот пример использует ++ как пре-инкрементный оператор:

var a = [];
var i = 0;
while (i < 10) {
    a.push(++i);
}
trace(a.join());

Результат выполнения этого скритпа:

1,2,3,4,5,6,7,8,9,10

Этот пример использует ++ как оператор пост-инкремента:

var a = [];
var i = 0;
while (i < 10) {
a.push(i++);
    }
trace(a.join());

Результат выполнения этого скритпа:

0,1,2,3,4,5,6,7,8,9


break

A-C > break

break

Синтаксис

break;

Аргументы

Нет.

Описание

Команда; используется в циклах (for, for..in, do...while или while). Команда break предписывает Flash-у прервать выполнение цикла и выполнять следующее за циклом выражение. Используйте break при работе с вложенными циклами.

Player

Flash 4 или выше.

Пример

Используем break, чтобы прервать бесконечный цикл:

i = 0;
while (true) {
    if (i >= 100) {
        break;
    }
    i++;
}


call

A-C > call

call

Синтаксис

call(frame);

Аргументы

frame Имя или номер фрейма, где содержится вызываемый скрипт.

Описание

Команда; вызывает из текущего скрипта прикрепленный скрипт - "подпрограмму". Когда его выполнение закончится, локальные переменные уничтожаются.

Player

Flash 4 или выше. В Flash 5 рекомендуется использовать команду function.

См. также

function


chr

A-C > chr

chr

Синтаксис

chr(number);

Аргументы

number ASCII-код для представления его в виде строковой переменной.

Описание

Строковая функция; преобразует ASCII-код в строковую переменную.

Player

Flash 4 или выше. В Flash 5 используйте метод String.fromCharCode.

Пример

Преобразуем ASCII-код 65 в букву "A":

chr(65) = "A"

См. также

String.fromCharCode


Color (object)

A-C > Color (object)

Color (object)

Объект Color позволяет устанавливать и получать RGB-значение цвета муви-клипа и изменять его. Объект Color поддерживается в Flash 5 и более поздними версиями Flash Player.

Прежде чем пользоваться методами Color объекта, необходимо с помощью конструктора new Color() создать экземпляр объекта Color.

Таблица методов объекта Color
Метод | Описание
getRGB | Возвращает значение RGB, установленное последним вызовом setRGB.
getTransform | Возвращает информацию об изменениях, внесенных последним вызовом setTransform.
setRGB | Устанавливает шестнадцатеричное RGB значение для Color объекта.
setTransform | Производит изменения с цветом в Color объекте.

Конструктор объекта Color

Синтаксис

new Color(target);

Аргументы

target Имя муви-клипа, цвет которого хотят изменить.

Описание

Конструктор; создает объект Color для муви-клипа, определенного в качестве аргумента target.

Player

Flash 5 или выше.

Пример

Создаем объект Color по имени myColor для муви-клипа myMovie:

myColor = new Color(myMovie);


Color.getRGB

A-C > Color.getRGB

Color.getRGB

Синтаксис

myColor.getRGB();

Аргументы

Нет.

Описание

Метод; Возвращает значение RGB, установленное последним вызовом setRGB.

Player

Flash 5 или выше.

Пример

Получаем шестнадцатеричное RGB значение в виде строки:

value = (getRGB()).toString(16);

See also

Color.setRGB


Color.getTransform

A-C > Color.getTransform

Color.getTransform

Синтаксис

myColor.getTransform();

Аргументы

Нет.

Описание

Метод; возвращает информацию об изменениях, внесенных последним вызовом setTransform.

Player

Flash 5 или выше.

См. также

Color.setTransform


Color.setRGB

A-C > Color.setRGB

Color.setRGB

Синтаксис

myColor.setRGB(0xRRGGBB);

Аргументы

0xRRGGBB Шестнадцатеричное RGB значение устанавливаемого цвета. Каждая компонента RR, GG, и BB кодируется двумя шестнадцатеричными цифрами.

Описание

Метод; устанавливает шестнадцатеричное RGB значение для Color объекта. Вызов этого метода отменяет все изменения, вызванные последним вызовом setTransform.

Player

Flash 5 или выше.

Пример

Выставляем RGB цвет для муви-клипа myMovie:

myColor = new Color(myMovie);
myColor.setRGB(0x993366);

См. также

Color.setTransform


Color.setTransform

A-C > Color.setTransform

Color.setTransform

Синтаксис

myColor.setTransform(colorTransformObject);

Аргументы

colorTransformObject объект, созданный при помощи конструктора объекта Object, устанавливающий изменения цвета значениями параметров. colorTransformObject имеет параметры ra, rb, ga, gb, ba, bb, aa, ab, значение которых определяется ниже.

Описание

Метод; задает изменение цвет объекта Color. Аргумент colorTransformObject - это объект, созданный конструктором объекта Object, с параметрами, задающими процентное или абсолютное изменение трех цветовых компонент (red, green, blue), и прозрачности alpha, в формате 0xRRGGBBAA.

Параметры объекта colorTransformObject:

ra процентное изменение красной компоненты (-100 to 100).
rb абсолютное изменение красной компоненты (-255 to 255).
ga процентное изменение зеленой компоненты (-100 to 100).
gb абсолютное изменение зеленой компоненты (-255 to 255).
ba процентное изменение синей компоненты (-100 to 100).
bb абсолютное изменение синей компоненты (-255 to 255).
aa процентное изменение прозрачности (-100 to 100).
ab абсолютное изменение прозрачности (-255 to 255).

Изменение цвета производится следующим образом:

myColorTransform = new Object();
myColorTransform.ra = 50;
myColorTransform.rb = 244;
myColorTransform.ga = 40;
myColorTransform.gb = 112;
myColorTransform.ba = 12;
myColorTransform.bb = 90;
myColorTransform.aa = 40;
myColorTransform.ab = 70;

Можете использовать также следующий синтаксис:

myColorTransform = { ra: '50', rb: '244', ga: '40', gb: '112', ba: '12', bb: '90', aa: '40', ab: '70'}

Player

Flash 5 или выше.

Пример

Создаем новый объект Color для муви-клипа, color transformobject с описанными выше параметрами, используя конструктор объекта Object, и передаем объекту Color этот color transformobject, используя метод setTransform.

// Создаем объект Color
myColor = new Color(myMovie);

// Вызываем myColorTransfrom и создаем color transform object
// the generic Object object
myColorTransform = new Object;

// Задаем параметры
myColorTransform = { ra: '50', rb: '244', ga: '40', gb: '112', ba: '12', bb: '90', aa: '40', ab: '70'}

// Связываем color transform object с объектом Color, созданным выше
myColor.setTransform(myColorTransform);


continue

A-C > continue

continue

Синтаксис

continue;

Аргументы

Нет.

Описание

Команда; фигурирует внутри некоторых типах операторов цикла.

В цикле while, continue заставляет Flash пропустить оставшуюся часть тела цикла, и перейти к его вершине, где проверяется условие выхода из цикла.

В цикле do...while, continue заставляет Flash пропустить оставшуюся часть тела цикла, и перейти к его окончанию, где проверяется условие выхода из цикла.

В цикле for, continue заставляет Flash пропустить оставшуюся часть тела цикла, и перейти туда, где вычисляется условие выхода из цикла.

В цикле for...in, continue заставляет Flash пропустить оставшуюся часть тела цикла, и перейти к его вершине, где обрабатывается следующее значение.

Player

Flash 4 или выше.

См. также


_currentframe

A-C > _currentframe

_currentframe

Синтаксис

instancename._currentframe

Аргументы

instancename Имя экземпляра муви-клипа.

Описание

Свойство (только возвращаемое, установить нельзя); возвращает номер кадра, где муви-клип находится в данный момент.

Player

Flash 4 или выше.

Пример

Используем _currentframe, чтобы отправить клип на фрэйм, отстоящий от текущего на пять кадров впереди:

gotoAndStop(_currentframe + 5);


! (logical NOT)

Операторы > ! (logical NOT)

! (логическое НЕ)

Синтаксис

!expression

Аргументы

expression Переменная или оцениваемое выражение.

Описание

Логический оператор; инвертирует булево значение переменной или выражения. Если expression является переменной с абсолютным или конвертированным значением true, то !expression будет соответствовать false. Если выражение x && y оценивается как false, то !(x && y), как true. Этот оператор идентичен оператору not, который использовался во Flash 4.

Player

Flash 4 или более поздней версии.

Пример

В этом примере переменная happy принята за false, оператор if проверяет условие !happy, и если оно есть true, то trace посылает строку в Output окно.

happy = false;
if (!happy){
trace("don't worry be happy");
}

Следующие строки иллюстрируют результат действия оператора !:

! true возвращает false

! false возвращает true


Date (object)

Date > Date (object)

Date (object)

Объект Date позволяет получить дату и время по Гринвичу (глобальные) и текущие (системные), где запущен Flash Player. Чтобы воспользоваться методами объекта Date, необходимо сначала создать его экземпляр с помощью конструктора.

При работе с объектом Date необходим Flash 5 Player.

Методы объекта Date не статичные и применяются отдельно для каждого экземпляра объекта Date, для которого были вызваны.

Таблица методов объекта Date
Метод | Описание
getDate | Возвращает день месяца указанного объекта Date согласно системному времени.
getDay | Возвращает день недели указанного объекта Date согласно системному времени.
getFullYear | Возвращает четырехзначное значение года указанного объекта Date согласно системному времени.
getHours | Возвращает час указанного объекта Date согласно системному времени.
getMilliseconds | Возвращает количество миллисекунд указанного объекта Date согласно системному времени.
getMinutes | Возвращает количество минут указанного объекта Date согласно системному времени.
getMonth | Возвращает месяц указанного объекта Date согласно системному времени.
getSeconds | Возвращает количество секунд указанного объекта Date согласно системному времени.
getTime | Возвращает количество миллисекунд, прошедших с 1 января 1970, для указанного объекта Date.
getTimezoneOffset | Возвращает разницу в минутах между системным и глобальным временем.
getUTCDate | Возвращает день месяца указанного объекта Date согласно глобальному времени.
getUTCDay | Возвращает день недели указанного объекта Date согласно глобальному времени.
getUTCFullYear | Возвращает четырехзначное значение года указанного объекта Date согласно глобальному времени.
getUTCHours | Возвращает час указанного объекта Date согласно глобальному времени.
getUTCMilliseconds | Возвращает количество миллисекунд указанного объекта Date согласно глобальному времени.
getUTCMinutes | Возвращает количество минут указанного объекта Date согласно глобальному времени.
getUTCMonth | Возвращает месяц указанного объекта Date согласно глобальному времени.
getUTCSeconds | Возвращает количество секунд указанного объекта Date согласно глобальному времени.
getYear | Возвращает значение года указанного объекта Date согласно системному времени.
setDate | Выставляет день месяца объекта Date согласно системному времени.
setFullYear | Выставляет полную дату объекта Date согласно системному времени.
setHours | Выставляет час объекта Date согласно системному времени.
setMilliseconds | Выставляет количество миллисекунд объекта Date согласно системному времени.
setMinutes | Выставляет количество минут объекта Date согласно системному времени.
setMonth | Выставляет месяц объекта Date согласно системному времени.
setSeconds | Выставляет количество секунд объекта Date согласно системному времени.
setTime | Выставляет дату указанного объекта Date в миллисекундах.
setUTCDate | Выставляет дату указанного объекта Date согласно глобальному времени.
setUTCFullYear | Выставляет год указанного объекта Date согласно глобальному времени.
setUTCHours | Выставляет час указанного объекта Date согласно глобальному времени.
setUTCMilliseconds | Выставляет миллисекунды указанного объекта Date согласно глобальному времени.
setUTCMinutes | Выставляет минуты указанного объекта Date согласно глобальному времени.
setUTCMonth | Выставляет месяц указанного объекта Date согласно глобальному времени.
setUTCSeconds | Выставляет секунды указанного объекта Date согласно глобальному времени.
setYear | Выставляет год указанного объекта Date согласно системному времени.
toString | Возвращает строку, представляющую дату и время, содержащиеся в объекте Date.
Date.UTC | Возвращает количество миллисекунд, прошедших с 00.00 1 января 1970 г. по глобальному времени до заданного времени.

Конструктор объекта Date

Синтаксис

new Date();
new Date(year [, month [, date [, hour [, minute [, second [, millisecond ]]]]]] );

Аргументы

year Число от 0 до 99, задающих год между 1900 и 1999, иначе должны быть заданы все четыре цифры.

month Целое от 0 (январь) до 11 (декабрь); необязательный аргумент.

date Целое от 0 до 31; необязательный аргумент.

hour Целое от 0 (полночь) до 23 (11 вечера).

minute Целое от 0 до 59; необязательный аргумент.

second Целое от 0 до 59; необязательный аргумент.

millisecond Целое от 0 до 999; необязательный аргумент.

Описание

Объект; создает и хранит дату и время.

Player

Flash 5 или выше.

Пример

Получаем текущие дату и время:

now = new Date();

Создаем новый объект Date, хранящий день рождения Гарри, 7 августа 1974:

gary_birthday = new Date (74, 7, 7);

Создаем новый объект Date, получаем данные с помощью методов getMonth, getDate, и getFullYear, форматируем их, а получившуюся строку отправляем в текстовое поле dateTextField.

myDate = new Date();
dateTextField = (mydate.getMonth() + "/" + myDate.getDate() + "/" + mydate.getFullYear());


Date.getDate

Date > Date.getDate

Date.getDate

Синтаксис

myDate.getDate();

Аргументы

Нет.

Описание

Метод; Возвращает день месяца (целое от 1 до 31) указанного объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.getDay

Date > Date.getDay

Date.getDay

Синтаксис

myDate.getDay();

Аргументы

Нет.

Описание

Метод; Возвращает день недели (0 для воскресенья, 1 для понедельника, и т.д.) указанного объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.getFullYear

Date > Date.getFullYear

Date.getFullYear

Синтаксис

myDate.getFullYear();

Аргументы

Нет.

Описание

Метод; возвращает четырехзначное значение года указанного объекта Date согласно системному времени.

Player

Flash 5 или выше.

Пример

Создаем новый объект Date и посылаем значение, полученное методом getFullYear, в окно Output:

myDate = new Date();
trace(myDate.getFullYear());


Date.getHours

Date > Date.getHours

Date.getHours

Синтаксис

myDate.getHours();

Аргументы

Нет.

Описание

Метод; Возвращает час (целое от 0 до 23) указанного объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.getMilliseconds

Date > Date.getMilliseconds

Date.getMilliseconds

Синтаксис

myDate.getMilliseconds();

Аргументы

Нет.

Описание

Метод; возвращает количество миллисекунд (целое от 0 до 999) указанного объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.getMinutes

Date > Date.getMinutes

Date.getMinutes

Синтаксис

myDate.getMinutes();

Аргументы

Нет.

Описание

Метод; возвращает количество минут (целое от 0 до 59) указанного объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.getMonth

Date > Date.getMonth

Date.getMonth

Синтаксис

myDate.getMonth();

Аргументы

Нет.

Описание

Метод; возвращает месяц (0 - январь, 1 - февраль, и т.д.) указанного объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.getSeconds

Date > Date.getSeconds

Date.getSeconds

Синтаксис

myDate.getSeconds();

Аргументы

Нет.

Описание

Метод; возвращает количество секунд (целое от 0 до 59) указанного объекта Date согласно системному времени.

Player

Flash 5 или выше.


Date.getTime

Date > Date.getTime

Date.getTime

Синтаксис

myDate.getTime();

Аргументы

Нет.

Описание

Метод; Возвращает количество миллисекунд (целое от 0 до 999), прошедших с 1 января 1970, для указанного объекта Date; глобальное время. Используйте этот метод для представления определенного момента времени в различных часовых поясах.

Player

Flash 5 или выше


!= (inequality)

Операторы > != (inequality)

!= (неравенство)

Синтаксис

expression1 != expression2

Аргументы

expression1, expression2 Числа, строки, булевы значения, переменные, объекты, массивы или функции.

Описание

Оператор (эквивалентности); тестирует два выражения прямо противоположным образом, нежели оператор ==. Если expression1 эквивалентен expression2, то результат есть false. Так же как и при использовании оператора ==, определение эквивалентности зависит от сравниваемых типов данных.

Числа, строки, булевы значения сравниваются по значению.
Переменные, объекты, массивы и функции сравниваются по содержанию 1.

Player

Flash 5 или более поздней версии.

Пример

Этот пример показывает результат действий оператора !=.

5 != 8 возвращает true

5 != 5 возвращает false

Следующий пример показывает использование оператора != в команде if :

a = "David";
b = "Fool"
if (a != b){
trace("David is not a fool");
}

Смотри также

== (equality)

От редактора:

  1. Имеется в виду, что в отличие от чисел, булеанов и строк, являющихся по сути константами, переменные, объекты, массивы и функции, являются контейнерами с переменным содержанием.


Date.getTimezoneOffset

Date > Date.getTimezoneOffset

Date.getTimezoneOffset

Синтаксис

mydate.getTimezoneOffset();

Аргументы

Нет.

Описание

Метод; возвращает разницу в минутах между системным и глобальным временем.

Player

Flash 5 и выше.

Пример

Получаем разницу между летним временем в Сан-Франциско и гринвичским. Поправка на летнее время происходит, если метод был вызван именно в это время.

new Date().getTimezoneOffset();

Результат:

420 (7 hours * 60 minutes/hour = 420 minutes)


Date.getUTCDate

Date > Date.getUTCDate

Date.getUTCDate

Синтаксис

myDate.getUTCDate();

Аргументы

Нет.

Описание

Метод; возвращает день месяца указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.getUTCDay

Date > Date.getUTCDay

Date.getUTCDay

Синтаксис

myDate.getUTCDate();

Аргументы

Нет.

Описание

Метод; возвращает день недели указанного объекта Date согласно глобальному времени.


Date.getUTCFullYear

Date > Date.getUTCFullYear

Date.getUTCFullYear

Синтаксис

myDate.getUTCFullYear();

Аргументы

Нет.

Описание

Метод; возвращает четырехзначное значение года указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.getUTCHours

Date > Date.getUTCHours

Date.getUTCHours

Синтаксис

myDate.getUTCHours();

Аргументы

Нет.

Описание

Метод; возвращает час указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.getUTCMilliseconds

Date > Date.getUTCMilliseconds

Date.getUTCMilliseconds

Синтаксис

myDate.getUTCMilliseconds();

Аргументы

Нет.

Описание

Метод; возвращает количество миллисекунд указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.getUTCMinutes

Date > Date.getUTCMinutes

Date.getUTCMinutes

Синтаксис

myDate.getUTCMinutes();

Аргументы

Нет.

Описание

Метод; возвращает количество минут указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.getUTCMonth

Date > Date.getUTCMonth

Date.getUTCMonth

Синтаксис

myDate.getUTCMonth();

Аргументы

Нет.

Описание

Метод; возвращает месяц указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.getUTCSeconds

Date > Date.getUTCSeconds

Date.getUTCSeconds

Синтаксис

myDate.getUTCSeconds();

Аргументы

Нет.

Описание

Метод; возвращает количество секунд указанного объекта Date согласно глобальному времени.

Player

Flash 5 или выше.


Date.getYear

Date > Date.getYear

Date.getYear

Синтаксис

myDate.getYear();

Аргументы

Нет.

Описание

Метод; возвращает значение года указанного объекта Date согласно системному времени. Значение года представлено как "четырехзначный год" - 1900; например, год 2000 будет представлен как 100.

Player

Flash 5 или выше.